Home > Articles > Networking > Routing & Switching

  • Print
  • + Share This
This chapter is from the book

Configuring TE Tunnels to Carry MPLS VPN Traffic

MPLS VPN traffic can be carried over MPLS traffic engineering (TE) tunnels.

Two different configurations are discussed in this section:

  • Transport of MPLS VPN traffic over TE tunnels between PE routers

  • Transport of MPLS VPN traffic over TE tunnels between P routers

Figure 6-28 shows both of these configurations.

Figure 6-28

Figure 6-28. Transport of MPLS VPN Traffic over PE-PE and P-P Routers

Configuring TE Tunnels Between PE Routers

In this configuration, PE routers are configured as TE tunnel head-end and tail-end routers. P routers are configured as TE midpoint routers.

Configuring the Head-End Router

The configuration of the head-end (PE) router consists of the following steps, which are examined in detail in the sections that follow:

Step 1

Globally enable MPLS TE.

Step 2

Configure interface parameters.

Step 3

Configure the backbone IGP for MPLS TE.

Step 4

Configure the MPLS TE tunnel.


Step 1: Globally Enable MPLS TE

The first step in the configuration of the head-end router is to globally enable MPLS TE.

Example 6-29 shows how to enable MPLS TE on the head-end router.

Example 6-29 Enabling MPLS TE on the Head-end Router

mpls traffic-eng tunnels

The mpls traffic-eng tunnels command globally enables MPLS TE on the router.

Step 2: Configure Interface Parameters

The next step is to enable MPLS TE and RSVP on core interfaces.

Example 6-30 shows the configuration of MPLS TE on core interfaces.

Example 6-30 Configuration of MPLS TE on Core Interfaces

interface Serial4/0
 mpls traffic-eng tunnels
 ip rsvp bandwidth 1024

The command mpls traffic-eng tunnels enables MPLS TE on core interfaces.

The ip rsvp bandwidth interface_bandwidth command configures the maximum reservable bandwidth on the interface. In this case, 1024 kbps is configured as the amount of bandwidth reservable on the interface.

Step 3: Configure the Backbone IGP for MPLS TE

The backbone IGP must be configured to support MPLS TE. The only two IGPs that currently support MPLS TE are IS-IS and OSPF.

Example 6-31 shows the configuration of IS-IS to support MPLS TE.

Example 6-31 Configuration of IS-IS to Support MPLS TE

router isis
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2

The router isis command begins IS-IS configuration on the router.

The command metric-style wide configures IS-IS to send and receive 24- and 32-bit metrics. Support for wide metrics is essential for MPLS TE.

The next command, mpls traffic-eng router-id interface, configures a router ID to be used with TE.

The final command in the configuration is mpls traffic-eng level-1 | level-2. This command enables MPLS TE within the specified IS-IS level. The appropriate IS-IS level should be specified, but note that if interarea MPLS TE is being used, both level 1 and level 2 should be specified on level 1/2 routers.

Example 6-32 shows the configuration for OSPF to support MPLS TE.

Example 6-32 Configuration of OSPF to Support MPLS TE

router ospf 10
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0

The router ospf process_id command begins OSPF configuration on the router.

Next is the mpls traffic-eng router-id interface command, which configures a router ID for MPLS TE.

Finally, the command mpls traffic-eng area area_id enables MPLS TE within the specified area. If you are using interarea MPLS TE, ensure that all areas that the tunnel will transit are specified on Area Border Routers (ABRs). On non-ABRs, configure the area in which the router is.

Step 4: Configure the MPLS TE Tunnel

The next step in the configuration of the head-end router is the configuration of the TE tunnel itself.

Example 6-33 shows the configuration of the MPLS TE tunnel.

Example 6-33 Configuration of the MPLS TE Tunnel

interface Tunnel10
 ip unnumbered Loopback0
 tunnel destination 10.1.1.4
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng bandwidth 256
 tunnel mpls traffic-eng path-option 10 dynamic

In Example 6-33, tunnel interface 10 is configured for MPLS TE.

The command ip unnumbered interface is configured. MPLS tunnels must be configured with an IP address, and though it is not mandatory, ip unnumbered is recommended. Do not forget this command when configuring the TE tunnel. If an IP address is not configured on the tunnel interface, no traffic will be forwarded over it.

The next command, tunnel destination ip_address, configures the TE tunnel destination. This is the MPLS router ID of the tail-end router.

The command tunnel mode mpls traffic-eng command enables the tunnel interface for MPLS TE.

Following the tunnel mode mpls traffic-eng command is tunnel mpls traffic-eng autoroute announce. This command allows the IGP to use the tunnel in SPF calculations, which, in turn, allows VPN traffic to be forwarded over the tunnel. Note that tunnel mpls traffic-eng autoroute announce is not supported for interarea tunnels.

Another method of forwarding VPN traffic over TE tunnels is to use static routes. Make sure that you configure either autoroute or static routes to direct traffic into the TE tunnel. If you do not do this, the TE tunnel will not carry VPN traffic.

Next is the tunnel mpls traffic-eng bandwidth bandwidth command. This command is optional and specifies an amount of bandwidth to be reserved for the TE tunnel along its path.

The final command is tunnel mpls traffic-eng path-option number dynamic. This command configures the tunnel to take a dynamically calculated route across the network to the tail-end router. Note that this command is not supported for interarea tunnels.

Another option is to use an explicit path. When using explicit paths, the path across the backbone is specified on a hop-by-hop basis.

Example 6-34 shows the configuration of an explicit path.

Example 6-34 Configuration of an Explicit Path for an MPLS TE Tunnel

interface Tunnel10
 tunnel mpls traffic-eng path-option 5 explicit name TEPATH1
!
ip explicit-path name TEPATH1 enable
 next-address 10.20.10.2
 next-address 10.20.40.2
 next-address 10.20.50.2
 next-address 10.20.30.2

In Example 6-34, an explicit path called TEPATH1 is specified on a hop-by-hop basis across the backbone. These hops can be either interface addresses or TE IDs.

When specifying an explicit path for interarea tunnels, be sure to use the loose keyword for each hop that corresponds to an IS-IS level-1/level-2 router or OSPF ABR. In addition, the hop-by-hop path should include the addresses of IS-IS level-1/level-2 routers or OSPF ABRs on the way to the tail-end router.

Configuring the Midpoint and Tail-End Routers

The configuration of the midpoint and the tail-end routers is to a large extent the same as that for the head-end router.

The steps used to configure intermediate and tail-end routers are as follows:

Step 1

Globally enable MPLS TE.

Step 2

Configure interface parameters.

Step 3

Configure the IGP for MPLS TE.


As you can see, the only difference in the configuration is that a tunnel interface is not configured. Refer to the previous section for an explanation of the configuration of these steps. Remember that TE tunnels are unidirectional, so you will need another TE tunnel configured in the opposite direction for bidirectional TE traffic forwarding.

TE Tunnels Between P Routers

The configuration of a TE tunnel to support MPLS VPN traffic between P routers is much the same as that for a tunnel between PE routers but with one key difference on the head-end router: enabling LDP (or TDP) on the tunnel interface.

Because the configuration for intermediate and tail-end routers is the same as that described in the previous section, only the configuration of the head-end router is described here.

Example 6-35 shows the configuration of the MPLS TE tunnel interface.

Example 6-35 Configuration of the MPLS TE Tunnel Interface

interface Tunnel10
 ip unnumbered Loopback0
 no ip directed-broadcast
 mpls ip
 tunnel destination 10.1.1.3
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng bandwidth 256
 tunnel mpls traffic-eng path-option 5 dynamic

Highlighted line 1 shows the key difference in the configuration of a MPLS TE tunnel between P routers. The command mpls ip enables LDP (or TDP) on the tunnel interface. This is crucial if VPN traffic is not to be dropped by the tail-end router.

Note that although it is not strictly required, you may also want to configure the mpls ip command on TE tunnels between PE routers—it cannot hurt, and you never know when it might become essential because of a network topology change.

Refer to the previous section for an explanation of other commands configured in Example 6-35.

  • + Share This
  • 🔖 Save To Your Account

InformIT Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from InformIT and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites, develop new products and services, conduct educational research and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by InformIT. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.informit.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020