Home > Articles > Certification > Cisco Certification > CCIE

This chapter is from the book

Section 3: ISDN (8 Points)

  • Ensure that VLAN3 and R4 Lo0 are accessible from R1 and beyond should the Frame Relay network fail either physically or logically. If VLAN3 and R4 Lo0 networks are restored while the ISDN line is active, ensure that traffic is routed over the Frame Relay network to these destinations immediately.

As no static routes are permitted and backing up the Frame Relay interface will not help as this only works if the Frame Relay interface is physically down, the only option will be to use the dialer-watch feature. Both networks must be down before the router dials out so VLAN3 and R4 Lo0 should be added to a dialer watch-list and corresponding dialer watch-group number under the BRI interface on R1. R1 is used to dial out as the question states that the two networks should be accessible from R1. You are also later advised that only R1 should dial into R4.

You should notice that when you fail the Frame Relay network to test this that after the ISDN is activated and the Frame Relay network is then restored that the routing table on R1 shows identical hop counts for all remote networks via R4 over both the Frame Relay and ISDN line as shown in Example 1-23.

This condition can keep the ISDN line from ever deactivating as the ISDN network can now be used as a valid means to transport data to the RIP advertised remote networks, you should also notice that the question requires that the Frame Relay routes should be used "immediately" when restored and, at this point, routers R1 and R4 can choose between Frame Relay and ISDN.

RIP obviously does not take into account the bandwidth of available routes. You, therefore, need to make the ISDN routes less desirable and add additional hop count to RIP using an offset-list on R4 and R1 out over the ISDN line (inbound over both routers will also be acceptable). This ensures when the Frame Relay is restored and for the period where both Frame Relay and ISDN lines are active and receiving RIP routes that the hop count is more favorable over Frame Relay because of the additional hop count incurred over ISDN after the offset-list is applied.

The ISDN line can not be used to route traffic while a higher-speed Frame Relay connection is available as shown in Example 1-25. Dialer-watch does not require interesting traffic to trigger the dial so the dialer-list should be an implicit deny of any IP traffic; otherwise, any traffic will potentially keep the line up after initiated. It is better practice and shows a better understanding of the dialer-watch process to, therefore, have the following dialer-list on R1; dialer-list 10 protocol ip deny. You will find with this strict policing of the interesting traffic, your ISDN line will stay down when the networks are restored over the Frame Relay. If you have configured this question correctly as in Example 1-24, you have scored 5 points; if you have used a dialer-list that denies RIP and the line stays down, you have only scored 3 points. Test your scenario thoroughly if you have first denied RIP then allowed all other IP traffic and also not applied the offset-list; you could find that with two routes in the routing table with identical metrics that traffic, such as BGP, will toggle between the two routes and keep the line up constantly. In addition, other IP traffic could be classed as interesting and keep the line up.

Example 1-23 R1 Routing Table Pre Offset-List with the ISDN Line Active After the Frame Relay Network Has Been Restored

R1#sh ip route
R    172.16.0.0/16 [120/1] via 10.90.90.1, 00:00:22, Serial0/0
     10.0.0.0/8 is variably subnetted, 16 subnets, 5 masks
R       10.8.8.8/32 [120/4] via 10.10.10.2, 00:00:14, BRI0/0
                    [120/4] via 10.100.100.2, 00:00:14, Serial0/1.101
C       10.10.10.2/32 is directly connected, BRI0/0
C       10.100.100.0/28 is directly connected, Serial0/1.101
R       10.99.99.0/29 [120/2] via 10.10.10.2, 00:00:14, BRI0/0
                      [120/2] via 10.100.100.2, 00:00:14, Serial0/1.101
R       10.60.60.0/29 [120/2] via 10.10.10.2, 00:00:14, BRI0/0
                      [120/2] via 10.100.100.2, 00:00:14, Serial0/1.101
R       10.50.50.0/29 [120/4] via 10.10.10.2, 00:00:14, BRI0/0
                      [120/4] via 10.100.100.2, 00:00:14, Serial0/1.101
R       10.40.40.0/28 [120/1] via 10.10.10.2, 00:00:16, BRI0/0
                      [120/1] via 10.100.100.3, 00:00:16, Serial0/1.101
R       10.7.7.0/28 [120/4] via 10.10.10.2, 00:00:16, BRI0/0
                    [120/4] via 10.100.100.2, 00:00:16, Serial0/1.101
R       10.6.6.0/29 [120/2] via 10.10.10.2, 00:00:16, BRI0/0
                    [120/2] via 10.100.100.2, 00:00:16, Serial0/1.101
R       10.4.4.0/29 [120/1] via 10.10.10.2, 00:00:16, BRI0/0
                    [120/1] via 10.100.100.3, 00:00:16, Serial0/1.101
C       10.80.80.0/24 is directly connected, FastEthernet0/0
C       10.90.90.0/28 is directly connected, Serial0/0
C       10.1.1.0/28 is directly connected, Loopback0
C       10.10.10.0/28 is directly connected, BRI0/0
C       10.90.90.1/32 is directly connected, Serial0/0
R       10.5.5.4/30 [120/4] via 10.10.10.2, 00:00:16, BRI0/0
                    [120/4] via 10.100.100.2, 00:00:16, Serial0/1.101
R1#sh isdn history
--------------------------------------------------------------------------------
                                ISDN CALL HISTORY
--------------------------------------------------------------------------------
Call History contains all active calls, and a maximum of 100 inactive calls.
Inactive call data will be retained for a maximum of 15 minutes.
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------
Out                    2222                    82     37       82      0
--------------------------------------------------------------------------------

NOTE

The routing table output is taken after a Frame Relay failure is restored and the ISDN line is still active. The shading shows you the two available routes with the identical hop count on R1 before the offset-list is applied.

Example 1-24 Increasing the Hop Count Out of R4 and R1 ISDN Configuration

R1
router rip
offset-list 0 out 2 BRI0/0
R4
router rip
 offset-list 0 out 2 Dialer0

NOTE

offset-list 0 will apply the chosen additional hop count (2) to all networks being advertised from R4 and R1 out of their interfaces BRI0/0. A similar configuration could be placed on each BRI0/0 but inbound.

Example 1-25 R1 Routing Table Post Offset-List with the ISDN Line Active After the Frame Relay Network Has Been Restored

R1#sh ip route
R    172.16.0.0/16 [120/1] via 10.90.90.1, 00:00:09, Serial0/0
     10.0.0.0/8 is variably subnetted, 16 subnets, 5 masks
R       10.8.8.8/32 [120/4] via 10.100.100.2, 00:00:28, Serial0/1.101
C       10.10.10.2/32 is directly connected, BRI0/0
C       10.100.100.0/28 is directly connected, Serial0/1.101
R       10.99.99.0/29 [120/2] via 10.100.100.2, 00:00:28, Serial0/1.101
R       10.60.60.0/29 [120/2] via 10.100.100.2, 00:00:28, Serial0/1.101
R       10.50.50.0/29 [120/4] via 10.100.100.2, 00:00:28, Serial0/1.101
R       10.40.40.0/28 [120/1] via 10.100.100.3, 00:00:28, Serial0/1.101
R       10.7.7.0/28 [120/4] via 10.100.100.2, 00:00:28, Serial0/1.101
R       10.6.6.0/29 [120/2] via 10.100.100.2, 00:00:28, Serial0/1.101
R       10.4.4.0/29 [120/1] via 10.100.100.3, 00:00:28, Serial0/1.101
C       10.80.80.0/24 is directly connected, FastEthernet0/0
C       10.90.90.0/28 is directly connected, Serial0/0
C       10.1.1.0/28 is directly connected, Loopback0
C       10.10.10.0/28 is directly connected, BRI0/0
C       10.90.90.1/32 is directly connected, Serial0/0
R       10.5.5.4/30 [120/4] via 10.100.100.2, 00:00:00, Serial0/1.101

R1#sh isdn hist
--------------------------------------------------------------------------------
                                ISDN CALL HISTORY
--------------------------------------------------------------------------------
Call History contains all active calls, and a maximum of 100 inactive calls.
Inactive call data will be retained for a maximum of 15 minutes.
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------
Out                    2222                    92     27       92      0
--------------------------------------------------------------------------------

NOTE

The routing table output is taken after a Frame Relay failure is restored and the ISDN line is still active. This shows that the ISDN routes are no longer entered into the routing table on R1 because of the increased hop count over this environment. The routing table on R4 will act in exactly the same manner.

  • Configure R1 so that if half of the ISDN traffic to R4 is of an unacceptable quality, the line is automatically disconnected.

Configure ppp quality 50 under both R1 and R4 BRI0/0 interfaces, the figure (percentage) is for both incoming and outgoing directions on the interface, PPP will drop the line if the quality falls below 50 percent and initiate a timer before re-establishing the link. If you have configured this correctly, you have scored 1 point.

  • Allow only R1 to dial into R4. Do not use any PPP feature in your solution.

The question is not seeking configuration of CHAP on both routers as any router configured with the correct CHAP password could emulate R1 and gain access to R4. It is, therefore, required to configure R4 with isdn caller 1111 if using legacy DDR or dialer-caller 1111 if using dialer profiles to ensure that only R1, which is connected to the ISDN number 1111, can actually gain access by having R4 check the CLI before answering. You may have automatically assumed this must require CHAP but there is not sufficient detail in the question to suggest that CHAP or PAP is required. These are both also PPP features so it is disallowed anyway. If you have configured this correctly, you have scored 2 points.

NOTE

Your ISDN line or simulator must support CLI to test this feature.

  • Do not allow the ISDN to flap if the Frame Relay network goes up and down; only allow the line to be dropped if the Frame Relay connectivity is deemed to be reliable for 90 seconds.

By default, the ISDN line will be dropped when dialer-watch again has visibility if the networks listed in the dialer watch-list. To ensure the line remains active for 90 seconds the command dialer watch-disable 90 should be added to the BRI0/0 interface of R1. If you have configured this correctly, you have scored 1 point.

Example 1-26 and Example1-27 show the full final ISDN and relevant RIP configuration required for the ISDN backup on R1 and R4, using a mix of legacy and dialer profile commands.

Example 1-26 R1 Final ISDN and Relevant RIP Configuration

interface BRI0/0
 ip address 10.10.10.1 255.255.255.240
 encapsulation ppp
 dialer watch-disable 90
 dialer string 2222
 dialer watch-group 5
 dialer-group 10
 isdn switch-type basic-net3
 no peer neighbor-route
 ppp quality 50
!
router rip
 version 2
 passive-interface default
 no passive-interface BRI0/0
 offset-list 0 out 2 BRI0/0
 network 10.0.0.0
!
dialer watch-list 5 ip 10.4.4.0 255.255.255.240
dialer watch-list 5 ip 10.40.40.0 255.255.255.240
dialer-list 10 protocol ip deny

Example 1-27 R4 Final ISDN and Relevant RIP Configuration

interface BRI0/0
encapsulation ppp
isdn switch-type basic-net3
dialer pool-member 1

!
interface Dialer0
 ip address 10.10.10.2 255.255.255.240
 encapsulation ppp
 dialer pool 1
 dialer-group 10
 ppp quality 50
 dialer-caller 1111
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial0/0.1
 no passive-interface Dialer0
 offset-list 0 out 2 D0
 dialer-list 10 protocol ip permit

  • + Share This
  • 🔖 Save To Your Account

InformIT Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from InformIT and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites, develop new products and services, conduct educational research and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by InformIT. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.informit.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020