Home > Articles > Certification > Cisco Certification > CCNP

  • Print
  • + Share This
This chapter is from the book

This chapter is from the book

Practical Exercise: Routing OSPF

NOTE

Practical Exercises are designed to test your knowledge of the topics covered in this chapter. The Practical Exercise begins by giving you some information about a situation and then asks you to work through the solution on your own. The solution can be found at the end.

Configure the network in Figure 3-6 for OSPF routing using the IP addressing scheme provided. Ensure that both routers R1 and R2 have full connectivity to Routers R3 and R6 in the backbone. Use the ping command to ensure all networks are reachable. You must use OSPF as your only dynamic routing protocol.

Figure 3-6Figure 3-6 Practical Exercise: Routing OSPF

Practical Exercise Solution

You will notice that the IP addressing scheme uses VLSM and the serial links use the subnet 141.108.10.0.

The serial link contains a mask that is 255.255.255.252, or /30.

The following example configurations provide a solution using OSPF. This practical example is similar to Scenario 2-2 with the extra link between area 1 and area 0. This means that you need to configure two virtual links: one from router R2 to R6 and another between R1 and R3. This second virtual link is required in case of link failure or hardware failure from the Routers R1 and R2.

Configure the loopbacks with VLSM and experiment with debug commands to discover why IP entries are added or not advertised. Remove the second virtual link from R1 to R3, and see how OSPF behaves when the link between R2 and R6 fails.

You will find that because the areas are partitioned, you actually do need two virtual links to ensure full connectivity in any network failure situation. Example 3-62 displays R1's full working configuration.

Example 3-62 R1's Full Configuration

version 12.0

!

hostname R1

!

enable password cisco

!

ip subnet-zero

no ip domain-lookup

interface Loopback0

ip address 131.108.4.1 255.255.255.128

ip ospf cost 90

!

interface Loopback1

ip address 131.108.4.129 255.255.255.128

ip ospf cost 90

!

interface Loopback2

ip address 131.108.5.1 255.255.255.224

ip ospf cost 90

!

interface Ethernet0/0

ip address 131.108.1.1 255.255.255.0

!

interface Serial0/0

ip address 141.108.10.9 255.255.255.252

clockrate 125000

!

interface Serial0/1

no ip address

shutdown

clockrate 128000

!

router ospf 1

area 2 virtual-link 141.108.2.1

network 131.108.1.0 0.0.0.255 area 1

network 131.108.4.0 0.0.0.127 area 1

network 131.108.4.128 0.0.0.127 area 1

network 131.108.5.0 0.0.0.31 area 1

network 141.108.10.8 0.0.0.3 area 2

!

line con 0

line aux 0

line vty 0 4

!

end


Example 3-63 displays R2's full working configuration.

Example 3-63 R2's Full Configuration

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R2

!

enable password cisco

!

ip subnet-zero

no ip domain-lookup

!

interface Loopback0

ip address 131.108.5.33 255.255.255.224

ip ospf network point-to-point

ip ospf cost 1000

!

interface Loopback1

ip address 131.108.6.1 255.255.255.255

!

interface Loopback2

ip address 131.108.6.2 255.255.255.255

!

interface Ethernet0/0

ip address 131.108.1.2 255.255.255.0

ip ospf priority 255

interface Serial1/0

ip address 141.108.10.1 255.255.255.252

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

router ospf 2

area 2 virtual-link 141.108.12.1

network 131.108.1.0 0.0.0.255 area 1

network 131.108.5.32 0.0.0.31 area 1

network 131.108.6.1 0.0.0.0 area 1

network 131.108.6.2 0.0.0.0 area 1

network 141.108.10.0 0.0.0.3 area 2

!

line con 0

line aux 0

line vty 0 4

!

end


Example 3-64 displays R3's working configuration.

Example 3-64 R3's Full Configuration

version 12.0

hostname R3

!

enable password cisco

!

ip subnet-zero

interface Loopback0

ip address 141.108.1.1 255.255.255.128

ip ospf network point-to-point

!

interface Loopback1

ip address 141.108.1.129 255.255.255.128

ip ospf network point-to-point

!

interface Loopback2

ip address 141.108.2.1 255.255.255.224

ip ospf network point-to-point

!

interface Ethernet0

ip address 131.108.33.1 255.255.255.0

!

interface Serial0

ip address 141.108.10.10 255.255.255.252

!

interface Serial1

ip address 141.108.10.5 255.255.255.252

!

router ospf 3

area 2 virtual-link 131.108.5.1

network 131.108.33.0 0.0.0.255 area 0

network 141.108.1.0 0.0.0.127 area 0

network 141.108.1.128 0.0.0.127 area 0

network 141.108.2.0 0.0.0.31 area 0

network 141.108.10.4 0.0.0.3 area 0

network 141.108.10.8 0.0.0.3 area 2

!

line con 0

line aux 0

line vty 0 4

!

end


Finally, Example 3-65 displays R6's working configuration.

Example 3-65 R6's Full Configuration

version 12.0

hostname r6

!

enable password cisco

ip subnet-zero

!

interface Loopback0

ip address 141.108.9.1 255.255.255.128

ip ospf network point-to-point

interface Loopback1

ip address 141.108.9.129 255.255.255.128

ip ospf network point-to-point

interface Loopback2

ip address 141.108.12.1 255.255.255.0

ip ospf network point-to-point

interface Ethernet0

ip address 131.108.26.1 255.255.255.0

media-type 10BaseT

!

interface Serial0

ip address 141.108.10.6 255.255.255.252

clockrate 125000

!

interface Serial1

ip address 141.108.10.2 255.255.255.252

clockrate 125000

!

interface Serial2

shutdown

!

interface Serial3

shutdown

!

router ospf 6

area 2 virtual-link 131.108.6.2

network 131.108.26.0 0.0.0.255 area 0

network 141.108.9.0 0.0.0.127 area 0

network 141.108.9.128 0.0.0.127 area 0

network 141.108.10.0 0.0.0.3 area 2

network 141.108.10.4 0.0.0.3 area 0

network 141.108.12.0 0.0.0.255 area 0

!

line con 0

line aux 0

line vty 0 4

end


  • + Share This
  • 🔖 Save To Your Account

InformIT Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from InformIT and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites, develop new products and services, conduct educational research and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by InformIT. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.informit.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020