Home > Articles > Networking > Routing & Switching

IP Routing Use Cases

  • Print
  • + Share This
This chapter is from the book

Scalable Data Center Interconnect

Today's businesses are seeing more and more consolidation for both file and application servers into a small number of data centers. Major drivers for this trend include cost savings, regulatory compliance, and ease of backup and administration.

At the heart of this, there is also a virtualization trend, where compute cycles are being isolated or abstracted from storage. This has created newer technologies for virtual machine high availability, and migration such as VMotion, clustering, or even geo-clustering of servers, which require extending Layer 2 VLANs across the WAN (data center interconnect).

Now, when looking at the data center connection and trying to tie it up with the application vendor requirements, almost all suggest using Layer 2 adjacent servers. To satisfy or emulate the requirement of L2 adjacencies across the WAN, various requirements emerge from these trends:

  • Loop prevention: This refers to isolation of Spanning Tree Protocol (STP) to each data center itself, and not extended across the data center interconnect (DCI).
  • Redundancy: This refers to the DCI solution itself not being prone to node or link failures. That, of course, requires redundancy.
  • Convergence times: Apparently, there is no set standard for this requirement for DCI. It really depends on what applications are being run (for example, a requirement driven by VMotion stipulates no more than a couple of seconds for convergence).
  • Usage of multiple paths: This is where technologies such as Virtual Switching Systems (VSS) and Multichassis EtherChannel (MEC) come into play. There is another similar solution known as virtual port channel (vPC), which essentially allows creating an EtherChannel where member links are across two different physical systems.

Three types of transport are common for DCI:

  • Dark fiber: Fiber that is not lit yet is called dark fiber. Not very many organizations have access to dark fiber, but the ones who have see it as the most preferred way of doing DCI. This is usually limited in distance.
  • IP: This is a rather common medium and usually consists of some kind of private IP services that most SPs offer across geographies.
  • MPLS: This is one of the more common ways to connect data centers.

The ASR 1000 supports almost all forms of Gigabit Ethernet coarse/dense wavelength-division multiplexing (CWDM/DWDM) optics, although the Catalyst 6500 with VSS/MEC has a solution that meets all the requirements in this arena, including multisite DC connectivity.

For IP and MPLS, the ASR 1000 offers (complementing the Cisco 6500 solution) Ethernet over MPLS and Ethernet over MPLS over GRE, starting from IOS XE 2.4 for dual-site DCI.

Figure 12-8 shows the MPLS transport and active/active EoMPLS pseudowires across DCI routers.

Figure 12-8

Figure 12-8 Encrypting Ethernet frames at Layer 2 using TrustSec and avoiding the use Layer 3 encryption such as IPsec.

Figure 12-9 shows the MPLS transport and active/active EoMPLS pseudowires across DCI routers. Here the DC core switches are Nexus 7Ks running TrustSec to encrypt packets at Layer 2 hop by hop.

Figure 12-9

Figure 12-9 EoMPLS scenario where the transport cloud is MPLS.

The solution in Figure 12-9 shows a unique advantage where any traffic leaving the premise is required to be encrypted, as this provides a native way to encrypt all traffic. This requirement is common in government and state agencies.

Figure 12-10 shows the IP transport and active/active EoMPLSoGRE tunnels across DCI routers.

Figure 12-10

Figure 12-10 EoMPLSoGRE scenario where the transport cloud is IP.

This can also be seen as a consolidation strategy, especially for green-field deployments, where ASR 1000 working as a DCI LAN extension router can also serve as a consolidated unified WAN services router. This brings down the TCO much lower and at the same time allows for faster qualification, where the ASR 1000 functions as a private WAN aggregation, and even perhaps the Internet edge can be collapsed at the consolidated WAN edge.

Figure 12-11 shows the unified WAN edge, which consolidates the DCI with multiple other functions.

Figure 12-11

Figure 12-11 Example of DCI and WAN edge functional collapse in a single router.

Use Case: Encrypting Traffic over an EoMPLS Psuedowire at Layer 2 Using TrustSec

Assume that an organization wants to connect two different data centers and extend multiple VLANs across these two sites for connecting various clusters, geo-clusters. Assume that the transport method in the middle is MPLS and the organization is using Nexus 7Ks as data center core switches. The customer also wants to start with a clear-text (nonencrypted) DCI, but later on would also like to add encryption to it to deal with regulatory compliance. This must be met without much configuration overhead.

Now, to meet these requirements, you need to extend the Layer 2 connectivity across the sites. Because the transport medium is MPLS, you can start with clear-text requirement and deploy the ASR 1000, as shown in Figure 12-8, and then later move to the deployment illustrated in Figure 12-9 by turning on TrustSec (or 802.1AE) link-layer encryption on the Nexus transparently without changing anything on the ASR 1000!

The examples that follow examine the configuration for both the ASR 1000 (port mode EoMPLS) and TrustSec on the Nexus 7000.

Figure 12-12 shows the final topology with both Nexus 7K and ASR 1000 connected with vPC.

Figure 12-12

Figure 12-12 Nexus 7K and ASR 1000 connected via vPC.

Example 12-1 shows the ASR 1000 port mode EoMPLS configuration, which can be used to theoretically extend 4K VLANs.

Example 12-1. Port Mode EoMPLS Configuration for the ASR 1000 with Remote Port Shutdown Enabled by Default

ASR1000-1:
ASR1000-1(config)# interface Loopback0
ASR1000-1(config-if)# ip address 192.168.100.1 255.255.255.255
!
ASR1000-1(config)# interface GigabitEthernet0/0/0
 ASR1000-1(config-if)# mtu 9216
ASR1000-1(config-if)# no ip address
ASR1000-1(config-if)# negotiation auto
ASR1000-1(config-if)# xconnect 192.168.100.2 100 encapsulation mpls
!
ASR1000-1(config)# interface GigabitEthernet0/0/1
ASR1000-1(config-if)# description to ASR-2
ASR1000-1(config-if)# mtu 9216
ASR1000-1(config-if)# ip address 10.1.2.1 255.255.255.0
ASR1000-1(config-if)# load-interval 30
ASR1000-1(config-if)# negotiation auto
ASR1000-1(config-if)# mpls label protocol ldp
ASR1000-1(config-if)# mpls ip
!
!
ASR1000-1(config)# interface GigabitEthernet0/0/3
ASR1000-1(config-if)# description to ASR-2
ASR1000-1(config-if)# mtu 9216
ASR1000-1(config-if)# ip address 10.1.1.1 255.255.255.0
ASR1000-1(config-if)# load-interval 30
ASR1000-1(config-if)# negotiation auto
ASR1000-1(config-if)# mpls label protocol ldp
ASR1000-1(config-if)# mpls ip
-----------------------------------------------------------------------------------
ASR1000-2:
ASR1000-2(config)# interface Loopback0
ASR1000-2(config-if)# ip address 192.168.100.2 255.255.255.255
!
ASR1000-2(config)# interface GigabitEthernet0/0/0
ASR1000-2(config-if)# mtu 9216
ASR1000-2(config-if)# no ip address
ASR1000-2(config-if)# negotiation auto
ASR1000-2(config-if)#  xconnect 192.168.100.1 100 encapsulation mpls
!
ASR1000-2(config)# interface GigabitEthernet0/0/1
ASR1000-2(config-if)# description to ASR-1
ASR1000-2(config-if)# mtu 9216
ASR1000-2(config-if)# ip address 10.1.2.2 255.255.255.0
ASR1000-2(config-if)# load-interval 30
ASR1000-2(config-if)# mpls label protocol ldp
ASR1000-2(config-if)# mpls ip
!
!
ASR1000-2(config)# interface GigabitEthernet0/0/3
ASR1000-2(config-if)# description to ASR-1
ASR1000-2(config-if)# mtu 9216
ASR1000-2(config-if)# ip address 10.1.1.2 255.255.255.0
ASR1000-2(config-if)# mpls label protocol ldp
ASR1000-2(config-if)# mpls ip

Example 12-2 shows the Nexus 7000 configuration to use TrustSec for all traffic going outbound on to the EoMPLS pseudowires (over an MPLS cloud).

Example 12-2. Nexus 7K TrustSec Configuration

Nexus-7K-1# sh run cts
version 4.1(2)
feature dot1x
feature cts
cts device-id Nexus-7K-1 password 7 qxz12345

interface Ethernet1/12
  switchport
  switchport access vlan 666
  cts manual
    sap pmk abcdef1234000000000000000000000000000000000000000000000000000000
  mtu 9216
  no shutdown

interface Vlan666
  no shutdown
  ip address 155.5.5.1/24
-----------------------------------------------------------------------------------
Nexus-7K-2# sh run cts
version 4.1(2)
feature dot1x
feature cts
cts device-id Nexus-7K-2 password 7 qxz12345
interface Ethernet1/12
  switchport
  switchport access vlan 666
  cts manual
    sap pmk abcdef1234000000000000000000000000000000000000000000000000000000
  mtu 9216
  no shutdown
interface Vlan666
  no shutdown
  mtu 9216
  ip address 155.5.5.2/24

Example 12-3 shows that the TrustSec session is established.

Example 12-3. Confirmation That TrustSec Is Negotiated and Is Up

Operational Status (TrustSec 802.1AE SAP negotiation successful):
Nexus-7K-1# show cts interface e 1/12
CTS Information for Interface Ethernet1/12:
    CTS is enabled, mode:    CTS_MODE_MANUAL
    IFC state:                CTS_IFC_ST_CTS_OPEN_STATE
    Authentication Status:   CTS_AUTHC_SKIPPED_CONFIG
      Peer Identity:
      Peer is:               Not CTS Capable
      802.1X role:           CTS_ROLE_UNKNOWN
      Last Re-Authentication:
    Authorization Status:   CTS_AUTHZ_SKIPPED_CONFIG
      PEER SGT:              0
      Peer SGT assignment:  Not Trusted
      Global policy fallback access list:
    SAP Status:               CTS_SAP_SUCCESS
      Configured pairwise ciphers: GCM_ENCRYPT
      Replay protection: Disabled
      Replay protection mode: Strict
      Selected cipher: GCM_ENCRYPT
      Current receive SPI: sci:1b54c148d80000 an:2
      Current transmit SPI: sci:225577968c0000 an:2
Operational Status (TrustSec 802.1AE SAP negotiation successful):
----------------------------------------------------------------------------------------------
Nexus-7K-2# show cts interface e 1/12
CTS Information for Interface Ethernet1/12:
    CTS is enabled, mode:      CTS_MODE_MANUAL
    IFC state:                CTS_IFC_ST_CTS_OPEN_STATE
    Authentication Status:   CTS_AUTHC_SKIPPED_CONFIG
      Peer Identity:
      Peer is:                Not CTS Capable
      802.1X role:            CTS_ROLE_UNKNOWN
      Last Re-Authentication:
    Authorization Status:   CTS_AUTHZ_SKIPPED_CONFIG
      PEER SGT:              0
      Peer SGT assignment:  Not Trusted
      Global policy fallback access list:
    SAP Status:              CTS_SAP_SUCCESS
      Configured pairwise ciphers: GCM_ENCRYPT
      Replay protection: Disabled
      Replay protection mode: Strict
      Selected cipher: GCM_ENCRYPT
      Current receive SPI: sci:225577968c0000 an:2
      Current transmit SPI: sci:1b54c148d80000 an:2

As shown in Figure 12-12, the two ASR 1000s are connected via two active/active EoMPLS pseudowires. To deal with a failure scenario, the ASR 1000 uses a feature called Remote Pseudo Wire Shutdown. The behavior on the ASR 1000 is a bit different than on the Catalyst 6500/7600, where the feature does not depend on interworking with the Ethernet LMIs.

On the ASR 1000, this feature, upon pseudowire down state, shuts down the local laser on the port with "xconnect", gi0/0/0, as shown in the use case. This is seen by the peer Ethernet port as the interface going down, and it will go to down/down. This allows the downstream devices to stop sending traffic to the port and results in almost instant convergence EoMPLS remote port shutdown provides faster failover times for both local/remote node or link failure scenarios.

This behavior is very helpful in the vPC scenario, because it will trigger the LACP (Link Aggregation Control Protocol) to converge instantly and will remove the member link from the virtual port channel.

  • + Share This
  • 🔖 Save To Your Account

InformIT Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from InformIT and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites, develop new products and services, conduct educational research and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by InformIT. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.informit.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020