Home > Articles > Certification > Cisco Certification > CCIE

This chapter is from the book

Section 7.0: AAA

7.1: AAA on the Router

  1. Configure AAA on R4 to use the TACACS+ server.

  2. Configure authentication, EXEC authorization, and command-level 1/10/15 authorization.

  3. Move the show running-config command to level 10 for user1 to be able to invoke it.

  4. Configure fallback to local in the event the AAA server goes down.

  5. Make sure you use a named method list and apply it to vty lines. Do not configure any authentication or authorization for console or auxiliary ports, or you will lose all marks.

  6. Use the following example to configure all of the above.

  7. aaa new-model
    aaa authentication login vtyline group tacacs+ local
    aaa authentication login con-none none
    aaa authorization exec vtyexec group tacacs+ local 
    aaa authorization exec conexec none 
    aaa authorization commands 1 comm1 group tacacs+ local 
    aaa authorization commands 1 comm-con-none none 
    aaa authorization commands 10 comm10 group tacacs+ local 
    aaa authorization commands 10 comm-con-none none 
    aaa authorization commands 15 comm15 group tacacs+ local 
    aaa authorization commands 15 comm-con-none none 
    !
    username user1 privilege 10 password 7 044E18031D70
    username user2 privilege 15 password 7 13100417195E
    !
    privilege exec level 10 show run 
    privilege exec level 15 show!
    line con 0
     exec-timeout 0 0
     authorization commands 1 comm-con-none
     authorization commands 10 comm-con-none
     authorization commands 15 comm-con-none
     authorization exec conexec
     login authentication con-none
    line aux 0
     authorization commands 1 comm-con-none
     authorization commands 10 comm-con-none
     authorization commands 15 comm-con-none
     authorization exec conexec
     login authentication con-none
    line vty 0 4
     authorization commands 1 comm1
     authorization commands 10 comm10
     authorization commands 15 comm15
     authorization exec vtyexec
     login authentication vtyline
    !
    end
  8. Configure ACS with two users as follows.

  9. User1 with privilege level 10 and permit the show run command. See Figure 1-6 for user settings on CiscoSecure ACS.

    User2 with privilege level 15 with all commands permitted. See Figure 1-7 for user settings on CiscoSecure ACS.

  10. Configure CiscoSecure ACS users above with corresponding privilege levels, so when they log in, they land in enable mode and don't need to enter enable. You need to configure exec authorization to achieve this task. Refer to Figure 1-6 for user1 and Figure 1-7 for user2 profile settings on ACS.

  11. Figure 6Figure 1-61 User1 Settings on CiscoSecure ACS

    Figure 6

    Figure 6

    Figure 7Figure 1-7 User2 Settings on CiscoSecure ACS

    Figure 7

    Figure 7

7.2: AAA on PIX

  1. Configure TACACS+ authentication and authorization for Telnet service on PIX (refer to the example that follows item 3).

  2. Configure static translation for Loopback1 of R6. (Refer to the example that follows item 3 to configure the PIX.)

  3. Configure username r6telnet on ACS with Per User Command Authorization set to permit Telnet service for R6 Loopback1 only. Refer to Figure 1-8 for r6telnet profile settings on ACS.

  4. pix# show aaa
    aaa authentication include telnet outside 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 ACS
    aaa authorization include telnet outside 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 ACS
    pix#
    pix# show aaa-server 
    aaa-server ACS (inside) host 192.168.6.6 cisco timeout 10
    pix#
    pix(config)# show access-list outside
    access-list outside permit tcp any host 10.50.31.6 eq tacacs (hitcnt=103) 
    access-list outside permit tcp any host 16.16.16.16 eq telnet (hitcnt=7)
    pix(config)# show static
    static (inside,outside) 16.16.16.16 16.16.16.16 netmask 255.255.255.255 0 0 
    ! Login capture from R3 telnetting to R6 loopback1:
    r3#telnet 16.16.16.16
    Trying 16.16.16.16 ... Open
    
    Username: r6telnet
    Password: r6telnet
    
    User Access Verification
    Password: 
    r6>en
    Password: 
    r6#
    r6#
    ! After successfully logging on to R6, confirm that 
    ! authentication/authorization is working on pix;
    pix# show uauth
          Current Most Seen
    Authenticated Users  1   1
    Authen In Progress  0   1
    user 'r6telnet' at 10.50.31.2, authorized to:
     port 16.16.16.16/telnet
     absolute timeout: 0:05:00
     inactivity timeout: 0:00:00

    Figure 8Figure 1-8 r6telnet Settings on CiscoSecure ACS

    Figure 8

    Figure 8

     

    NOTE

    If Shell Command Authorization Set does not appear in User Setup in ACS, go to Interface Configuration and select TACACS+ and tick the User column for Shell (exec). See Figure 1-9.

    Figure 9Figure 1-9 Interface Configuration on ACS

    NOTE

    The Reports and Activity section in CiscoSecure ACS is very useful for troubleshooting. Verify FAILED/PASSED attempts in Reports, as shown in Figure 1-10.

    Figure 10Figure 1-10 Reports and Activity in ACS

  • + Share This
  • 🔖 Save To Your Account

InformIT Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from InformIT and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites, develop new products and services, conduct educational research and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by InformIT. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.informit.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020