Home > Articles > Security > Network Security

  • Print
  • + Share This
This chapter is from the book

Virtual Private Networks (VPNs)

The huge increase in the number of VPN clients and companies wanting to use VPNs requires administrators to understand the special security considerations necessary when dealing with VPNs. Because most VPNs are used over a connection to the Internet, any security gap has the potential to be exploited by hundreds of hackers.

VPNs are built by using tunneling protocols, which are protocols that are encapsulated within another protocol. Examples of tunneling protocols used in VPNs are General Routing Encapsulation (GRE), Layer 2 Tunneling Protocol (L2TP), Encapsulation Security Protocol (ESP), Cisco Encryption Technology (CET), and the Layer 2 Forwarding (L2F) protocols. This section covers some of the more commonly used tunneling protocols.

Although a tunneling protocol by itself does offer some protection, greater protection can be obtained by adding encryption within the tunnel. Because a tunnel can normally only be entered from one of the endpoints, some administrators consider them safe without encryption. Only encryption can truly protect data. The "man in the middle" form of attack can be used to inject a device in the middle of a tunnel. This is why a tunnel without encryption is not truly secure.

Because most tunnels can carry encrypted traffic, there is no reason other than router overhead not to also encrypt traffic running through the tunnel. If the performance of your routers is adversely affected by the combination of encryption and tunneling, the routers should be upgraded.

Before discussing how to set up an encrypted tunnel, this section includes a quick overview of some of the types of tunnels and encryption available on Cisco equipment.

L2F

The Layer 2 Forwarding (L2F) protocol is a Cisco proprietary protocol developed to allow Virtual Private Dial-up Network (VPDN) connections. While still supported for various other functions, L2F has largely been replaced by L2TP.

L2TP

Layer 2 Tunneling Protocol (L2TP) builds on the best features present in both the L2F and PPTP protocols. Supporting both IP and non-IP protocols, L2TP is used mainly for dial-up connections.

Generic Routing Encapsulation (GRE) Tunneling

Generic routing encapsulation (GRE) tunnels build a path through the public Internet while encapsulating traffic with new packet headers that ensure the delivery to a specified destination. GRE tunneling is also commonly used to transfer non-IP traffic over an IP network by encapsulating this non-IP traffic within IP.

Encryption

Cisco supports both IPSec and Cisco Encryption Technology (CET) data encryption within GRE tunnels.

IPSec is an open standard, supporting 56-bit, 128-bit, and 256-bit encryption algorithms. Supported on platforms such as Windows and UNIX, IPSec uses certificate authentication and Internet Key Exchange (IKE).

CET is a Cisco standard that supports 40-bit and 56-bit encryption algorithms. CET can be used only between two Cisco routers. Administrators need to be aware that with the exception of the acceleration card within the 7200 and 7500 series routers, CET will be discontinued with the next major release after IOS version 12.1.

If you are currently deploying CET, you should consider upgrading your configurations before you are forced to when installing a new IOS version. Cisco recommends that IPSec with IKE be used instead of CET for encryption within the tunnel.

See the article at this URL for more details about the CET end-of-life announcement: http://www.cisco.com/warp/public/cc/general/bulletin/security/1118_pp.htm

IPSec Configuration

The following configurations show how a main router and a branch router can be set up to accept a VPN connection using IPSec encryption. The new commands will be explored after the configurations. The following is the main office router configuration:

access-list 101 permit any any

crypto map branchoffice 10 ipsec-isakmp
match address 101
set transform-set mytransformset
set peer 172.30.2.2

interface Serial0
ip address 172.30.2.1
crypto map branchoffice

The following is the branch router configuration:

access-list 101 permit any any

crypto map branchoffice 10 ipsec-isakmp
match address 101
set transform-set mytransformset
set peer 172.30.2.1

interface Serial0
ip address 172.30.2.2
crypto map branchoffice

The crypto map branchoffice 10 ipsec-isakmp line defines a map name (branchoffice) and assigns a number (10) to that map name. Next, the line defines that you will use IKE to establish IPSec security associations for the traffic specified in the map statement.

The match address command specifies that extended access list 101 is used to determine what traffic is encrypted. A named access list can also be used.

The set transform-set command specifies the name mytransformset. This name is compared to the peer router. If the transform set on the peer router is the same, encryption and decryption takes place. If the names are different, no data transfer occurs.

The set peer command sets the IP address of the peer router. The peer router must also have the correct IP address configured.

Within the interface, there is the crypto map command that associates this interface with the globally defined mapping of branchoffice.

This was a very simple example. Next, look at an example that is closer to real life. Take extra time to read all of the imbedded comments within this configuration:

access-list 199 permit udp any eq 500 any eq 500
access-list 199 permit 50 any any
access-list 199 permit 51 any any
!These ports are necessary because IKE and IPSec use them

access-list 150 permit 50 any any
access-list 150 permit 51 any any
access-list 150 permit udp any eq 500 any eq 500
 !Since you will have two access lists (one inbound and one outbound)
!on the serial interface, you will need to allow IKE
!and IPSec traffic for both of these interfaces.

access-list 101 permit tcp 172.30.1.0 0.0.0.255 172.20.3.0 0.0.0.255 eq 23
access-list 101 permit tcp 172.30.1.0 0.0.0.255 eq 23 172.20.3.0 0.0.0.255
!Why use another access list? You want to encrypt all
!data that uses port 23 (Telnet) either coming or going from the main branch.
!You will use the number 101 later to define what is encrypted.

crypto transform-set encryp-auth esp-des esp-sha-hmac
crypto transform-set auth-only ah-sha-hmac
!You define the IPSec protection types for use on each type of traffic

crypto map BranchOffice 10 ipsec-isakmp
match address 101
!Remember that you are watching for the number 101?
!This refers to access list number 101, which is used to determine
!what traffic should be encrypted

set transform-set mytransformset
set peer 172.30.2.1

interface Serial0
ip address 172.30.2.2
crypto map branchoffice
ip access-group 199 in
!You need to allow IKE and IPSec traffic through
ip access-group 150 out
!You need the traffic to flow both ways
  • + Share This
  • 🔖 Save To Your Account

InformIT Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from InformIT and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites, develop new products and services, conduct educational research and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by InformIT. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.informit.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020