Home > Articles

  • Print
  • + Share This
This chapter is from the book

Verifying EIGRP Operation

This section discusses commands used to verify EIGRP operation.

Table 3-8 describes some show commands used to verify EIGRP operation. Other options might be available with these commands; use the Cisco IOS integrated help feature to see the full-command syntax.

Table 3-8. EIGRP show Commands

Command

Description

show ip eigrp neighbors

Displays neighbors discovered by EIGRP.

show ip route

Displays the current entries in the IP routing table for all configured routing protocols.

show ip route eigrp

Displays the current EIGRP entries in the IP routing table.

show ip protocols

Displays the parameters and current state of the active routing protocol processes. For EIGRP, this command shows the EIGRP autonomous system number, filtering and redistribution numbers, and neighbors and distance information.

show ip eigrp interfaces

Displays information about interfaces configured for EIGRP.

show ip eigrp topology

Displays the EIGRP topology table. This command shows the topology table, the active or passive state of routes, the number of successors, and the FD to the destination. Note that only successor and feasible successor routes are displayed; add the all-links keyword to display all routes, including those not eligible to be successor or feasible successor routes.

show ip eigrp traffic

Displays the number of EIGRP packets sent and received. This command displays statistics on hello packets, updates, queries, replies, and acknowledgments.

Table 3-9 describes debug commands used to verify EIGRP operation. Other options might be available with these commands; use the Cisco IOS integrated help feature to see the full command syntax.

Table 3-9. EIGRP debug Commands

Command

Description

debug eigrp packets

Displays the types of EIGRP packets sent and received. A maximum of 11 packet types can be selected for individual or group display.

debug ip eigrp

Displays packets that are sent and received on an interface. Because this command generates large amounts of output, use it only when traffic on the network is light.

debug ip eigrp summary

Displays a summarized version of EIGRP activity. It also displays filtering and redistribution numbers and neighbors and distance information.

debug eigrp neighbors

Displays neighbors discovered by EIGRP and the contents of the hello packets.

The following sections provide sample output from some of these commands, using the network in Figure 3-36 to illustrate the configuration, verification, and troubleshooting of EIGRP. Example 3-24 shows the configuration of the R1 router.

Figure 3-36

Figure 3-36 Example Network for EIGRP Verification

Example 3-24. Configuration for Router R1 in Figure 3-36

R1#show running-config
<output omitted>
interface FastEthernet0/0
  ip address 172.16.1.1 255.255.255.0

<output omitted>
interface Serial0/0/1
 bandwidth 64
 ip address 192.168.1.101 255.255.255.224

<output omitted>
router eigrp 100
 network 172.16.1.0 0.0.0.255
 network 192.168.1.0

On the R1 router, EIGRP is enabled in autonomous system 100. The network 172.16.1.0 0.0.0.255 command starts EIGRP on the Fast Ethernet 0/0 interface and allows router R1 to advertise this network. With the wildcard mask used, this command specifies that only interfaces on the 172.16.1.0/24 subnet will participate in EIGRP. Note, however, the full Class B network 172.16.0.0 will be advertised, because EIGRP automatically summarizes routes on the major network boundary by default. The network 192.168.1.0 command starts EIGRP on the serial 0/0/1 interface, and allows router R1 to advertise this network.

Example 3-25 shows the configuration of the R2 router.

Example 3-25. Configuration for Router R2 in Figure 3-36

R2#show running-config
<output omitted>
interface FastEthernet0/0
  ip address 172.17.2.2 255.255.255.0

<output omitted>
interface Serial0/0/1
 bandwidth 64
 ip address 192.168.1.102 255.255.255.224

<output omitted>
router eigrp 100
 network 172.17.2.0 0.0.0.255
 network 192.168.1.0

EIGRP is also enabled in autonomous system 100 on the R2 router. The network 172.17.2.0 0.0.0.255 command starts EIGRP on the Fast Ethernet 0/0 interface and allows router R2 to advertise this network. With the wildcard mask used, this command specifies that only interfaces on the 172.17.2.0/24 subnet will participate in EIGRP. Note, however, the full Class B network 172.17.0.0 will be advertised, because EIGRP automatically summarizes routes on the major network boundary by default. The network 192.168.1.0 command starts EIGRP on the serial 0/0/1 interface and allows router R2 to advertise this network.

show ip route and show ip route eigrp for EIGRP Examples

To verify that the router recognizes EIGRP routes for any neighbors, use the show ip route eigrp command, as shown in Example 3-26. Example 3-27 exhibits the show ip route command, which displays the full IP routing table, including the EIGRP routes.

Example 3-26. show ip route eigrp Command Output

R1#show ip route eigrp
D    172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:07:01, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:05:13, Null0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
D       192.168.1.0/24 is a summary, 00:05:13, Null0

Example 3-27. show ip route Command Output

R1#show ip route
<output omitted>
Gateway of last resort is not set
D    172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:06:55, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:05:07, Null0
C       172.16.1.0/24 is directly connected, FastEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.96/27 is directly connected, Serial0/0/1
D       192.168.1.0/24 is a summary, 00:05:07, Null0

Using the highlighted line in Example 3-26 as an example, the fields in the routing table are interpreted as follows:

  • Internal EIGRP routes are identified with a D in the leftmost column. (External EIGRP routes, not shown in this example, are identified with a D EX in the leftmost column.)
  • The next column is the network number (172.17.0.0/16 in this example).
  • After each network number is a field in brackets (90/40514560 in this example). The second number in brackets is the EIGRP metric. As discussed in the "EIGRP Metric Calculation" section earlier in this chapter, the default EIGRP metric is the least-cost bandwidth plus the accumulated delays. The EIGRP metric for a network is the same as its FD in the EIGRP topology table.

    The first number, 90 in this case, is the administrative distance. Recall from Chapter 2 that administrative distance is used to select the best path when a router learns two or more routes to exactly the same destination from different routing sources. For example, consider that this router uses RIP and EIGRP and that RIP has a route to network 172.17.0.0 that is three hops away. The router, without the administrative distance, cannot compare three hops to an EIGRP metric of 40,514,560. The router does not know the bandwidth associated with hops, and EIGRP does not use hop count as a metric.

    To correct this problem, Cisco established an administrative distance for each routing protocol: the lower the value, the more preferred the route is. By default, EIGRP internal routes have an administrative distance of 90, and RIP has an administrative distance of 120. Because EIGRP has a metric based on bandwidth and delays, it is preferred over RIP's hop count metric. As a result, in this example, the EIGRP route would be installed in the routing table.

  • The next field, via 192.168.1.102 in this example, is the address of the next-hop router to which this router passes packets destined for 172.17.0.0/16. The next-hop address in the routing table is the same as the successor in the EIGRP topology table.
  • The route also has a time associated with it (00:07:01 in this example); this is the length of time since EIGRP last advertised this network to this router. EIGRP does not refresh routes periodically; it resends the routing table only when neighbor adjacencies change.
  • The interface, serial 0/0/1 in this case, indicates the interface out which packets for 172.17.0.0 are sent.

Notice that the routing table includes routes, to null0, for the advertised (summarized) routes. Cisco IOS Software automatically puts these routes in the table; they are called summary routes. Null 0 is a directly connected, software-only interface. The use of the null0 interface prevents the router from trying to forward traffic to other routers in search of a more precise, longer match. For example, if the R1 router in Figure 3-36 receives a packet to an unknown subnet that is part of the summarized range—172.16.3.5 for example—the packet matches the summary route based on the longest match. The packet is forwarded to the null0 interface (in other words, it is dropped, or sent to the bit bucket), which prevents the router from forwarding the packet to a default route and possibly creating a routing loop.

show ip protocols Example

Use the show ip protocols command to provide information about any and all dynamic routing protocols running on the router.

As shown in Example 3-28, the command output displays any route filtering occurring on EIGRP outbound or inbound updates. It also identifies whether EIGRP is generating a default network or receiving a default network in EIGRP updates and provides information about additional settings for EIGRP, such as default K values, hop count, and variance.

Example 3-28. show ip protocols Command Output

R1#show ip protocols
Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Automatic address summarization:
    192.168.1.0/24 for FastEthernet0/0
      Summarizing with metric 40512000
    172.16.0.0/16 for Serial0/0/1
      Summarizing with metric 28160
  Maximum path: 4
  Routing for Networks:
    172.16.1.0/24
    192.168.1.0
  Routing Information Sources:
    Gateway           Distance    Last Update
    (this router)           90    00:09:38
    Gateway           Distance    Last Update
    192.168.1.102           90    00:09:40
Distance: internal 90 external 170

The output in Example 3-28 also indicates that automatic summarization is enabled (this is the default) and that the router is allowed to load-balance over a maximum of four paths. Cisco IOS Software allows configuration of up to 16 paths for equal-cost load balancing, using the maximum-paths router configuration command.

The networks for which the router is routing are also displayed. As shown in Example 3-28, the format of the output varies, depending on the use of the wildcard mask in the network command. If a wildcard mask is used, the network address is displayed with a prefix length. If a wildcard mask is not used, the Class A, B, or C major network is displayed.

The routing information source portion of this command output identifies all other routers that have an EIGRP neighbor relationship with this router. The show ip eigrp neighbors command provides a detailed display of EIGRP neighbors.

The show ip protocols command output also provides the two administrative distances for EIGRP. An administrative distance of 90 applies to networks from other routers inside the same autonomous system number; these are considered internal networks. An administrative distance of 170 applies to networks introduced to EIGRP for this autonomous system through redistribution; these are called external networks.

show ip eigrp interfaces Example

Example 3-29 demonstrates show ip eigrp interfaces command output.

Example 3-29. show ip eigrp interfaces Command Output

R1#show ip eigrp interfaces
IP-EIGRP interfaces for process 100
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              0        0/0         0       0/10           0           0
Se0/0/1            1        0/0        10      10/380        424           0

The show ip eigrp interfaces command displays information about interfaces configured for EIGRP. This output includes the following key elements:

  • Interface—Interface over which EIGRP is configured
  • Peers—Number of directly connected EIGRP neighbors
  • Xmit Queue Un/Reliable—Number of packets remaining in the Unreliable and Reliable transmit queues
  • Mean SRTT—Mean SRTT interval, in milliseconds
  • Pacing Time Un/Reliable—Pacing time used to determine when EIGRP packets should be sent out the interface (for unreliable and reliable packets)
  • Multicast Flow Timer—Maximum number of seconds that the router will wait for an ACK packet after sending a multicast EIGRP packet, before switching from multicast to unicast
  • Pending Routes—Number of routes in the packets in the transmit queue waiting to be sent

show ip eigrp topology Example

Another command used to verify EIGRP operations is the show ip eigrp topology command; Example 3-30 demonstrates output generated from this command.

Example 3-30. show ip eigrp topology Command Output

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(192.168.1.101)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
P 192.168.1.96/27, 1 successors, FD is 40512000
        via Connected, Serial0/0/1
P 192.168.1.0/24, 1 successors, FD is 40512000
        via Summary (40512000/0), Null0
P 172.16.0.0/16, 1 successors, FD is 28160
        via Summary (28160/0), Null0
P 172.16.1.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 172.17.0.0/16, 1 successors, FD is 40514560
        via 192.168.1.102 (40514560/28160), Serial0/0/1

The command output illustrates that router R1 has an ID of 192.168.1.101 and is in autonomous system 100. The EIGRP ID is the highest IP address on an active interface for this router.

The command output also lists the networks known by this router through the EIGRP routing process. The codes used in the first column of this output are as follows:

  • Passive (P)—This network is available, and installation can occur in the routing table. Passive is the correct state for a stable network.
  • Active (A)—This network is currently unavailable, and installation cannot occur in the routing table. Being active means that outstanding queries exist for this network.
  • Update (U)—This network is being updated (placed in an update packet). This code also applies if the router is waiting for an acknowledgment for this update packet.
  • Query (Q)—There is an outstanding query packet for this network other than being in the active state. This code also applies if the router is waiting for an acknowledgment for a query packet.
  • Reply (R)—The router is generating a reply for this network or is waiting for an acknowledgment for the reply packet.
  • Stuck-in-active (S)—There is an EIGRP convergence problem for this network.

The number of successors available for a route is indicated in the command output. The number of successors corresponds to the number of best routes with equal cost; all networks in Example 3-30 have one successor.

For each network, the FD is listed next, followed by an indication of how the route was learned, such as the next-hop address if the route was learned via another router. Next is a field in brackets. The first number in the brackets is the FD for that network through the next-hop router, and the second number in the brackets is the AD from the next-hop router to the destination network.

show ip eigrp traffic Example

To display the number of various EIGRP packets sent and received, use the show ip eigrp traffic command, as illustrated in Example 3-31. For example, in this network, router R1 has sent 429 hello messages and received 192 hello messages.

Example 3-31. show ip eigrp traffic Command Output

R1#show ip eigrp traffic
IP-EIGRP Traffic Statistics for AS 100
  Hellos sent/received: 429/192
  Updates sent/received: 4/4
  Queries sent/received: 1/0
  Replies sent/received: 0/1
  Acks sent/received: 4/3
  Input queue high water mark 1, 0 drops
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
  Hello Process ID: 113
PDM Process ID: 73

debug eigrp packets Examples

You can use the debug eigrp packets command to verify EIGRP connectivity. This command displays the types of EIGRP packets sent and received by the router that this command is executed on. Different packet types can be selected for individual or group display. Example 3-32 shows some output from this command on R2, when an interface on R1 comes up.

Example 3-32. debug eigrp packets Command Output on R2 When a Neighbor's Interface Comes Up

R2#debug eigrp packets
EIGRP Packets debugging is on
    (UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
*May 11 04:02:55.821: EIGRP: Sending HELLO on Serial0/0/1
*May 11 04:02:55.821:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*May 11 04:02:58.309: EIGRP: Received HELLO on Serial0/0/1 nbr 192.168.1.101
*May 11 04:02:58.309:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/0
*May 11 04:02:58.585: EIGRP: Sending HELLO on FastEthernet0/0
*May 11 04:02:58.585:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*May 11 04:02:59.093: EIGRP: Received UPDATE on Serial0/0/1 nbr 192.168.1.101
*May 11 04:02:59.093:   AS 100, Flags 0x0, Seq 5/4 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/0
*May 11 04:02:59.093: EIGRP: Enqueueing ACK on Serial0/0/1 nbr 192.168.1.101
*May 11 04:02:59.093:   Ack seq 5 iidbQ un/rely 0/0 peerQ un/rely 1/0
*May 11 04:02:59.097: EIGRP: Sending ACK on Serial0/0/1 nbr 192.168.1.101
*May 11 04:02:59.097:   AS 100, Flags 0x0, Seq 0/5 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 1/0
*May 11 04:02:59.109: EIGRP: Enqueueing UPDATE on Serial0/0/1 iidbQ un/rely 0/1 serno 9-9
*May 11 04:02:59.113: EIGRP: Enqueueing UPDATE on Serial0/0/1 nbr 192.168.1.101 iidbQ un/
  rely 0/0 peerQ un/rely 0/0 serno 9-9
*May 11 04:02:59.113: EIGRP: Sending UPDATE on Serial0/0/1 nbr 192.168.1.101
*May 11 04:02:59.113:   AS 100, Flags 0x0, Seq 5/5 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/1 serno 9-9
*May 11 04:02:59.133: EIGRP: Received ACK on Serial0/0/1 nbr 192.168.1.101
*May 11 04:02:59.133:   AS 100, Flags 0x0, Seq 0/5 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/1
*May 11 04:02:59.133: EIGRP: Serial0/0/1 multicast flow blocking cleared
R2#
*May 11 04:03:00.441: EIGRP: Sending HELLO on Serial0/0/1
*May 11 04:03:00.441:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*May 11 04:03:03.209: EIGRP: Received HELLO on Serial0/0/1 nbr 192.168.1.101
*May 11 04:03:03.209:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/0

The debug eigrp packets command traces transmission and receipt of EIGRP packets. The output in Example 3-32 shows normal transmission and receipt of EIGRP packets. The serial link is an HDLC point-to-point link; therefore, the default hello time interval is 5 seconds. Hello packets are sent unreliably, so the sequence number (Seq) does not increment.

In this sample output, when R2 receives an update from R1, values appear in the sequence number field. Seq 5/4 indicates that 192.168.1.101 is sending this packet as sequence number 5 to R2 and that sequence number 4 has been received from R2 by neighbor 192.168.1.101. 192.168.1.101 is expecting to receive sequence number 5 in the next reliable packet from R2.

R2 returns an ACK packet with Seq 0/5. The acknowledgment is sent as an unreliable packet, but the neighbor unreliable/reliable flag (un/rel 1/0) is set. This means that the acknowledgment was sent in response to a reliable packet.

The serial number (serno 9-9) reflects the number of changes that the two neighbors register in their EIGRP topology tables. A single update can contain more than 100 networks that all produce an update, because all are now unavailable.

When an interface on R1 (R2's EIGRP neighbor 192.168.1.101) is shut down, the resulting output on R2 is shown in Example 3-33. R1 sends a query packet to R2 to determine whether R2 knows a path to the lost network. R2 responds with an ACK packet to acknowledge the query packet; a reliable packet must be explicitly acknowledged with an ACK packet. R2 also responds to the query with a reply packet. The serial number reference (10-12) represents the number of changes to the topology table since the start of the neighbor relationship between these two EIGRP neighbors.

Example 3-33. debug eigrp packets Command Output on R2 When a Neighbor's Interface Is Shut Down

R2#debug eigrp packets
*May 11 04:20:43.361: EIGRP: Received QUERY on Serial0/0/1 nbr 192.168.1.101
*May 11 04:20:43.361:   AS 100, Flags 0x0, Seq 6/5 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/0
*May 11 04:20:43.361: EIGRP: Enqueueing ACK on Serial0/0/1 nbr 192.168.1.101
*May 11 04:20:43.361:   Ack seq 6 iidbQ un/rely 0/0 peerQ un/rely 1/0
*May 11 04:20:43.365: EIGRP: Sending ACK on Serial0/0/1 nbr 192.168.1.101
*May 11 04:20:43.365:   AS 100, Flags 0x0, Seq 0/6 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 1/0
*May 11 04:20:43.373: EIGRP: Enqueueing REPLY on Serial0/0/1 nbr 192.168.1.101 iidbQ un/
  rely 0/1 peerQ un/rely 0/0 serno 10-12
*May 11 04:20:43.377: EIGRP: Requeued unicast on Serial0/0/1
R2#
*May 11 04:20:43.381: EIGRP: Sending REPLY on Serial0/0/1 nbr 192.168.1.101
*May 11 04:20:43.381:   AS 100, Flags 0x0, Seq 6/6 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/1 serno 10-12
*May 11 04:20:43.405: EIGRP: Received ACK on Serial0/0/1 nbr 192.168.1.101
*May 11 04:20:43.405:   AS 100, Flags 0x0, Seq 0/6 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/
  rely 0/1

debug ip eigrp Examples

You can use the debug ip eigrp command to verify EIGRP operation. This command displays EIGRP packets that this router sends and receives. Example 3-34 shows the contents of the updates that are reported when you use the debug ip eigrp command on R2 to monitor when an interface on R1 comes up.

Example 3-34. debug ip eigrp Command Output on R2 When a Neighbor's Interface Comes Up

R2#debug ip eigrp
IP-EIGRP Route Events debugging is on
R2#
*May 11 04:24:05.261: IP-EIGRP(Default-IP-Routing-Table:100): Processing incoming UPDATE
  packet
*May 11 04:24:05.261: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.1.0/24
 M 4294967295 - 40000000 4294967295 SM 4294967295 - 40000000 4294967295
*May 11 04:24:05.261: IP-EIGRP(Default-IP-Routing-Table:100): Int 172.16.0.0/16
M 40514560 - 40000000 514560 SM 28160 - 25600 2560
*May 11 04:24:05.261: IP-EIGRP(Default-IP-Routing-Table:100): route installed for
172.16.0.0  ()
*May 11 04:24:05.277: IP-EIGRP(Default-IP-Routing-Table:100): Int 172.16.0.0/16 metric
40514560 - 40000000 514560

In this example, an internal route (indicated by Int) for 172.16.0.0/16 is advertised to R2.

Recall that by default the EIGRP metric is equal to the bandwidth plus the delay. The EIGRP process uses the source metric (SM) information in the update to calculate the AD and place it in the EIGRP topology table. In this example, the SM information is SM 28160 – 25600 2560, which means the source metric (the AD) = 28160 = 25600 (the bandwidth) + 2560 (the delay).

The EIGRP metric calculation for the total delay uses the metric (M) information in the update. In this example, the M information is M 40514560 – 40000000 514560, which means the metric (the FD) = 40514560 = 40000000 (the bandwidth) + 514560 (the delay).

The EIGRP metric for this route is equal to the FD and, therefore, is 40,514,560.

Example 3-35 illustrates what occurs when R2 processes an incoming query packet for network 172.16.0.0/16 when the interface on the neighboring router (R1) that leads to that network is shut down. Note that comments (preceded by an exclamation point [!]) have been added to this output for easier understanding.

Example 3-35. debug ip eigrp Command Output

R2#debug ip eigrp
IP-EIGRP Route Events debugging is on
R2#
! An interface on EIGRP neighbor R1 was shutdown
! R2 receives a query looking for a lost path from R1
*May 11 04:35:44.281: IP-EIGRP(Default-IP-Routing-Table:100): Processing incoming QUERY
  packet
*May 11 04:35:44.281: IP-EIGRP(Default-IP-Routing-Table:100): Int 172.16.1.0/24
M 4294967295 - 0 4294967295 SM 4294967295 - 0 4294967295
*May 11 04:35:44.281: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.1.0/24
 M 4294967295 - 0 4294967295 SM 4294967295 - 0 4294967295
*May 11 04:35:44.281: IP-EIGRP(Default-IP-Routing-Table:100): Int 172.16.0.0/16
M 4294967295 - 0 4294967295 SM 4294967295 - 0 4294967295
! R2 realizes that if it cannot use R1 for this network then
! it does not have an entry in the routing table for this network
*May 11 04:35:44.281: IP-EIGRP(Default-IP-Routing-Table:100): 172.16.0.0/16 routing table 
  not updated thru 192.168.1.101
R2#
*May 11 04:35:44.301: IP-EIGRP(Default-IP-Routing-Table:100): 172.16.1.0/24 - not in IP
  routing table
*May 11 04:35:44.301: IP-EIGRP(Default-IP-Routing-Table:100): Int 172.16.1.0/24 metric
  4294967295 - 0 4294967295
*May 11 04:35:44.301: IP-EIGRP(Default-IP-Routing-Table:100): 192.168.1.0/24 - poison
  advertise out Serial0/0/1
*May 11 04:35:44.301: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.1.0/24 metric
  40512000 - 40000000 512000
*May 11 04:35:44.301: IP-EIGRP(Default-IP-Routing-Table:100): 172.16.0.0/16 - not in IP
  routing table
! R2 sends an update to R1 saying it does not know how to reach that network either
*May 11 04:35:44.301: IP-EIGRP(Default-IP-Routing-Table:100): Int 172.16.0.0/16 metric 
  4294967295 - 40000000 4294967295
R2#

The neighbor previously advertised 172.16.0.0/16 to this router. The query performs the following two functions:

  • R2 discovers that its neighbor no longer knows how to get to network 172.16.0.0/16. The metric value (4,294,967,295) is the highest possible value; it indicates that the route is unreachable. R2 removes this entry from the EIGRP topology table and looks for alternative EIGRP routes.
  • The debug output indicates that the routing table is not updated; this means that EIGRP did not find an alternative route to the network. The next statement verifies that the EIGRP process has removed the old route and that the route is not in the IP routing table. R2 then informs the neighbor that it does not have a path to this network either.
  • + Share This
  • 🔖 Save To Your Account