Home > Articles > Operating Systems, Server > Solaris

Like this article? We recommend

Runbook for Creating the Solaris Volume Manager Software State Database

In runbooks, the following disk names are assumed.

primary mirror c0t0d0
secondary mirror c0t1d0
backup system disk c0t2d0
hot spare disk c0t3d0

These names are placeholders for the real disk names. In most cases, the logical disk names will be different.

As a first step for each of the presented configurations, the Solaris Volume Manager software state database replicas must be created. Providing more than one replica protects the configuration against losing the definition of the volumes.

Solaris Volume Manager software has the following behavior with respect to loss of replicas:

  • The system panics when more than half of the replicas break.

  • The system does not boot unless more than half of the replicas are available. The system administrator must remove broken replicas in single-user mode to restore the majority.

Ideally, three replicas are created, each on a different disk, connected to a different host bus adapter. In this runbook, we assume that only the system disks are under control of Solaris Volume Manager software, and this ideal replica configuration is not always possible.

Be aware that the optimal replica configuration may be different from the one presented here, in the case that the data disks are also under control of Solaris Volume Manager software and can contain state database replicas.

Replica creation for the two-disk configuration (and disabling the quorum rule).

metadb -a -f -c 2 c0t0d0s7
 metadb -a -c 2 c0t1d0s7
 echo set md:mirrored_root_flag=1 >> /etc/system

Replica creation for the three-disk and four-disk configuration. (Do not create unnecessary multiple copies per disk.)

metadb -a -f c0t0d0s7
metadb -a   c0t1d0s7
metadb -a   c0t2d0s7

Runbook for the Two-Disk Configuration

Copy the VTOC to the mirror disk. It is not necessary to make this disk bootable because the bootblock from the first submirror is copied to the second submirror during the resync operation. Use the prtvtoc command as follows.

prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2

Create the state database replicas as described in the previous runbook.

Create the volumes, as follows.

metainit -f d10 1 1 c0t0d0s0
metainit -f d11 1 1 c0t0d0s1
metainit -f d13 1 1 c0t0d0s3
 
metainit d20 1 1 c0t1d0s0
metainit d21 1 1 c0t1d0s1
metainit d23 1 1 c0t1d0s3

metainit d0 -m d10
metainit d1 -m d11
metainit d3 -m d13

Make the system boot from the mirror, as follows.

metaroot d0

Replace the remaining partitions with volumes in /etc/vfstab, as follows.

cp /etc/vfstab /etc/vfstab.tmp
 cat /etc/vfstab.tmp | \
   sed s,/dev/dsk/c0t0d0s1,/dev/md/dsk/d1, | \
   sed s,/dev/dsk/c0t0d0s3,/dev/md/dsk/d3, | \ 
   sed s,/dev/rdsk/c0t0d0s3,/dev/md/rdsk/d3, > /etc/vfstab

Document the physical device name of the two disks in the mirror, as shown in the underlined portion of the following example for the disk c0t1d0.

ls -l /dev/rdsk/c0t1d0s0
lrwxrwxrwx  1 root  other  68 Nov 30 15:43 /dev/rdsk/c0t1d0s0 -> 
../../devices/ssm@0,0/pci@18,700000/pci@2/SUNW,isptwo@4/sd@1,0:a,raw

Halt the system, as follows.

init 0

Create an OBP alias for the bootable disks. Beware that for disks on certain controllers, the sd driver name must be replaced by disk. Verify this, using the OBP show-disks command before entering the nvalias commands.

ok nvalias bootdisk /ssm@0,0/pci@18,700000/pci@2/SUNW,isptwo@4/sd@0,0:a
ok nvalias mirrdisk /ssm@0,0/pci@18,700000/pci@2/SUNW,isptwo@4/sd@1,0:a
ok setenv boot-device bootdisk mirrdisk
ok boot

Attach the submirrors, as follows.

metattach d0 d20
metattach d1 d21
metattach d3 d23

Runbook for the Three-Disk Configuration

Copy the VTOC and the boot block to the contingency disk, as shown here.

prtvtoc /dev/rdsk/c0t0d0s2| fmthard -s - /dev/rdsk/c0t2d0s2
/usr/sbin/installboot /usr/platform/´uname -i´/lib/fs/ufs/bootblk 
/dev/rdsk/c0t2d0s2

Create the state databases and volumes as described in the runbook for the two-disk configuration.

Perform a full backup of the file systems to the backup system disk and modify system files so that the disk becomes bootable from partitions.

newfs /dev/rdsk/c0t2d0s0
mount /dev/dsk/c0t2d0s0 /mnt
ufsdump 0f - / | (cd /mnt; ufsrestore rf - )
cat /etc/vfstab | \
   sed s,/dev/md/dsk/d0,/dev/dsk/c0t2d0s0, | \
   sed s,/dev/md/dsk/d1,/dev/dsk/c0t2d0s1, | \
   sed s,/dev/md/dsk/d3,/dev/dsk/c0t2d0s3, | \
   sed s,/dev/md/rdsk/d0,/dev/rdsk/c0t2d0s0, | \
   sed s,/dev/md/rdsk/d1,/dev/rdsk/c0t2d0s1, | \
   sed s,/dev/md/rdsk/d3,/dev/rdsk/c0t2d0s3, > /mnt/etc/vfstab
 cat /etc/system | grep -v rootdev > /mnt/etc/system
 umount /mnt

 newfs /dev/rdsk/c0t2d0s3
 mount /dev/dsk/c0t2d0s3 /mnt
 ufsdump 0f - /var | (cd /mnt; ufsrestore rf - )
 umount /mnt

Put the preceding commands in a script /usr/local/system-backup, make the script executable, and execute from cron, as shown here. Note that this is the most rudimentary implementation. You may want to refine this by using a combination of full and incremental ufsdump and more sophisticated update schemes.

10 1 * * 0  /usr/local/system-backup

Create an OBP alias for the contingency disk, as described earlier.

Runbook for the Four-Disk Configuration

Copy the VTOC and boot block to the fourth disk. This disk must also be made bootable for the unlikely situation that the hot spare actually kicks in and later becomes the only surviving disk in the mirror.

prtvtoc /dev/rdsk/c0t0d0s2| fmthard -s - /dev/rdsk/c0t3d0s2
/usr/sbin/installboot /usr/platform/´uname -i´/lib/fs/ufs/bootblk 
/dev/rdsk/c0t3d0s2

Create the state database replicas and volumes, configure the contingency disk as described in the previous runbook.

Configure the hot spare pools. Each mirror gets its own hot spare pool with a partition of the corresponding size, as follows. Putting all spare partitions in the same pool is simpler, but correct behavior then depends on the order of the partitions in the pool.

metahs -a hsp000 c0t3d0s0
metaparam -h hsp000 d10
metaparam -h hsp000 d20
 
metahs -a hsp001 c0t3d0s1
metaparam -h hsp001 d11
metaparam -h hsp001 d21
 
metahs -a hsp003 c0t3d0s3
metaparam -h hsp003 d13
metaparam -h hsp003 d23

Use of the SUNBEsdm Package

With this article, we provide the SUNBEsdm package. The package contains a script sdmsetup that greatly reduces the manual work to implement the runbooks mentioned in this article. The SUNBEsdm package is not supported by Sun, and is only provided, here, to demonstrate our example.

Take care to minimize the risk of running the script sdmsetup. This script does not modify your system, but rather generates the commands to be executed, allowing for inspection prior to execution.

The prerequisites for sdmsetup are as follows:

  • Solstice DiskSuite 4.2.1 software must be installed.

  • No state database or volume must already exist.

  • A free slice must exist to be used as state database.

  • A free slice must exist to be used as dump device (optional).

  • All currently mounted file systems must correspond to entries in /etc/vfstab.

  • All used disks must be of the same geometry.

  • Slice 2 on all disks must cover the entire disk.

A README file in the package contains detailed instructions for the usage of the script.

Ordering Sun Documents

The SunDocsSM program provides more than 250 manuals from Sun Microsystems, Inc. If you live in the United States, Canada, Europe, or Japan, you can purchase documentation sets or individual manuals through this program.

Accessing Sun Documentation Online

The docs.sun.com web site enables you to access Sun technical documentation online. You can browse the docs.sun.com archive or search for a specific book title or subject. The URL is http://docs.sun.com/

To reference Sun BluePrints OnLine articles, visit the Sun BluePrints OnLine Web site at: http://www.sun.com/blueprints/online.html

InformIT Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from InformIT and its family of brands. I can unsubscribe at any time.

Overview


Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information


To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites, develop new products and services, conduct educational research and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@informit.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information


Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security


Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children


This site is not directed to children under the age of 13.

Marketing


Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information


If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out


Users can always make an informed choice as to whether they should proceed with certain services offered by InformIT. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.informit.com/u.aspx.

Sale of Personal Information


Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents


California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure


Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links


This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact


Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice


We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020