Home > Articles > Certification > Cisco Certification > CCNP

  • Print
  • + Share This
This chapter is from the book

Practical Exercise 8-2 Solution

Examples 8-44 and 8-45 show the bridging configurations of both DSL CPE devices.

Example 8-44 Configuration Output for lab-827A

lab-827A#show running-config
Building configuration...
Current configuration : 763 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lab-827A
!
ip subnet-zero
no ip routing
!
interface Ethernet0
 ip address 10.2.2.2 255.255.255.0
 no ip route-cache
 bridge-group 1
 hold-queue 100 out
!
interface ATM0
 mac-address 0001.96a4.84ac
 ip address 10.2.2.2 255.255.255.0
 no ip route-cache
 no atm ilmi-keepalive
 pvc 0/35
 encapsulation aal5snap
 !
 dsl operating-mode auto
 dsl power-cutback 0
 bridge-group 1
!
ip classless
ip http server
!
bridge 1 protocol ieee
call rsvp-sync
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

Example 8-45 Configuration Output for lab-827B

lab-827B#show running-config
Building configuration...
Current configuration : 670 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-827B
!
no logging console
!
ip subnet-zero
no ip routing
!
interface Ethernet0
 ip address 10.2.2.3 255.255.255.0
 no ip route-cache
 bridge-group 1
 hold-queue 100 out
!
interface ATM0
 mac-address 0001.96a4.8fae
 ip address 10.2.2.3 255.255.255.0
 no ip route-cache
 no atm ilmi-keepalive
 pvc 0/35
 encapsulation aal5snap
 !
 dsl operating-mode auto
 bridge-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
bridge 1 protocol ieee
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

Example 8-46 shows the bridging configuration of the Cisco 6400.

Example 8-46 Configuration Output for lab-6400NRP

lab-6400NRP#show running-config
Building configuration...
Current configuration : 907 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-6400NRP
!
logging rate-limit console 10 except errors
no logging console
!
redundancy
 main-cpu
 auto-sync standard
 no secondary console enable
ip subnet-zero
!
bridge irb
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 hold-queue 500 in
!
interface ATM0/0/0.135 point-to-point
 pvc 1/35
 encapsulation aal5snap
 !
 bridge-group 1
!
interface ATM0/0/0.235 point-to-point
 pvc 2/35
 encapsulation aal5snap
 !
 bridge-group 1
!
interface Ethernet0/0/1
 ip address negotiated
!
interface Ethernet0/0/0
 no ip address
 shutdown
!
interface FastEthernet0/0/0
 no ip address
 half-duplex
!
interface BVI1
 ip address 10.2.2.1 255.255.255.0
!
ip classless
ip http server
!
!
!
!
bridge 1 protocol ieee
 bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
end

Example 8-47 shows that Bridge group 1 is running the IEEE Spanning Tree Protocol.

Example 8-47 Displaying the Spanning Tree Protocol (IEEE)

lab-6400NRP#show spanning-tree 1
 Bridge group 1 is executing the ieee compatible Spanning Tree protocol
 Bridge Identifier has priority 32768, address 0000.0c7f.70fc
 Configured hello time 2, max age 20, forward delay 15
 We are the root of the spanning tree
 Topology change flag not set, detected flag not set
 Number of topology changes 4 last change occurred 00:35:16 ago
     from ATM0/0/0.235
 Times: hold 1, topology change 35, notification 2
     hello 2, max age 20, forward delay 15
 Timers: hello 0, topology change 0, notification 0, aging 300
 Port 6 (ATM0/0/0.135) of Bridge group 1 is forwarding
  Port path cost 14, Port priority 128, Port Identifier 128.6.
  Designated root has priority 32768, address 0000.0c7f.70fc
  Designated bridge has priority 32768, address 0000.0c7f.70fc
  Designated port id is 128.6, designated path cost 0
  Timers: message age 0, forward delay 0, hold 0
  Number of transitions to forwarding state: 1
  BPDU: sent 1663, received 2
 Port 8 (ATM0/0/0.235) of Bridge group 1 is forwarding
  Port path cost 14, Port priority 128, Port Identifier 128.8.
  Designated root has priority 32768, address 0000.0c7f.70fc
  Designated bridge has priority 32768, address 0000.0c7f.70fc
  Designated port id is 128.8, designated path cost 0
  Timers: message age 0, forward delay 0, hold 0
  Number of transitions to forwarding state: 1
  BPDU: sent 1527, received 1

Example 8-48 shows the IP and MAC addresses of lab-827A and lab-827B. show arp is a useful command to verify whether bridging is configured properly.

Example 8-48 Displaying ARP Information

lab-6400NRP#show arp
Protocol Address     Age (min) Hardware Addr  Type  Interface
Internet 10.2.2.2        31  0001.96a4.84ac ARPA  BVI1
Internet 10.2.2.3        31  0001.96a4.8fae ARPA  BVI1
Internet 10.2.2.1        -  0050.7359.35a6 ARPA  BVI1

Example 8-49 illustrates that both subinterfaces are in the same bridge group (Bridge group 1), and traffic is passed among them. show bridge is another useful command to debug RFC 1483 bridging.

Example 8-49 Displaying Classes of Entries in the Bridge Forwarding Database

lab-6400NRP#show bridge verbose
Total of 300 station blocks, 298 free
Codes: P - permanent, S - self
BG Hash   Address   Action Interface   VC  Age  RX count  TX count
 1 21/0  0001.96a4.8fae forward ATM0/0/0.235  2   0     5     5
 1 28/0  0001.96a4.84ac forward ATM0/0/0.135  1   0    100    100
Flood ports (BG 1)      RX count  TX count
ATM0/0/0.135            0      0
ATM0/0/0.235            0      0
  • + Share This
  • 🔖 Save To Your Account