Home > Articles

  • Print
  • + Share This
This chapter is from the book

This chapter is from the book

Case Study: QoS in the Acme, Inc. Network

Acme, Inc. currently uses five different classes of service on the Acme network. For simplicity's sake, and because of the 3-bit resolution of some QoS technologies, such as 802.1p LAN CoS, MPLS EXP, and IP precedence, Acme IT limits its QoS to classes that can be identified in 3 bits. Traffic is classified at the WAN edge by matching IP precedence values—only the first 3 bits of the ToS byte, which cover 7 DSCP values each.

The policy template shown in Table 5-5 deals with policy marking of packets in Acme. It shows QoS policy for voice, video, and data classifications and their breakout assignments based on circuit speed, allocation per class as a percentage, and the classifications assigned.

Table 5-5 Sample Policy Template Breakdown

Policy Number

30

25

20

15

10

5

 

Bandwidth at Interface Line Rate (in kbps)

 

 

 

 

 

Class

622000

155000

45000 to 34000

34000 to 2048

2048 to 1024

1024 to 256

Management

2%

2%

2%

2%

2%

6%

Voice

EF

10%

33%

33%

33%

33%

33%

Video

AF4

5%

5%

8%

7%

10%

5%

Signaling

AF3

5%

5%

5%

5%

5%

10%

Default

BE

58%

45%

50%

43%

40%

36%

Scavenger

CS1

20%

10%

10%

10%

10%

10%

Total

100%

100%

100%

100%

100%

100%

IP precedence values 6 and 7 are also used for network control traffic (routing protocols). Most of this traffic is link-local (CE-PE only), allowing an individual class of traffic to be set up for this traffic on a WAN port with minimum bandwidth. On the CE side of the CE-to-PE links, it is recommended that a separate class be used for management traffic. On the PE side of the CE-to-PE link, this tends to vary with each provider. This traffic must, at a minimum, be mapped to a high-priority data class of service in the service provider cloud.

QoS for Low-Speed Links: 64 kbps to 1024 kbps

LFI allows large packets on a serial link to be divided into using MLP or Frame Relay encapsulation with FRF.12 fragmentation.

To determine the LFI fragment size, you must consider the packet flow through the router. Following the link fragmentation process and LLQ/CBWFQ's fragment ordering, frag-ments are placed on a transmit ring buffer or TX ring. The TX ring then queues packets onto the physical interface in a FIFO fashion.

Example 5-5 shows examples of applications using MLP and FRF.12.

Example 5-5 LFI on MLP

interface Multilink1     Multilink bundle interface
bandwidtd XXX       Enter Link bandwidth in kbps
 ip address 10.52.255.1 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip authentication mode eigrp 109 md5
 ip authentication key-chain eigrp 100 apple_key
 max-reserved-bandwidth 100
 service-policy output WAN-EDGE  Apply service policy outbound
 ppp multilink       Configure Multilink
 ppp multilink fragment-delay 10  Set the max packet delay in ms
          (determines fragment size)
 ppp multilink interleave    Enable LFI
 multilink-group 1      Apply template to multilink group #1
!
!
interface Serial S:P
 description Multilink PPP group member
 bandwidth XXX       Configure bandwidth equal to full line rate
 no ip address
 no ip redirects
 no ip proxy-arp
 encapsulation ppp
 fair-queue
 ppp multilink       enable multilink on interface
 multilink-group 1      Assign interface to multilink group 1
!
interface Serial S:P     Next I/F when MLP Bundling is required
 description Multilink PPP group member
 bandwidth XXX

Slow-Speed (768-kbps) Leased-Line Recommendation: Use MLP LFI and cRTP

For slow-speed leased lines, LFI is required to minimize serialization delay. Therefore, MLP is the only encapsulation option on slow-speed leased lines because MLP LFI is the only mechanism available for fragmentation and interleaving on such links. Optionally, cRTP can be enabled either as part of the modular QoS command-line interface (MQC) policy map or under the multilink interface (using the ip rtp header-compression command). Ensure that MLP LFI and cRTP, if enabled, are configured on both ends of the point-to-point link, as shown in Example 5-6.

Example 5-6 Slow-Speed (768-kbps) Leased-Line QoS Design Example

!
policy-map WAN-EDGE
class Voice
priority percent 33 ! Maximum recommended LLQ value
compress header ip rtp ! Enables Class-Based cRTP
class Call Signaling
bandwidth percent 5 ! BW guarantee for Call-Signaling
!
interface Multilink1
description 768 kbps Leased-Line to RBR-3745-Left
ip address 10.1.112.1 255.255.255.252
service-policy output WAN-EDGE ! Attaches the MQC policy to Mu1
ppp multilink
ppp multilink fragment delay 10 ! Limits serialization delay to 10 ms
ppp multilink interleave ! Enables interleaving of Voice with Data
ppp multilink group 1
!
_
!
interface Serial1/0
bandwidth 786
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1 ! Includes interface Ser1/0 into Mu1 group
!

These examples cover the application of the WAN-EDGE service policy discussed in Example 5-4. For more examples of configuring the WAN edge, refer to the Cisco QoS Solution Reference Network Design,

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf.

  • + Share This
  • 🔖 Save To Your Account