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Introduction

Welcome to Microsoft Expression Web 2 On Demand, a 
visual quick reference book that shows you how to work 
efficiently with Expression Web 2.  This book provides com-
plete coverage of basic to advanced Expression Web 2 skills.

How This Book Works
You don’t have to read this book in any particular order.
We’ve designed the book so that you can jump in, get the
information you need, and jump out. However, the book does
follow a logical progression from simple tasks to more com-
plex ones. Each task is presented on no more than two facing
pages, which lets you focus on a single task without having
to turn the page. To find the information that you need, just
look up the task in the table of contents or index, and turn to
the page listed. Read the task introduction, follow the step-
by-step instructions in the left column along with screen illus-
trations in the right column, and you’re done.

What’s New
If you’re searching for what’s new in Expression Web 2, just
look for the icon: New!. The new icon appears in the table of
contents and through out this book so you can quickly and
easily identify a new or improved feature in Expression Web.
A complete description of each new feature appears in the
New Features guide in the back of this book.

Keyboard Shortcuts
Most menu commands have a keyboard equivalent, such as
Ctrl+P, as a quicker alternative to using the mouse. A com-
plete list of keyboard shortcuts is available in the back of this
book and on the Web at www.perspection.com.

How You’ll Learn

How This Book Works

What’s New

Keyboard Shortcuts

Step-by-Step Instructions

Real World Examples

Workshop

Get More on the Web

Get Updates

Expression Studio

www.perspection.com
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Step-by-Step
Instructions
This book provides concise step-
by-step instructions that show you
“how” to accomplish a task. Each
set of instructions include illustra-
tions that directly correspond to
the easy-to-read steps. Also
included in the text are time-
savers, tables, and sidebars to
help you work more efficiently or
to teach you more in-depth infor-
mation. A “Did You Know?” pro-
vides tips and techniques to help
you work smarter, while a “See
Also” leads you to other parts of
the book containing related infor-
mation about the task. 

Real World Examples
This book uses real world exam-
ples files to give you a context in
which to use the task. By using
the example files, you won’t waste
time looking for or creating sam-
ple files. You get a start file and a
result file, so you can compare
your work. Not every topic needs
an example file, such as changing
options, so we provide a complete
list of the example files used
through out the book. The exam-
ple files that you need for project
tasks along with a complete file
list are available on the Web at
www.perspection.com.

Real world
examples help
you apply what
you’ve learned
to other tasks.

Illustrations
match the
numbered
steps.

Numbered
steps guide
you through
each task.

Did You Know? alerts
you to tips, techniques
and related information.

See Also points you to
related information in
the book.

Easy-to-follow
introductions
focus on a
single concept.

www.perspection.com
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Workshop
This book shows you how to put
together the individual step-by-
step tasks into indepth projects
with the Workshop. You start each
project with a sample file, work
through the steps, and then com-
pare your results with project
results file at the end. The Work-
shop projects and associated files
are available on the Web at
www.perspection.com.

Get More on the Web
In addition to the information in
this book, you can also get more
information on the Web to help
you get up to speed faster with
Expression Web. Some of the
information includes: 

More Content
◆ Photographs. Download

photographs and other
graphics to use in your Web
pages.

◆ More Content. Download new
content developed after
publication.

You can access these additional
resources on the Web at 
www.perspection.com.

The Workshop
walks you through
indepth projects to
help you put
Expression Web 
to work.

Additional content 
is available on the
Web. You can
download
photographs for
your own use.

www.perspection.com
www.perspection.com
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Get Updates
Like any software, it continues to
change and get better with
updates and patches, so it’s
important to regularly check the
Microsoft Expression Web 
site at www.microsoft.com
/expression, and then click 
Expression Web under Products.

Expression Studio
Expression Web is part of the
Microsoft Expression Studio,
which includes Expression Design,
Blend, and Media. Expression
Design is a professional illustra-
tion and graphic design tool that
lets you build compelling ele-
ments for both Web and desktop
application user interfaces.
Expression Blend is the profes-
sional design tool to create engag-
ing, Web-connected, user
experiences for Windows. Expres-
sion Media is a professional asset
management tool to visually cata-
log and organize all your digital
assets for effortless retrieval and
presentation. See Chapter 16,
“Working with Expression Studio”
on page 385 for more information
and step-by-step instructions for
using individual Expression 
Studio programs.

Check the
Expression Web
onlne site to Get
Updates.

Expression Studio
combines Web
tools to create
an expanded Web
development
environment.

www.microsoft.com/expression
www.microsoft.com/expression


Working with Web Pages

Introduction

Once on the Web, you can open other Web pages in the
Folder List or Folders views, or you can even open up
another page using the Windows menu. Microsoft Expression
Web provides several ways to navigate between pages. After
you open a Web page, you can use the document tabs at the
top of the editing window in Design view, choose the Web
page’s name from the Window menu, or press Ctrl+Tab until
the page you want appears in the window to navigate
between pages. 

One of the most user-friendly components of Expression
Web is its capability to automatically convert text and images
into HTML format. When you save a Web site or Web page, it
is actually being saved in HTML format. After you create a
Web site, you can use the Folder List view to quickly and eas-
ily manage individual Web pages.

When looking at a Web site, there are certain details that
can make your Web pages a site that visitors will return to.
Microsoft Expression Web helps you generate that type of
site.  Visitors might notice a washed out background picture
called a watermark. Or maybe it’s a soothing color or light
sound as you pass over certain feature of the page. Having a
custom feel will express to your visitors that you’ve spent
time and looked at every detail of your site.

You can preview your Web pages in a browser, or in
Design view. Because each browser can display your site dif-
ferently, you will want to examine your site using several of
the most popular browser formats. You can also create your
own template, instead of using one of the built-in page tem-
plates that comes with Expression Web. 3

3
What You’ll Do

Create an HTML Page

Open Web Pages from Within a Web

Navigate Web Pages

Display Web Pages in the HTML Format

Manage Web Pages

Set the Home Page

Change the Web Page Title

Change Web Page Properties

Insert Background Pictures and
Watermarks

Change Background Colors

Add Background Sound

Set Page Size

Preview and Print Web Pages

Export Web Content

Create a Page Template

Use a Dynamic Page Template

Create a Master and Content Page

Save a Web Page with 
Different Formats

Animate Page Transitions

43
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An HTML page is a common Web page. HTML is a coding language
that describes the elements on a Web page and instructs a Web
browser how to display it. As you add elements to an HTML page in
Design view, Expression Web creates the HTML code behind it. If you
are familiar with the HTML language, you can use the Code view to
make code changes. Split view allows you to display Design and Code
view at the same time, which makes it a beneficial learning tool. When
you add an element in Design view, you can view the related code in
Code view. You can use the New submenu on the File menu or the New
button on the Common toolbar to create a new HTML page. With the
Page Editor Options dialog box, you can set the default type for new
documents and the default file extension—either .html or .htm—for
new HTML documents (New!).

Creating an HTML
Page

Create an HTML Page Quickly

Click the Web Site tab for the site
in which you want a new page. 

Use any of the following methods:

◆ Click the File menu, point to
New, and then click HTML.

◆ Click the New button list arrow
on the Common toolbar, and
then click HTML.

◆ Click the New button on the
Common toolbar (applies when
HTML is set as the default
document type).

TIMESAVER Press Ctrl+N to
create a new HTML page.

An untitled Web page appears
without the use of New dialog box. 

Click the Save button on the
Common toolbar, type a name for
the page, and then click Save.

3

2

1
2 New HTML page
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Create an HTML Page

Click the Web Site tab for the site
in which you want a new page. 

Click the New button list arrow on
the Common toolbar, and then
click Page.

In the left pane, click General.

Click HTML.

Click OK.

An untitled Web page appears. 

Click the Save button on the
Common toolbar, type a name for
the page, and then click Save.

Set the Default Document Type

Click the Tools menu, and then
click Page Editor Options.

Click the Authoring tab.

Click the Default Document list
arrow, and then select the
document type you want.

Click the .html or .htm option for
the default HTML file extension
(New!).

To add a byte order mark (BOM) to
a new UTF-8 document, select the
check boxes next to the
extensions you want, or deselect
the ones you don’t want (New!).

Click OK.6

5

4

3

2

1

6

5

4

3

2

1

5

3 4

6

2

5

3

4



Expression Web allows you to multi-task, which means you can have
more than one Web page open at the same time. After you open a Web
site, you can quickly open Web pages in Folders view, or from the
Folder List instead of using the Open button on the Common toolbar or
the Open command on the File menu. If you want to view open Web
pages in a separate Expression Web window, you can display the page,
and then choose Open in New Window from the Window menu. You
can press Alt+Tab to switch between the separate windows. Instead of
starting from scratch to create a new page, you can open a copy of an
existing page with the default new Web page title of Untitled_1.htm.
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Opening Web Pages
from Within a Web

Open a Web Page in Folders
View

Open the Web site with the Web
page you want to open.

Click the Web Site tab.

Click the Folders button.

Double-click the icon or file name
representing the page you want to
access.

4

3

2

1

Did You Know?
You can open a linked page from
Design view. Press and hold Ctrl and
click a hyperlink in the page, or right-
click a hyperlink in a page that’s
already open, and then click Follow
Hyperlink. 3

2

4

See Also
See “Opening an Existing Web Page”
on page 13  for information on opening
an external Web page.
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Open a Web Page Using the
Folder List

Open the Web site with the Web
page you want to open.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

Double-click the page you want to
open.

Open a Copy of a Web Page
Using the Folder List

Open the Web site with the Web
page you want to open.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

Right-click the page you want to
copy, and then click New From
Existing Page.

A new untitled page appears in the
Editing window with content and
formats from the original template
Web page.

Click the Save button on the
Common toolbar.

Navigate to the Web site folder
location where you want to add
pages.

Type a name for the page, or use
the suggested name, and then
click Save.

6

5

4

3

2

1

3

2

1

2 3 Web page opened from Folder List1

2

3

4 1



Expression Web provides several ways to navigate between pages.
After you open a Web page, you can use the document tabs at the top
of the Editing window, choose the Web page’s name from the Window
menu, or press Ctrl+Tab until the page you want appears in the window
to navigate between pages. 
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Navigating Web 
Pages

Navigate Web Pages Using
Document Tabs

Open the Web site with the Web
page you want to display, and then
open the Web page.

Click the document tab with the
page you want to display.

Navigate Web Pages Using the
Windows Menu

Open the Web site with the Web
page you want to display, and then
open the Web page.

Click the Window menu.

This displays a list of up to nine
open Web pages.

Click the page you want to open.
The Web page opens in Page
view.

3

2

1

2

1

1 2

1

3

2



One of the most user-friendly components of Expression Web is its
capability to automatically convert text and images into HTML format. If
you’re familiar with HTML, you might be comfortable enough to work in
this mode. HTML adds a series of format instructions to your content
using tags, such as <i>, that indicate how to format the text for display
on the Web. Use the Quick Tag Selector to select any tag in your Web
page. Use the Quick Tag Editor to insert, wrap, and edit HTML tags.
Expression Web uses colored text to distinguish between elements
when working in HTML format.
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Displaying Web 
Pages in the HTML
Format

Display a Web Page in HTML

Open the Web page you want to
display in the HTML format.

Click the Split or Code button at
the bottom of the window. 

The Web page appears in HTML
coded form.

Display HTML Tags in 
Design View

Open the Web page you want to
display HTML tags.

Click the View menu‚ and then
click Quick Tag Selector.

HTML tags appear in capsule-size,
six-sided frames within the text.

To turn off HTML tags, click the
View menu‚ and then click Quick
Tag Selector again.

3

2

1

2

1

2 Quick Tag Selector1

2

1



After you create a Web site, you can use the Folder List to quickly and
easily manage individual Web pages, files and folders. If a page name
is not exactly what you want, you can quickly rename it. The page
name is the file name in your folder list, such as default.htm. You can
create and name a new folder and move pages to a different location. If
you no longer need or want a Web page, you can remove it. You can
determine whether you want the page deleted from your hard drive or
just from the Web.
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Managing Web Pages

Rename a Web Page

Open the Web site with the Web
page you want to rename.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to rename, and
then click Rename.

TIMESAVER Click the file
name in the Folder List, click the
file again to highlight it.

Select the name of the Web page
file, except the extension, such as
.htm.

Type a new name, and then press
Enter.

5

4

3

2

1

Did You Know?
You can delete a Web page. In the
Folder List, right-click the Web page
you want to delete, click Delete, and
then click Yes.

1

3

2

5
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Create a New Folder

Open the Web site with the Web
page you want to rename.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

Click the New Folder button.

Type a new name, and then press
Enter.

Move a Web Page

Open the Web site with the Web
page you want to move.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, display the page
you want to use.

Drag the page icon to the position
where you want it to occupy on
your site.

4

3

2

1

4

3

2

1 32

4

1

1 4

3

2



52 Chapter 3

When you create a Web site using a template, Expression Web auto-
matically creates a home page called default.htm, which is the first
page visitors see when they visit your site. If you already have a home
page or want to create a different one, you can quickly set the one you
want as the new home page using the Folder List.

Setting the Home 
Page

Set a Web Page as the Home
Page

Open the Web site with the Web
page you want to change.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to set as the new
home page, and then click Set as
Home Page.

3

2

1

2

3

1
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A Web page title is the text that visitors see on the title bar of their Web
browser when they display the Web page. Expression Web automati-
cally sets the Web page title to the same text as the Web page file
name. However, the two perform different tasks. The Web page title
displays a message, while the Web pane name identifies a file. When
you save a Web page, you can change the title. If you didn’t change the
title during the save process or you want to change it, you can use the
Properties dialog box.

Changing the Web
Page Title

Change the Web Page Title

Open the Web site with the Web
page you want to change.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to change, and
then click Properties.

The Properties dialog box opens,
displaying the General tab with the
current title selected.

Type a new name for the title.

Click OK.5

4

3

2

1

Did You Know?
You can change a Web page title in
the Title column. If the Title column in
the Editing window is enabled, you can
select the title text, and then type a
new title.

2

3

1

5

4
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Expression Web allows you to change individual Web page properties
using the Page Properties dialog box. You can change the Web page
title, add a page description, and specify keywords for search engines
(which aren’t used to much anymore; most search engines use other
methods). You can also insert a background sound or image, make the
background image a transparent watermark, or change the color. When
you insert a background sound, it plays once when you open the Web
page unless you select the Loop option. In addition, you can change the
color of page text and hyperlinks. For advanced feature, you can set
page margins, work with code snippets, or specify a language.

Changing Web Page
Properties

Change Web Page Properties

Open the Web site with the Web
page you want to change, and
then click the Web page tab.

Click the File menu, and then click
Properties.

Click the tab you want to use, and
then select the options you want:

◆ General. Use this tab to change
the Web page title, add a page
description, specify keywords
for search engines, and insert a
background sound. You can
also specify a base location,
which changes the root
location (where your home
page is typically located). 

◆ Formatting. Use this tab to
insert a background image, and
make it a watermark
(transparent). To delete a
background, select the image
path and delete it. You can also
use this tab to change the
background, text, or link colors
on the current page. If you
insert a background sound, you
can also select the look option.

Continue Next Page

3

2

1
General properties

Add text

Add background
sound

Change colors

Change background

Formatting properties
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◆ Advanced. Use this tab to set
margins for the current page.
However, it’s more efficient to
make margin changes using
CSS.

◆ Custom. Use this tab to add,
modify, or remove custom code
snippets based on system and
user variables. A code snippet
is a reusable segment of code.

◆ Language. Use this tab to
specify the page language and
HTML encoding you want to
use. These options make sure
your Web browser and
Expression Web uses the right
characters set for the selected
language. The default for HTML
encoding is Unicode (UTF-8).
You can also include a byte
order mark (BOM) (New!).

Click OK.5

Did You Know?
What is a Unicode? A character cod-
ing standard that defines a set of let-
ters, numbers, and symbols that
represent almost all of the written lan-
guages in the world.

Advanced properties

Set margins

Language properties

Set language and
HTML encoding
options

Select to include a byte order mark (BOM)

See Also
See “Adding and Removing Byte Order
Marks” on page 366  for information on
byte order marks (BOM).
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You can use a picture as the background for a page. Pictures can be
taken from elsewhere on your site, a file, clip art, or the Web. You can
also use a background picture in watermark form. A watermark is a
background effect that displays a graphic in a light shade behind your
text on your page. You can use a washed out version of your company
logo, or you can add graphical text such as Under Construction.
Pictures and watermarks display in the background titled across the
page. Be aware that not all Web browsers support watermarks.

Inserting Background
Pictures and
Watermarks

Insert a Background Picture

Open and display the Web page
you want to use. 

Right-click anywhere on the page
to which you want to insert a
background picture, and then click
Page Properties.

Click the Formatting tab.

Select the Background Picture
check box. 

TROUBLE? If the option is
grayed out, you need to open the
master page.

Click Browse.

Locate and select the picture you
want to insert, and then click
Open.

The picture you selected now
opens as a background image.

Click OK.7

6

5

4

3

2

1

Did You Know?
You can avoid picture background
tiling. Make your picture wider than
any typical computer screen. You can
use a solid background color or make
it transparent to achieve the look you
want.

7

3 4

5
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Insert a Background Picture
Watermark

Open and display the Web page
you want to use. 

Right-click anywhere on the page
to which you want to insert a
background picture, and then click
Page Properties.

Click the Formatting tab.

Select the Background Picture
check box. 

Select the Make it a watermark
check box.

Click Browse.

Locate and select the picture you
want to insert, and then click
Open.

The picture you selected now
opens as a background image. 

Click OK.8

7

6

5

4

3

2

1

8

3 4 5
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If you’d like to add some interest to your pages, you can add back-
ground colors. When selecting background colors, some creative judg-
ment is required. For example, if you choose a dark color for your
background, make sure you use a light color for your text (the most
commonly used is white) to generate the appropriate contrast required
for easy reading.

Changing Background
Colors

Change the Background Color of
a Web Page

Open and display the Web page
you want to use. 

Right-click the page to which you
want to change a background
color, and then click Page
Properties.

Click the Formatting tab.

Click the Background list arrow.

Click the color you want on the
color palette.

Click OK.6

5

4

3

2
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You can introduce background sounds to accompany and enhance
your Web page. There’s nothing like hearing a favorite tune when you
enter a site or visit a particular page. The sound can be played continu-
ously in a loop, or you can set it for a desired number of plays. Be
aware that not all browsers support background sound.

Adding Background
Sound

Add a Background Sound to a
Web Page

Open and display the Web page
you want to use. 

Right-click the page to which you
want to add a background sound,
and then click Page Properties.

If necessary, click the General tab.

Type the sound file name or click
Browse, locate and select the
sound file you want to use, and
then click Open.

To set the sound to repeat
continuously, clear the Forever
check box, and then click the
number arrows in the Loop box to
set the number of times you want
the sound to play.

Click OK.

Whenever a visitor opens the
page, they will hear the sound
effect you chose.

6

5

4

3

2
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5
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4
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Since visitors to your Web site can use different screen resolutions or
window sizes, you need to develop Web pages so a variety of users
can view it without having to zoom in or scroll to much. You can use the
Page Size command to simulate different page size to see how your
pages look. The page sizes available using the Page Size command
correspond to standard screen resolutions, which include 640 x 480,
800 x 600 and 1024 x 768 (all maximized). 

1 2

Setting Page Size

Change the Page Size View

Click the View menu, and then
point to Page Size.

Click the page size you want.

TIMESAVER Click the current
page size on the status bar, and
then click a new size.

2

1
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Change the Page Size

Click the View menu, point to Page
Size, and then click Modify Page
Sizes.

Perform the page size commands
you want:

◆ Add. Click Add, enter width,
height and a description, and
then click OK.

◆ Modify. Select a page size,
click Modify, make changes,
and then click OK.

◆ Remove. Select a page size,
and then click Remove.

◆ Reset. Click Reset to return to
default page sizes.

Click OK.3

2

1

3

2



Because each browser can display your site differently, you will want
to examine your site using several of the most popular browser formats
and different sizes. When you are ready to see how your page will look
to visitors, click the Preview in Browser button arrow on the Common
toolbar and then select a browser and a window size. When you select
a browser, the program starts and displays your Web page as you
would see it on the Web. If you want to add additional browsers to the
list, you can select them using the Edit Browser List dialog box. You can
also simulate the page size of a browser as you work in Design view by
selecting different page sizes on the Page Sizes submenu on the View
menu.
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Previewing Web
Pages

Add Browsers to the Preview 

Click the File menu, point to
Preview in Browser, and then
click Edit Browser List.

Click Add.

The Add Browser dialog box
opens.

Type the browser’s name.

Click Browse.

Navigate to the location where the
browser program is stored, select
it, and then click Open.

Click OK.

To automatically save a Web page
before previewing, select the
Automatically save page before
previewing check box.

To specify the window sizes you
want, select the 640 x 480, 800 x
600, or 1024 x 768 check boxes.

Click OK.9
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Preview a Web Page Using 
a Browser

Open the Web page you want to
preview.

Click the Preview in Browser
button arrow. 

Click the browser with the specific
size you want to use to preview
your site or page. 

TIMESAVER Press F12 to
preview the Web page in the most
recently used browser and size.

3

2

1

Did You Know?
You need to install other browsers
before you can preview your pages.
You must have previously installed the
full version of other browsers like
Netscape Navigator or Fire Fox if you
want to preview how your pages will
appear to users of those browsers.

You need to save your pages before
you can preview them. To be sure that
you have saved the page you want to
preview, click the Automatically save
page before previewing check box to
select it in the Edit Browser List dialog
box. Click the File menu, point to
Preview in Browser, and then click Edit
Browser List.

You can change the Web page size in
Design view. Click the View menu,
point to Page Size, and then select the
size you want. If the Design view win-
dow is wider than the width you spec-
ify, gray areas appear on either side. If
Design view is narrower than the
width you specify, you’ll need to scroll
the Design view window right or left. A
dotted line across the page indicates
the bottom of the browser window.

2 3

Click to preview selected
page in multiple browsers

Preview in Internet Explorer



Printed pages are helpful when you are working in Preview view.
Rather than toggling between a page in progress and a Browser
Preview of that page, for example, you can print the Preview so that
you have it in hard copy format. Printouts are also helpful when editing
your pages. Before printing, you can preview the page to determine
that there are no obvious errors.
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Previewing and
Printing Web Pages

Print Preview Web Pages

Open and display the Web page
you want to preview.

Click the File menu‚ point to Print,
and then click Print Preview. This
opens a scaled-down image of the
page you want to print and a
series of buttons. The button
choices are:

◆ Print button. Engages the
printing process. The preview
closes and the Print dialog box
opens.

◆ Next Page button. Displays the
next page in the sequence for
multiple-page printing.

◆ Previous Page button. Takes
you to the previous page in a
sequence.

◆ Two Page button. Toggles
between a single-page and a
two-page spread in Preview
mode.

◆ Zoom In button. Magnifies the
preview image.

◆ Zoom Out button. Reduces the
size of the characters to show
more of the page preview.

◆ Close button. Closes the
Preview mode.

When you’re done, click the Close
button.

3

2

1
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Print Web Pages

Open and display the Web page
you want to print.

Click the File menu‚ point to Print,
and then click Print.

Select the print options you want.

Click OK.4

3

2

1

For Your Information

Setting Up the Print Page Format 
When you print a Web page, you can use the Print Page Setup dialog
box to control the printing of text and graphics on a page. To open
the Print Page Setup dialog box, click the File menu, point to Print,
and then click Page Setup. The Print Page Setup dialog box allows
you to specify page margins and header and footer information. In
the Headers and Footers text boxes, you can type text to appear as a
header and footer of a Web page you print. In these text boxes, you
can also use variables to substitute information about the current
page, and you can combine text and codes. For example, if you type
Page &p of &P in the Header text box, the current page number and
the total number of pages print at the top of each printed page.
Check Expression Web and Internet Explorer Help for a complete list
of header and footer codes.

4

3



When you export Web content, you save the information in a new for-
mat so that it can be opened in an entirely different program. You can
export one or more files from Expression Web to a location outside your
Web using the Export command or Copy and Paste commands. This
process can be executed using the Folder List or Folders view. 
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Exporting Web 
Content

Export Web Content 

Open the Web site with the Web
page you want to change.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, select the file
you want to export.

Click the File menu‚ point to
Export, and then click File.

Navigate to the drive and folder
location where you want to export
the Web content.

Type a name for the page, or use
the suggested name.

Click the Save as type list arrow,
and then click the file type you
want.

◆ HTML (.htm, .html)

◆ GIF and JPEG (.gif, .jpg)

◆ Microsoft Office Files (.doc,
.xls, .ppt)

Click Save.8

7

6

5

4

3

2

1

8

5

7

6



Working with Web Pages 67

Export Web Content Using Copy 
and Paste

Select the information you want to
copy.

Click the Edit menu, and then click
Copy.

Display the location in which you
want to move the content.

Click the area where you want to
place the content.

Click the Paste button on the
toolbar.

The source files or folders are
copied into their new location.

5

4

3

2
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Instead of using one of the built-in page templates that comes with
Expression Web, you can create your own. There are two kinds of page
templates: static and dynamic. A static template is a Web page you
create and design, which is completely editable. After you save a static
page template, you can access it in the My Templates tab of the Page
Templates dialog box. A dynamic template is a Web page with editable
areas like a static template, yet also contains non-editable areas with
content that changes based on circumstances, such as actions taken
by a user or the date. 
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Creating a Page
Template

Create a Static Template

Design and display the Web page
you want to create into a static
template.

Click the File menu‚ and then click
Save As.

Type a name for the template.

Click the Save as type list arrow,
and then click Page Template.

The folder location changes to the
Pages folder, where Expression
Web stores page templates.

Click Save.

Type the title you want for the
template.

Type a description for the
template.

To save the template in the current
Web site, select the Save
Template in Current Web site
check box.

Click OK.9
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Create a Dynamic Template

Design and display the Web page
you want to create into a dynamic
template. Be sure to leave areas
open to create editable regions.

Click the File menu‚ and then click
Save As.

Type a name for the template.

Click the Save as type list arrow,
and then click Dynamic Web
Template.

The folder location changes to the
Pages folder, where Expression
Web stores page templates.

Click Save.

Create Editable Regions for a
Dynamic Template

Display the Dynamic Web
Template you want to change.

Select the page area you want to
vary from page to page.

Click the Format menu‚ point to
Dynamic Web Template, and then
click Manage Editable Regions.

Type a name for the area you
selected.

Click Add.

Click Close.

You can repeat Steps 2 through 6
to designate other dynamic areas.

6
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After you create a dynamic Web template, you can apply, or attach, the
template to an open Web page. When you attach a dynamic Web tem-
plate to a Web page, Expression Web tries to map regions on the ordi-
nary Web page to editable regions in the template. If you don’t like the
initial mapping, you can modify or skip it. After you attach a dynamic
Web template to an ordinary Web page, you can modify non-editable
regions in Code view, or any editor other than Design view to create
updatable content.
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Using a Dynamic 
Page Template

Attach a Dynamic Web Template

Display the Web page in which
you want to apply a dynamic page
template.

Click the Format menu‚ point to
Dynamic Web Template, and then
click Attach Dynamic Web
Template.

Locate and select the dynamic
Web template you want to apply.

Click Open.

Select which regions in the new
page will receive content/regions
from the old page.

Click Modify, select a new
mapping, and then click OK.

Click OK to attach the template.

Click Close.8

7
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Did You Know?
You can manage editable regions.
Click the Format menu, point to
Dynamic Web Template, and then click
Manage Editable Regions.

4

3

8



Working with Web Pages 71

Update a Dynamic Web
Template

Open the dynamic Web page
template, and then make the
changes you want to update on
other pages.

Click the Format menu‚ and then
point to Dynamic Web Template.

Click the update command you
want.

◆ Update Selected Page

◆ Update All Pages

◆ Update Attached Pages

3

2

1

Did You Know?
You can detach a Dynamic Web
Template from a Web page. Open and
display the Web page with the
Dynamic Web Template attached, click
the Format menu, point to Dynamic
Web Template, and then click Detach
from Dynamic Web Template. If you
want to open an attached Dynamic
Web Template page, click Open
Attached Dynamic Web Template on
the submenu.

2

3
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A Master page is a special type of ASP.NET page that allows you to
share contents, such as graphics, HTML code, and ASP.NET controls,
between pages. Master pages are similar to Dynamic Web Templates
because they share elements between pages. However, Master pages
add the ability to share code. If you have ASP.NET 2.0 available on your
Web server, you can take advantage of Master pages. A Master page
uses content controls instead of editable regions in a Dynamic Web
Template. The content control on the Master page (ContentPlace
Holder) maps to the content control on the Content page (Content).
After you create a Master page using a template in the New dialog box,
you need to save it with the .master file extension. Now, you can create
a Content page and link it to a Master page.

Creating a Master 
and Content Page

Create a Master Web Page

Click the File menu‚ point to New,
and then click Page.

In the left pane, click General or
ASP.NET.

Click Master Page.

Click OK.

An Untitled_1.master page
appears in the Editing window.

Click the File menu‚ and then click
Save As.

Type a name for the master page.

Click the Save as type list arrow,
and then click Master Page.

Click Save.8

7

6
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Did You Know?
You can manage content regions. Click
the Format menu, point to Master
Pages, and then click Manage Content
Regions.

4
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Create a Content Web Page

Click the File menu‚ point to New,
and then click Page.

In the left pane, click General or
ASP.NET.

Click Create from Master Page.

Click OK.

Click the Specific Master Page
option.

Click Browse, locate and select
the master page, and then click
Open.

Click OK.

An Untitled_1.aspx content page
appears in the Editing window.

The Content page pulls in the
content from the Master page in
the ControlPlaceHolder control.

Click the File menu‚ and then click
Save As.

Type a name for the content page.

Click the Save as type list arrow,
and then click Web Pages.

This saves the content page with
the .aspx extension.

Click Save.11
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Did You Know?
You can detach a Master page. Open
and display the Content page, click the
Format menu, point to Master Pages,
and then click Detach from Master
Page. If you want to open an attached
Master page, click Open Attached
Master Page on the submenu.
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A file type specifies the file format (for example, a template) as well as
the program and version in which the file was created (for example,
Expression Web). You might want to change the type if you’re creating
a custom template or sharing files with someone who needs them for
use in another program. You use the Save As dialog box to change the
file type for a page. The Save as type list arrow displays a list of the
available formats for the program or current selection.

Saving a Web Page
with Different Formats

Save a Web Page as a 
Different Type

Open and display the Web page
you want to save in a different
format.

Click the File menu, and then click
Save As.

Navigate to the drive and folder
location where you want to save
the Web page.

Type a name for the page, or use
the suggested name.

Click the Save as type list arrow,
and then click the file type you
want.

Click Save.6

5

4

3

2

1

See Also
See “Expression Web Formats” on
page 75 for information on selecting
the right file format.

6

3

5
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For Your Information

Saving Web Related Files

When you use Web related-files, typically scripts, created in other
programs, make changes, and save the Web page or Web site,
Expression Web saves the other Web related-files in their native file
format. Some of the native file formats include ColdFusion Markup
Language (.cfm), PHP Script (.php, .php2,.php3, .php4), HTML File with
Server Side (.shtm, .shtml, .shm), State Transition Diagram model file
(.stm), Hypertext template (.htt), Hypertext application (.hta), HTML
Component (.htc), Ascii text file (.asc), and Microsoft .NET Web
Service file (.asmx). The files listed in the Save File Formats table on
the next page are included in this list too.
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Expression Web Save File Formats

Save As file type Extension Used to save

All Files *.* Complete Web site

Web Pages Files in their native format; includes the formats in this 
list and the ones in the side bar on the previous page

HTML Files .htm, .html Web pages as a HTML file

Dynamic Web Template .dwt Web pages as a changeable Expression Web template

ASP and ASPX Files .asp, .aspx Web pages as a Microsoft Active Server Page

Master Page .master Web pages as Expression Web master page file; a 
special type of ASP.NET file

JScript Files .js Scripts as a Microsoft Scripting Language "JScript" file

VBScript Files .vba Scripts as a Visual Basic for Applications file

PHP Files (New!) .php Web pages as a PHP file

CSS Files .css Web pages as a cascading style sheet

XML .xml, .xsd,.xsl, .xslt, .dtd Web pages as an XML file

Text .txt Web pages as a text file

Page Template .tem Web pages as a static Expression Web template

Expression Web Formats

Expression Web Open File Formats

Files of type Extension Used to open

All files in the above table All files from the above list
are included in this list

Recover Text from Any file *.* Text files not supported (from this list below)

WordPerfect 5.x .doc WordPerfect 5.0 files

WordPerfect 6.0 .wpd, .doc WordPerfect 6.0 files

Word 2007 Document  .docx Word 2007 documents

Word 2007 Macro-Enabled .docx Word 2007 documents that contains Visual Basic 
Document for Applications (VBA) code

Word 97 - 2003 Document .doc Word 97 to Word 2003 documents

Works 6.0 - 9.0 .wps Works 6.0-9.0 files



76 Chapter 3

You can use animation in your Web site to provide interest and call
attention to important information. When you move from one Web page
to another, you can display a transition effect between the two pages.
You can select a transition effect, and then specify when the page tran-
sition occurs, and how long it lasts. The only disadvantage of page
transitions is that the browser must wait for the entire Web page to
load before it can apply the transition effect. Be aware that animated
page transitions are not supported by all browsers.

Animating Page
Transitions

Apply a Page Transition

Open and display the Web page
you want to use. 

Click the Format menu, and then
click Page Transition.

Click the Event list arrow, and then
click an event type: Page Enter,
Page Exit, Site Enter, or Site Exit.

Click the transition effect you
want.

Set the duration (in seconds) of
the transition effect.

Click OK.6
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Index

A

About Microsoft Expression Web, 20
absolute positioning, 305

options, 134
accelerator keys to menu, assigning, 368
accessibility information

Accessibility Properties dialog box, 27
checking Web pages for, 341
prompts for, 360

Accessibility Properties dialog box, 27
actions in behaviors, 194
ActiveX controls

running, 165
previewing media, 166-167
setting security options, 164

add-ins, loading/unloading, 383
Adobe

Acrobat files, hyperlinks to, 175
Flash

checking for, 204
inserting movies, 154-155
playing movies, 166-167
setting properties, 156-157

Shockwave, checking for, 204
advanced buttons in forms, 261, 270-271
AIFF sounds, playing, 210
alignment. See also tables

of graphics, 138-139
for inline frames, 249
of interactive buttons, 190
of layout tables, 213
line alignment, changing, 91
of text, 88

animating page transitions, 76
antonyms, finding, 113
Apple QuickTime (MOV)

ActiveX controls, setting security

options, 164checking for, 204
installing for, in Expression Media, 390
overview, 153
previewing, 166-167

Apple Safari
work with Silverlight, 162

Application Options dialog box, 359
Apply Styles task pane, 8, 287, 295
artboard

in Expression Design, 387
in Expression Blend, 396

ASP (Active Server Pages), 217. See also
ASP.NET

database, saving form results to, 280
as form handler, 278

ASP.NET. See also Master page
overview, 313, 314
controls, 315-319

AJAX, 315, 318
custom, 319

creating Web pages in, 314
customizing options, 359
hyperlink parameters, adding, 173
login, adding, 315
options, customizing, 359
preview pages, with Expression

Development Server, 352-353
saving Web pages in, 75
validation, for forms, 315
WebParts, adding, 315

ASPX format, 37
saving Web pages in, 75

attachments
dynamic templates, attaching, 70
Master page, attaching, 72

attributes of HTML tags, 286, 292
audio. See sounds
Auto Thumbnail button, 130-131
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AutoFit To Contents command, 227
AutoFormat for tables, 237
Auto Indent, 361
Auto-Scale of cells, 213
autostretching layout tables, 216

B

backgrounds. See also tables
changing colors, 58
deleting images, 54
inserting images, 54, 56
for interactive buttons, 191
sounds, inserting, 54, 59

Backspace key, 80
Banner and Contents template, 243-244
base location, specifying, 54
behaviors, 189

Call Script behavior, 209
Change Property behavior, 206-207
Check Browser behavior, 204
deleting, 196
elements, adding to, 195
Go To URL behavior, 197
Jump Menu behavior, 198-199
modifying, 196
Open Browser behavior, 208
order of behavior, changing, 195
paragraph, adding to text in, 195
Play Sound behavior, 210
Popup Message behavior, 200
Preload Images behavior, 202
Set Text behavior, 200
Swap Images behavior, 202-203
viewing, 194

Behaviors task pane, 189
Besides New Window target hyperlink, 177
bevels to graphics, adding, 144
Blink effect, 100
BMP files, 118
boilerplate text, 78
boldfacing

text, 98
updates tags for, 360

Bookmark dialog box, 170
bookmarks

creating, 170

deleting, 170-171
hyperlinks, creating, 172
navigating to, 170-171

borders, 241. See also frames pages; tables
Change Property behavior, 206-207
for inline frames, 249

Borders and Shading dialog box, 146-147
padding for graphics, setting, 145

Borders button, 146-147
brightness of graphic, adjusting, 140
Bring Forward/Send Backward, 135
browsers. See also hyperlinks

colors, safe, 376
frames, resizing, 248
low resolution graphics, support for, 

150-151
Open Browser behavior, 208
previewing Web pages in, 62-63
symbols, support for, 89
version, checking, 204
watermarks, support for, 56

built-in styles, 95
bulleted/numbered lists

adding items to, 92
creating, 92
custom bullets, inserting, 93
format, changing, 92

buttons. See also interactive buttons; tool-
bars

forms, inserting in, 270-271
Menu bar, assigning to, 368

Byte Order Mark (BOM)
adding/removing, 366-367

C

Call Script behavior, 209
camera, inserting graphics from, 124
Capitalize effect, 100
captions. See tables
catalog

in Expression Media, 390
Cell Properties dialog box, 234-235, 240
cells. See layout tables; tables
centering

table cell contents, 231
text, 88
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CGI script as form handler, 278
Change Property behavior, 206-207
Change Property Restore behavior, 206-207
characters

spacing, changing, 86
special characters, inserting, 89

check boxes in forms, 261, 269
Check Browser behavior, 204
Check for Updates command, 20
Check Plug-In behavior, 204-205
check-in/check-out, documents

removed from product, 403
Citation effect, 100
class-based styles, 298

creating, 299
clearing properties, 305
clip art, inserting, 148
Clipboard for moving/copying text, 84-85
closing

task panes, 9
Web pages, 21

code. See also code snippets; HTML
(Hypertext Markup Language)

finding/replacing, 102-103
fixed-width fonts for, 114
formatting options, 362-363

Code effect, 100
code snippets, 286

changing options, 364
editing, 55
List Code Snippets command, 296
reusing, 364

Code view, 4, 14-15, 16
dynamic template regions, editing, 70
for HTML code, 44-45, 286

colors. See also backgrounds; fonts; 
graphics; tables

browser safe colors, 376
custom colors, creating, 376-377
defining custom palette, 376
deleting custom colors, 377
hyperlink colors, changing, 178-179
for interactive buttons, 190-191
line color, changing, 91
more colors, adding, 101
of table borders, 233

color scheme
changing, user interface, 5, 356

columns and rows. See also tables
frames into columns or rows, 

splitting, 255
COM (Component Object Model) 

add-ins, 383
commands. See also toolbars

in Help Menu, 20
Menu bar, assigning to, 368-369

Common toolbar, 6
community information, 20
compatibility

checking Web page compatibility, 
342-343

highlighting incompatible HTML, 361
viewing the Compatibility Task Pane, 343

Compatibility Task Pane, 342-343
Complete Word command, 296
CompuServe's Graphics Interchange, 118
confirmation page, custom, 275
contact information forms, 257
Contact Us information, 20
containers

paragraph containers, 82
text containers, 78

Content page, creating, 72-73
Contents template, 243-244
contrast of graphic, adjusting, 140
conventional tables. See tables
copying

exporting Web content by, 67
files, 12
graphics from Web, 125
interactive buttons, 192
reports, 338-339
styles, 301
template pages for new Web page, 29
text, 84-85
toolbar button image, 374
in Web page, 11

Crop button, 132
cropping graphics, 132
CSS (Cascading Style Sheets), 24, 77, 285,

287. See also external style sheets;
IntelliSense

adding pages to Web site with, 37
Code Formatting options, 362-363
embedded CSS, creating, 95
error-checking, 310-311
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CSS (continued)
ID styles for layout, creating, 308-309
layouts, 287, 306

scratch, creating from page from,
308-309

template, creating page from, 306-307
moving internal styles to external style

sheets, 303
options, setting, 312
overflow property, 292
pages, creating, 306
saving CSS files, 75
tools, 287, 295
usage problems, checking for, 310-311

CSS Properties task pane, 287, 295
CSS Reports, 310-311
Custom Dictionaries dialog box, 108
Customize dialog box

special operating mode, 371
toolbars, showing/hiding, 370

customizing, 355. See also macros
ASP options, 359
bullets, 93
confirmation pages, 275
frames page template, 244
FTP transfer options, 359
general options, 356
Menu bar, 368-369
Reports view, 358
toolbars, 372-373

D

data formatting. See formatting
data view. See XML
databases

form results to database, saving, 280-281
updating, 281
Web sites, configuring connections for,

352-353
debugging macros, 378-379, 382
default.htm, 26

setting Web page as, 52
Definition effect, 100
definition list, creating, 96-97
Delete key, 80
deleting. See also toolbars

backgrounds, 54

behaviors, 196
bookmarks, 170-171
bullets/numbers from lists, 92
colors, custom, 377
COM add-ins, 383
files, 12
forms or form fields, 259
frames, 254
hidden data for Web site, 41
hotspots, 184
layers, 136
macros, 381
properties, 207
spell-checking symbols, 112
styles, 95, 301
table elements, 230
template pages, 28
Web pages, 50
Web sites, 41

Design mode, 4
Design view, 14-15, 16

default text, changing, 114
formatting options, setting, 365
grid, working with, 304
HTML

pages, displaying, 44-45
tags, displaying, 49

linked Web pages, opening, 46
optimizing published HTML code in, 345
rulers, working with, 304
size of Web page, changing, 63

dialog boxes, help in, 19
dictionaries. See spell-checking
digital camera, inserting graphics from, 124
disabled users. See also accessibility

information
visually impaired persons, alternative

text for, 121
discussion form handler, creating, 279
disk-based sites, 24-25

for empty Web site, 31
Distribute Columns Evenly command, 227
Distribute Rows Evenly command, 227
DOC files

exporting Web content as, 66
hyperlinks to, 175
inserting text from, 115

docking toolbars, 6-7
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doctype declarations, 342
document check-in/check-out

removed from product, 403
document tabs, navigating with, 48
double-spacing text, 86-87
downloading. See also updates

Slow Pages report, 358
drag-and-drop

Customize dialog box and, 371
text, moving/copying, 84

Draw Layout Cell button, 216
drop-down boxes in forms, 261, 266
.dwt files, 26
dynamic templates

attaching, 70
creating, 68-69
detaching, 71
editable regions, creating, 69, 70
saving, 75
updating, 71

Dynamic Web Template, 37

E

Edit Browser List dialog box, 62-63
Edit Hyperlinks dialog box, 188
Edit Tag command, 294
editing

frames pages, 253
graphics, 127
horizontal lines, 90-91
hotspots, 184
hyperlinks, 178-179
interactive buttons, 192-193
menu entries, 374
styles, 301
target frames, 252
text, 80
toolbar buttons, 374

Editing window, 10
editors. See also Quick Tag Editor

configuring external editors, 357
effects

bevels to graphics, adding, 144
font effects, adding, 100

e-mail
form results, sending, 276-277

hyperlinks to addresses, 176
embedded style sheets, 287
embedding Windows media, 158-159
Emphasis effect, 100
empty Web site, creating, 30-31
End Sub in macros, 379
error-checking CSS, 310-311
events

in behaviors, 194
in HTML code, 286

exclusion dictionaries, 108-109
existing Web site, opening, 32-33
exiting Expression Web, 22
Export Web Package dialog box, 38
exporting. See importing/exporting
Expression Blend, 1, 162, 385

artboard, 396
interactivity, adding, 400
project, 396
XAML, creating, 396
work in, 398-399

Expression Design, 1, 385
new document, 387
open graphic, 387

format types, 387
overview, 386
work in, 388-389

Expression Development Server
enabling, for PHP and ASP.NET, 352-353

Expression Encoder, 1, 162, 385
encode jobs, 395
overview, 394
profiles, 395
work in, 394, 395

Expression Media, 1, 385
catalog, 390
keywords, 392
manage files, 392-393
overview, 390-391
views, 391

Extending Expression Web, 20
Expression Studio, 1, 385
external style sheets, 287

attaching to Web page, 302-303
creating, 302

Eye icon, 136-137
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F

feedback forms, 257
fields. See forms
File command, 115
file formats. See also specific types

different format, saving Web page in, 74
supported formats, list of, 75

files. See file formats; folders and files
Fill Color button, 238
Fill Down command, 223
Fill Right command, 223
Find and Replace dialog box, 102-105
Find task pane, 102-105
finding/replacing

code, 102-103
HTML tags, 104-105
query, saving search as, 105
text, 102-103

FireFox, Mozilla
version checking, 204
work with Silverlight, 162

fixed positioning, 305
fixed-width fonts, 114
Flash. See Adobe
flipping graphics, 133
floating properties, 305
Folder list, 10. See also importing/exporting

graphics, inserting, 120-121
opening Web page with, 47
publishing individual files in, 349

Folder List task pane, 8
folders and files, 10. See also file formats;

forms; templates; 
copying files, 12
deleting files, 12
determining contents of, 10
graphics from files, inserting, 120
hidden files, tracking, 24
hyperlinks to files, creating, 174-175
importing Web content from, 34
metadata, tracking with, 24
moving files, 12
new folders, creating, 51
renaming

files, 12
Web folder, 40

text from file, inserting, 115

Folders view, 14
opening Web pages in, 46
publishing individual files in, 349

Font dialog box, 99
Font menu, 375
fonts

Change Property behavior, 206
changing, 98-99
colors

more colors, adding, 101
selecting, 98

default fonts, changing, 114
displaying fonts in Font menu, 375
effects, adding, 100
for interactive buttons, 190
for Jump Menu, 199
size, changing, 98-99

Footer template, 243-244
footers. See headers and footers
Footnotes template, 243-244
Form Controls, 258
form handlers

overview, 282-283
saving results to, 278-279

formatting. See also CSS (Cascading Style
Sheets)

bulleted/numbered lists, 92
graphics formats, changing, 148-149
setting Design View options, 365
showing/hiding marks, 82
tables, 236-237
text, 98-99
Web page formatting, setting, 54
XML formatting, applying, 332-333

forms, 257. See also registration forms
advanced buttons in forms, 261, 270-271
buttons, inserting, 270-271
check boxes in, 261, 269
confirmation page, custom, 275
creating, 258-259
custom form handler, results to, 278-279
customizing options, 360
database, saving results to, 280-281
deleting forms or fields, 259
discussion form handler, creating, 279
drop-down boxes in, 261, 266
e-mail, sending results as, 276-277
fields
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deleting, 259
file upload fields, inserting, 273
understanding, 261

files
saving form results to, 274
upload fields, inserting, 273

form handlers, saving results to, 278-279
group boxes for, 261, 267
labels for, 261, 253a
list of element types, 261
naming, 260
picture buttons, inserting, 261, 272
properties

setting, 260
text properties, changing, 265

push buttons in, 270
radio buttons in, 261, 268
Reset buttons in, 261, 270
saving

custom form handler, results to, 278-
279

database, results to, 280-281
file, saving results to, 274

Submit buttons in, 261, 270
tab order, setting, 262
tables, inserting, 259
text boxes/areas, inserting, 261, 264-265
types of, 257

Frame Properties dialog box, 248
frames, 241. See also frames pages; inline

frames
columns or rows, splitting into, 255
content, adding, 246
deleting, 254
hidden frame borders, 256
initial page display, 248
inline frames, inserting, 245
margins, setting, 248
New Page option, 246-247
properties, changing, 248-249
resizeable frames, creating, 248
resizing, 247
scrollbars, 248

for inline frames, 249
showing/hiding, 253

Set Initial Page option, 246
showing/hiding

borders, 256

scrollbars, 256
size, setting, 248
splitting, 255
target frames, creating, 252

frames pages
creating with templates, 243
customizing templates, 244
editing, 253
reselecting, 251
saving, 250-251
showing/hiding borders, 256
titles, modifying, 251
viewing, 242

framesets, 250-251
FrontPage Extensions

database, saving form results to, 280-281
form handlers requiring, 278
form results as e-mail, sending, 276-277
form results to file, saving, 274
as remote server, 346
WebDAV, 34

FTP (File Transfer Protocol), 24-25
customizing transfer options, 359
for empty Web site, 31
as remote server, 346

G

GIF format, 118. See also graphics
bullets, customizing, 93
exporting Web content as, 66
for transparent graphics, 142

Go To URL behavior, 197
grammar-checking, 112
graphics, 117-118. See also hotspots;

thumbnails; transparent graphics
aligning, 138-139
bevels, adding, 144
borders, adding, 144, 146-147
brightness, adjusting, 140
camera, inserting graphics from, 124
contrast, adjusting, 140
copying graphics from Web, 125
cropping, 132
defaults, changing, 119
directly resizing, 128
display, changing, 150-151
files, inserting from, 120
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graphics (continued)
flipping, 133
Folder list, inserting from, 120-121
formats, changing, 148-149
forms, picture buttons in, 261, 272
Graphics Editor Program, 

configuring, 150
grayscale, converting to, 142
hyperlinks, adding, 180-181
layers, working with, 136-137
low resolution graphics, creating, 

150-151
margins, adding, 145
moving, 126
numerically resizing, 129
pasting graphics from Web, 125
Pictures toolbar, modifying with, 127
Photoshop files, inserting, 122-123
positioning, changing, 134
resampling, 128-129
resizing, 128-129
restoring, 152
rotating, 133
scanner, inserting graphics from, 124
selecting, 126
shading, adding, 146-147
stacking order, changing, 135
tables, adding to, 240
tracing, 121
vertical alignment of, 138-139
washing out color in, 141
Web page save, changing format 

during, 149
wrapping text around, 138

Graphics Editor Program, configuring, 150
grayscale, converting graphic to, 142
Greek, setting keyboard for, 110
grid, working with, 304
group boxes in forms, 261, 267
guest book forms, 257

H

Header template, 243-244
headers and footers

Microsoft Excel data, tables created
from, 217

Print Page Setup dialog box, 
setting in, 65

tag-based styles for, 298
headings

centered text for, 88
creating, 96

Hebrew, setting keyboard for, 110
height. See also tables

layout tables, 213, 216
of lines, 91

help
dialog box, help in, 19
Help Viewer, 18-19
searching for, 19

Help menu, 18-19
commands in, 20

Help Viewer, 18-19
hiding. See showing/hiding
Highlight Hotspots button, 184
highlighting

HTML code, invalid/incompatible, 361
text, 98

home page, setting, 52
horizontal alignment options, 138
horizontal lines, inserting, 90-91
Hot Java version, checking, 204
hotspots

adding to graphics, 182
edges, showing, 184
editing, 184
text-based hotspots, adding, 182-183

hover image for interactive buttons, 191
HSL (hue, saturation, luminosity) 

colors, 377
HTML (Hypertext Markup Language), 37,

286. See also bookmarks; code snip-
pets; CSS (Cascading Style Sheets);
Master page; Quick Tag Editor; Quick
Tag selector; tag-based styles

attributes of HTML tags, 286, 292
Code view displaying, 16
compatibility, checking for, 342-343
for CSS pages, 306
displaying Web pages in, 49
exporting Web content as, 66
finding/replacing tags, 104-105
form results, saving, 274
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HTML (continued)
inserting

common tags, 288-289
tags, 290
text from HTML code, 115

invalid/incompatible HTML, 
highlighting, 361

language of page, specifying, 55
optimizing published HTML code, 

344-345
pages, creating, 44-45
properties of tags, showing, 290
Quick Tag Selector/Quick Tag Editor, 286
saving files, 75
tabs, support for, 222
tag tools, using, 290-291
text, tags for, 78
working with, 286

HTTP (Hyper-Text Transfer Protocol). 
See also HTTP sites

Internet URLs including, 33
HTTP sites, 24-25

for empty Web site, 31
HTTPS sites, 24-25
hue of color, 377
hyperlinks. See also hotspots

to Adobe Acrobat files, 175
to bookmarks, 172
colors, changing, 178-179
deleting, 178
editing, 178-179
to e-mail addresses, 176
to files, 174-175
graphics, adding to, 180-181
for interactive buttons, 190-191
for new internal page, 180-181
to non-available Web pages, 172-173
Open Browser behavior, 208
parameters, adding, 173
recalculating hyperlinks, 187
repairing broken links, 188
ScreenTips, adding, 185
single hyperlink, verifying, 187
tag-based styles for, 298
to target frames, 177
verifying, 187
to Web pages, 174

Hyperlinks view, 14-15, 186

I

IDs
CSS layout, styles for, 308-309
layers, value for, 136
for tables, 360

image maps for hotspots, 182
images. See graphics
importing/exporting

copy and paste, exporting with, 67
folders and files, importing content

from, 34
Photoshop files, 122-123
Web content, exporting, 66-67
Web site, importing content from, 34-35

indenting
with Auto Indent, 361
paragraph indentation, changing, 86-87

inherit positioning, 305
inline frames

inserting, 245
properties, changing, 249

inline styles, 287
creating, 300

input elements in forms, 261
Insert HTML command, 294
Insert Table dialog box, 218
insertion point, 11
Install Now option, 3
installing

browsers, 63
Expression Web, 3
.NET Framework 2.0, 2

IntelliSense, 286
options, setting, 297

PHP for, 322-333
using, 296

interactive buttons, 189
copying, 192
creating, 190-191
editing, 192-193

interlaced graphics, 119
internal style sheets, 287
Internet Explorer 

version, checking, 204
work with Silverlight, 162

Internet Information Services (IIS), 217
Internet URLs, 33
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ISAPI as form handler, 278
italicizing

text, 98
updates tags for, 360

J

JavaScript, 37
Call Script behavior with, 209
saving files, 75

job
in Expression Encoder, 395

JPEG format, 118. See also graphics
bullets, customizing, 93
exporting Web content as, 66

Jump Menu behavior, 198-199
style, changing, 199

Jump Menu Go behavior, 198-199
justified text, 88

K

Keyboard effect, 100
keyboards

languages, switching for, 360
layout, specifying, 110

keywords, specifying, 54

L

labels for forms, 261, 253a
languages

keyboards, automatic switching of, 360
spell-checking, 110-111
for Web site, 55, 352-353

layers, creating, 137
Layers task pane, 136-137
layout tables

creating, 212-213
drawing tables and cells, 214-215
height, 213, 216
modifying, 216
moving, 214-215
properties, changing, 213
resizing, 213-215

layouts. See CSS (Cascading Style Sheets)
left-aligning

table cell contents, 231

text, 88
lines

breaks, inserting, 82-83
horizontal lines, inserting, 90-91
marks, showing/hiding, 82
numbers, displaying, 361
spacing, changing, 86-87

links, 169. See also hyperlinks
Web pages, opening, 46

List Members command, 296
lists. See also bulleted/numbered lists

definition list, creating, 96-97
sublists, creating, 94

loading COM add-ins, 383
log on forms, 257
logos as watermark, 56
Loop option, 55
low resolution graphics, creating, 150-151
luminosity of color, 377

M

macros, 355, 378-379
debugging macros, 378-379, 382
deleting macros, 381
Menu bar, assigning to, 368
recording macros, 380
running macros, 381
Sub/End Sub in, 379

Manage Styles task pane, 198, 287, 295
tag-based styles in, 298

margins
current page margins, setting, 55
frame margins, setting, 248
graphics, adding to, 145
for inline frames, 249
in layout tables, 213
left margin, adding, 361
Print Page Setup dialog box, 

setting in, 65
viewing and changing, 17

Margins and Padding command, 17
Master page

creating, 72
detaching, 73
format, 37
saving, 75

master.dwt, 26
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mathematical symbols, inserting, 89
maximizing task panes, 8
Menu bar, customizing, 368-369
menus

accelerator key, assigning, 368
commands, executing, 7
editing entries, 374
Jump Menu behavior, adding, 198-199
naming new menus, 369
new menu, creating, 369
options, changing, 375

merging cells in tables, 228-229
metadata, 24

configuring use of, 352
Microsoft Access, saving form 

results to, 280
Microsoft Excel data, tables from, 217
Microsoft Expression Blend. See Expression

Blend
Microsoft Expression Design. See

Expression Design
MIcrosoft Expression Development Server.

See Expression Development Server
Microsoft Expression Encoder. See

Silverlight
MIcrosoft Expression Media. See

Expression Media
Microsoft Silverlight. See Silverlight
Microsoft Expression Web Online, 20
Microsoft Expression Web Setup Wizard, 3
Microsoft FrontPage. See also FrontPage

Extensions
importing page from, 34

Microsoft Vista system requirements, 2
Microsoft Visual Basic Editor, 379
Microsoft Windows Media Player, 204
Microsoft Windows XP system 

requirements, 2
MIDI, Play Sound behavior with, 210
minimizing task panes, 8
More Colors option, 101
MOV. See Apple QuickTime
moving

external style sheets, internal 
styles to, 303

files, 12
graphics, 126
hotspots, 184
layout tables, 214-215

text, 84-85
toolbars, 6-7
in Web pages, 11, 51

Mozilla 5.0 version, checking, 204
MPEG (Motion Picture Experts Group), 153

ActiveX controls, setting security
options, 164

previewing, 166-167
multimedia, 153 See also sounds

ActiveX Controls
options, setting, 164
running, 165

inserting
Flash, 154-155
Silverlight media, 163
Windows Media, 158-159

playing, 166-167
previewing, 167-168

My Templates tab, 68

N

naming/renaming
bookmarks, 170
class-based styles, 299
custom toolbars, 373
files, 12
forms, 260
frames for hyperlinks, 248
inline frame hyperlinks, 249
menus, 369
UNC (Universal Naming Conventions),

347
Web site, renaming, 40, 352

navigating
to bookmarks, 170-171
in tables, 220
Web pages, 48

.NET Framework 2.0, installing, 2

.NET Programmability Support, installing, 3
Netscape Navigator version, checking, 204
New command, 11
New dialog box

adding pages to Web site, 36-37
for one page blank Web site, 30
templates in, 243
Web Site tab, 25

New Document button, 11



422

New Document dialog box
in Expression Design, 387

new folders, creating, 50
New Style button, 298
NSAPI as form handler, 278
numbered lists. See bulleted/numbered

lists
numerically resizing graphics, 129

O

objects. See graphics
ODBC-compliant database, saving form

results to, 280
one page site, creating, 30
one-celled table, creating, 222
Open Browser behavior, 208
opening

existing Web pages/Web sites, 13, 32-33
Find and Replace dialog box, 104
folders and files, 10
Pictures toolbar, 139
task panes, 9
template pages, 26

Opera version, checking, 204
optimizing published HTML code, 344-345
order forms, 257
Overline effect, 100

P

padding. See also tables
graphics, adding to, 145
viewing and changing, 17

Page Default target hyperlink, 177
page descriptions, adding, 54
Page Editor Options dialog box, 119

code formatting options, 362-363
code snippet options, changing, 364
compatibility, checking, 342
CSS options, setting, 312
customizing with, 360-361
default text, changing, 114
IntelliSense in, 296

page numbers, adding, 65
Page Options dialog box

grid options, 304
ruler options, 304

Page Properties dialog box, 54-55
Page Size command, 60-61
Page view, opening Web page in, 13
paragraphs

behaviors to text, adding, 195
breaks, inserting, 83
containers, 82
indentation, changing, 86-87
marks, showing/hiding, 82
Paste Text options, 85
tag-based styles for, 298

Parameter Info command, 296
Parent Frame target hyperlink, 177
passwords for forms, 261
pasteboard

in Expression Design, 387
Paste command, 84-85
Paste Text command, 84-85

options, 85
pasting

exporting Web content by, 67
graphics from Web, 125
ID duplicates, eliminating, 360
text, 84-85
toolbar button image, 374

PDAs (personal data assistants). See CSS
(Cascading Style Sheets)

PDF files, hyperlinks to, 175
Personal Web Package

creating, 38
importing, 34

Photoshop PSD files
inserting, 122-123
editing, 122-123

PHP
create, page, 321
IntelliSense, for PHP, 323
code

overview, 320
example, 320
insert script, 324-325
work with, 322

options, setting for Web sites, 352-353
preview pages, with Expression

Development Server, 352-353
PHP hyperlink parameters, adding, 173
Picture Actions button, 128
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Picture dialog box for thumbnails, 121
pictures

background, using as, 56
bullets, using as, 93
forms, picture buttons in, 261, 272
tables, adding to, 240

Pictures toolbar. See also graphics
Bring Forward/Send Backward 

buttons, 135
Crop button, 132
graphics, modifying, 127
opening, 139

pixels
in Expression Design, 386

plain text option, 85
Play Sound behavior, 210
plug-ins

changing properties, 384
checking for, 204-205

PNG files, 118
Popup Message behavior, 200
Position Absolutely button, 134
Position dialog box, 135
positioning. See also absolute positioning

graphics, 134
properties, 305
table captions, 225

PPT format, exporting Web content in, 66
preloading images, 202

button images, 191
pressed image for interactive button, 191
Preview in Browser button, 62
previewing

in browsers, 62-63
printed Web pages, 64-65
Web sites, 352

Print Page Setup dialog box, 65
Print Preview, 64-65
printing Web pages, 64-65
printouts, previewing, 64-65
privacy information, obtaining, 20
profiles

in Expression Encoder, 395
progressive passes graphics, 119
project

in Expression Blend, 396
properties. See also forms; tables

adding, 207
Change Property behavior, 206-207
clearing properties, 305
deleting, 207
floating properties, 305
frame properties, changing, 248-249
inline frame properties, changing, 249
layout table properties, changing, 213
modifying, 207
publishing properties, changing, 347

Properties dialog box, 53, 54
proportional fonts, 114
publishing Web sites, 335

destination, entering, 347
"don't" publish pages, marking, 340
entire site, publishing, 348
individual pages, publishing, 349
optimizing published HTML code, 

344-345
properties, changing, 347
settings changing, 352-353
UNC (Universal Naming Conventions)

and, 347
updating Web sites, 350-351
working on, 346

push buttons in forms, 270

Q

quality graphics, 119
Que Publishing Web site, 379
query, saving search as, 105
query strings, 173
Quick Tag Editor, 49, 286

using, 294
Quick Tag Selector, 49, 286

using, 293
QuickTime (MOV), Apple

ActiveX controls, setting security
options, 164

installing for, in Expression Media, 390

R

radio buttons in forms, 261, 268
Real Audio, 210
RealNetworks, 204
RealPlayer, 204
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RealVideo (RAM), 153, 166
recalculating hyperlinks, 187
recording macros, 380
redoing typing, 81
REG (red, green, blue) colors, 376
registration forms, 257

form handlers, creating, 279
relative positioning, 305
remote servers, connecting to, 346-347
Remote Web Site view, 14, 346-347

files, displaying, 349
renaming. See naming/renaming
repairing hyperlinks, 188
replacing. See finding/replacing
reports

saving or copying, 338-339
Web site reports, 336-337

Reports view, 14-15
customizing, 358
hyperlinks, verifying, 187

request forms, 257
Resample button, 128
resampling graphics, 128-129
Reset buttons in forms, 261, 270
Reset Workspace Layout option, 9
resizing. See also tables

frames, 247
graphics, 128-129
hotspots, 184
layout tables and cells, 213-215
positioning layer, 135
toolbars, 6-7
Web pages, 60-61, 63

Restore button, 152
restoring

with Change Property Restore behavior,
206-207

graphics, 152
with Swap Image Restore behavior, 

202-203
right-aligning

table cell contents, 231
text, 88

rotating graphics, 133
RSS feed. See XML
RTF files, inserting text from, 115
rulers, working with, 304

running macros, 381

S

Same Frame target hyperlink, 177
Sample effect, 100
saturation of color, 377
Save All command, 39
Save As dialog box, 12

file type, changing, 74
Save As Type list arrow, 74
Save Embedded Files dialog 

box, 39, 119, 127
formats, changing, 148

saving
different formats, Web pages in, 74
frames pages, 250-251
framesets, 251
list of formats, 75
and previewing, 63
reports, 338-339
Web pages, 12
Web sites, 39

scanner, inserting graphics from, 124
ScreenTips

hyperlinks, adding to, 185
shortcut keys, showing, 375
tag attributes for, 292

scripts
Call Script behavior, 209
executing, 209
Web site script language, 352-353

scrollbars. See frames
search forms, 257
searching. See also finding/replacing

for help, 19
Section 508 accessibility requirements, 341
Select File dialog box, 115
selecting

graphics, 126
table elements, 221
text, 79

Selector, 287, 298
Send Backward/Bring Forward, 135
servers

opening Web site from, 33
remote server, connecting to, 346-347
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Set Text behavior, 200
Set Text of Frame behavior, 200
Set Text of Layer behavior, 200
Set Text of Status Bar behavior, 200-201
Set Text of Text Field behavior, 200
shading

for graphics, 146-147
for lines, 91

shortcut keys, displaying, 375
Show Tag Properties button, 292
showing/hiding. See also toolbars

line marks, 82
paragraph marks, 82
scrollbars, 253
Status bar, 356
visual aids, 17

sight impaired persons, alternative 
text for, 121

Silverlight
creating

in Expression Blend, 396
in Expression Encoder, 394, 395

inserting, 163
overview, 162, 385

Site Settings dialog box, 352
size. See also resizing

font size, 98-99
frame size, setting, 248
of Web page, 60-61, 63

Slow Pages report, 358
Snap to Grid, 304
snippets. See code snippets
solid lines, creating, 91
sorting in Web site reports, 337
sounds

background sounds, inserting, 54, 59
Play Sound behavior, 210

spacing. See also tables
character spacing, changing, 86
double-spacing text, 86-87
line spacing, changing, 86-87

span of cell, changing, 235
spell-checking

as you type, 112
custom dictionaries, using, 108
default spelling language, setting, 111
exclusion dictionaries, 108-109

languages, setting, 110-111
symbols, deleting, 112
Web pages, 106
Web sites, 106-107

Split view, 4, 14-15, 16
HTML

code, viewing, 286
pages in, 44-45

splitting
cells in tables, 228
frames, 255

SSL (Secure Sockets Layer), 24-25
for empty Web site, 30-31

stacking order for graphics, changing, 135
starting Expression Web, 4
static positioning, 305
static templates

creating, 68
saving, 75

Status bar
code errors in, 342
Set Text of Text Field behavior, 200-201
showing/hiding, 356

Strong effect, 100
Style Application toolbar, 295
Style list arrow, 93
styles, 77, 285. See also class-based styles;

inline styles; tag-based styles
definition list, creating, 96-97
deleting, 95
heading styles, 96
for Jump Menu, 199
text, applying to, 95
working with, 301

Sub in macros, 379
sublists, creating, 94
Submit buttons in forms, 261, 270
survey forms, 257
Swap Image Restore behavior, 202-203
Swap Images behavior, 194, 202-203
swapping images, 202-203
switching

between tables, 212
between Web pages and views, 16

symbols, inserting, 89
synonyms, finding, 113
system requirements, 2
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T

Table AutoFormat Combo button, 236
table cell padding. See padding
Table Properties dialog box, 217, 238, 240
tables, 211. See also layout tables

adding cells, rows or columns to, 226
alignment

of captions, 224
cell alignment options, 235
of cell contents, 231
changing, 232

AutoFormatting, 237
backgrounds

changing, 238-239
formatting, 236

borders
changing, 233
colors, changing, 238-239
setting, 219

captions, 224-225
deleting, 230
repositioning, 225

colors
background colors, changing, 236
of borders, 233
elements of table, adding to, 238-239

converting text to, 222
creating, 218
deleting elements of, 230
drawing cells, 214
Excel data, creating with, 217
filling cells with information, 223
floating text in, 232
formatting, 236-237
forms, inserting into, 259
graphics, adding, 240
height and width

changing, 232
setting, 219

horizontal cell alignment, 235
HTML tab support for, 222
ID attributes, adding, 360
images, adding, 240
information, filling cells with, 223
layout of cells, changing, 235

merging cells in, 228-229
navigating in, 220
one-celled table, creating, 222
padding of cells

changing, 232
setting, 219

properties, 219
changing, 232-233
setting, 219

resizing
cells, rows or columns, 234
columns and rows, 227

selecting elements in, 221
spacing of cells

changing, 232
setting, 219

span of cell, changing, 235
splitting cells, 228
switching between, 212
text

converting text to table, 222
entering, 220
filling cells with, 223
floating, 232

vertical cell alignment, 235
Tables toolbar, 236
tabs

document tabs, navigating with, 48
form tab order, setting, 262
HTML tabs, 222

Tag Properties task pane, 8, 273, 287, 290-
291, 295

attributes of tags, setting, 292
display, changing, 290-291

tag-based styles, 287
creating, 298

tags. See HTML (Hypertext Markup
Language)

target frames, creating, 252
target hyperlinks, creating, 177
task panes

contents, displaying, 9
maximizing/minimizing, 8
opening/closing, 9
rearranging, 9

tasks for misspelled words, 107
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templates, 23. See also dynamic templates;
frames pages; static templates

adding pages to Web site with, 36-37
copying pages for new Web pages, 29
creating Web sites with, 25
for CSS layout page, 306-307
deleting pages in, 28
for layout tables, 212
opening template pages, 26
planning, 24
replacing content in, 27
text from, 78

text, 77. See also fonts; headings; lines;
paragraphs; tables; wrapping text

alignment, setting, 88
behaviors, adding, 195
blank page, entering on, 78
character spacing, changing, 86
default text, changing, 114
drag-and-drop, moving/copying with, 84
editing text, 80
file, inserting text from, 115
finding/replacing, 102-103
floating properties, 305
formatting, 98-99
hotspots, adding text-based, 182-183
for inline frames, 249
inserting and editing, 80
Open Browser behavior with, 208
redoing typing, 81
selecting text, 79
styles, applying, 95
symbols, inserting, 89
template text, working with, 78
undoing typing, 81

text area/text boxes in forms, 261, 264-265
text files, 37

inserting text from, 115
saving, 75

text messages in Popup Message window,
200

thesaurus, using, 113
thumbnails

auto thumbnail properties, setting, 
130-131

creating, 130
displaying images, 121

tiling, avoiding, 56

titles
centered text for, 88
of frames, 248-249, 250-251
for inline frames, 249
Web page title, changing, 53, 54

toolbars
adding/deleting buttons, 371
commands

choosing, 6
copying, 369

custom toolbar, creating, 372-373
deleting

buttons, 371
custom toolbar, 373

editing buttons, 374
moving, 6-7
options, changing, 375
renaming custom toolbar, 373
resizing, 6-7
showing/hiding, 6

buttons, 370
Toolbox, 8
tools

CSS tools, 287, 295
tag tools, using, 290-291

tooltips. See ScreenTips
Trace Image option, 121
tracing graphics, 121
transparent graphics, 119

converting to, 142-143
turning on/off paste options, 85

U

UNC (Universal Naming Conventions), 347
Under Construction Pictures, 56
underlining text, 98
undocking toolbars, 6-7
undoing

bevel changes, 144
text, 81

Unicode, 55
unloading COM add-ins, 383
updates

checking for, 20
databases, 281
dynamic templates, updating, 71
Web sites, 350-351



428

upload fields in forms, 273
URLs (Uniform Resource Locators)

existing Web page, opening, 13
for frames, 248
Go To URL behavior, 197
hotspot URLs, editing, 184
Internet URLs, 33
Open Browser behavior, specifying, 208
opening Web sites with, 32
and publishing Web sites, 347

user-defined styles, 95
user interface, in Expression Web

color scheme, changing, 5, 356

V

Variable effect, 100
VBScript files, saving, 75
vector graphics

in Expression Design, 386, 388-389
verifying hyperlinks, 187
versions of browser, checking for, 204
vertical alignment of graphics, 138-139
Vertical Split template, 243
video formats, 153
View tabs, 4
views and viewing

behaviors, 194
frames pages, 242
switching between Web pages and, 16
Tables toolbar, 236
Web site reports, 336
working with views, 14-15

visibility behaviors, 206-207
Vista. See Windows Vista
visual aids, showing/hiding, 17
Visual Aids menu, 17
visually impaired persons, alternative text

for, 121

W

watermarks, 54, 56
background picture as watermark, insert-

ing, 56-57
WAV files, 210
WCAG accessibility requirements, 341
Web pages. See also backgrounds; hyper-

links; Master page; previewing; pub-
lishing Web sites; saving; text; Web
sites

accessibility, checking for, 341
advanced properties, setting, 55
animating page transitions, 76
ASP.NET pages, creating, 314
closing, 21
compatibility, checking for, 342-343
Content page, 72-73
copy of page, opening, 47
CSS pages, creating, 306
deleting, 50
disabilities, accessibility for users 

with, 341
existing page, opening, 13
external style sheets, attaching, 302-303
finding/replacing text or code, 102-103
Folder list, opening with, 47
Folders view, opening in, 46
formats for, 37
formatting options, setting, 54
general options, setting, 54
Go To URL behavior, 197
graphic format, changing, 149
home page, setting as, 52
HTML pages, creating, 44-45
hyperlinks, creating, 174
language of page, specifying, 55
moving, 51
navigating, 48
new folders, creating, 51
page numbers, adding, 65
previewing, 62-63
properties, changing, 54-55
recently opened pages, opening, 13
renaming, 50
saving, 12
simple page, creating, 11
size, setting, 60-61, 63
spell-checking, 106
switching between views and, 16
title, changing, 53

Web servers. See servers
Web Site Wizard, importing with, 34
Web sites. See also publishing Web sites;

templates; Web pages; 
adding pages to, 36-37
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animating page transitions, 76
deleting, 41
empty Web site, creating, 30-31
existing site, opening, 32-33
finding/replacing text or code, 102-103
folders and files, list of, 10
Go To URL behavior, 197
importing content from, 34-35
introduction to, 23
languages, setting, 110-111
last opened site, opening, 32
names, changing, 352
one page site, creating, 30
planning, 24
previewing, 352
recently opened site, opening, 32
remote servers, connecting to, 346-347
renaming, 40
reports, generating, 336-337
saving, 39
spell-checking, 106-107
types of, 24
updating, 350-351

WebDAV, 34
as remote server, 346

WebTV version, checking, 204
Whole Page target hyperlink, 177
width. See also tables

of interactive buttons, 191
of layout tables, 213, 216
line width, changing, 91

window, viewing, 5
Windows color scheme

changing, user interface, 5, 356
Windows Media Audio (WMA)

inserting, 158-159
setting options, 160

Windows Media Video (WMV)
inserting, 158-159
setting options, 160

Windows menu, navigating with, 48
Windows Vista

exclusion dictionary in, 109
languages, setting keyboard for, 110

Windows Presentation Foundation
in Expression Blend, 396

Windows XP
exclusion dictionary in, 109
languages, setting keyboard for, 110

WMF files, 118. See also graphics
WMfiles, 119
Word 2007 files, 115
word wrap, 361
workgroups

removed from product, 403
Wrap Tag command, 294
Wrapping Style options, 138
wrapping text, 11

on graphics, 138
word wrap, 361

WYSIWYG view, 14

X

XAML (eXtensible Application Markup
Language)

creating, 396
inserting, Silverlight media, 163
overview, 162-163

XHMTL 1.0 Transitional rules, 342
XLS format, exporting Web content as, 66
XML (eXtensible Markup Language), 37, 326

applying, 335
checking, pages, 332
creating

page, 326
data view

creating, 327
formatting, 330-331
work with, 328-329

form results, saving, 274
formatting, applying, 333
RSS feed, 334
saving, 75

Z

ZIP files, hyperlinks to, 175
z-value

for layers, 136
for positioning graphics, 135
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