
Working with Web Pages

Introduction

Once on the Web, you can open other Web pages in the
Folder List or Folders views, or you can even open up
another page using the Windows menu. Microsoft Expression
Web provides several ways to navigate between pages. After
you open a Web page, you can use the document tabs at the
top of the editing window in Design view, choose the Web
page’s name from the Window menu, or press Ctrl+Tab until
the page you want appears in the window to navigate
between pages. 

One of the most user-friendly components of Expression
Web is its capability to automatically convert text and images
into HTML format. When you save a Web site or Web page, it
is actually being saved in HTML format. After you create a
Web site, you can use the Folder List view to quickly and eas-
ily manage individual Web pages.

When looking at a Web site, there are certain details that
can make your Web pages a site that visitors will return to.
Microsoft Expression Web helps you generate that type of
site.  Visitors might notice a washed out background picture
called a watermark. Or maybe it’s a soothing color or light
sound as you pass over certain feature of the page. Having a
custom feel will express to your visitors that you’ve spent
time and looked at every detail of your site.

You can preview your Web pages in a browser, or in
Design view. Because each browser can display your site dif-
ferently, you will want to examine your site using several of
the most popular browser formats. You can also create your
own template, instead of using one of the built-in page tem-
plates that comes with Expression Web. 3

3
What You’ll Do

Create an HTML or ASP.NET Page

Open Web Pages from Within a Web

Navigate Web Pages

Display Web Pages in the HTML Format

Manage Web Pages

Set the Home Page

Change the Web Page Title

Change Web Page Properties

Insert Background Pictures and
Watermarks

Change Background Colors

Add Background Sound

Set Page Size

Preview and Print Web Pages

Export Web Content

Create a Page Template

Use a Dynamic Page Template

Create a Master and Content Page

Save a Web Page with 
Different Formats

Animate Page Transitions
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An HTML page is a common Web page. HTML is a coding language
that describes the elements on a Web page and instructs a Web
browser how to display it. As you add elements to an HTML page in
Design view, Expression Web creates the HTML code behind it. If you
are familiar with the HTML language, you can use the Code view to
make code changes. Split view allows you to display Design and Code
view at the same time, which makes it a beneficial learning tool. When
you add an element in Design view, you can view the related code in
Code view. 

Creating an HTML
Page

Create an HTML Page

Click the Web Site tab for the site
in which you want a new page. 

Click the New button list arrow on
the Common toolbar, and then
click Page.

TIMESAVER Click the New
button list arrow on the Common
toolbar, and then click HTML.

In the left pane, click General.

Click HTML.

Click OK.

An untitled Web page appears. 

Click the Save button on the
Common toolbar, type a name for
the page, and then click Save.
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ASP.NET is the latest dynamic Web site technology from Microsoft.
With ASP.NET 2.0, you can display data from a database on a Web
page, allow users to create accounts and log in to your Web site, add
validation to forms, and add dynamic Web site navigation. ASP.NET is a
server technology, so in order to use it, you need to install it on a Web
server; check with your administrator or ISP about installing ASP.NET
2.0. You also need to install .NET Framework 2.0, which already comes
installed with Microsoft Windows Vista. You can also download it from
the Microsoft Web site at www.microsoft.com. You can use the New
dialog box to create several different types of ASP.NET pages.

Creating an ASP.NET
Page

Create an ASP.NET Page

Click the Web Site tab for the site
in which you want a new page. 

Click the New button list arrow on
the Common toolbar, and then
click Page.

In the left pane, click ASP.NET.

Click the type of ASP.NET page you
want.

Click OK.

An untitled Web page appears. 

Click the Save button on the
Common toolbar, type a name for
the page, and then click Save.
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Did You Know?
You can test your ASP.NET pages
without a Web server. If you want to
create ASP.NET pages, yet you don’t
have access to a Web server during
development, Expression Web provides
an ASP.NET Development Server so
you can test your ASP.NET pages.

3 4

5

See Also
See “Changing Web Site Settings” on
page 312  for information on setting up
the ASP.NET Development Server.
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Expression Web allows you to multi-task, which means you can have
more than one Web page open at the same time. After you open a Web
site, you can quickly open Web pages in Folders view, or from the
Folder List instead of using the Open button on the Common toolbar or
the Open command on the File menu. If you want to view open Web
pages in a separate Expression Web window, you can display the page,
and then choose Open in New Window from the Window menu. You
can press Alt+Tab to switch between the separate windows. Instead of
starting from scratch to create a new page, you can open a copy of an
existing page with the default new Web page title of Untitled_1.htm.

46

Opening Web Pages
from Within a Web

Open a Web Page in Folders
View

Open the Web site with the Web
page you want to open.

Click the Web Site tab.

Click the Folders button.

Double-click the icon or file name
representing the page you want to
access. 

4

3

2

1

Did You Know?
You can open a linked page from
Design view. Press and hold Ctrl and
click a hyperlink in the page, or right-
click a hyperlink in a page that’s
already open, and then click Follow
Hyperlink. 3

2

4

See Also
See “Opening an Existing Web Page”
on page 13  for information on opening
an external Web page.

C03WE07.qxd  3/14/2007  12:35 AM  Page 46



Chapter 3 Working with Web Pages 47

Open a Web Page Using the
Folder List

Open the Web site with the Web
page you want to open.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

Double-click the page you want to
open.

Open a Copy of a Web Page
Using the Folder List

Open the Web site with the Web
page you want to open.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

Right-click the page you want to
copy, and then click New From
Existing Page.

A new untitled page appears in the
Editing window with content and
formats from the original template
Web page.

Click the Save button on the
Common toolbar.

Navigate to the Web site folder
location where you want to add
pages.

Type a name for the page, or use
the suggested name, and then
click Save.

6

5

4

3

2

1

3

2

1

2 3 Web page opened from Folder List1

2

3

4 1

C03WE07.qxd  3/14/2007  12:36 AM  Page 47



Expression Web provides several ways to navigate between pages.
After you open a Web page, you can use the document tabs at the top
of the Editing window, choose the Web page’s name from the Window
menu, or press Ctrl+Tab until the page you want appears in the window
to navigate between pages. 

48

Navigating Web 
Pages

Navigate Web Pages Using
Document Tabs

Open the Web site with the Web
page you want to display, and then
open the Web page.

Click the document tab with the
page you want to display.

Navigate Web Pages Using the
Windows Menu

Open the Web site with the Web
page you want to display, and then
open the Web page.

Click the Window menu. 

This displays a list of up to nine
open Web pages.

Click the page you want to open.
The Web page opens in Page
view.
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One of the most user-friendly components of Expression Web is its
capability to automatically convert text and images into HTML format. If
you’re familiar with HTML, you might be comfortable enough to work in
this mode. HTML adds a series of format instructions to your content
using tags, such as <i>, that indicate how to format the text for display
on the Web. Use the Quick Tag Selector to select any tag in your Web
page. Use the Quick Tag Editor to insert, wrap, and edit HTML tags.
Expression Web uses colored text to distinguish between elements
when working in HTML format.

Chapter 3 Working with Web Pages 49

Displaying Web 
Pages in the HTML
Format

Display a Web Page in HTML

Open the Web page you want to
display in the HTML format.

Click the Split or Code button at
the bottom of the window. 

The Web page appears in HTML
coded form.

Display HTML Tags in 
Design View

Open the Web page you want to
display HTML tags.

Click the View menu‚ and then
click Quick Tag Selector. 

HTML tags appear in capsule-size,
six-sided frames within the text.

To turn off HTML tags, click the
View menu‚ and then click Quick
Tag Selector again. 

3
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2 Quick Tag Selector1
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After you create a Web site, you can use the Folder List to quickly and
easily manage individual Web pages, files and folders. If a page name
is not exactly what you want, you can quickly rename it. The page
name is the file name in your folder list, such as default.htm. You can
create and name a new folder and move pages to a different location. If
you no longer need or want a Web page, you can remove it. You can
determine whether you want the page deleted from your hard drive or
just from the Web.

50

Managing Web Pages

Rename a Web Page

Open the Web site with the Web
page you want to rename.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to rename, and
then click Rename.

TIMESAVER Click the file
name in the Folder List, click the
file again to highlight it.

Select the name of the Web page
file, except the extension, such as
.htm.

Type a new name, and then press
Enter.

5

4
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2

1

Did You Know?
You can delete a Web page. In the
Folder List, right-click the Web page
you want to delete, click Delete, and
then click Yes.

1

3

2

5

C03WE07.qxd  3/14/2007  12:37 AM  Page 50



Chapter 3 Working with Web Pages 51

Create a New Folder

Open the Web site with the Web
page you want to rename.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

Click the New Folder button.

Type a new name, and then press
Enter.

Move a Web Page

Open the Web site with the Web
page you want to move.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, display the page
you want to use.

Drag the page icon to the position
where you want it to occupy on
your site.
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When you create a Web site using a template, Expression Web auto-
matically creates a home page called default.htm, which is the first
page visitors see when they visit your site. If you already have a home
page or want to create a different one, you can quickly set the one you
want as the new home page using the Folder List.

Setting the Home 
Page

Set a Web Page as the Home
Page

Open the Web site with the Web
page you want to change.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to set as the new
home page, and then click Set as
Home Page.
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A Web page title is the text that visitors see on the title bar of their Web
browser when they display the Web page. Expression Web automati-
cally sets the Web page title to the same text as the Web page file
name. However, the two perform different tasks. The Web page title
displays a message, while the Web pane name identifies a file. When
you save a Web page, you can change the title. If you didn’t change the
title during the save process or you want to change it, you can use the
Properties dialog box.

Changing the Web
Page Title

Change the Web Page Title

Open the Web site with the Web
page you want to change.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to change, and
then click Properties.

The Properties dialog box opens,
displaying the General tab with the
current title selected.

Type a new name for the title.

Click OK.5

4

3

2

1

Did You Know?
You can change a Web page title in
the Title column. If the Title column in
the Editing window is enabled, you can
select the title text, and then type a
new title.
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Expression Web allows you to change individual Web page properties
using the Page Properties dialog box. You can change the Web page
title, add a page description, and specify keywords for search engines
(which aren’t used to much anymore; most search engines use other
methods). You can also insert a background sound or image, make the
background image a transparent watermark, or change the color. When
you insert a background sound, it plays once when you open the Web
page unless you select the Loop option. In addition, you can change the
color of page text and hyperlinks. For advanced feature, you can set
page margins, work with code snippets, specify a language, or set
workgroup options.

Changing Web Page
Properties

Change Web Page Properties

Open the Web site with the Web
page you want to change, and
then click the Web page tab.

Click the File menu, and then click
Properties.

Click the tab you want to use, and
then select the options you want:

◆ General. Use this tab to change
the Web page title, add a page
description, specify keywords
for search engines, and insert a
background sound. You can
also specify a base location,
which changes the root
location (where your home
page is typically located). 

◆ Formatting. Use this tab to
insert a background image, and
make it a watermark
(transparent). To delete a
background, select the image
path and delete it. You can also
use this tab to change the
background, text, or link colors
on the current page. If you
insert a background sound, you
can also select the look option.

Continue Next Page

3

2

1
General properties

Add text

Add background
sound

Change colors

Change background

Formatting properties
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◆ Advanced. Use this tab to set
margins for the current page.
However, it’s more efficient to
make margin changes using
CSS.

◆ Custom. Use this tab to add,
modify, or remove custom code
snippets based on system and
user variables. A code snippet
is a reusable segment of code.

◆ Language. Use this tab to
specify the page language and
HTML encoding you want to
use. These options make sure
your Web browser and
Expression Web uses the right
characters set for the selected
language. The default for HTML
encoding is Unicode (UTF-8).

◆ Workgroup. Use this tab to set
options that are useful when
you have multiple people
working on a site. You can
organize pages in categories,
assign pages to a specific
person, and specify current
review status.

Click OK.5

Did You Know?
What is a Unicode? A character cod-
ing standard that defines a set of let-
ters, numbers, and symbols that
represent almost all of the written lan-
guages in the world.

Advanced properties

Set margins

Language properties

Set language and
HTML encoding
options

Workgroup properties

Set options to
work on a team
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You can use a picture as the background for a page. Pictures can be
taken from elsewhere on your site, a file, clip art, or the Web. You can
also use a background picture in watermark form. A watermark is a
background effect that displays a graphic in a light shade behind your
text on your page. You can use a washed out version of your company
logo, or you can add graphical text such as Under Construction.
Pictures and watermarks display in the background titled across the
page. Be aware that not all Web browsers support watermarks.

Inserting Background
Pictures and
Watermarks

Insert a Background Picture

Open and display the Web page
you want to use. 

Right-click anywhere on the page
to which you want to insert a
background picture, and then click
Page Properties.

Click the Formatting tab.

Select the Background Picture
check box. 

TROUBLE? If the option is
grayed out, you need to open the
master page.

Click Browse.

Locate and select the picture you
want to insert, and then click
Open. 

The picture you selected now
opens as a background image.

Click OK.7

6

5

4

3

2

1

Did You Know?
You can avoid picture background
tiling. Make your picture wider than
any typical computer screen. You can
use a solid background color or make
it transparent to achieve the look you
want.

7

3 4

5
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Insert a Background Picture
Watermark

Open and display the Web page
you want to use. 

Right-click anywhere on the page
to which you want to insert a
background picture, and then click
Page Properties.

Click the Formatting tab.

Select the Background Picture
check box. 

Select the Make it a watermark
check box.

Click Browse.

Locate and select the picture you
want to insert, and then click
Open. 

The picture you selected now
opens as a background image. 

Click OK.8
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If you’d like to add some interest to your pages, you can add back-
ground colors. When selecting background colors, some creative judg-
ment is required. For example, if you choose a dark color for your
background, make sure you use a light color for your text (the most
commonly used is white) to generate the appropriate contrast required
for easy reading.

Changing Background
Colors

Change the Background Color of
a Web Page

Open and display the Web page
you want to use. 

Right-click the page to which you
want to change a background
color, and then click Page
Properties.

Click the Formatting tab.

Click the Background list arrow.

Click the color you want on the
color palette.

Click OK.6

5

4
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3
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4

C03WE07.qxd  3/14/2007  12:40 AM  Page 58



Chapter 3 Working with Web Pages 59

You can introduce background sounds to accompany and enhance
your Web page. There’s nothing like hearing a favorite tune when you
enter a site or visit a particular page. The sound can be played continu-
ously in a loop, or you can set it for a desired number of plays. Be
aware that not all browsers support background sound.

Adding Background
Sound

Add a Background Sound to a
Web Page

Open and display the Web page
you want to use. 

Right-click the page to which you
want to add a background sound,
and then click Page Properties.

If necessary, click the General tab.

Type the sound file name or click
Browse, locate and select the
sound file you want to use, and
then click Open. 

To set the sound to repeat
continuously, clear the Forever
check box, and then click the
number arrows in the Loop box to
set the number of times you want
the sound to play.

Click OK. 

Whenever a visitor opens the
page, they will hear the sound
effect you chose.
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Since visitors to your Web site can use different screen resolutions or
window sizes, you need to develop Web pages so a variety of users
can view it without having to zoom in or scroll to much. You can use the
Page Size command to simulate different page size to see how your
pages look. The page sizes available using the Page Size command
correspond to standard screen resolutions, which include 640 x 480,
800 x 600 and 1024 x 768 (all maximized). 

1 2

Setting Page Size

Change the Page Size View

Click the View menu, and then
point to Page Size.

Click the page size you want.

TIMESAVER Click the current
page size on the status bar, and
then click a new size.

2

1
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Change the Page Size

Click the View menu, point to Page
Size, and then click Modify Page
Sizes. 

Perform the page size commands
you want:

◆ Add. Click Add, enter width,
height and a description, and
then click OK.

◆ Modify. Select a page size,
click Modify, make changes,
and then click OK.

◆ Remove. Select a page size,
and then click Remove.

◆ Reset. Click Reset to return to
default page sizes.

Click OK.3

2

1

3

2
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Because each browser can display your site differently, you will want
to examine your site using several of the most popular browser formats
and different sizes. When you are ready to see how your page will look
to visitors, click the Preview in Browser button arrow on the Common
toolbar and then select a browser and a window size. When you select
a browser, the program starts and displays your Web page as you
would see it on the Web. If you want to add additional browsers to the
list, you can select them using the Edit Browser List dialog box. You can
also simulate the page size of a browser as you work in Design view by
selecting different page sizes on the Page Sizes submenu on the View
menu.

62

Previewing Web
Pages

Add Browsers to the Preview 

Click the File menu, point to
Preview in Browser, and then
click Edit Browser List.

Click Add.

The Add Browser dialog box
opens.

Type the browser’s name.

Click Browse.

Navigate to the location where the
browser program is stored, select
it, and then click Open.

Click OK.

To automatically save a Web page
before previewing, select the
Automatically save page before
previewing check box.

To specify the window sizes you
want, select the 640 x 480, 800 x
600, or 1024 x 768 check boxes.

Click OK.9
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Preview a Web Page Using 
a Browser

Open the Web page you want to
preview.

Click the Preview in Browser
button arrow. 

Click the browser with the specific
size you want to use to preview
your site or page. 

TIMESAVER Press F12 to
preview the Web page in the most
recently used browser and size.

3

2

1

Did You Know?
You need to install other browsers
before you can preview your pages.
You must have previously installed the
full version of other browsers like
Netscape Navigator or Fire Fox if you
want to preview how your pages will
appear to users of those browsers.

You need to save your pages before
you can preview them. To be sure that
you have saved the page you want to
preview, click the Automatically save
page before previewing check box to
select it in the Edit Browser List dialog
box. Click the File menu, point to
Preview in Browser, and then click Edit
Browser List.

You can change the Web page size in
Design view. Click the View menu,
point to Page Size, and then select the
size you want. If the Design view win-
dow is wider than the width you spec-
ify, gray areas appear on either side. If
Design view is narrower than the
width you specify, you’ll need to scroll
the Design view window right or left. A
dotted line across the page indicates
the bottom of the browser window.

2 3

Click to preview selected
page in multiple browsers

Preview in Internet Explorer
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Printed pages are helpful when you are working in Preview view.
Rather than toggling between a page in progress and a Browser
Preview of that page, for example, you can print the Preview so that
you have it in hard copy format. Printouts are also helpful when editing
your pages. Before printing, you can preview the page to determine
that there are no obvious errors.

64

Previewing and
Printing Web Pages

Print Preview Web Pages

Open and display the Web page
you want to preview.

Click the File menu‚ point to Print,
and then click Print Preview. This
opens a scaled-down image of the
page you want to print and a
series of buttons. The button
choices are:

◆ Print button. Engages the
printing process. The preview
closes and the Print dialog box
opens.

◆ Next Page button. Displays the
next page in the sequence for
multiple-page printing.

◆ Previous Page button. Takes
you to the previous page in a
sequence.

◆ Two Page button. Toggles
between a single-page and a
two-page spread in Preview
mode.

◆ Zoom In button. Magnifies the
preview image.

◆ Zoom Out button. Reduces the
size of the characters to show
more of the page preview.

◆ Close button. Closes the
Preview mode.

When you’re done, click the Close
button.

3

2

1
2 1 3
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Print Web Pages

Open and display the Web page
you want to print.

Click the File menu‚ point to Print,
and then click Print. 

Select the print options you want.

Click OK.4

3

2

1

For Your Information

Setting Up the Print Page Format 
When you print a Web page, you can use the Print Page Setup dialog
box to control the printing of text and graphics on a page. To open
the Print Page Setup dialog box, click the File menu, point to Print,
and then click Page Setup. The Print Page Setup dialog box allows
you to specify page margins and header and footer information. In
the Headers and Footers text boxes, you can type text to appear as a
header and footer of a Web page you print. In these text boxes, you
can also use variables to substitute information about the current
page, and you can combine text and codes. For example, if you type
Page &p of &P in the Header text box, the current page number and
the total number of pages print at the top of each printed page.
Check Expression Web and Internet Explorer Help for a complete list
of header and footer codes.

4

3
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When you export Web content, you save the information in a new for-
mat so that it can be opened in an entirely different program. You can
export one or more files from Expression Web to a location outside your
Web using the Export command or Copy and Paste commands. This
process can be executed using the Folder List or Folders view. 

66

Exporting Web 
Content

Export Web Content 

Open the Web site with the Web
page you want to change.

If necessary, click the View menu,
and then click Folder List to
display the Folder List.

In the Folder List, select the file
you want to export.

Click the File menu‚ point to
Export, and then click File. 

Navigate to the drive and folder
location where you want to export
the Web content.

Type a name for the page, or use
the suggested name.

Click the Save as type list arrow,
and then click the file type you
want.

◆ HTML (.htm, .html)

◆ GIF and JPEG (.gif, .jpg)

◆ Microsoft Office Files (.doc,
.xls, .ppt)

Click Save.8
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Export Web Content Using Copy 
and Paste

Select the information you want to
copy.

Click the Edit menu, and then click
Copy.

Display the location in which you
want to move the content.

Click the area where you want to
place the content.

Click the Paste button on the
toolbar.

The source files or folders are
copied into their new location.

5

4

3

2

1

2 1

5 4 3
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Instead of using one of the built-in page templates that comes with
Expression Web, you can create your own. There are two kinds of page
templates: static and dynamic. A static template is a Web page you
create and design, which is completely editable. After you save a static
page template, you can access it in the My Templates tab of the Page
Templates dialog box. A dynamic template is a Web page with editable
areas like a static template, yet also contains non-editable areas with
content that changes based on circumstances, such as actions taken
by a user or the date. 

68

Creating a Page
Template

Create a Static Template

Design and display the Web page
you want to create into a static
template.

Click the File menu‚ and then click
Save As.

Type a name for the template.

Click the Save as type list arrow,
and then click Page Template.

The folder location changes to the
Pages folder, where Expression
Web stores page templates.

Click Save.

Type the title you want for the
template.

Type a description for the
template.

To save the template in the current
Web site, select the Save
Template in Current Web site
check box.

Click OK.9
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Create a Dynamic Template

Design and display the Web page
you want to create into a dynamic
template. Be sure to leave areas
open to create editable regions.

Click the File menu‚ and then click
Save As.

Type a name for the template.

Click the Save as type list arrow,
and then click Dynamic Web
Template.

The folder location changes to the
Pages folder, where Expression
Web stores page templates.

Click Save.

Create Editable Regions for a
Dynamic Template

Display the Dynamic Web
Template you want to change.

Select the page area you want to
vary from page to page.

Click the Format menu‚ point to
Dynamic Web Template, and then
click Manage Editable Regions.

Type a name for the area you
selected.

Click Add.

Click Close.

You can repeat Steps 2 through 6
to designate other dynamic areas.
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After you create a dynamic Web template, you can apply, or attach, the
template to an open Web page. When you attach a dynamic Web tem-
plate to a Web page, Expression Web tries to map regions on the ordi-
nary Web page to editable regions in the template. If you don’t like the
initial mapping, you can modify or skip it. After you attach a dynamic
Web template to an ordinary Web page, you can modify non-editable
regions in Code view, or any editor other than Design view to create
updatable content.

70

Using a Dynamic 
Page Template

Attach a Dynamic Web Template

Display the Web page in which
you want to apply a dynamic page
template.

Click the Format menu‚ point to
Dynamic Web Template, and then
click Attach Dynamic Web
Template.

Locate and select the dynamic
Web template you want to apply.

Click Open.

Select which regions in the new
page will receive content/regions
from the old page.

Click Modify, select a new
mapping, and then click OK.

Click OK to attach the template.

Click Close.8
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Did You Know?
You can manage editable regions.
Click the Format menu, point to
Dynamic Web Template, and then click
Manage Editable Regions.
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Update a Dynamic Web
Template

Open the dynamic Web page
template, and then make the
changes you want to update on
other pages.

Click the Format menu‚ and then
point to Dynamic Web Template.

Click the update command you
want.

◆ Update Selected Page

◆ Update All Pages

◆ Update Attached Pages

3

2

1

Did You Know?
You can detach a Dynamic Web
Template from a Web page. Open and
display the Web page with the
Dynamic Web Template attached, click
the Format menu, point to Dynamic
Web Template, and then click Detach
from Dynamic Web Template. If you
want to open an attached Dynamic
Web Template page, click Open
Attached Dynamic Web Template on
the submenu.

2

3
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A Master page is a special type of ASP.NET page that allows you to
share contents, such as graphics, HTML code, and ASP.NET controls,
between pages. Master pages are similar to Dynamic Web Templates
because they share elements between pages. However, Master pages
add the ability to share code. If you have ASP.NET 2.0 available on your
Web server, you can take advantage of Master pages. A Master page
uses content controls instead of editable regions in a Dynamic Web
Template. The content control on the Master page (ContentPlace
Holder) maps to the content control on the Content page (Content).
After you create a Master page using a template in the New dialog box,
you need to save it with the .master file extension. Now, you can create
a Content page and link it to a Master page.

Creating a Master 
and Content Page

Create a Master Web Page

Click the File menu‚ point to New,
and then click Page.

In the left pane, click General or
ASP.NET.

Click Master Page.

Click OK.

An Untitled_1.master page
appears in the Editing window.

Click the File menu‚ and then click
Save As.

Type a name for the master page.

Click the Save as type list arrow,
and then click Master Page.

Click Save.8
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Did You Know?
You can manage content regions. Click
the Format menu, point to Master
Pages, and then click Manage Content
Regions.
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Create a Content Web Page

Click the File menu‚ point to New,
and then click Page.

In the left pane, click General or
ASP.NET.

Click Create from Master Page.

Click OK.

Click the Specific Master Page
option.

Click Browse, locate and select
the master page, and then click
Open.

Click OK.

An Untitled_1.aspx content page
appears in the Editing window.

The Content page pulls in the
content from the Master page in
the ControlPlaceHolder control.

Click the File menu‚ and then click
Save As.

Type a name for the content page.

Click the Save as type list arrow,
and then click Web Pages.

This saves the content page with
the .aspx extension.

Click Save.11
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Did You Know?
You can detach a Master page. Open
and display the Content page, click the
Format menu, point to Master Pages,
and then click Detach from Master
Page. If you want to open an attached
Master page, click Open Attached
Master Page on the submenu.
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A file type specifies the file format (for example, a template) as well as
the program and version in which the file was created (for example,
Expression Web). You might want to change the type if you’re creating
a custom template or sharing files with someone who needs them for
use in another program. You use the Save As dialog box to change the
file type for a page. The Save as type list arrow displays a list of the
available formats for the program or current selection.

Saving a Web Page
with Different Formats

Save a Web Page as a 
Different Type

Open and display the Web page
you want to save in a different
format.

Click the File menu, and then click
Save As.

Navigate to the drive and folder
location where you want to save
the Web page.

Type a name for the page, or use
the suggested name.

Click the Save as type list arrow,
and then click the file type you
want.

Click Save.6
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1

See Also
See “Expression Web Formats” on
page 75 for information on selecting
the right file format.
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For Your Information

Saving Web Related Files

When you use Web related-files, typically scripts, created in other
programs, make changes, and save the Web page or Web site,
Expression Web saves the other Web related-files in their native file
format. Some of the native file formats include ColdFusion Markup
Language (.cfm), PHP Script (.php, .php2,.php3, .php4), HTML File with
Server Side (.shtm, .shtml, .shm), State Transition Diagram model file
(.stm), Hypertext template (.htt), Hypertext application (.hta), HTML
Component (.htc), Ascii text file (.asc), and Microsoft .NET Web
Service file (.asmx). The files listed in the Save File Formats table on
the next page are included in this list too.
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Expression Web Save File Formats

Save As file type Extension Used to save

All Files *.* Complete Web site

Web Pages Files in their native format; includes the formats in this 
list and the ones in the side bar on the previous page

HTML Files .htm, .html Web pages as a HTML file

Dynamic Web Template .dwt Web pages as a changeable Expression Web template

ASP and ASPX Files .asp, .aspx Web pages as a Microsoft Active Server Page

Master Page .master Web pages as Expression Web master page file; a 
special type of ASP.NET file

JScript Files .js Scripts as a Microsoft Scripting Language "JScript" file

VBScript Files .vba Scripts as a Visual Basic for Applications file

CSS Files .css Web pages as a cascading style sheet

XML .xml, .xsd,.xsl, .xslt, .dtd Web pages as an XML file

Text .txt Web pages as a text file

Page Template .tem Web pages as a static Expression Web template

Expression Web Formats

Expression Web Open File Formats

Files of type Extension Used to open

All files in the above table All files from the above list
are included in this list

Recover Text from Any file *.* Text files not supported (from this list below)

WordPerfect 5.x .doc WordPerfect 5.0 files

WordPerfect 6.0 .wpd, .doc WordPerfect 6.0 files

Works 6.0 - 9.0 .wps Works 6.0-9.0 files

Word 2007 Document  (New!) .docx Word 2007 documents

Word 2007 Macro-Enabled .docx Word 2007 documents that contains Visual Basic 
Document  (New!) for Applications (VBA) code

Word 97 - 2003 Document .doc Word 97 to Word 2003 documents
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You can use animation in your Web site to provide interest and call
attention to important information. When you move from one Web page
to another, you can display a transition effect between the two pages.
You can select a transition effect, and then specify when the page tran-
sition occurs, and how long it lasts. The only disadvantage of page
transitions is that the browser must wait for the entire Web page to
load before it can apply the transition effect. Be aware that animated
page transitions are not supported by all browsers.

Animating Page
Transitions

Apply a Page Transition

Open and display the Web page
you want to use. 

Click the Format menu, and then
click Page Transition.

Click the Event list arrow, and then
click an event type: Page Enter,
Page Exit, Site Enter, or Site Exit.

Click the transition effect you
want.

Set the duration (in seconds) of
the transition effect.

Click OK.6
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