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CHAPTER 22

Analyzing Data with 
PivotTable Reports

A PivotTable report is a special kind of table that summarizes information from 
selected fi elds of a data source. The source can be a Microsoft Offi ce Excel 2007 

list, a relational database fi le, an Online Analytical Processing (OLAP) cube, or mul-
tiple consolidation ranges (multiple ranges containing similar data, which the PivotTable 
can assemble and summarize). When you create a PivotTable, you specify which fi elds 
you’re interested in, how you want the table organized, and what kinds of calculations 
you want the table to perform. After you build the table, you can rearrange it to view 
your data from alternative perspectives. This ability to “pivot” the dimensions of your 
table—for example, to transpose column headings to row positions—gives the PivotTable 
its name and its analytical power.

Introducing PivotTables
PivotTables are linked to the data from which they’re derived. If the PivotTable is based 
on external data (data stored outside Excel), you can choose to have it refreshed at regu-
lar time intervals, or you can refresh it whenever you want.

Figure 22-1 shows Books.xlsx, a list of sales fi gures for a small publishing fi rm. The 
list is organized by year, quarter, category, distribution channel, units sold, and sales 
receipts. The data spans a period of eight quarters (2005 and 2006). The fi rm publishes 
six categories of fi ction (Mystery, Western, Romance, Sci Fi, Young Adult, and Children) 
and uses three distribution channels—domestic, international, and mail order. It’s diffi -
cult to get useful summary information by looking at a list like this, even though the list 
itself is well organized.

You’ll fi nd the Books.xlsx fi le in the Sample Files section of the companion CD.
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Figure 22-1 It’s diffi cult to see the bottom line in a fl at list like this; turning the list into a PivotTable 
will help.

Figures 22-2 through 22-4 show several ways you can transform this fl at table into 
 PivotTables that show summary information at a glance. 

The example on the left in Figure 22-2 breaks the data down fi rst by category, second 
by distribution channel, and fi nally by year, with the total sales at each level displayed 
in column B. Looking at this table, you can see (among many other details) that the 
 Children category generated domestic sales of $363,222, with more revenue in 2005 
than in 2006. 

In the example on the right in Figure 22-2, the per-category data is broken out fi rst by 
year and then by distribution channel. The data is the same; only the perspective is 
 different.
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Figure 22-2 These two PivotTables provide summary views of the information in Figure 22-1.

Both the PivotTables shown in Figure 22-2 are single-axis tables. That is, we’ve gener-
ated a set of row labels (Children, Mystery, Romance, and so on) and set up outline 
entries below these labels. (And, by default, Offi ce Excel 2007 displays outline controls 
beside all the headings, so we can collapse or expand the headings to suit our needs.)

Figure 22-3 shows a more elaborate PivotTable that uses two axes. Along the row axis, 
we have categories broken out by distribution channel. Along the column axis, we have 
years (2005 and 2006). And we added the quarterly detail (not included in the Figure 
22-2 examples) so we can see how each category in each channel did each quarter of 
each year. With four dimensions (category, distribution channel, year, and quarter) and 
two axes (row and column), we have a lot of choices about how to arrange the furniture. 
Figure 22-3 shows only one of many possible permutations.



C
h

ap
ter 22

714 Chapter 22 Analyzing Data with PivotTable Reports 
Figure 22-3 In this PivotTable, we’ve rearranged the data along two axes—rows and columns.

Figure 22-4 presents a different view. Now the distribution channels are arrayed by 
themselves along the column axis, while the row axis offers years broken out by quar-
ters. The category, meanwhile, has been moved to what you might think of as a page 
axis. The data has been fi ltered to show the numbers for a single category, Mystery, but 
by using the fi lter control at the right edge of cell B2, we could switch the table to a dif-
ferent category (or combination of categories). Filtering the Category dimension by one 
category after another would be like fl ipping through a stack of index cards.

None of these tables required more than a few clicks to generate.
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Figure 22-4 This PivotTable presents a “fi ltered” view, confi ning the report to a single category.

Creating a PivotTable
You can create a PivotTable from either an Excel range or an external data source. 
If you’re working from an Excel range, your data should meet the criteria for a well-
 constructed list. That is, it should have column labels at the top (the headings will 
become fi eld names in the PivotTable), each column should contain a particular 
kind of data item, and you should not have any blank rows within the range. If the 
range includes summary formulas (totals, subtotals, or averages, for example), you 
should omit them from the PivotTable; the PivotTable will perform its own summary 
 calculations.

For information about connecting to and querying external data sources, see Chapter 23, 
“Working with External Data.”

The source range on your Excel worksheet can be a table (as described in Chapter 21, 
“Managing Information in Tables”) or an ordinary list. Starting from a table has the 
advantage of allowing for expansion. When you create a PivotTable from a table, Excel 
references your source data by its table name (either a default name, such as Table1, or 
the name you assign to the table). If you add rows to a table, the table name automati-
cally adjusts to encompass the new data, and hence your PivotTable stays in sync with 
the expanded source data.
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For information about converting a list to a table, see “Creating a Table” on page 669.

To create a PivotTable, select a single cell within the source data and do either of the 
following:

O Click the Insert tab, and then click PivotTable (in the Tables group).

O If your source data is a table and you’re currently on the Design tab under Table 
Tools, click Summarize With PivotTable (in the Tools group).

Either way, the Create PivotTable dialog box appears. If your source data has a name 
(we’ve assigned the name BookSales to the source table in our example), that name 
appears in the Table/Range box. Otherwise, Excel discerns the extent of your source 
data and presents a range reference in that box:

By default, your PivotTable arrives on a new worksheet, and that’s generally a good 
arrangement. If you want it elsewhere, specify where in the Location box. After you 
click OK, Excel generates a blank table layout on the left side of the worksheet and dis-
plays the PivotTable Field List window on the right (see Figure 22-5). The PivotTable 
Field List window is docked at the right by default. You can make it wider or narrower 
by dragging the split bar on its left edge. You can also undock it or drag it across the 
worksheet and dock it on the left.

Note
If you want to work with only a subset of items in a fi eld, you can fi lter the fi eld before 

you add it to the table. If your data source is large, and particularly if the source is exter-

nal, you can save some time by fi ltering in advance. (You can also fi lter fi elds after you 

have created the table, of course.) To fi lter a fi eld before you add it to the table, select 

the fi eld name in the PivotTable Field List window, and then click the arrow on the right. 

For more details, see “Filtering PivotTable Fields” on page 728.

Note
If you want to work with only a subset of items in a fi eld, you can fi lter the fi eld before

you add it to the table. If your data source is large, and particularly if the source is exter-

nal, you can save some time by fi ltering in advance. (You can also fi lter fi elds after you

have created the table, of course.) To fi lter a fi eld before you add it to the table, select 

the fi eld name in the PivotTable Field List window, and then click the arrow on the right.

For more details, see “Filtering PivotTable Fields” on page 728.
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Figure 22-5 As you select the check boxes for fi elds in the PivotTable Field List window, Excel popu-
lates the table layout at the left side of the worksheet.

To put some fi elds and data on that blank layout, begin by selecting the check boxes 
for those fi elds in the Choose Fields To Add To Report area of the PivotTable Field List 
window. As you select fi elds, Excel positions them in the four boxes below. These four 
boxes represent the various components of the table. The Row Labels and Column 
Labels boxes hold the fi elds that will appear on the row and column axes. The Report 
Filter box holds the fi eld (or fi elds) you want to use to fi lter the table (comparable to the 
Category fi eld in Figure 22-4), and the Values box holds the fi eld (or fi elds) you want to 
use for calculations—the data you’re summarizing (your sales, for example).

Initially, Excel puts selected fi elds in default table locations that depend on their data 
types. Most likely you’ll want some arrangement other than the one you get by default. 
That’s not a problem, because you can move fi elds from one location to another easily; 
just drag them between the various boxes below the PivotTable Field List window. Let’s 
look at an example.

To create the table shown in Figure 22-3, we want to put the Category and Channel 
fi elds in the Row Labels box, the Year and Quarter fi elds in the Column Labels box, 
and the Sales fi eld in the Values box. When we select the check boxes for those fi elds, 
Excel drops the Category and Channel fi elds in the Row Labels box (because they are 
text fi elds) and the Sales fi eld in the Values box (because it’s a numeric fi eld). These are 
all good guesses on the part of Excel—and, in fact, it’s just what we want. In addition to 
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putting fi eld headings in the appropriate boxes, Excel begins creating our PivotTable—
as Figure 22-6 shows.

Figure 22-6 Excel builds the table, piece by piece, as you select fi elds.

So far, so good. The numeric formats aren’t right, but we can fi x that easily enough.

What remains is to put the Year and Quarter fi elds into the Column Labels box. Unfor-
tunately, if we simply select their check boxes, Excel drops these fi elds in the Values 
box, because the fi elds are numbers and the program has a predilection for adding 
numbers. This (see Figure 22-7) is defi nitely not what we want.

The solution is simple: Select the check boxes for the Year and Quarter fi elds, and then 
drag the Sum of Quarter and Sum of Year headings from the Values box to the Column 
Labels box. (Alternatively, you can make sure your fi eld headings go where you want 
them by dragging them directly from the Choose Fields To Add To Report box to the 
appropriate boxes below, disregarding the defaults.)
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Figure 22-7 By default, Excel puts all numeric fi elds, including years and quarters, in the Values 
box. You can fi x that by dragging fi eld headings to the appropriate locations.

Rearranging PivotTable Fields
To pivot, or rearrange, a PivotTable, drag one or more fi eld headings from one part 
of the PivotTable Field List window to another. For example, by using the mouse to 
change this confi guration of the PivotTable Field List window:
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to this one:

we can change the table from the form shown in Figure 22-3 to this:

Note
If you don’t see the PivotTable Field List window, select a cell in the PivotTable (it disap-

pears when your selection is not within the table). If you still don’t see it, click the Options 

tab under PivotTable Tools on the Ribbon, and then click Field List. This button is a handy 

way to toggle the fi eld list in and out of view, letting you reduce distraction when you 

don’t need to do any fi eld rearrangement.

Note
If you don’t see the PivotTable Field List window, select a cell in the PivotTable (it disap-

pears when your selection is not within the table). If you still don’t see it, click the Options

tab under PivotTable Tools on the Ribbon, and then click Field List. This button is a handy

way to toggle the fi eld list in and out of view, letting you reduce distraction when you 

don’t need to do any fi eld rearrangement.
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Earlier versions of Excel let you move fi elds around by dragging them directly on the 

table, instead of requiring you to work with the PivotTable Field List window. If you prefer 

that way of working, right-click any cell in the PivotTable, and click PivotTable Options. 

In the PivotTable Options dialog box, click the Display tab. Then select the Classic Pivot-

Table Layout (Enables Dragging Of Fields In The Grid) check box. Note, however, that this 

option also changes the appearance of your table from the compact, outline-style pre-

sentation of Excel 2007 to the more space-consuming tabular style of earlier versions.

To rearrange fi elds within the same axis—for example to put Year before Quarter or 
Channel before Category in Figure 22-3, you can drag fi eld headings from one place to 
another within the same area of the PivotTable Field List window. Often it’s simpler to 
click the arrow to the right of the fi eld heading you want to move. (For example, you 
might click the arrow to the right of Category in the Row Labels box.) The menu that 
appears includes easy-to-use positioning commands:

Refreshing a PivotTable
Because users often generate PivotTables from large volumes of data (and in many cases 
that data resides on external servers), Excel doesn’t automatically update PivotTables 
when their source data changes. To refresh a PivotTable, right-click any cell within it, 
and click Refresh. Alternatively, under PivotTable Tools, click the Options tab, and then 
click Refresh in the Data group. Or, if you like keyboard shortcuts, press Alt+F5.

To ensure that your PivotTable is sorted whenever you open the fi le, click a cell within 
the table, click the Options tab under PivotTable Tools, and then click Options in the 
PivotTable group. In the PivotTable Options dialog box, click the Data tab. Then select 
the Refresh Data When Opening The File check box, and click OK.

SIDE OUT Pivot Your Tables the Excel 2003 Way If You Prefer

Earlier versions of Excel let you move fi elds around by dragging them directly on the 

table, instead of requiring you to work with the PivotTable Field List window. If you prefer

that way of working, right-click any cell in the PivotTable, and click PivotTable Options. 

In the PivotTable Options dialog box, click the Display tab. Then select the Classic Pivot-

Table Layout (Enables Dragging Of Fields In The Grid) check box. Note, however, that this

option also changes the appearance of your table from the compact, outline-style pre-

sentation of Excel 2007 to the more space-consuming tabular style of earlier versions.
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Changing the Numeric Format of PivotTable Data
As Figure 22-6 shows, Excel initially displays numeric PivotTable data in the General 
format, regardless of how it’s formatted in your source range. To fi x that, right-click a 
cell in the fi eld you want to change, and then click Number Format.

Choosing Report Layout Options
PivotTables in Excel 2007, by default, use a more compact presentation style than ear-
lier versions used. This default layout (called Compact) indents inner fi elds on the row 
axis beneath their outer fi elds, letting you see more information at a glance. If you pre-
fer, you can select from two alternative layouts, called Outline and Tabular. To switch 
from one layout to another, select a cell within the table, click the Design tab under 
PivotTable Tools, click Report Layout (in the Layout group), and then click one of the 
displayed layouts (Show In Compact Form, Show In Outline Form, or Show In Tabular 
Form). Figure 22-8 compares the three layout options.

Note that the layout options affect the row axis only. For example, the outline form sim-
ply indents the distribution channels below each category of book.

Figure 22-8 Excel offers three PivotTable layout options: Compact (left), Outline (center), and 
 Tabular (right).
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Formatting a PivotTable
The Design tab that appears on the Ribbon under PivotTable Tools when you select 
any part of a PivotTable includes a large selection of professionally designed PivotTable 
styles. These work just like—and, in fact, are similar to—the styles available with ordi-
nary tables. By choosing from the PivotTable Styles gallery, you can ensure that your 
PivotTable looks good and uses colors consistent with the rest of your workbook. You 
can customize the built-in style choices by selecting or clearing the check boxes in the 
PivotTable Style Options group, and you can add your own designs by clicking New 
PivotTable Style at the bottom of the PivotTable Styles gallery. To display the PivotTable 
Styles gallery, click the More button at the bottom of the scroll bar. (This button is a 
small arrow with a line above it.) For more information about using and customizing 
built-in styles, see “Formatting Tables” on page 705.

Customizing the Display of Empty or Error Cells
Empty cells in a PivotTable are usually displayed as empty cells. If you prefer, you can 
have your PivotTable display something else—a text value such as NA, perhaps—in cells 
that would otherwise be empty. To do this, right-click any cell in the PivotTable, and 
click PivotTable Options. On the Layout & Format tab in the PivotTable Options dialog 
box, select the For Empty Cells Show check box, and in the text box type the text or 
value that you want to see.

If a worksheet formula references a cell containing an error value, that formula returns 
the same error value. This is usually true in PivotTables as well. Error values in your 
source data propagate themselves into the PivotTable. If you prefer, you can have error 
values generate blank cells or text values. To customize this aspect of PivotTable behav-
ior, right-click any cell in the PivotTable, and click PivotTable Options. On the Layout 
& Format tab in the PivotTable Options dialog box, select the For Error Values Show 
check box. Then, in the text box, type what you want to see.

Merging and Centering Field Labels
When you have two or more fi elds stacked either on the column axis or on the row axis 
of a PivotTable, centering the outer labels over the inner ones can sometimes improve 
the table’s readability. Just right-click a PivotTable cell, click PivotTable Options, and 
then select the Merge And Center Cells With Labels check box on the Layout & Format 
tab in the PivotTable Options dialog box. With this option, you can change this kind of 
presentation:

to this:
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Hiding Outline Controls
You’ll probably fi nd outline controls useful in some contexts and not in others. They’re 
great when you have large or complex PivotTables and you want to be able to switch 
quickly from a details view to an overview. But if you fi nd they clutter the picture instead 
of enhancing it, you can banish them easily: Select a PivotTable cell, click the Options 
tab under PivotTable Tools, and then click the +/– Buttons in the Show/Hide group.

Note
With outline controls suppressed, you can still expand and collapse fi eld headings. Select 

a heading in the fi eld you’re interested in, click the Options tab under PivotTable Tools on 

the Ribbon, and then click Expand Entire Field or Collapse Entire Field in the Active Field 

group.

Hiding Row Labels and Column Labels
The headings Row Labels and Column Labels that Excel displays near the upper-left cor-
ner of your PivotTable may prove distracting at times. You can suppress them by select-
ing a PivotTable cell, clicking the Options tab under PivotTable Tools, and then clicking 
Field Headers in the Show/Hide group. Note, however, that removing these labels also 
removes their associated fi lter controls—and you might want those controls from time 
to time (see “Filtering PivotTable Fields” on page 728). The Field Headers command is a 
toggle. Click it again to restore the headings—and the fi lter controls.

Note
You can change the name of a PivotTable fi eld or an item within a fi eld by selecting any 

occurrence of it and typing the name you want. When you change one occurrence, all 

occurrences in the table change. 

Displaying Totals and Subtotals
By default, Excel generates grand totals for all outer fi elds in your PivotTable using the 
same summary function as the body of the table. In Figure 22-3, for example, row 30 
displays grand totals for each quarter of each year, as well as for the years themselves. 
Column L, meanwhile, displays per-category totals by channel. The intersection of 
column L and row 30 displays the grandest of totals, the sum of all sales for the period 
covered by the table. Because the body of the table uses the SUM function, all these 
grand totals do as well.

Note
With outline controls suppressed, you can still expand and collapse fi eld headings. Select 

a heading in the fi eld you’re interested in, click the Options tab under PivotTable Tools on 

the Ribbon, and then click Expand Entire Field or Collapse Entire Field in the Active Field

group.

Note
You can change the name of a PivotTable fi eld or an item within a fi eld by selecting any 

occurrence of it and typing the name you want. When you change one occurrence, all

occurrences in the table change. 
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To remove grand totals from a PivotTable, right-click any cell in the table, and click 
Pivot Table Options. On the Totals & Filters tab in the PivotTable Options dialog box, 
clear the Show Grand Totals For Rows check box, the Show Grand Totals For Columns 
check box, or both check boxes.

Naturally, PivotTables are not restricted to calculating sums. For other calculation 
options, see “Changing PivotTable Calculations” on page 731.

Customizing Subtotals
By default, Excel creates subtotals for all but the innermost fi elds. For example, in Fig-
ure 22-3, cell B6 displays the sum of cells B7:B9 (the Children subtotal for Quarter 1 of 
2005), cell C10 displays the sum of cells C11:C13 (the Mystery subtotal for Quarter 2 
of 2005), and so on. Columns F and K display yearly subtotals. The innermost fi elds, 
Channel (for the row axis) and Quarter (for the column axis), do not have subtotals.

To fi nd options affecting all subtotals, select a cell in the PivotTable, click the Design 
tab under PivotTable Tools, and then click Subtotals on the left edge of the Ribbon:

You can use this menu to turn subtotaling off altogether or to move row-axis subtotals 
from their default position above the detail items to a position below.

To customize subtotals for a particular fi eld, right-click an item in the fi eld, and then 
click Field Options. (Alternatively, select an item in the fi eld, click the Options tab 
under PivotTable Tools, and then click Field Settings in the Active Field group.) Fig-
ure 22-9 shows the Field Settings dialog box for the Category fi eld in our example 
 PivotTable.

The Automatic option on the Subtotals & Filters tab in this dialog box means—as Auto-
matic means throughout Excel—you’re letting the program decide what to do. In other 
words, this option gets the default behavior. You can turn off subtotals for the selected 
fi eld by selecting None. Selecting Custom lets you change the default subtotal calcula-
tion, such as from Sum to Average. And, as the text above the function list suggests, 
you’re not limited to one function. You can select as many as you need by holding down 
Ctrl while you click. Figure 22-10 shows a PivotTable with four subtotaling calculations 
applied to the Category fi eld. (Note that when you have multiple subtotals for a fi eld, 
Excel moves them below the detail.)
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Figure 22-9 In the Field Settings dialog box, you can override the default subtotaling behavior for 
a particular fi eld.

Figure 22-10 You can generate subtotals using more than one summary function; this table uses 
four for the Category fi eld.
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By using the Field Settings dialog box, you can also generate subtotals for innermost 
fi elds—subtotals that Excel usually does not display. Such inner subtotals appear at 
the bottom of the table (just above the grand total row) or at the right side of the table 
(just to the left of the grand total column). Figure 22-11 shows an example of inner-fi eld 
 subtotaling.

Figure 22-11 Subtotals for Channel, an inner fi eld, appear in rows 30–32 of this table.

Sorting PivotTable Fields
You can sort a PivotTable fi eld either by its own items (for example, alphabetizing the 
categories in Figure 22-11) or on the basis of values in the body of the table (for exam-
ple, sorting categories in descending order of sales totals so the best-selling categories 
appear at the top). To sort a fi eld, right-click any item in that fi eld, and then click Sort. 
On the menu that appears, you can click Sort A To Z or Sort Z To A if you want to sort 
the fi eld by its own items. If you want to sort the fi eld by values in the body of the table, 
click More Sort Options. You’ll see a dialog box similar to the one shown on the next 
page (with the name of the fi eld you selected in the title of the dialog box).
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To sort by values in the table body instead of by items in the selected fi eld, open the 
Ascending or Descending list. The list will include the available value fi elds.

Note
To ensure that Excel retains your sort specifi cation when you update your PivotTable, 

click More Options in the dialog box shown above. Then select Sort Automatically Every 

Time The Report Is Updated.

Filtering PivotTable Fields
Filtering a fi eld lets you focus your table on a subset of items in that fi eld. You can fi lter 
on the basis of the fi eld’s own content (only the Children and Young Adult categories, 
for example) or on the basis of values associated with the fi eld (for example, the three 
categories with the best overall sales). You can apply fi lters either in the PivotTable Field 
List window or on the PivotTable. If you’re working with a large external data source 
and you need only a subset of the data, you can save yourself some time by fi ltering in 
the PivotTable Field List window before you execute the query and create the table.

To fi lter in the PivotTable Field List window, select the heading for the fi eld you want 
to fi lter, and then click the arrow to the right of the fi eld heading. The dialog box that 
appears includes check boxes for each unique item in the selected fi eld:

Note
To ensure that Excel retains your sort specifi cation when you update your PivotTable, 

click More Options in the dialog box shown above. Then select Sort Automatically Every

Time The Report Is Updated.
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You can use the check boxes to select one or more particular items in your selected 
fi eld. If your fi eld is more complex than the example here, you might want to click Label 
Filters, in response to which Excel presents many additional fi ltering options:
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The options that appear on this menu are tailored for the data type of the selected fi eld. 
If your fi eld holds dates instead of text, for example, you will see these options:

To fi lter a fi eld on the basis of values associated with that fi eld, click the arrow next to 
the fi eld heading in the PivotTable Field List window, and then click Value Filters on the 
menu that appears. For example, to fi lter the PivotTable in Figure 22-3 so it shows only 
the three categories with the highest total sales, click the arrow beside Category, and 
then click Value Filters. In the Value Filters menu:

you would click Top 10, which would take you to the Top 10 Filter dialog box:
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where you replace the 10 with a 3 and then click OK. Figure 22-12 shows the result.

Figure 22-12 We fi ltered the table to show only the three best-selling categories.

Note that when you apply a value fi lter to a fi eld, Excel bases its calculations on the cur-
rent grand total associated with that fi eld. If we wanted to see the three top-selling cat-
egories for the year 2005 (in the example shown in Figure 22-3), we would need to fi lter 
the Year fi eld as well as the Category fi eld.

 Changing PivotTable Calculations
By default, Excel populates the Values area of your PivotTable by applying the SUM 
function to any numeric fi eld you put there or by applying the COUNT function to any 
nonnumeric fi eld. But you can choose from many alternative forms of calculation, and 
you can add your own calculated fi elds to the table.

Using a Different Summary Function
To switch to a different summary function, right-click any cell in the Values area of your 
PivotTable, and then click Value Field Settings. (Alternatively, click the Options tab 
under PivotTable Tools, and then click Field Settings in the Active Field group.) Excel 
displays the Value Field Settings dialog box, shown in Figure 22-13. Select the function 
you want from the Summarize Value Field By list, and then click OK.
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Figure 22-13 Using this dialog box, you can change the function applied to a fi eld in the Values 
area of your PivotTable.

Excel fi lls in the Custom Name line in this dialog box according to your selection in the 
Summarize Value Field By list. If you switch from SUM to AVERAGE, for example, the 
Custom Name line changes to include the word Average. You can type whatever you like 
there, though.

Applying Multiple Summary Functions to the Same Field
You can apply as many summary functions as you want to a value fi eld. To use a second 
or subsequent function with a fi eld that’s already in the Values area of your PivotTable, 
drag another copy of the fi eld from the PivotTable Field List window into the Values 
box. Then select a Values area cell, return to the Value Field Settings dialog box, and 
select the function you want to use. The available functions are SUM, COUNT, AVER-
AGE, MAX, MIN, PRODUCT, COUNT NUMBERS, STDDEV, STDDEVP, VAR, and VARP.

Using Custom Calculations
In addition to the standard summary functions enumerated in the previous paragraph, 
Excel also offers a set of custom calculations. With these you can have each item in 
the Values area of your table report its value as a percentage of the total values in the 
same row or column, create running totals, or show each value as a percentage of some 
base value.

To apply a custom calculation, right-click a cell in the Values area, and then click Value 
Field Settings. Click the Show Values As tab in the Value Field Settings dialog box. Then 
select a calculation from the Show Values As list. Table 22-1 lists the available options.

When you select a calculation in the Show Values As list, the Base Field and Base Item 
boxes display choices that are relevant to your calculation. For example, as Figure 22-14 
shows, if you select Difference From in our books example, the Base Field box  displays 
Quarter, Category, Channel, and so on. If you select Quarter in this list, the Base 
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Item box presents the four quarters, along with the self-explanatory items (Previous) 
and (Next).

Table 22-1 Custom Calculation Options

Difference From Displays data as a difference from a specifi ed base fi eld and 
base item

% Of Displays data as a percentage of the value of a specifi ed base 
fi eld and base item

% Difference From Displays data as a percentage difference from a specifi ed base 
fi eld and base item

Running Total In Displays data as a running total

% Of Row Displays each data item as a percentage of the total of the items 
in its row

% Of Total Displays each data item as a percentage of the grand total of all 
items in its fi eld

Index Uses this formula: ((value in cell) * Grand Total of Grand Totals)) / 
((Grand Row Total) * (Grand Column Total))

Figure 22-14 When you choose a calculation such as Difference From, the Base Field and Base 
Item boxes display relevant options.

Figure 22-15 and Figure 22-16 illustrate some ways you can modify default calculations 
and Values fi eld names. The table in Figure 22-15 lists 2006–2007 performances at 
major opera houses around the world by theater, country, opera, composer, and perfor-
mance date. The PivotTable in Figure 22-16 includes the Date fi eld twice in the Values 
box. The default summary calculation for date data is Count, and that’s fi ne because we 
want the number of performances and counting dates is a way to get that. But we used 
the Custom Name box in the Value Field Settings dialog box (refer to Figure 22-13) to 
change the name from Count of Date to No. of Performances. When we dragged the 
second instance of the Date fi eld into the Values box, we used the Value Field Settings 
dialog box to make the fi eld report the percentage of total. You could use similar tech-
niques with other kinds of polling or survey applications.



C
h

ap
ter 22

734 Chapter 22 Analyzing Data with PivotTable Reports 
Figure 22-15 From this table, a PivotTable will apply the COUNT function to the Date fi eld to count 
performances.

You’ll fi nd the OperaSked.xlsx fi le in the Sample Files section of the companion CD.

Note
If you fi lter a fi eld, percentage-of-total calculations are based on the data that meets the 

fi lter criterion, not the unfi ltered data set.

Using Calculated Fields and Items
In case custom calculations don’t meet all your analytic needs, Excel lets you add cal-
culated fi elds and calculated items to your PivotTables. A calculated fi eld is a new fi eld, 
derived from calculations performed on existing fi elds in your table. A calculated item is 
a new item in an existing fi eld, derived from calculations performed on other items that 
are already in the fi eld. After you create a custom fi eld or item, Excel makes it available 
to your table, as though it were part of your data source.

Custom fi elds and items can apply arithmetic operations to any data already in your 
PivotTable (including data generated by other custom fi elds or items), but they cannot 
reference worksheet data outside the PivotTable.

Note
If you fi lter a fi eld, percentage-of-total calculations are based on the data that meets the

fi lter criterion, not the unfi ltered data set.
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Figure 22-16 The PivotTable uses the Date fi eld from Figure 22-15 twice—once to count perfor-
mances, a second time to calculate percentage of total.

Creating a Calculated Field

To create a calculated fi eld, select any cell in the PivotTable. Then click the Options tab 
under PivotTable Tools, and click Formulas in the Tools group. On the Tools menu, 
click Calculated Field. Figure 22-17 shows the Insert Calculated Field dialog box.

Figure 22-17 Create a calculated fi eld in this dialog box.
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Type a name for your calculated fi eld in the Name box. Then type a formula in the For-
mula box. To enter a fi eld in the formula, select it from the Fields list, and click Insert 
Field. Figure 22-18 shows an example of a calculated fi eld.

Figure 22-18 This calculated fi eld multiples an existing fi eld by a constant.

Excel adds a new calculated fi eld to your PivotTable when you click either Add or OK. 
You can then work with the new fi eld using the same techniques you use to work with 
existing fi elds.

Creating a Calculated Item

To create a calculated item for a fi eld, select any existing item in the fi eld or the fi eld 
heading. Then click the Options tab under PivotTable Tools, and click Formulas in the 
Tools group. On the Formulas menu, click Calculated Item. Excel displays a dialog box 
comparable to the one in Figure 22-19.

Figure 22-19 Use this dialog box to create a calculated item for a fi eld.
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To create a calculated item, type a unique name for the item in the Name box. Then 
enter a formula in the Formula box. You can select from the Fields and Items lists and 
click Insert Field and Insert Item to enter fi eld and item names in the formula.

Note
You cannot create calculated items in fi elds that have custom subtotals.

Figure 22-20 shows an example of a calculated item. In this case the new item repre-
sents domestic sales divided by the sum of international and mail order sales.

Figure 22-20 This calculated item will appear by default whenever you include the Channel fi eld in 
the PivotTable.

Displaying a List of Calculated Fields and Items

To display a list of your calculated fi elds and items, along with their formulas, click the 
Options tab under PivotTable Tools, and then click Formulas in the Tools group. On 
the Formulas menu, click List Formulas. Excel displays the list on a new worksheet, as 
shown in Figure 22-21.

As the note in Figure 22-21 indicates, you need to be careful when a cell in your table 
is affected by more than one calculated fi eld or item. In such cases, the value is set by 
the formula that’s executed last. The Solve Order information in the list of calculated 
fi elds and items tells you which formula that is. If you need to change the solve order, 
select the worksheet that contains the PivotTable, click the Options tab under Pivot-
Table Tools, and then click Formulas in the Tools group. On the Formulas menu, click 
Solve Order.

Note
You cannot create calculated items in fi elds that have custom subtotals.
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Figure 22-21 Excel lists calculated fi elds and items on a new worksheet.

Grouping and Ungrouping Data
PivotTables group inner fi eld items under each outer fi eld heading and, if requested, 
create subtotals for each group of inner fi eld items. You might fi nd it convenient to 
group items in additional ways—for example, to collect monthly items into quarterly 
groups or sets of numbers into larger numeric categories. Excel provides several 
options for grouping items.

Creating Ad Hoc Item Groupings
Suppose that after looking at Figure 22-3 you decide you’d like to see the domestic 
and international sales fi gures grouped into a category called Retail. To create this 
group, select the Domestic and International items anywhere in the table. Then click 
the Options tab under PivotTable Tools, and click Group Selection in the Group group. 
Excel creates a new heading called Group1:
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Now you can rename Group1 by simply typing over any instance of it.

Grouping Items in Date or Time Ranges
Figure 22-22 shows a PivotTable that summarizes daily transactions by payee. As you 
can see, the data in this table is extremely sparse. Most intersections between a day 
item and a payee item are blank.

You’ll fi nd the Transactions.xlsx fi le in the Sample Files section of the companion CD.

To make this kind of table more meaningful, you can group the date fi eld. To do this, 
select an item in the fi eld. Then click the Options tab under PivotTable Tools, and click 
Group Field. Excel responds by displaying the Grouping dialog box, shown in Fig-
ure 22-23.

Excel gives you a great deal of fl exibility in the way your date and time fi elds are 
grouped. In the By list, you can choose any common time interval, from seconds to 
years, and if the standard intervals don’t meet your needs, you can select an arbitrary 
number of days. You can also create two or more groupings at the same time (hold 
down Ctrl while you select); the results of grouping by both Quarter and Month are 
shown in Figure 22-24.
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Figure 22-22 To make the data in this table more meaningful, you can group the date fi eld.

Figure 22-23 Excel gives you lots of ways to group by date.
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Figure 22-24 In this table, daily data is grouped by months and then by quarters.

Displaying the Details Behind a Data Value
If you double-click any PivotTable value that represents a summary calculation, Excel 
displays the details behind that calculation on a new worksheet. For example, in 
Figure 22-24, cell B13 informs us that we spent $529.75 at Coho Vineyard & Winery 
during the month of January. Double-clicking B13 reveals the details, as shown on the 
next page.
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Creating PivotCharts
PivotCharts, like PivotTables, summarize tabular information and allow for easy trans-
position of fi elds and axes. They’re a great way to study or present elements of your 
data set.

You can create a PivotChart directly from your source data by selecting a cell in the 
original data range, clicking the Insert tab, clicking the arrow beneath PivotTable in 
the Tables group, and then clicking PivotChart. After you specify or confi rm your data 
source and indicate where you want the new PivotChart to reside (in a location either 
on the existing worksheet or on a new worksheet), Excel presents both a PivotTable 
layout and a blank chart canvas, along with a PivotChart Filter Pane (see Figure 22-25). 
Excel creates a PivotTable at the same time it creates a PivotChart—and hence you see a 
blank table layout. The PivotChart Filter Pane doesn’t really add any capability that isn’t 
available via the PivotTable Field List window, so you might want to close one or the 
other to make more room on the worksheet.
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Figure 22-25 When you create a new PivotChart, Excel draws a blank chart canvas as well as a 
blank table layout. The program creates a PivotTable at the same time it creates the PivotChart.

Figure 22-26 shows a simple PivotChart created from this chapter’s Books table. 
Because charts are generally most effective when applied to a modest amount of data, 
we’ve used the Report Filter box to restrict the presentation to a single category (Chil-
dren), and we’ve fi ltered the Channel fi eld to show international and mail order sales 
only. We’ve also tidied up a bit by closing the PivotTable Field List window and drag-
ging the PivotChart Filter Pane to a less obtrusive position.

As you can see, when you select a PivotChart, Excel adds a new set of tabs on the Rib-
bon, under PivotChart Tools. With these tabs, you can manipulate and format your 
PivotChart the same way you would an ordinary chart. (For details about working with 
charts, see Chapter 19, “Basic Charting Techniques,” and Chapter 20, “Charting Beyond 
the Ribbon.”)

A PivotChart and its associated PivotTable are inextricably linked. You can manipulate 
fi elds and axes in either, and the other stays in step.
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Figure 22-26 We’ve used a PivotChart to plot two distribution channels for one book category.

In Figures 22-25 and 22-26, we created a PivotChart directly from the source data. You 
can also create one from an existing PivotTable. Select any cell in the PivotTable, click 
the Options tab under PivotTable Tools, and then click PivotChart in the Tools group.
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