
The Art of Texturing
in Maya

In this chapter, you examine how to prepare your polygonal model

to receive a custom texture in Photoshop. This process requires

understanding the concepts behind UVs and UV layouts for poly-

gons in Maya. You learn how to create these UV layouts, import

them into Photoshop, and use them as a template to create a texture

for your objects.

UVs and the UV Coordinate System
Every polygonal object in Maya has UVs. They are a vertex-like

polygon component used strictly for texturing purposes. UVs

enable you to take a three-dimensional surface and lay it out flat so

that you can paint a texture on it in a program such as Photoshop.

As an analogy, consider having to print a design on a beach ball

using a computer printer. To do this, the beach ball’s surface needs

to be completely flat and laid out in a configuration that fits com-

pletely within a standard sheet of paper. Unfortunately, laying the

surface out in this manner means you would have to completely

destroy the beach ball. This is where UVs come into play. UVs are an
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entirely separate coordinate system, fully independent of the location of a model’s vertices. They

are almost like a “second surface” that you can use to flatten the object out without destroying the

model’s shape.

All the polygonal primitives in Maya are created with a default set of UVs that can be viewed with

the UV Texture Editor, located under the Window menu in Maya. In TUTORIAL 19.1, you use

this editor to get an idea of what a UV layout looks like on a primitive cube.

TUTORIAL 19.1: Examining UV Layouts

1. Open Maya and start a new scene.

2. From the Create menu, choose Polygon Primitives > Cube.

3. Choose Window > UV Texture Editor. This window shows you the UV layout on selected
objects (see FIGURE 19.1). Keep in mind that if you have nothing selected, this window
is blank.

Chapter 19 The Art of Texturing with Maya2

FIGURE 19.1 The default UV layout of a cube.

Notice that the UVs for the cube are arranged as though it were unfolded and laid out flat.
At the same time, however, the cube retains its original shape because the actual vertex
locations in 3D space are separate from the UV coordinates.

END TUTORIAL 19.1
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UVs and the UV Coordinate System 3

Because UVs exist in a coordinate system separate from a model’s vertices, their position has no

effect on the final model. UV coordinate space is a two-dimensional system rather than a three-

dimensional one. Its two dimensions, U and V, are surface dependent, meaning they exist only

along an object’s surface. For example, pretend that your stomach has UV coordinates. The U

direction runs horizontally, and the V direction runs vertically. If you draw a line across your

stomach from left to right, that line moves only in the U direction of the UV coordinate space.

No matter how far you continue the line, even around to your back, you are still moving only in

the U direction along the surface. The UV coordinate system, therefore, is a two-dimensional sys-

tem that “wraps around” a three-dimensional one.

The UV Texture Editor
The UV Texture Editor is the primary tool for creating UV layouts in Maya. UVs can be 

edited, manipulated, and controlled by using the UV Texture Editor, which you viewed in

TUTORIAL 19.1. In this section, you examine this editor briefly to see how it’s used to control

your object’s UVs. The editor is divided into three main areas: the menu bar, the toolbar, and the

view.

The Menu Bar

The menu bar contains all the relevant commands to control your UVs. The following list

describes the menu items:

. Polygons—This menu contains all the commands needed to lay out the UVs of a polygon

model. Instead of explaining each one now, you learn about these commands as you use

them in the following tutorials.

. Subdivs—This menu contains a few commands necessary for adjusting UVs on a subdivi-

sion surface. This menu isn’t covered in this book.

. View—This menu contains many commands for controlling what you see in the view-

port. Sometimes it can be difficult to tell what UVs are doing, especially when your layout

consists of several overlapping pieces. Using this menu, you can show or hide specific

groups of UVs to help make the arrangement process easier.

. Select—This menu has a variety of useful commands to help with selection of your

object’s components. You can use these commands to select all UVs within a contiguous

piece, or shell, and to convert a specific selection into vertices, edges, faces, or UVs.

. Image—This menu provides controls for how the texture is displayed in the UV Texture

Editor.

. Help—This menu gives you access to Maya’s help system.
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The Toolbar

Across the toolbar are a series of icons and entry fields that can be used for many commands (see

Table 19.1); these commands are also available from the main menu. Also, notice that the

toolbar is divided into six collapsible groups to save space.

TABLE 19.1 UV Texture Editor Toolbar

Icon Name Description

Flip UVs (U direction) Flips the selected UVs horizontally in the UV
Texture Editor.

Flip UVs (V direction) Flips the selected UVs vertically in the UV Texture
Editor.

Rotate UVs Counterclockwise Rotates all selected UVs 45 degrees in a counter-
clockwise direction. 

Rotate UVs Clockwise Rotates all selected UVs 45 degrees in a clock-
wise direction. 

Cut UVs Divides a piece of the UV layout along selected
edges. Although selecting edges is the most effi-
cient way to use this tool, you can also use it with
selections of UVs.

Sew UVs Attaches two edges together in UV space. It does-
n’t affect the shape of the actual model, even
though you’re working with polygonal edges. Note
that when selecting one edge in the UV Texture
Editor, the corresponding edge shared on the
model is also selected.

Layout UVs Automatically generates a layout for the UVs of
your model based on a set of criteria you enter in
the options dialog box. Using this command from
the Polygons menu to open the Options dialog box
is usually easier.

Move and Sew UVs Moves and attaches selections of edges to one
another. The difference between this command and
Sew UVs is that Move and Sew UVs tries to move
the pieces of the layout, instead of just the edges.

Split Selected UV Breaks a single UV up so that there’s one UV for
each edge that was leading into that UV. For exam-
ple, if you have four edges leading into a single UV,
this command would break that UV into four sepa-
rate UVs.

Chapter 19 The Art of Texturing with Maya4
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The UV Texture Editor 5

TABLE 19.1 Continued

Icon Name Description

Cycle UVs Cycles through all the UVs within the face that con-
tains the selected UV, and then selects all the
edges of that face. This command can be useful
when you’re having a difficult time seeing what a
particular face is shaped like in the UV Texture
Editor.

Align UVs (minimum U) Aligns a selection of two or more UVs in the U
direction so that they line up with the UV that was
farthest to the left in the UV Texture Editor.

Align UVs (maximum U) The same as the previous command, except that
the UVs are aligned in the U direction to the UV
that was farthest to the right in the UV Texture
Editor.

Align UVs (minimum V) Aligns a selection of two or more UVs in the V
direction so that they line up with the UV that was
the closest to the bottom of the UV Texture Editor.

Align UVs (maximum V) The same as the previous command, except that
the UVs are aligned in the V direction to the UV
that was closest to the top of the UV Texture
Editor.

Grid UVs Moves the selected UVs to the nearest grid inter-
section based on the settings created for the com-
mand. Using this command’s Options dialog box
from the Polygons menu is easier.

Relax UVs More evenly distributes the selected piece of the
UV layout to make more efficient use of texture
space. The result is not unlike taking an average
location for all the UVs of a selected piece.

Toggle Isolate Select Mode Hides all UVs that aren’t currently selected, which
can make manipulating the UVs much easier.

Add Selected Adds the current selection to the current isolated
selection, making it visible.

Remove All Clears the current isolated selection, essentially
hiding all objects visible while the isolated select
is active.

Remove Selected Removes any selected UVs from the current iso-
lated selection.
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TABLE 19.1 Continued

Icon Name Description

Show Background Image Shows or hides the texture you’re applying to your 
(toggle on/off) objects in the UV Texture Editor. The texture tile

outside the 0 – 1 texture space, which you discuss
in a moment.

Show Grid (toggle on/off) Toggles the display of the grid in the UV Texture
Editor.

Snap to Pixels (toggle on/off) Controls whether you can snap UVs to pixel bor-
ders. This option is useful when you’re trying to be
precise about which texture pixels are included in
your UV layout.

Filtered Display Mode Specifies whether the texture is rendered with 
(toggle on/off) hardware filtering in the UV Texture Editor or is

drawn with sharply defined pixels.

Image Ratio (toggle on/off) Controls whether the texture space is square or
matches the size ratio of the selected texture.
Because all Unreal textures must be square, you
don’t need to use this option for game models.

Texture Borders (toggle on/off) Controls whether UV borders are drawn with a thick
line instead of the single pixel line.

Display RGB Channels Displays the color information of the texture in the
UV Texture Editor.

Display Alpha Channel Displays the alpha information for the texture in
the UV Texture Editor.

U and V coordinate entry fields Used to type in an exact location in UV space,
moving the selected UV to that location.

Refresh the Current UV Values Refreshes the UV coordinate entry fields to display
the correct number for the selected UV.

Copy UVs Copies the selected vertex colors, UVs, or shaders
to the Clipboard so that you can paste them onto
other UV sets.

Paste UVs Pastes any vertex colors, UVs, or shaders that are
stored in the Clipboard.

Paste U Value to Selected UVs Pastes the U value that has been stored in the
Clipboard onto the selected UVs.

Paste V Value to Selected UVs Pastes the V value that has been stored in the
Clipboard onto the selected UVs.

Copy/Paste for UVs/Faces Determines whether copy and paste work for UVs 
(toggle) or faces.

Chapter 19 The Art of Texturing with Maya6
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The UV Texture Editor 7

The Viewport

You navigate the UV Texture Editor viewport exactly the same way as the orthographic views in

Maya. Alt+MMB pans the view, and Alt+LMB and MMB zoom the view. You can also use

Alt+LMB to pan the camera, something you can’t do in an orthographic viewport.

The UV Texture Editor viewport has a unique grid that’s divided into four quadrants, with the

upper-right quadrant darker than the rest. This quadrant is darker to indicate that your entire

texture fits into this quadrant. Outside the upper-right quadrant, the texture simply repeats, or

tiles. In most cases, therefore, you want your entire UV layout to exist within this grid’s upper-

right quadrant, which is also known as the 0–1 texture space because all the coordinates for this

quadrant exist within 0 and 1.

Mapping UVs
Before you can start laying out an object’s UVs, you must understand how to map UVs in the UV

Texture Editor. UV mapping is a way to take a selection of faces and lay out their corresponding

UVs in the UV Texture Editor. Several types of UV mapping are available in Maya, but this book

focuses on three: automatic mapping, planar mapping, and cylindrical mapping.

Mapping Methods

With automatic mapping, Maya

automatically lays out your

model’s UVs based on a series of

criteria (see Figure 19.2). You

can control the method used in

automatic mapping in the tool’s

Options dialog box, which you can

access by choosing Edit Polygons

> Texture > Automatic Mapping

from the main menu. You’ll find

several options for controlling the

way the automatic mapping takes

place. Unfortunately, this com-

mand rarely yields usable results

for your game models because the

UVs are usually laid out in a pat-

tern that’s practically impossible

to follow. However, you can use this method as a “quick fix” to achieve a simple UV layout, espe-

cially when you intend to use the textures already included in Unreal.

FIGURE 19.2 A character model with UVs laid out with
automatic mapping.
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In planar mapping, the UVs of

selected faces are laid out as

though they had been pulled off

the model and laid out flat onto a

single plane. You can choose a

specific axis on which the plane is

projected, or you can let Maya act

to interpolate one based on the

angle of all the selected faces.

You’ll be using this mapping

method a bit later. Figure 19.3
shows a planar mapped sphere, in

which the plane is projected down

the Z-axis.

In cylindrical mapping, the UVs

are laid out as though they had

been projected onto a cylinder.

This mapping method is espe-

cially useful for character faces

and for any object that’s roughly

cylindrical in form, such as an

arm or leg. For example, if you cut

the leg off a pair of pants, the leg

would be a cylindrical form. If

you make a cut that runs all the

way along the inseam, you could

then lay the fabric out flat. This is

exactly how cylindrical mapping

works. Figure 19.4 shows a

character’s leg that has been

mapped cylindrically.

Creating UV Layouts
Mapping is only the first step in creating a proper layout for your UVs. On an actual model, you

map each part of the model, a piece at a time, using the mapping method best suited to that spe-

cific area of the model. When finished, you have a series of pieces representing your model that

are laid out flat. At that point, all you need to do is move, rotate, and scale each piece in the UV

Texture Editor so that they all fit in the 0–1 texture space.

Chapter 19 The Art of Texturing with Maya8

FIGURE 19.3 A planar projected sphere.

FIGURE 19.4 A cylindrically mapped leg.
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Creating UV Layouts 9

This process might seem easy, and in concept, it is quite easy; in practice, however, laying out an

object’s UVs can be time consuming. Also, many beginners wonder what’s the right or correct way

to lay out an object’s UVs. Unfortunately, this is where many users run into the fine line between

a skill and an art form. The truth is that there is no single “correct” way to create a UV layout—

only the method that works best for you or your texture artist. Before you get too far into that,

however, try creating your own UV layout for a simple object in TUTORIAL 19.2. Over the next

few tutorials, you create a static mesh of a dice; later, using the skills you learn in Chapter 20,

“Static Meshes,” you can import it into Unreal with a complete texture.

TUTORIAL 19.2: Creating a Mesh and Preparing for UV Layout

1. Start a new scene in Maya.
Verify that you’re in the
Modeling menu set (if not,
press F3).

2. Create a polygon cube with a
length, width, and height of
64 (see FIGURE 19.5).
Name the cube Dice.

3. With the cube selected, choose
Edit Polygons > Bevel >
options box from the menu. In
the Bevel Options dialog box,
set the Offset value to 6, and
click Bevel. This creates an
extra set of faces at the cor-
ners of the cube, which round
it out without adding too much
detail (see FIGURE 19.6).

4. The bevel action has caused
the cube to lose its UVs, so
you need to create them from
scratch. You can verify this by
selecting the Dice and open-
ing the UV Texture Editor from
the Window menu.

For now, you’ll just create a
simple mapping to use as a
reference so that you can tell
what has been laid out and
what has not. To do this, select the Dice and choose Edit Polygons > Texture > Planar
Map > options box from the menu. Make sure the Fit to Best Plane option is enabled, and
click Project. This creates a single map that includes all the faces.

FIGURE 19.5 The cube that will become your Dice.

FIGURE 19.6 The edges of the cube have been beveled
to create a simple rounding.
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5. Select the Dice in Object mode, and open the UV Texture Editor. You see the UV layout for
the object, which looks similar to an orthographic view.

6. Press F12 to make UVs selectable, and then draw a marquee selection across all the UVs
in the UV Texture Editor. Try the Move, Rotate, and Scale tools to see how they work on
the UV selection. When you’re finished, move the UVs to the side, outside the 0–1 texture
space. You’ll be using these UVs only as a starting point for your layout. With that, your
Dice is ready to create the UV layout. Save the file as UnrealDice.

END TUTORIAL 19.2

As mentioned earlier, there’s no right or wrong way to lay out an object’s UVs. There are some

fundamental guidelines to consider, however, and they are explained as you come across them in

subsequent tutorials. In TUTORIAL 19.3, you create a simple UV layout for the static mesh cre-

ated in TUTORIAL 19.2.

TUTORIAL 19.3: Creating a UV Layout for the Static Mesh

1. Continue from TUTORIAL 19.2, or open the file you saved at the end of that tutorial.
You’re going to create a UV layout that you can paint in Photoshop.

2. In the Perspective viewport,
press F11 to make faces
selectable. Select the face
at the top of the Dice. From
the Edit Polygons menu,
choose Texture > Planar
Map.

3. Open the UV Texture Editor.
Notice the interesting manip-
ulator visible on the mapped
UVs (see FIGURE 19.7).
It’s a combination of the
Move, Rotate, and Scale
tools. You can use the
arrows or the small blue ring
in the center to move. The
arc in the middle is for rota-
tion. The three squares are

Chapter 19 The Art of Texturing with Maya10

FIGURE 19.7 This manipulator becomes available when
you create mappings.
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Creating UV Layouts 11

used for scaling in U, V, or U
and V simultaneously. Areas
on the border of the manipu-
lator, such as at the corners,
are pale blue, red, or green.
They are used for a special
type of scaling that enables
you to expand the manipula-
tor without affecting the
other sides.

4. Move and scale the selected
face so that its lower-left
corner is at the UV coordi-
nates 0.4, 0.7. Place the
upper-right corner at the
coordinates 0.6, 0.9. You
can use the numeric entry
fields in the toolbar, or sim-
ply use the Move tool with
grid snapping activated to
help. Make sure the piece
remains a perfect square, as
in FIGURE 19.8.

5. Now, select the bottommost
face of the Dice and apply
planar mapping to it. Adjust
the face so that it’s aligned
with the grid, exactly one
grid space to the right of the
first face you mapped (see
FIGURE 19.9).

FIGURE 19.8 The first face of the Dice is now laid out.

FIGURE 19.9 Two faces are now laid out.
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6. Continue this pattern to lay
out the rest of the Dice
object’s major faces. After
you map a face, always
place the face on the oppo-
site side next to it. For
example, place the left and
right faces next to each
other and the front and back
faces next to each other.
When finished, you should
have something similar to
FIGURE 19.10.

7. In the UV Texture Editor,
move and scale the remain-
ing UVs that are still outside
the UV Texture Editor so that
they fit in the area to the
right of the major faces you
just laid out. All these corner
faces have the same color,
so their placement is not
that important. In fact, if you
want to, you could scale
them down so that they fit
inside a single pixel.
Whatever color that single
pixel contains is spread
across all the UV faces that
were scaled into the area.

8. Save your work. Now you’re
ready to take this UV layout
into Photoshop.

END TUTORIAL 19.3

Creating Textures from UV Layouts
Now that you have seen how to create a UV layout for your object, you need to learn how this lay-

out can be used to create a texture in an external paint application, such as Photoshop. You won’t,

however, import the texture into Unreal, as the methods for this process have already been 

Chapter 19 The Art of Texturing with Maya12

FIGURE 19.10 The major faces of the Dice object are
now laid out.

FIGURE 19.11 All the faces of the Dice are completely
laid out.
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Creating Textures from UV Layouts 13

covered in Chapter 9, “Interactive Elements.” In TUTORIAL 19.4, you import the UV layout

created in Maya into Photoshop to create a texture.

TUTORIAL 19.4: Exporting Your UVs into Photoshop

1. Continue from TUTORIAL 19.3, or open the file you saved at the end of that tutorial.
You’re going to import the UV layout you created into Photoshop so that you can create a
texture with it.

2. With the Dice selected, go to the UV Texture Editor. From the Polygons menu, choose UV
Snapshot. Set the File Name text box to a path and name you can easily locate. Set the size
in X and Y to 512. The Color Value setting controls what color the lines of the UV layout are.
Because  the background is always black, stick with white for the UV layout lines. Also, make
sure the image format is set to Targa (see FIGURE 19.12). Click OK when done.

3. Open Photoshop, and open the Targa file you just created from the same path used in the UV
Snapshot dialog box. You see the same thing you saw in the 0–1 texture space in Maya’s 
UV Texture Editor, except that the image
is white UVs on a black background.

4. As a rule, you should never paint on
your UV snapshot, so create a new
layer over the background layer. Name
this layer DiceColor.

5. With the new layer selected, use the
Paint Bucket tool and fill the layer
with white. Bring the layer’s opacity
down to about 90% so that you can
barely see where the UVs exist.

6. Remember how you mapped first one side
of the Dice object and then the opposite
side? On real dice, numbers on opposite
sides always add up to seven. With that in
mind, make a series of dots in the laid out
UVs that coincide with the dots on an
actual set of dice. Use FIGURE 19.13 if
you need help.

7. Set the opacity for the DiceColor layer back
to 100%. Save your work as a new Targa
file with the name DiceTextureComplete.
Choose 32-bit when prompted how to save
the Targa file.

FIGURE 19.12 These are the settings you need
in the UV Snapshot dialog box.

FIGURE 19.13 Here is the dot pattern
for your layout. Note that the DiceColor layer
has been lightened a bit for clarity.END TUTORIAL 19.4
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Because you already know how to create new textures for materials (covered in Chapter 8,

“Creating Materials in Unreal”) and because you have yet to learn how to get Maya models into

Unreal as static meshes, in TUTORIAL 19.5, you simply add the texture to the object in Maya.

After you read Chapter 20, “Static Meshes,” you’ll know everything you need to know to create

static meshes and import a custom texture based on UV layouts.

TUTORIAL 19.5: Applying the New Texture

1. Return to Maya. Open the Maya file you
saved in TUTORIAL 19.3, if it’s not
open already.

2. Right-click on the object, and from the
marking menu, choose Material >
Assign New Material > Lambert. This
creates a new Lambert material,
applies it to the object, and opens the
Attribute Editor for the new material.
Click the Map button (with the check-
ered pattern) next to the Color slider.
In the Create Render Node dialog box,
click the File texture button.

3. In the Attribute Editor, next to Image Name, is a small button with a folder icon. Click this but-
ton, and navigate to the DiceTextureComplete.tga texture you finished in TUTORIAL 19.4.

4. If you press 6 on the keyboard, you’ll notice that the object seems to be almost com-
pletely transparent, but this is nothing to worry about. The reason it looks transparent is
that the Targa file has an alpha channel to control its transparency. Maya noticed the
alpha channel and took the liberty of assigning its data to the Transparency attribute.

5. You need to break the connection
from the File texture to the mater-
ial’s Transparency. Open the Hyper-
shade window. Right-click on
Lambert2, and choose Graph
Network.

6. In the Work Area of the Hyper-
shade, you see the network from
the shader. Note that between
the File1 and Lambert2 nodes,
there are two connections: The
top one is feeding the color, and
the bottom is feeding the trans-
parency (see FIGURE 19.14).

Chapter 19 The Art of Texturing with Maya14

FIGURE 19.14 The two nodes of the shader, with
two connections between.

NOTE
You can also disconnect the nodes by typing the fol-
lowing Maya Embedded Language (MELScript) line
into the command line at the bottom of the interface:
disconnectAttr file1.outTransparency lam-
bert2.transparency;

This line performs the same function as removing the
wire between the two nodes.

NOTE
Because the texture’s placement now depends on the
UVs, you can delete the Place2DTexture node from the
Lambert2 network. It has no effect on the final object.
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Creating Textures from UV Layouts 15

Click on the bottom connection wire.
The tooltip should say it connects
from file1.outTransparency to lam-
bert2.transparency. With the wire
selected, press the Backspace or
Delete key to break the connection
between the nodes, allowing you to
see the Dice clearly in the viewport
(see FIGURE 19.15).

7. Save your work. After CHAPTER 20,
“Static Meshes,” you’ll be able to
bring this Dice into Unreal and use it
as a new decoration in your levels.

END TUTORIAL 19.5

One of the most important things to remember about UVs is that they can be overlapped to repeat

a texture on a surface. This process can be a little difficult to picture at first, so in TUTORIAL 19.6,

you see how it works.

TUTORIAL 19.6: Overlapping UVs

1. Continue from TUTORIAL 19.5, or open the file you saved at the end of that tutorial.

2. Select the Dice object, and open
the UV Texture Editor. You see the
texture you created in Photoshop
in the background. If necessary,
switch off the background image
to make it easier to see the UVs.

3. You have six squares of UVs
that make up the sides of the
Dice. For this tutorial, you place
each square on top of the
square that’s in the upper left,
which is the side with one dot.
One at a time, place the other
five squares on top of the first
square. You can snap the ver-
tices if you like, but for this
example, precision is not vital. In
Figures 19.16 and 19.17,

FIGURE 19.15 The Dice’s texture can now be seen
because the connection from the alpha channel to the
transparency has been broken.

FIGURE 19.16 All six squares have been “stacked”
onto the area with the one dot.
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you can see what this looks
like in the UV Texture Editor
and the viewport.

4. Save your work. Remember
that you can think of UVs in
the UV Texture Editor as points
that sample areas of the tex-
ture. Moving the UVs around
causes your object to sample
different parts of the texture at
the locations those UVs have
on the surface.

END TUTORIAL 19.6

UV Layouts for Characters
At this point, you have created a basic UV layout for a static mesh. Character UV layouts are sim-

ilar, but often require a lot more planning. When creating a UV layout for your character, you

should consider three major points. First, you’ll probably have an easier time if you begin the lay-

out process by drafting your layout on a piece of paper. This gives you a map that you can follow

as to where certain pieces should be. Second, develop a standard layout for your characters. For

example, you place faces for a character’s right leg in generally the same location for the UV lay-

outs of all your characters. Having a standard layout makes it easier for you or your texture artist

when it’s time to paint a texture.

Third, you should consider how you plan to use the textures on your character. All the characters

available in Unreal Tournament 2004 include two textures: one for the main body, which is usu-

ally at a resolution of 1024×1024, and a separate texture just for the head, also at 1024×1024.

Having these two textures serves two purposes. First, it allows for highly detailed faces and heads

because all the texture’s resolution is used to color only the head. Second, it makes it possible to

create several different characters by using the same model and body textures. The end result is

as though you had several different characters wearing the same uniform or one character wear-

ing different uniforms.

Chapter 19 The Art of Texturing with Maya16

FIGURE 19.17 The result of overlapping these
UVs is that the texture repeats on the surface.

NOTE
If you can, watch the viewport as you move
the UV squares. You see the texture shift
along the surface of the Dice until each
side contains a single dot.
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UV Layouts for Characters 17

In Tutorials 19.7 and 19.8, you take a look at how to lay out some of a character’s UVs. The

entire character layout process isn’t covered, however, as it’s typically a slow process involving

repeating many of the same techniques.

TUTORIAL 19.7: Laying Out the UVs of a Character’s Shirt

1. In Maya, open the
CharacterComplete.mb file, which
contains a completed character
model. If you check the UV Texture
Editor, you can see that the charac-
ter’s UVs are completely haywire
right now.

2. Select the character, and choose
Edit Polygons > Texture > Planar
Mapping > options box from the
main menu. In the Polygon Planar
Projection Options dialog box,
enable the Fit to Bounding Box
option and select Z Axis to create a
planar projection of the entire char-
acter (see FIGURE 19.18). Click
the Project button when you’re
done.

3. Open the UV Texture Editor, and 
take a look at what you’ve done.
The character’s UVs are very 
similar to what the character
would look like in the Front
orthographic view. Using an ini-
tial mapping of this type gives
you a guide for what parts have
been mapped and what parts
have not.

Move and scale the UVs a bit,
and place them outside the 0–1
texture space, as shown in
FIGURE 19.19.

4. Back in the viewport, switch to
Face component mode by press-
ing F11. Select the faces on the
front of the character’s shirt.
Make sure you select only faces

FIGURE 19.18 You can use these settings for
your initial planar projection.

FIGURE 19.19 This initial planar map is just a
reminder of which parts have yet to be laid out.

NOTE
At this point, you could use the Polygons > Layout UVs
command from the UV Texture Editor’s menu, and you
would get a basic but relatively usable layout. This method
is sometimes useful when you need to quickly texture a
character or object that isn’t seen often or not up close.
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that are relatively planar to
each other, meaning that
the faces should meet
each other at a very slight
angle whenever possible.
This helps avoid texture
stretching later. At the bot-
tom of the shirt, select the
first 16 faces, as shown in
FIGURE 19.20.

5. With the faces selected,
choose Edit Polygons >
Texture > Planar Mapping
> options box. Enable the
Fit to Best Plane option,
which automatically ori-
ents the plane for opti-
mum results. Click the
Project button when fin-
ished.

6. Back in the UV Texture
Editor, move, rotate, and
scale the newly mapped
faces so that they’re
somewhere within the 0–1
texture space (see
FIGURE 19.21). The
placement doesn’t really
matter now; you can
always move them around
later. Notice that the faces
you just mapped have
been moved off the origi-
nal planar map.

7. In the viewport, select the next row of faces on the shirt, and make another planar map. In
the UV Texture Editor, rotate and scale these newly mapped faces so that they’re directly
above the last set you mapped. Be sure to scale them to a size relative to the faces you
mapped earlier.

When you first map the new faces, you can’t see the last mapping you created because
when you’re selecting faces, you can see only the faces that are selected. Right-click over
the new mapping, and choose UVs from the marking menu. Some of these new UVs are
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FIGURE 19.20 Faces selected for the next mapping.

FIGURE 19.21 The first faces of the shirt have been
mapped and positioned.
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probably overlapping some
of your older mappings, as
in FIGURE 19.22.

8. In this situation, you can
use a special selection
operation for UVs: selecting
a separate piece, or shell.
Select a single UV vertex of
the four faces you just
mapped, and choose Select
> Select Shell from the UV
Texture Editor menu. This
command automatically
selects all the UVs in that
piece, which makes select-
ing overlapping UV pieces
easy. With the piece
selected, move and scale it
into position over the first
12 faces you mapped ear-
lier (see FIGURE 19.23).

9. You now have a gap
between these two pieces.
Gaps between UV pieces
can lead to seams in the
texture, so you should go
ahead and remove them.
Keep in mind that you can’t
always remove every gap
between your UV pieces.
Inevitably, you’ll have gaps
somewhere. Just do your
best to have them fall in
places where a seam would
be less likely to be noticed,
such as on the shirt’s
sides and under the arms.

To close the gap between
these two pieces, you use
the Sew UVs command. Press F9 to make edges selectable. Select one edge at the 
bottom of the most recent mapping. Notice how the corresponding edge beneath it is 

FIGURE 19.22 The new mapping for the four faces of
the chest overlaps the other UVs, making it difficult to select
specific UVs.

FIGURE 19.23 The next set of UVs has been moved
above the first.
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automatically selected,
too, because these two
edges are, in fact, the
same edge on the model.
Choose Polygons > Sew
UVs from the UV Texture
Editor menu. You’ll see the
two edges merge together
into one. Repeat this step
to sew up the seam
between the two pieces
(see FIGURE 19.24).

10. Repeat the steps for mak-
ing planar maps and
sewing them together until
you have a single piece
that represents the front
of the shirt (see FIGURE
19.25). You can then
make a separate piece
that forms the back of the
shirt, or if you prefer, make
a single piece that’s the
whole shirt. This piece
would be like making a cut
on either side of the shirt,
from the bottom, through
the armpit, and to the bot-
tom of the end of the
sleeve. You could then
open the shirt up and lay
it flat.

11. Save your work. You could
use these methods to
move around the entire
character, laying out all
the UVs you find. 

You can try the other mapping methods dis-
cussed earlier. In TUTORIAL 19.8, you’ll try
using a cylindrical map around the faces of
the character’s leg.

END TUTORIAL 19.7
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FIGURE 19.24 The two pieces of the shirt have been sewn
together.

FIGURE 19.25 The UVs of the front of the shirt have been
laid out.

NOTE
Remember when making your planar maps to select
faces that are already close to being planar to each
other. This technique helps avoid texture distortions
later.
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TUTORIAL 19.8: Using a Cylindrical Map for a UV Layout

1. Continue from TUTORIAL
19.7. You’re going to lay
out the UVs for one of the
character’s legs.

2. First, select all the faces
around the character’s left
leg (see FIGURE 19.26).
You can make several mar-
quee selections while hold-
ing the Shift and Ctrl keys,
or you can use the Paint
Selection tool, found under
the Edit menu. This tool
enables you to select com-
ponents in a paintbrush
fashion across your model.

3. With the faces selected,
choose Edit Polygons >
Texture > Cylindrical
Mapping to create a wire-
frame cylinder to be used
for the map. To begin using
it, MMB-drag one of the
red handles midway along
the cylinder. This enables
you to close the cylinder’s
sweep (circumference).

4. At the middle of the cylin-
der, MMB-drag the red ring
to rotate the cylinder so
that its seam runs along
the inside of the charac-
ter’s leg (see FIGURE
19.27). If possible, watch
the UV Texture Editor while
you’re doing this to help
prevent obvious texture
seams on the leg.

FIGURE 19.26 All faces of the leg have been selected.

FIGURE 19.27 The Cylindrical Mapping manipulator is sur-
rounding the leg.
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5. At the bottom of the Cylin-
drical Mapping manipulator
is a small red cross. MMB-
click it to activate a new
manipulator that’s similar to
the Move/Rotate/Scale tool.
Use it to rotate the entire
cylinder in the X-axis so that
it’s aligned more with the
angle of the leg. A rotation
of about -5 degrees should
do. Look at your results in
the UV Texture Editor (see
FIGURE 19.28).

6. You can repeat this process
with the right leg and both
arms. Combining the skills
you learned in TUTORIAL
19.7, you could then create
your own UV layout.

END TUTORIAL 19.8

Considerations for UV Layouts
Remember that laying out UVs for a character isn’t the kind of process you’re going to finish in a

matter of minutes or even hours. Creating an efficient UV layout is a skill that comes with prac-

tice and effort. The following list offers a few pointers, however, that should help you as you get

started:

. Go slow. Don’t rush by mapping several faces at the same time and just fitting them in

wherever you can.

. Be organized. Don’t just sling your mappings into the texture space. Have a plan when

you begin, and try to follow it.

. Use as much of the texture space as you can. Typically, your texture is 1024×1024. Any

gaps in your pieces are a waste of precious pixels. Try to keep everything as tight as 

possible.
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FIGURE 19.28 The UVs of the leg have been cylindrically
mapped and are ready to be laid out.
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. Keep UV face sizes in relation to their polygonal counterparts. This guideline can be con-

fusing, but think about it: If a single face of your model is very small, you don’t want that

face to take up half your available texture space. Keeping the sizes of polygon faces and

faces relative in the UV Texture Editor prevents your texture from becoming distorted.

. You can place the UVs of your character’s head so that they stretch across the entire 0–1

texture space, even though they overlap other UVs. This is because you’re usually placing

a separate face texture on

the head anyway.

. Practice and use as many

of the tools in the UV

Texture Editor as you can,

especially those in the

View menu. Hiding what

you’re not working on

makes your life far easier

when working on UV lay-

outs.

. Don’t be hard on yourself.

UV layouts are an art form

that no one just knows

spontaneously. Becoming

skilled at UV layouts takes

a lot of time and effort.

As an example, FIGURE 19.29

shows the UV layout for the

Jugg character in Unreal

Tournament 2004, such as

Gorge. Notice that it’s broken

up into many pieces—so many

pieces, in fact, that differentiat-

ing one piece from the next is

hard. On the other hand, you

can also see that it uses almost

every pixel of the texture area,

so the character can be covered

with as much texture as 

FIGURE 19.29 The UV layout for an official Unreal
Tournament 2004 character.

FIGURE 19.30 The same Unreal Tournament 2004 charac-
ter whose UV layout is shown in Figure 19.29.
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possible. Obviously, this layout

required a lot of planning and

work to ensure that the texture

artist knows which pieces of the

UV layout correspond with

what parts of the character.

Also, notice a piece that sits out-

side the 0–1 texture space. This

piece is making use of the fact

that textures repeat as you go

outside the 0–1 texture space.

FIGURES 19.30 and 19.31

show the character with his tex-

ture applied and what the tex-

ture looks like in the UV

Texture Editor.

Summary
In this chapter, you’ve taken a look at several aspects of creating a UV layout for your character.

You learned how to use the UV Texture Editor, a variety of mapping methods, and several tools

you can use to lay your UVs out in the 0–1 texture space. Remember that no one can tell you the

“right” way to lay out the UVs of your characters or objects. The best way is always the way that’s

easiest for you to understand and follow.
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FIGURE 19.31 The texture used on the character, as seen
in the UV Texture Editor.

23 6922 ch19  10/12/04  11:13 AM  Page 24


