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Introduction

Welcome to Adobe Illustrator CS5 On Demand, a visual quick
reference book that shows you how to work efficiently with
Illustrator.  This book provides complete coverage of basic to
advanced Illustrator skills.

How This Book Works
You don’t have to read this book in any particular order.
We’ve designed the book so that you can jump in, get the
information you need, and jump out. However, the book does
follow a logical progression from simple tasks to more com-
plex ones. Each task is presented on no more than two facing
pages, which lets you focus on a single task without having
to turn the page. To find the information that you need, just
look up the task in the table of contents or index, and turn to
the page listed. Read the task introduction, follow the step-
by-step instructions in the left column along with screen illus-
trations in the right column, and you’re done.

What’s New
If you’re searching for what’s new in Illustrator CS5, just look
for the icon: New!. The new icon appears in the table of con-
tents and throughout this book so you can quickly and easily
identify a new or improved feature in Illustrator. A complete
description of each new feature appears in the New Features
guide in the back of this book.

Keyboard Shortcuts
Most menu commands have a keyboard equivalent, such as
Ctrl+P (Win) or A+P (Mac), as a quicker alternative to using
the mouse. A complete list of keyboard shortcuts is available
on the Web at www.perspection.com and in the back of this
book.

How You’ll Learn

How This Book Works

What’s New

Keyboard Shortcuts

Step-by-Step Instructions

Real World Examples

Workshops

Adobe Certified Expert

Get More on the Web

www.perspection.com
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Step-by-Step
Instructions
This book provides concise step-
by-step instructions that show you
“how” to accomplish a task. Each
set of instructions includes illus-
trations that directly correspond to
the easy-to-read steps. Also
included in the text are time-
savers, tables, and sidebars to
help you work more efficiently or
to teach you more in-depth infor-
mation. A “Did You Know?” pro-
vides tips and techniques to help
you work smarter, while a “See
Also” leads you to other parts of
the book containing related infor-
mation about the task. 

Real World Examples
This book uses real world exam-
ple files to give you a context in
which to use the task. By using
the example files, you won’t waste
time looking for or creating sam-
ple files. You get a start file and a
result file, so you can compare
your work. Not every topic needs
an example file, such as changing
options, so we provide a complete
list of the example files used
throughout the book. The example
files that you need for project
tasks along with a complete file
list are available on the Web at
www.perspection.com.

Real world
examples help
you apply what
you’ve learned
to other tasks.

Illustrations
match the
numbered
steps.

Numbered
steps guide
you through
each task.

Did You Know? alerts
you to tips, techniques
and related information.

See Also points you to
related information in
the book.

Easy-to-follow
introductions
focus on a
single concept.

www.perspection.com


The Workshops
walk you through
in-depth projects
to help you put
Illustrator to
work.

Introduction xix

Workshops
This book shows you how to put
together the individual step-by-
step tasks into in-depth projects
with the Workshop. You start each
project with a sample file, work
through the steps, and then com-
pare your results with a project
results file at the end. The Work-
shop projects and associated files
are available on the Web at
www.perspection.com.

Adobe Certified Expert
This book prepares you fully for
the Adobe Certified Expert (ACE)
exam for Adobe Illustrator CS5.
Each Adobe Certified Expert certifi-
cation level has a set of objec-
tives, which are organized into
broader skill sets. To prepare for
the certification exam, you should
review and perform each task
identified with an ACE objective to
confirm that you can meet the
requirements for the exam. Infor-
mation about the ACE program is
available in the back of this book.
The Adobe Certified Expert objec-
tives and the specific pages that
cover them are available on the
Web at www.perspection.com.

www.perspection.com
www.perspection.com


xx

Get More on the Web
In addition to the information in
this book, you can also get more
information on the Web to help
you get up-to-speed faster with
Illustrator CS5. Some of the infor-
mation includes: 

Transition Helpers
◆ Only New Features.

Download and print the new
feature tasks as a quick and
easy guide.

Productivity Tools
◆ Keyboard Shortcuts.

Download a list of keyboard
shortcuts to learn faster ways
to get the job done. Also
available in the back of this
book.

More Content
◆ Photographs. Download

photographs and other
graphics to use in your
Illustrator documents. 

◆ More Content. Download
new content developed after
publication.

You can access these additional
resources on the Web at
www.perspection.com.

Additional
content
is available
on the Web. 

www.perspection.com
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Working with Objects

Introduction

Adobe Illustrator is an application that gives you great control
over vector graphics, which include vector shapes and vector
objects. Vector graphics are created using mathematical
shapes, not pixels, and that's why vector shapes are consid-
ered resolution-independent. When you draw a vector object,
you create one or more lines called a path. A path is made up
of one or more curved or straight line segments. The start and
end points for a line segment is known as an anchor point,
which you can drag to change and move. 

Illustrator provides drawing tools on the Tools panel that
you can use to create a variety of shapes, including rectan-
gles, rounded rectangles, ellipses, polygons, stars, flares,
lines, arcs, spirals, rectangle grids, and polar (circular) grids.
After you draw an object, you can use Illustrator selection
tools to modify it. The two main selection tools are the
Selection tool and the Direct Selection tool. The Selection tool
allows you to select entire objects, while the Direct Selection
tool allows you to select paths and segments. In addition to
these tools, you can also use the Select menu. The Select
menu provides a variety of powerful selection commands for
you to use in a document or artboard. For example, you can
select objects whose attributes (including Appearance,
Blending Modes, Fill & Stroke, Opacity, and Stroke Color) are
similar to the current or last selection. 

After you select one or more objects, you can move,
align, group, and transform them. The transformation tools
allow you to rotate, scale (resize), reflect (mirror image), or
shear (slant) an object. 

What You’ll Do

Understand Vector and Raster Images

Understand Paths

Select a Drawing Mode

Create Pixel Aligned Objects

Create Rectangle and Ellipses

Create Polygons and Stars

Create Line Segments

Create Arcs, Spirals, and Grids

Use the Shape Builder Tool

Create Perspective Objects

Use the Selection Tool

Use the Direct Selection Tool

Use the Lasso Tool

Use the Magic Wand Tool

Select and Group Objects

Save and Edit Selections

Move and Duplicate Objects

Align and Distribute Objects

Transform Objects

Rotate, Scale, Reflect, or Shear Objects

Apply Multiple Transformations

Reshape Objects with Envelopes
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Illustrator is an application that gives you
great control over vector graphics, which
include vector shapes and vector objects.
Vector graphics are created using mathemati-
cal shapes, not pixels, and that's why vector
shapes are considered resolution-independ-
ent. For example, if you enlarge a vector
image to 100 times its original size, Illustrator
merely changes the mathematical formulas to
reflect the new size, and since vector shapes
are constructed of mathematical data instead
of pixels, file sizes are extremely small.

Raster graphics, such as bitmaps and pho-
tographs, are images creating using individ-
ual pixels that identify one piece of color
information. The reason raster images are
considered resolution-dependent is that once
the image is created or scanned, any enlarge-
ment of the image forces Illustrator to enlarge
and average the existing color information in
the document. This process, called interpola-
tion, is what causes enlarged raster images to
become blurred, or pixelated. 

Understanding Vector and Raster Graphics

Raster ImageVector Image

Close up shows lines Close up shows pixels 
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When you draw an object, you create one or
more lines called a path. A path is made up of
one or more curved or straight lines, known
as segments. The start and end points for a
segment is called an anchor point. An anchor
point is a bending point to modify the line
segment. A path can be open or closed. An
open path has open-ended endpoints, such as
a line, while a closed path has connected end-
points, such as a circle. Paths can have two
types of anchor points: smooth points or cor-
ner points. A smooth point connects two
curved segments to create a smooth line,
while a corner point connects two straight or
curved segments to create a path direction
change. You can draw a path using both
smooth and corner points. The outline of a
path is called a stroke, which you can format
with different characteristics. You can specify
stroke weight (thickness), color, or a dashed
pattern. The interior of an open or closed path
is called a fill, which you can also format with
a color or gradient.

You can change the shape of a path by
dragging its anchor point. A selected anchor
point or endpoint appears as a solid square,
while an unselected one appears as a white
square.  When you select an anchor point
with a curved segment, a direction line
appears with direction points on each end,
which you can drag to change the shape of
the path. When you change the shape of a
smooth point with curved segments on each
side, both segments get changed. When you
change a shape of a corner point, the corner
is maintained, but adjusted based on the
change. 

Working with Anchor Points
In Illustrator, you can show or hide anchor
points, direction lines, and direction points by
choosing the View menu, and then choosing
Show Edges or Hide Edges. If you want to
show or hide direction lines for selected
anchor points, select the Direct Selection tool,
select the anchor point that you want, and
then click Show Handles For Multiple Selected
Anchor Points or Hide Handles For Multiple
Selected Anchor Points button in the Control
panel.

You can specify options in the Selection &
Anchor Display preferences to always show
handles when multiple anchor points are
selected (this option is turned off by default).

Understanding Paths

Closed path

Open path
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Selecting a Drawing
Mode

Select a Drawing Mode

Select the Drawing Mode tool on
the Tools panel:

◆ Draw Normal. Draws an object
on top of any other object; the
default mode.

◆ Draw Behind. Draws an object
behind all objects (no selection)
or directly behind a selected
object.

◆ Draw Inside. Draws an object
inside a single selected object.

TIMESAVER Press Shift+D to
cycle through the Drawing Mode
tools.

1

In Illustrator, you can specify how and where you want to draw an
object. You can draw on top of an object, behind an object, or inside an
object using one of the following drawing modes (New!): Draw Normal,
Draw Behind, or Draw Inside. Draw Normal mode is the default drawing
mode and the one used in previous versions of Illustrator. The Draw
Behind mode allows you to draw behind all objects on a selected layer
(no other objects selected). If an object is selected, the new object is
drawn directly behind it. The Draw Inside mode allows you to draw
inside a single selected object, which automatically creates a clipping
mask from the select object. You can select a drawing mode at the bot-
tom of the Tools panel or use the Shift+D keyboard shortcut to cycle
through each one.

Did You Know?
You can create a clipping mask using
the Draw Inside mode. Select the path
you want to draw, and then click the
Draw Inside mode button on the Tools
panel. Subsequent paths are clipped
by the selected path until you switch to
the Draw Normal mode. The clipping
masks created using the Draw Inside
mode retain the appearance on the
clipping path unlike the Make com-
mand on the Clipping Mask submenu
on the Object menu. 

1

Draw Inside

Draw Behind

Draw Normal

Draw Normal

Draw Behind

Draw Inside
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Creating Pixel Aligned
Objects

Work with Pixel Aligned
Objects
◆ Align All Objects in a New

Document. Click the File menu,
click New, specify new document
settings, select the Align New
Objects To Pixel Grid check box in
the Advanced section, and then
click OK.

◆ Align Existing Objects. Select the
object, open the Transform panel,
and then select the Align To Pixel
Grid check box.

◆ Not Align Objects. Select the
objects you want to change, click
the Select menu, point to Object,
and then click Not Aligned To
Pixel Grid.

◆ View The Pixel Grid. Click the
View menu, click Pixel Preview,
and then zoom to 600% or higher
(New!).

◆ To set preferences for viewing
pixel grid, click the Illustrator
(Mac) or Edit (Win) menu, point
to Preferences, click Guides &
Grid, select the Show Pixel
Grid (Above 600% Zoom) check
box, and then click OK (New!).

Pixel aligned vector objects (New!) allow you to create precisely drawn
images that look crisp and sharp for use on different outputs, such as
the Web and mobile devices. The Align to Pixel Grid option enables the
vertical and horizontal segments of the paths of an object to be nudged
and aligned to the pixel grid. The stroke width become full integer val-
ues to create crisp paths. To view the pixel grid, zoom to 600% or higher
in Pixel Preview mode. The Align to Pixel Grid option remains enabled
with the object until it’s disabled. You can set the option in the Advanced
section of the New Document dialog box or the Options menu on the
Transform panel. The option in the New Document dialog box, applies it
any new objects in the document. You cannot pixel-align objects without
paths, such as rasters, raster effects, and text objects.

Align To Pixel Grid option
in the Transform panel

Pixel Preview at 600% Object aligned to pixel grid
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Creating Rectangles
and Ellipses

Draw an Ellipse or Circle

Select the Ellipse tool on the Tools
panel.

TIMESAVER Press L to select
the Ellipse tool.

Select a Stroke and Fill Color from
the Colors area of the Tools panel.

Click and drag on the artboard,
and then release the mouse. 

TIMESAVER Press and hold
Shift while you drag to create a
circle.

To create an oval or circle with a
specific width and height, click on
the artboard where you want the
top left corner, enter width and
height values, and then click OK.

4

3

2

1

The Illustrator Tools panel includes several tools for quickly creating
simple geometric vector shapes. They are easy to use; you just click and
drag on the Stage to create the shapes. The Rectangle tool creates rec-
tangles with square or rounded corners. The Ellipse tool creates circular
shapes such as ovals and circles. These shapes can be comprised
either of Strokes, which are lines that surround and define the shape, or
Fills, which can be a color or texture inside the shape, or both.

Did You Know?
You can enter values ranging from 0 to
100 points in the Rounded Rectangle
Settings dialog box. A value of zero
gives you a straight-sided-square.
Higher numbers produce squares with
more rounded sides.

You can draw shapes without a stroke
or a fill. Set either of these properties
to No Fill in the Colors section of the
Tools panel or in the Color panel.

1

2

3

4
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Draw a Rectangle or Rounded
Rectangle

Click the Rectangle or Rounded
Rectangle tool on the Tools panel. 

TIMESAVER Press M to select
the Rectangle tool.

Select a Stroke and Fill color from
the Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse. 

TIMESAVER Press and hold
Shift while you drag to create a
square.

To create a square, rectangle, or
rounded rectangle with a specific
width and height, click on the
artboard where you want the top
left corner, enter width and height
values, and then click OK.

4

3

2

1

Did You Know?
You can change the corner radius for a
rounded rectangle. While you drag a
rounded rectangle, press the Up Arrow
or Down Arrow key. To create square
corners, press the Left Arrow key. To
create corners with maximum round-
ness, press the Right Arrow key.

You can draw shapes with no stroke
or fill. If you want to draw an oval or a
rectangle without a stroke or fill, you
can set either of these options to No
Fill in the Colors area of the Tools panel
or in the Color Mixer.

You can create a flare shape using the
Flare tool. Select the Flare tool on the
Tools panel, click and drag on the art-
board, and then release the mouse. 

2

1

3

4
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Creating Polygons 
and Stars

Draw a Polygon or Star Shape

Select the Polygon or Star tool on
the Tools panel. 

The pointer becomes a crosshair
that you can drag anywhere on the
artboard.

Select a Stroke and Fill color from
the Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse. 

TIMESAVER Press and hold
Shift while you drag to create a
proportional shape.

To create a shape with a specific
radius and number of sides or
points, click on the artboard where
you want the center of the shape,
enter the following values, and
then click OK.

◆ Polygon. Enter a radius and
number of sides for the
polygon. To create a triangle,
enter 3 sides.

◆ Star. Enter radius 1 for the
distance from the center of the
star to the innermost points and
enter radius 2 for the distance
from the center to the
outermost points.

4

3

2

1

The Polygon and Star tools work in much the same way as the Ellipse
and Rectangle tools do to allow you to easily create complex vector
shapes. You can use these tools to create either polygons or stars.
Polygons are shapes based on a center radius and a number of sides,
while stars are shapes based on two center radiuses: one for the dis-
tance from the center of the star to the innermost points, and another
for the distance from the center to the outermost points. Experiment
with several options to get the kind of shape you want.

1

2

3

Polygon options4

Star options4
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Creating Line
Segments

Draw a Line Segment

Click the Line Segment tool on the
Tools panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

TIMESAVER Press \ to select
the Line tool.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the line is the length you need. 

TIMESAVER Hold down the
Shift key, and then drag to draw a
45, 90, or 180 degree line. 

To create a line with a specific
length and angle, click on the
artboard where you want the line
to begin, enter length and angle
values, select the Fill Line check
box to fill the line with the current
fill color, and then click OK.

4

3

2

1

The Line Segment tool draws perfectly straight lines in any direction
you drag your mouse. In Illustrator, a line is called a stroke and there is
a variety of thicknesses, styles, colors, and fills that can be applied to it.
You can also create your own line style for specific types of dashed,
dotted or artistic lines. You can constrain the path a line draws to 45-
degree angles or create closed shapes by intersecting the lines you
draw.

2

1

3

4
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Creating Arcs and
Spirals

Draw an Arc

Click the Arc tool on the Tools
panel.

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the arc is the length you need. 

To create an arc with specific
settings, click on the artboard
where you want the arc to begin,
enter x and y lengths, specify type
(open or closed), arc direction
(Base Along) and slope options,
select the Fill Arc check box to fill
the arc with the current fill color,
and then click OK.

4

3

2

1

The Arc and Spiral tools make it easy to create unique and interesting
shapes. These tools draw curved lines to create an individual arc or a
Spiral wind. An arc consists of an x and y axis length, open or closed
path, arc direction (known as the Base Along), arc slope, and arc fill
(optional). A Spiral consists of a radius from the center to the outermost
point in the Spiral, decay (the amount each wind decreases), number of
segments for the spiral, and Spiral style. Each full wind of a Spiral con-
sists of four segments.

2

1

3

4
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Draw a Spiral

Click the Spiral tool on the Tools
panel.

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the Spiral is the length you need. 

To create a Spiral with specific
settings, click on the artboard
where you want the Spiral to
begin, enter a radius (distance)
from the center to the outermost
point, decay percentage (amount
of the wind decreases), the
number of segments, and style
options, and then click OK.

4

3

2

1

2

1

3

4
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Creating Grids

Draw Rectangle Grids

Click the Rectangle Grid tool on
the Tools panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the grid is the size you need. 

To create a grid with specific
settings, click on the artboard
where you want the grid reference
point, enter a width and height for
the grid, specify the number of
horizontal and vertical dividers,
select the Use Outside Rectangle
As Frame check box to replace
individual segments with a
separate rectangle object, select
the Fill Grid check box to fill the
grid with the current fill color, and
then click OK.

4

3

2

1

The grid tools on the Tools panel allow you to create a rectangular or
circular polar grid. The Rectangular Grid tool creates rectangular grids
of a specified size and number of horizontal and vertical dividers. The
Polar Grid tool creates concentric circles of a specified size and spe-
cific number of concentric and radial dividers.

2

1

3

4
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Draw Circular Polar Grids

Click the Polar Grid tool on the
Tools panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the grid is the size you need. 

To create a grid with specific
settings, click on the artboard
where you want the grid reference
point, enter a width and height for
the grid, specify the number of
concentric and radial dividers,
select the Create Compound Path
From Ellipses check box to
replace circles with separate
compound paths, select the Fill
Grid check box to fill the grid with
the current fill color, and then 
click OK.

4

3

2

1

2

1

3

4
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Using the Shape
Builder Tool

Create an Object with the Shape
Builder Tool

Click the Selection tool on the
Tools panel, and then select only
the paths you want to merge to
create a shape. 

Click the Shape Builder tool on the
Tools panel. By default, merge
mode is selected.

To break or extract a region from
the shape, click the selected
region.

To merge paths, drag along the
region.  

The two regions get merged to
form a new shape. The attributes
from the region are applied to the
merging shapes.

TIMESAVER Press Shift as
you drag, displays a rectangle
marquee for merging multiple
paths.

To erase paths, press Option (Mac)
or Alt (Win) and click the closed
region or edge you want to delete.

5

4

3

2

1

The Shape Builder tool (New!) allows you to create complex objects
by merging and erasing simpler objects. The Shape Builder tool selects
edges and regions of an object, which can be merged or erased to form
a new object. An edge is any section of a path that doesn’t intersect
the path of other selected objects and a region is a closed area. You
can also break overlapping objects to create new ones. The style
attributes of an object are adopted after the merge. By default, the
Shape Builder tool is in merge mode, however, you can switch to erase
mode by using the Option (Mac) or Alt (Win) key. Before you start using
the Shape Builder tool, you can set up and customize options, such as
coloring source, highlighting, and gap detection, to suit your own 
preferences.

2

1

3

4

5

Selected objects
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Set Shape Builder Tool Options

Double-click the Shape Builder
tool on the Tools panel. 

To detect and show the gap
between objects, select the Gap
Detection check box, and then
select a Gap Length, either Small
(3 points), Medium (6 points), or
Large (12 points), or select the
Custom check box and specify a
point size length.

IMPORTANT Make sure the
gap length value is close to the
actual gap length, otherwise
Illustrator may not detect it.

Specify the Options and Highlight
settings you want:

◆ Consider Open Filled Path as
Closed. Select to create an
invisible edge for an open path
to make a region.

◆ In Merge Mode. Clicking
Stroke Splits the Path. Select
to split the parent path into two;
the first edge you click
specifies the split location. 

◆ Pick Color From. Select Color
Swatches or Artwork as the
source for coloring objects. If
you select Color Swatches,
select the Cursor Swatch
Preview check box to preview
and select colors. 

◆ Fill. Select to highlight the
merged area in gray or mouse
over the selected path.

◆ Highlight Stroke When
Editable. Select to highlight
strokes you can edit in the
color you select.

Click OK.4

3

2

1

1

4

3

2
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Creating Perspective
Objects

Draw Perspective Objects

Click the Perspective Grid tool on
the Tools panel.

◆ If the grid doesn’t appear, click
the View menu, point to
Perspective Grid, and then
click Show Grid.

To select a perspective grid
preset, click the View menu, point
to Perspective Grid, point to a
Point Perspective (One, Two, or
Three), and then select a preset. 

To draw objects on the grid, do
any of the following: 

◆ Draw Perspective Objects.
Select a Line tool (other than
the Flare tool) or Rectangle
tool, and then drag to draw it. 

◆ Attach Normal Objects. Select
the plane to which you want to
use, select the normal object,
click the Object menu, point to
Perspective, and then click
Attach to Active Plane.

◆ Release Perspective Objects.
Select the attached object,
click the Object menu, point to
Perspective, and then click
Release with Perspective.

◆ Move Plane to Match Objects.
Select the existing object, click
the Object menu, point to
Perspective, and then click
Move Plane To Match Object.

3

2

1

The Perspective Grid tool (New!) allows you to display a perspective
grid that you can use to draw shapes and create scenes with 1, 2, or 3-
point perspective. For example, you can create a row of trees down a
street to create perspective. The perspective grid provides presets with
a 1, 2, or 3-point perspective to help you get started. You can change
the viewing angle and distance along with widgets to control vanishing
points, horizon height, ground level, and the origin. You can draw
objects directly on the perspective grid or attach existing ones to it. If
you want to match the depth or height of an existing perspective
object, you can use the Move Plane To Match Object command to
adjust the grid, so you can draw or adjust another object to it.

21

3 Drawn perspective object
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Adjust the Perspective Grid

Click the Perspective Grid tool on
the Tools panel.

◆ If the grid doesn’t appear, click
the View menu, point to
Perspective Grid, and then click
Show Grid.

To select the active grid plane, click
a plane in the cube (Right, Left, or
Horizontal) in the Plane Switching
Widget. Click the area outside the
cube to select no plane.

To adjust the perspective grid, drag
the left or right controls on the grid
for any of the following: 

◆ Ground Level. Moves the
perspective grid. 

◆ Vanishing Points. Adjusts the
perspective in or out.

◆ Horizon Height. Adjusts the
horizon line up or down.

◆ Extend the Grid. Extends or
shortens the perspective grid.

◆ Grid Plane Controls. Adjust the
Right, Horizontal, or Left. 

◆ Grid Cell Size. Increases or
decreases the grid cell size.

◆ Origin. Adjusts the X and Y
coordinates of the grid plane. 

To set perspective grid related
options, click the View menu, point
to Perspective Grid, and then click
any of the following: 

◆ Show/Hide Rulers. Shows or
hides the ruler on the height line. 

◆ Snap to Grid. Snaps an object to
a perspective gridlines. 

◆ Unlock/Lock Grid. Unlocks or
locks the perspective grid. 

◆ Lock Station Point. Locks the
station point in place. When you
move one vanishing point, the
other one moves in sync. 
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1 point perspective 2 point perspective

3 point perspective
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Working with
Perspective Objects

Modify Perspective Objects

Click the View menu, point to
Perspective Grid, and then click
Show Grid.

Click the Perspective Selection
tool on the Tools panel.

To work with perspective objects
on the grid, do any of the following: 

◆ Move Perspective Objects.
Select the object, and then drag
it to another position or use the
Arrow keys. Press tilde (~) to
constrain the move to parallel.

◆ Move or Copy Perspective
Objects and Grid Plane.
Double-click a grid plane
control, click the Move All
Objects or Copy All Objects
option, click OK, and then drag
the grid plane control.

◆ Copy Perspective Objects.
Select the object, and then
Option+drag (Mac) or Alt+drag
(Win) it to another position.

◆ Resize Perspective Objects.
Select the object, and then drag
a resize handle.

◆ Add Normal Objects. Select the
active plane, and then drag the
normal object to the plane. 

◆ Add Text and Symbols. Select
an existing normal text or
symbol, and then drag it on the
active plane. To modify the text
and symbols, use the Edit Text,
Edit Perspective, and Isolate
Selected Object buttons on the
Control panel.
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The Perspective Selection tool (New!) allows you to select, move,
scale, copy, and transform objects in perspective. You can also add nor-
mal objects, text, and symbols to the perspective grid. When you move
or change a normal object to the perspective grid, its appearance and
scale change to adhere to the grid. You can select perspective objects
in the grid with the Perspective Selection tool by clicking individual
objects or dragging a selection marquee, just like normal objects. 

Three perspective object on the grid;
they were moved, copied and resized.

2
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Customizing a
Perspective Grid

Set Perspective Grid Options

Double-lick the Perspective Grid
tool on the Tools panel.

Select the Show Active Plane
Widget check box to display it.

Click the Widget Position list
arrow, and then select a position. 

Select the Anchor Point Of
Perspective Artwork or the
Intersection Of Gridlines check
boxes to specify the points where
you want to temporarily hide the
active plane with the Shift key. 

Click OK.

Create a Perspective Grid Preset

Click the View menu, point to
Perspective Grid, and then click
Define Grid to create a grid (steps
3 thru 6) or manually create one.

Click the View menu, point to
Perspective Grid, and then click
Save Grid As Preset.

Type a name for the preset.

Specify the perspective grid
settings you want.

Specify the grid color & opacity
settings you want.

Click OK.

To edit a grid preset, click the Edit
menu, click Perspective Grid
Presets, select a preset, click Edit,
make changes, and then click OK.
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If you create your own perspective grid, you save it as a preset (New!)
for use later. You can create a perspective grid by using the Define Grid
command to set exacting measurements and options or by manually
adjusting an existing grid, and then saving it as a preset, which you can
edit at any time. When you create or work with an existing perspective
grid, you can set grid options (New!) to show or hide the active plane
widget, change the widget position, and specify which points you want
to use to temporarily hide the active plane with the Shift key.
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When you create vector graphics in Illustrator,
they are comprised of distinct segments that
can be selected separately or as a whole with
a variety of selection tools. The type of editing
you need to perform determines which tool
you use. For example, a simple rectangle is
comprised of four line segments that sur-
round the contour of the shape and one fill in
the center. Each of these parts can be selected
as a group with the Selection tool or individu-
ally with the Direct Selection tool. To select an
object using the fill, you need to deselect the
Object Selection by Path Only check box in
Selection & Anchor Display preferences. If an
object is behind another object, you can use
the keyboard shortcut A+click (Mac) or
Ctrl+click (Win) to select it (New!). The pointer
changes to an arrow with a small caret on the
first A/Ctrl+click; as you continue to click the
selection moves through the objects under
the pointer. To use this option, you need to
select the Control Click to Select Objects
Behind check box in Selection & Anchor
Display preferences.

In addition to the Selection and Direct
Selection tools, you can also use the Group
Selection tool to select all the anchor points
on a single path. With the Group Selection
tool, click to select an object, click twice to
select the object’s group, and click three times
to select the group within the group (if avail-
able). The Group Selection tool is useful for
working with multiple objects. If you want to
work with an individual object without affect-
ing other objects, it’s better to use Isolation
Mode.

The Lasso tool is a classic selection tool
that allows you to select path points and seg-
ments by dragging a freeform marquee
around them. 

The Magic Wand tool allows you to select
objects of the same or a similar fill color,
stroke color, stroke weight, opacity, or blend-
ing mode.

Understanding Selections

Selection preferences

Group selection tool

Selection tool

Lasso tool

Direct Selection tool

Magic
Wand

tool
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Using the Selection 
Tool

Select an Object with the
Selection Tool 

Click the Selection tool on the
Tools panel. 

The pointer becomes an arrow.

TIMESAVER Press V to select
the Selection tool.

Position the arrow on the edge of
the object, and then click it. 

◆ You can also drag a marquee
across all or part of the object
to select the entire path.

◆ If the path has a color fill,
appears in Preview mode, and
the Object Selection by Path
Only check box is deselected in
Selection & Anchor Display
preferences, you can also click
the fill to select the object.

To add or subtract objects from the
selection, hold down the Shift key,
and then click unselected objects
to add or click selected objects to
subtract them from the selection.
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There are several ways to select objects in Illustrator. With the
Selection tool, you can select an object's stroke or fill. You can only
select an object using the fill if the path appears in Preview mode, and
the Object Selection by Path Only check box is deselected in Selection
& Anchor Display preferences. After you select one or more objects,
you can add or subtract objects to/from the selection. In addition, you
can use the Selection tool and drag a marquee to select parts of the
object or drag over a portion of it to create a selection rectangle.
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Using the Direct
Selection Tool

Select Anchor Points and
Segments with the Direct
Selection Tool 

Click the Direct Selection tool on
the Tools panel. 

The pointer becomes an arrow.

TIMESAVER Press A to select
the Direct Selection tool.

Position the arrow on the edge of
the path and click to select a
segment, and then click an anchor
point to select it.

◆ You can also select an anchor
point directly. Pass the pointer
over a path and then point to an
anchor point and then click it.

◆ You can also drag a marquee
across all or part of the object
to select the entire path.

To add or subtract anchor points
or segments from the selection,
hold down the Shift key, and then
click unselected items to add them
or selected items to subtract them
from the selection.
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With the Direct Selection tool, you can select individual points and seg-
ments of a path. After you select one or more individual points and seg-
ments, you can add or subtract items to/from the selection. In addition,
you can also use the Direct Selection tool and drag a marquee to select
parts of the path or drag over a portion of it to create a selection rec-
tangle.
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Using the Lasso Tool

Select with the Lasso Tool

Click the Lasso tool on the Tools
panel.

Draw around the shapes you want
to select. 

To complete the selection, return
to the point where you started.
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Use the Lasso tool when you want to select shapes that are very close
to shapes you don't want to select. This tool allows you to draw around
the shape, selecting everything contained within the drawn area. When
you draw a selection, you can drag across a path to include it in the
selection instead of dragging completely around it. This selection tool is
useful when you are working with overlapping paths.

Did You Know?
You can select single or multiple
objects. Holding the Shift key adds line
segments and fills them. Shift-clicking
selected items deselects them. 
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The Magic Wand tool (so named since it looks like a magic wand) is
unique in the fact that you do not drag and select with this tool; you
simply click. The Magic Wand tool creates a selection based on the
shift in brightness ranges within an image. If there is a definable shift in
the brightness of the pixels, it can be a very powerful tool for the selec-
tion of odd-shaped areas. To use the Magic Wand, click on the Magic
Wand Tool button on the Tools panel.

Using the Magic 
Wand Tool

Select Options for the Magic
Wand Tool

Double-click the Magic Wand tool
on the Tools panel.

◆ You can also click the Window
menu, and then click Magic
Wand to display the panel.

Click the Options menu, and then
select the Show Stroke Options
and Show Transparency Options
(if necessary) to display them in
the Magic Wand panel.

◆ You can also click the double-
arrow next to the Magic Wand
title to display options.

Select the check box for the
attributes that you want the Magic
Wand to select. The options
include: Fill Color, Stroke Color,
Stroke Weight, Opacity, or
Blending Mode.

Enter a Tolerance value (0 to 255).
The higher the value, the more
information the Magic Wand tool
selects.

To select objects on all layers,
click the Options menu, and then
select Use All Layers to check it.
Select it again to select objects
only on the current layer.

To reset all fields in the Magic
Wand panel, click the Options
menu, and then click Reset.
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Use the Magic Wand Tool

Select the Magic Wand tool on the
Tools panel.

Click an object area to make a
selection.

Depending on the options you
selected in the Magic Wand panel,
other objects with the same or
similar attributes (fill color, stroke
color, stroke weight, opacity, or
blending mode) are selected.

To add to the selection, hold down
the Shift key, and then click
another unselected object. 

To subtract from the selection,
hold down the Alt (Win) or Option
(Mac) key, and then click a
selected object.
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Selecting and grouping objects makes it easier to work with multiple
objects as if they were a single object. You can easily select, isolate,
cut, copy, paste, move, recolor, and transform a grouped object. You
can group all types of objects, yet still edit individual objects within the
group as needed without having to ungroup them first by using
Isolation Mode. Illustrator places a grouped object on the top level of
the top object in the group and uses the same selection color. If you no
longer need to group objects, you can ungroup them. 

Selecting and
Grouping Objects

Create a Group

Select the Selection tool on the
Tools panel.

Use a selection method to select
the objects that you want in the
group.

Click the Objects menu, and then
click Group.

◆ You can use the Group
command again to group
objects already in a group; this
is known as a nested group. 

Ungroup Objects

Select the Selection tool on the
Tools panel.

Select the grouped objects that
you want to ungroup.

Click the Objects menu, and then
click Ungroup.

◆ If you have nested groups
within an object, you can use
the Ungroup command again to
ungroup it. 
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Use Isolation Mode to Work
with Groups

Select the Selection tool on the
Tools panel.

Double-click a grouped object.

◆ You need to click the Isolate
Selected Group button on the
Control panel or select the
Double-click to Isolate check
box in General preferences.

A gray bar appears with the name
of the group at the top of the
document window. All objects
outside the group are dimmed out
and uneditable. The words
“Isolation Mode” also appear on
the Layers panel.

Edit individual objects or add new
objects to the group.

To exit Isolation Mode, click the
gray bar. 
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The Select menu provides a variety of powerful selection commands
for you to use in a document or artboard. In addition to the common
commands, such as All, Deselect, and Inverse, you can also select
objects whose attributes (including Appearance, Blending Modes, Fill &
Stroke, Opacity, and Stroke Color) are similar to the current or last
selection. For more selection power, you can select objects based on
the object type (including All on Same Layers, Direction Handles, Brush
Strokes, Clipping Masks, Stray Points, Text Objects).

Selecting Similar
Objects

Use the Select Menu to Select
Objects

Click the Select menu.

Select the command that you
want:

◆ All. Selects all objects in the
document.

◆ All on Active Artboard. Selects
all objects in the active
artboard.

◆ Deselect. Deselects all objects
in the document.

◆ Reselect. Reselects the most
recent selection.

◆ Inverse. Inverses the current
selection.

◆ Next Object Above. Selects the
next object above the current
selection.

◆ Next Object Below. Selects the
next object below the current
selection.
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Select Similar Objects or Object
Attributes

Select an object on which to base
the new selection or deselect all
objects to base the new selection
on the last selected object.

Click the Select menu, and then
point to Same or Object.

Choose the command that you
want to use to make a selection.

Select Objects in the Layers
Panel

Open the Layers panel.

Click the expand/collapse triangle
to display the layer that you want
to select.

Click the selection area on the
right side of the layer in the Layers
panel that has the object that you
want to select.

◆ You can also click the Select
menu, point to Object, and then
click All on Same Layers to
select all on a layer. 
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If you frequently select the same elements in a document, you can save
yourself some time by saving the selection with a name of your choice.
After you save a selection, the saved selection name appears as a
menu command at the bottom of the Select menu. When you need to
make the same selection, simply choose the command. When you no
longer use a saved selection, you can delete it. 

Saving and Editing
Selections

Save and Use a Selection

Make the selection that you want
to save.

Click the Select menu, and then
click Save Selection.

Enter a name for the selection.

Click OK.

Click the Select menu, and then
click the name of the saved
selection at the bottom of the
menu.

Edit a Saved Selection

Click the Select menu, and then
click Edit Selection.

Select the saved selection that
you want to rename or delete.

To delete a saved selection, click
Delete.

To rename a saved selection,
change the name in the Name box.

Click OK.5
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Moving an object or group of objects is very easy. The simplest way is
to drag the edge of an object in Outline or Preview view. If you want to
constrain the movement of the object in multiples of 45 degrees, then
use the Shift key as you drag. While you drag an object, Smart Guides
appear automatically to make it easier for you to align objects with
other objects. 

Moving Objects

Move an Object

Select the Selection tool on the
Tools panel.

Select one or more objects that
you want to move.

Drag the edge of an object.

◆ To constrain the movement of
the object to multiples of 45
degrees or the current angle in
General preferences, hold
down the Shift key as you drag. 

◆ If the path has a color fill,
appears in Preview mode, and
the Object Selection by Path
Only check box is deselected in
Selection & Anchor Display
preferences, you can also click
the fill to select the object.
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See Also
See “Using Smart Guides” on page 50
for more information on setting Smart
Guide preferences and using Smart
Guides.

Did You Know?
You can delete an object. Select the
object that you want to delete, and
then press Delete, or click the Edit
menu, and then click Clear. 
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Duplicating objects can be a powerful way of creating geometrical art-
work. You can duplicate one or more selected objects by dragging
them, using Arrow keys, copying to and pasting from the Clipboard, or
using the Offset Path command. When you copy objects to the
Clipboard, you can paste them on an artboard several different ways:
Paste, Paste in Front, Paste in Back, Paste in Place (New!), or Paste
on All Artboards (New!). The Offset Path command duplicates a path
(along with fill and stroke attributes) and places it on the artboard
based on the offset distance specified in the Offset Path dialog box.
The duplicate path is reshaped to fit around the original path.

Duplicating Objects

Duplicate or Copy Objects

Select the Selection tool on the
Tools panel.

◆ If the object is in a group,
select the Direct Selection tool
on the Tools panel.

Use any of the following methods:

◆ Same Document. Hold down Alt
(Win) or Option (Mac), and then
drag the edge or fill of the
object.

◆ Different Documents. Open the
documents side by side, and
then drag the edge or fill of the
object from one document to
another. 

◆ Copy/Paste from Clipboard.
Select the object, click the Edit
menu, and then click Copy.
Click in the target document or
artboard, click the Edit menu,
and then click Paste, Paste in
Front, Paste in Back, Paste in
Place (New!), or Paste on All
Artboards (New!).

◆ Keyboard. Select the object,
press Control (Win) or A
(Mac), and then use an Arrow
key to move the duplicated
object in the direction you
want. The duplicate object
moves away from the original
object based on the current
keyboard increment value in
General preferences.
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Duplicate Objects Using an
Offset

Select the Selection tool on the
Tools panel.

Select an object.

Click the Object menu, point to
Path, and then click Offset Path.

Enter the distance you want to
offset the duplicate path from the
original object.

Click the Joins list arrow, and then
select a bend style: Miter
(pointed), Round (circular), or
Bevel (square-cornered).

You can set a limit (1-500) to
determine when a mitered corner
changes into a beveled corner. A
low number creates a more
beveled corner, while a high
number creates a sharper corner.

Click OK.7
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Aligning and
Distributing Objects

Align or Distribute Objects

Select the Selection tool on the
Tools panel.

Select two or more objects to align
them or select three or more
objects to distribute them.

Select the Align panel or click
Align on the Control panel.

Click the Options menu, and then
click Use Preview Bounds. A
checked option uses the object’s
stroke weight and any applied
effects when aligning or
distributing.

If you want to align objects along
the edges of the artboard, click the
Align To menu on the Align or
Control panel, and then click Align
to Artboard. Objects are moved on
the artboard based on the
alignment or distribution command
to the closest edge (top and
bottom, or left and right). 

If you want to align objects to a
key object, click an object to make
it the key object (a thick blue
outline appears and the Align To
Key Object option is selected in
the Align and Control panel).

Use the alignment and distribution
buttons on the Align or Control
panel.
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In addition to using grids and guides to align objects to a specific point,
you can align a group of objects to each other. The Align panel buttons
make it easy to align two or more objects relative to each other or to
the page. To evenly align several objects to each other across the doc-
ument, either horizontally or vertically, select them and then choose a
distribution option. Before you select an align command, specify how
you want Illustrator to align the objects. You can align the objects in
relation to the document or to the selected objects. If you want to align
all the objects to another object, you can select and use a key object,
before you select an alignment option. 
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Transforming Objects

Transform an Object with the
Bounding Box

Click the View menu, and then
click Show Bounding Box to
display it.

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Use any of the following methods:

◆ Scale. Drag a corner handle to
scale along two axes; drag a
side handle to scale along one
axis; Shift-drag to scale
proportionally; hold down Alt
(Win) or Option (Mac), and then
drag to scale from the center.
Also hold down Shift to scale
from the center proportionally.

◆ Reflect. Drag a side handle all
the way across the object to
the other side. 

◆ Rotate. Point slightly outside a
corner handle (pointer changes
to a double arrow), and then
drag in a circular motion. 

To rotate an object 180
degrees, drag a corner handle
diagonally all the way across
the object.

To transform an object using exact
values or percentages, select the
Transform panel.
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The easiest way to transform an object is to use the bounding box. With
the bounding box, you can quickly scale (resize), reflect (mirror), and
rotate an object. However, you cannot copy an object or move the ref-
erence point. As you drag to transform an object, you can use keyboard
keys to alter the results of a transformation. Experiment with the differ-
ent options to create some new results.
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Rotate
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Using the Free
Transform Tool

Transform an Object with the
Free Transform Tool

Select the Free Transform tool on
the Tools panel.

Select one or more objects to
transform.

Use any of the following methods:

◆ Scale. Drag a corner handle to
scale along two axes; drag a
side handle to scale along one
axis; Shift-drag to scale
proportionally; hold down Alt
(Win) or Option (Mac), and then
drag to scale from the center.
Also hold down Shift to scale
from the center proportionally.

◆ Reflect. Drag a side handle all
the way across the object to
the other side. 

◆ Rotate. Point slightly outside a
corner handle (pointer changes
to a double arrow), and then
drag in a circular motion. To
rotate in 45 degree increments,
Shift-drag.

To rotate an object 180
degrees, drag a corner handle
diagonally all the way across
the object.

◆ Shear. Drag a side handle and
then hold down Ctrl (Win) or
A (Mac) as you continue to
drag. To constrain the
movement, also press Shift. To
shear from the center, also
press Alt (Win) or Option (Mac). 
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The Free Transform tool allows you to rotate, scale (resize), reflect (mir-
ror image), or shear (slant) an object. In addition, you can apply per-
spective and distortion to an object. However, you cannot copy an
object or move the reference point. As you drag to transform an object,
you can use keyboard keys to alter the results of a transformation. To
help you align the results the way you want, you can use Smart Guides
to make it easier.  

1 2

Shear
Shear results
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◆ Perspective. Drag a side
handle and then hold down
Ctrl+Alt+Shift (Win) or
A+Option+Shift (Mac) as you
continue to drag. 

◆ Distort. Drag a corner handle
and then hold down Ctrl (Win)
or A (Mac) as you continue to
drag.

To use Smart Guides as you
transform an object:

◆ Select the Transform Tools
check box in Smart Guides
preferences.

◆ Click the View menu, and then
click Smart Guides to display
them.

◆ As you drag to transform an
object, smart guides appear  in
your document, which you can
use to align the transformed
object.

To transform an object using exact
values or percentages, select the
Transform panel.
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Perspective
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Rotating and Scaling
Objects

Rotate or Scale an Object

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Select the Rotate or Scale tool on
the Tools panel.

To move the reference point, click
a new point.

Use the appropriate method:

◆ Rotate. Drag in a circular
motion. To rotate in 45 degree
increments, Shift-drag. 

◆ Scale. Drag away from or
toward the object. Shift-drag to
scale proportionally; hold down
Alt (Win) or Option (Mac), and
then drag to scale from the
center. Also hold down Shift to
scale from the center
proportionally.

◆ Scale and Flip. Drag across the
entire object. 

◆ Scale and Copy. Hold down
Alt+Shift (Win) or Option+Shift
(Mac), and then drag. 

To rotate or scale an object using
exact values or percentages,
select the Transform panel.
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After you create an object, you can change its orientation by rotating it
or change its size by scaling it. For a freeform rotation, when you want
to rotate the object in other than 90 or 180 degree increments, you can
use the Rotate tool. To resize an object, either smaller or larger, you can
use the Scale tool. With either tool, you can transform the object from
its center or the reference point. To rotate or scale an object using
exact values or percentages, use the Transform panel, which is avail-
able on the Control panel or Window menu.
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Reflecting and
Shearing Objects

Reflect or Shear an Object

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Select the Reflect or Shear tool on
the Tools panel.

To move the reference point, click
a new point.

Use the appropriate method:

◆ Reflect. Click to establish a
reference point, and then click
again to establish the axis of
reflection.

◆ Shear. Drag away from the
object.

To reflect or shear an object using
exact values or percentages,
select the Transform panel.
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The Reflect and Shear tools on the Tools panel allow you to be creative
as you transform an object. The Reflect tool creates a mirror image of
an object, while the Shear tool creates a slanted image of an object. To
reflect or shear an object using exact values or percentages, open the
Transform panel, which is available on the Control panel or Window
menu.
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Applying Multiple
Transformations

Use the Transform Each
Command

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Click the Object menu, point to
Transform, and then click
Transform Each.

Select the Preview check box to
view your changes on the selected
object.

Do any of the following:

◆ Scale Horizontal or Vertical.
Drag the slider or enter a
percentage to scale objects
from their reference point.

◆ Move Horizontal or Vertical.
Drag the slider or enter a
percentage to move objects left
or right and up or down.

◆ Rotate Angle. Enter a rotate
angle or drag the dial. 

◆ Reflect X or Y. Select to create
a mirror reflection of the
objects.

◆ Reference Point. Click a square
to change the reference point. 

◆ Random. Select to apply
random transformations using
the values in the dialog box. 

Click OK or Copy (creates a copy
and applies the transformation).
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The Transform Each command allows you to transform multiple objects
relative to their individual reference points instead of a single reference
point. With the Transform Each command, you can scale or move
objects horizontally or vertically, rotate objects by a specific angle, and
create a mirror reflection of the objects. If you want to create a unique
effect, you can also have Illustrator apply random transformations. You
can also use the Transform Effect command to create similar effects,
which you can modify. 

2

5

4

6

Transformation
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Use the Transform Effect

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Click the Effect menu, point to
Distort & Transform, and then click
Transform.

Select the Preview check box to
view your changes on the selected
object.

Do any of the following:

◆ Scale Horizontal or Vertical.
Drag the slider or enter a
percentage to scale objects
from their reference point.

◆ Move Horizontal or Vertical.
Drag the slider or enter a
percentage to move objects left
or right and up or down.

◆ Rotate Angle. Enter a rotate
angle or drag the dial. 

◆ Copies. Enter the number of
copies you want.

◆ Reflect X or Y. Select to create
a mirror reflection of the
objects.

◆ Reference Point. Click a square
to change the reference point. 

◆ Random. Select to apply
random transformations using
the values in the dialog box. 

Click OK.

To edit the transformation, select
the object, and then click
Transform on the Appearance
panel.

7

6

5

4

3

2

1

Repeating a Transformation
The Transform Again command allows you to quickly repeat the last
transformation with the last-used values on a selected object. To use
the command, transform and select an object or group, click the
Object menu, point to Transform, and then click Transform Again or
press Ctrl+D (Win) or A+D (Mac).

For Your Information

2

6

4

5

Transformation
effect
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Reshaping Objects
with Envelopes

Distort Objects with an Envelope

Select the Selection tool on the
Tools panel.

Select one or more objects to
reshape.

Click the Object menu, point to
Envelope Distort, and then click
one of the following:

◆ Make With Warp. Uses a
preset warp shape.

◆ Make with Mesh. Uses a
rectangle grid.

◆ Make With Top Object. Uses an
object as the shape of the
envelope. The object needs to
be at the top of the stacking
order. 

Specify the options you want for
the envelope type; select the
Preview check box to view your
changes on the selected object.

Click OK.

Do any of the following:

◆ Reshape. Select the Selection
or Mesh tool, and then drag
any anchor points. 

◆ Delete Anchor Points. For a
mesh grid, select the Selection
or Mesh tool, select an anchor
point, and then press Delete.

◆ Add Anchor Points. For mesh
grid, select the Mesh tool, and
then click on the grid. 

6

5

4

3

2

1

Envelopes are objects you can use to reshape other objects, except
graphs, guides, or linked objects. You can use one of the built-in
envelopes or create your own out of an existing object. The built-in
envelopes use warp shapes or a mesh grid as the object. After you
apply an envelope, you can edit the original object or the envelope
(anchor points), separately, using the Selection and Mesh tools on the
Tools panel.

2

4

5

Selection tool

Mesh tool

Mesh point

Mesh grid
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Index

A
accented edges effects, 275
actions

Actions panel, 332–333
adding commands to, 338
adding stops to, 336
batch file processing, 340–341
building new, 334
built-in scripts, 342
controlling playback of, 335
deleting commands from, 339
inserting a non-recordable command in

an Action, 337
order of commands in, changing, 338
recording, 334
running actions within actions, 334
saving

as files, 333
into sets, 333

scripts, 342–343
activation, 2
active documents, 19
active windows, 18
Adobe.com, 450
Adobe Bridge

automating tasks in, 448
browsing documents with, 14
Camera Raw feature, 440–441
color settings, 105
components of, 437
description of, 436
editing images in, 446
Get Photos from Camera command, 439
opening documents with, 14–15, 438
placing graphics from, 240–241
preferences, setting, 444–445
revealing documents in, 14

Web Photo Gallery creation, 447
working with images using, 15, 442–443

Adobe ConnectNow, 436, 451
Adobe CS Live. See CS Live
Adobe Device Central

basic description of, 436, 454
checking content using, 455
components of, 454

Adobe ExtendScript Toolkit, 436
Adobe Extension Manager, 436, 456
Adobe Flex File, saving documents as, 386-

387
Adobe PDF Presets command (Edit menu),

379
Adobe Product Improvement Program, 23
Adobe Studio Exchange, 2
Adobe Updater, 21
Adobe Web site

Adobe Studio Exchange, 2
Community Help, 22

advanced print options, 366–367
Advanced tab (File Info dialog box), 371
alignment

anchor points, 164–165
objects, 94
paragraphs, 226
pixel grid, 65
slices, 411
stroke, 130

All Objects command (Select menu), 88
All Objects in Active Artboard command

(Select menu), 88
anchor points

adding new, 162–163
alignment, 164–165
Convert Anchor Point tool, 161
converting, 160–161
deleting, 163
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anchor points (continued)
direction lines, 158
endpoints, 165
highlighting, 158
moving, 158–159
paths and, 63
preferences, 158
selecting with Direct Selection tool, 82
showing and hiding, 63
smooth points, converting to corner

points, 160
anchors, 423
anti-aliasing, 218, 420
Appearance of Black preferences, 432
Appearance panel, 254–255
Arc tool, 70
arcs, drawing, 70
area graphs, 346-347
Area Type tool, 207
arranging

documents, 18
layers, 192–193
slices, 410–411

arrowheads, stroke, 132-133
art brushes, 298–299
Artboard tool

artboard creation, 34
Artboard Options button, 35
multiple artboards, 36

artboards
within artboards, 34
aspect ratio, 35
centerpoints, 35
deleting, 36
display options, 37
duplicating, 34
exiting editing mode, 34
landscape/portrait orientation, 35
moving, 36
multiple, working with, 36
navigating within, 34
presets, 34
previewing, 36
resizing, 36
rotating, 36
size, 35
switching between, 17, 37
video safe areas, 35

X and Y positioning, 35
artwork, inserting in documents, 16
Assign Profile command (Edit menu), 106
attributes

appearance, 254–255
stroke, 130–133

Audio Data tab (File Info dialog box), 370
auto slices, 406
AutoCAD drawing format, 375
AutoCAD File format, 375

B
bar graphs, 346-347
batch file processing, 340–341
Batch Rename command, 448
bend styles, 93
bevel bend style, 93
bevel joins, 131
bitmap, exporting documents as, 376
black appearance options, 432
bleed

bleed print option, 361
document creation, 32

Blend command (Objects menu), 141–142
Blend tool, 143
blends

blending fill colors, 140
changing and applying blend options,

142
creating automatically, 141
creating with Blend tool, 143
making and releasing blend objects, 141
objects, modifying, 144
opacity, 145
transformation, 144
transparency settings, 146

Bloat tool, 306
Blob Brush tool

brush options, setting, 173
merging paths with, 172

blur effects, 270
BMP format, 375
bold font, 218
Bounding Box command (View menu),

288–289
Bridge (Adobe)

automating tasks in, 448
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browsing documents with, 14
Camera Raw feature, 440–441
color settings, 105
components of, 437
description of, 436
editing images in, 446
Get Photos from Camera command, 439
Mini Bridge, 440
opening documents with, 14–15, 438
placing graphics from, 240–241
preferences, setting, 444–445
revealing documents in, 14
Web Photo Gallery creation, 447
working with images using, 15, 442–443

Bristle brushes, 302-303
creating and editing, 302-303

Browse in Bridge command (File menu),
14–15, 240–241

brushes
art, 298–299
Blob Brush tool, 173
Bristle, 302-303
Brushes panel, 291
calligraphic, 296–297
deleting, 304
Paintbrush tool, 292–293
pattern, 300–301
scatter, 294–295
strokes, removing, 304

Brushes panel, 291
built-in scripts, actions, 342

C
calligraphic brushes, 296–297
Camera Data tab (File Info dialog box), 370
Camera Raw feature, 440–441
caps, 131
case, text, 355
Categories tab (File Info dialog box), 370
center mark, 37
centerpoints, 35
Check Spelling command (Edit menu), 350
circles, drawing, 66
clearing

guides, 49
objects, 91

clipping masks

creating, 178
creating for groups or layers, 179
editing, 180
masked object, editing in Isolation

Mode, 181
release objects from, 179

clipping sets, 181
Close button, 26
Close command (File menu), 26
closed paths, 63
closing

documents, 26
Illustrator, 26
panels, 7

CMYK (Cyan, Magenta, Yellow and Black)
color mode, 28, 107, 111

collapsing panels, 7
Color Guide panel

applying color with, 122–123
color groups, 123
harmony rules, variations based on, 123
variation options, selecting, 121
variation types, displaying, 121

color management print options, 368
color modes. See also colors

changing, 108
CMYK, 28, 107, 111
document creation, 28
Grayscale, 28, 110
RGB, 28, 107, 110
switching between, 107
working with, 107

Color panel
Color sliders, 110
working with, 110–111

colored paper simulation, 33
colors. See also Color Guide panel; color

modes; Swatches panel
applying to objects, fills, or stroke, 109,

128
applying with Eyedropper tool, 136–137
Color Guide Panel, 121–123
Color panel, 110–111
color profiles, changing or removing, 105
color settings, changing, 104–105
converting to grayscale, 119
crop mark registration color, 54-55
gamut warning icon, 111
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colors (continued)
global, 118–120
grayscale images, 119
grid colors transparency settings, 33
grids, 52
guides, 48, 51
hue, 111
inverting, 120
Kuler panel, 116–117
Live Color feature, 124–125
luminosity, 111
nonglobal, 118–120
proofing, 126
replacing, 118–119
saturation, 111
selecting, 111
soft proof, 126
Swatches panel, 112–115
themes, 116–117
view box color, 42
Web-safe, 111

column graphs, 346-347
commands

adding to actions, 338
basic description of, 6
deleting from actions, 339
Panel Options menu, 9

Community Help site, 22
compound paths

creating, 176
releasing, 177
reversing object's fill in, 177

condensed font, 218
ConnectNow (Adobe), 436, 451
Constrain Angle general preference, 420
Control panel

anchor points, converting, 161
basic description of, 11
splitting paths using, 170-171
tools in, 6

Convert Anchor Point tool, 161
Convert to Shape command (Effect menu),

260
convert to shape effects, 260
converting anchor points, 160–161
Copy command (Edit menu), 215
copying text, 214–215
corner points, 160

Corner Radius general preference, 420
Create New Action button (Actions panel),

333
Create New Set button (Actions panel), 333
crop marks

creating, 54-55
deleting, 54
general preferences, 421
registration color, 54
trim marks, editable, 55

cross hairs, 37
Crystallize tool, 306
CS Live Services, 436, 450
CS News and Resources, 450
CS Review, 450, 452-453
cursor preferences, 420
curved segments, 159
curves, drawing, 157
custom dictionaries, spell checking, 351
Cut command (Edit menu), 215
cutout effects, 274

D
dashed stroke, 132
data graphs, 346-347
data sets

creating, 344–345
deleting, 344–345
renaming, 345

data variables, 344–345
deactivate Illustrator, 20
Define Pattern command (Edit menu), 138
Delete button (Actions panel), 333
deleting

anchor points, 163
artboards, 36
brushes, 304
commands from actions, 339
crop marks, 54-55
data sets, 344–345
files, 12
graphic styles, 253
layers, 189
objects, 91
selections, 90
slices, 408
symbols, 311
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workspaces, 59
Description tab (File Info dialog box), 370
Deselect command (Select menu), 88
Device Central (Adobe)

basic description of, 436
checking content using, 455
components of, 454

Device Central command (File menu), 39
DICOM tab (File Info dialog box), 371
dictionaries, spell checking, 351
diffuse glow effects, 275
Direct Selection tool

anchor points, adding new, 162
anchor points or segments, moving, 159
deleting anchor points using, 163
editing patterns using, 139
end points, connecting, 165
selecting anchor points and segments

with, 82
showing/hiding direction lines, 63
understanding selections, 80

direction lines
anchor points, 158
showing and hiding, 63

Distort & Transform command (Effect
menu), 100

distributing
objects, 94
slices, 411

dithering, 401
dividing paths, 169
drawing mode, 64

behind, 64
normal, 64
inside, 64

DOC format, 211
docking

documents, 19
panels, 8

Document Color Mode command (File
menu), 108, 356

Document Info panel, 372
Document Setup command (File menu), 32,

147
Document window, 6
documents

active, 19
arranging, 18

bleed and view options settings, 32
browsing with Adobe Bridge, 14
closing, 26
color modes, 28
creating

from scratch, 28
from templates, 30–31
using presets, 29

docking/undocking, 19
exporting

as bitmap, 376
Export command, 374
export file formats, 375
as Flash Movie, 380–381
to Photoshop, 378
with presets, 379
as TIFF format, 377

file information, inserting, 370–371
finding and replacing text and elements

in, 352–353
grid pattern, 19
inserting images in, 16
language settings, 33
linking, 16
measurement units, 32
opening

with Adobe Bridge, 14–15
existing documents, 12
recently opened, 13
from Welcome Screen, 13

printing, 356
revealing in Adobe Bridge, 14
rulers, 46–47
saving, 24–25

as Adobe Flex File, 386-387
as EPS format, 384–385
as FXG format, 386-387
as Microsoft Office, 388
as PDF format, 382–383
as template, 389
for the Web, 392–393

setting up, 32–33
spell checking, 350–351
switching between, 18
tabbed, 18
templates, 16
transparency settings, 32–33
type options settings, 33
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documents (continued)
view size, 17
viewing information in, 17
views, 38–41
windows, 18–19
working with multiple, 18–19

DOCX format, 211
double quotes, 33
drawing

arcs, 70
circles, 66
curves, 157
ellipses, 66
line segments, 69
with Pencil tool, 278–279
polygons, 68, 156
rectangle grids, 72
rectangles, 67
spirals, 70–71
stars, 68

drawing tablets, 434
drop shadow effects, 263
duplicating

artboards, 34
color in Swatches panel, 113
graphic styles, 251
layers, 194
objects, 92–93
slices, 408
symbols, 312

E
Edit Colors command (Edit menu), 120, 140
Edit Custom Dictionary command (Edit

menu), 351
Edit menu commands

Adobe PDF Presets, 379
Assign Profile, 106
Check Spelling, 350
Color Settings, 104
Copy, 215
Cut, 215
Define Pattern, 138
Edit Colors, 120, 140
Edit Custom Dictionary, 351
Find and Replace, 352–353
Paste, 214–215

Paste in Back, 215
Paste in Front, 215
Print Presets, 357
Redo, 57
Transparency Flattener Presets, 367
Undo, 57

Edit Selection command (Select menu), 90
Edit View command (View menu), 38
editing

blend objects, 144
clipping masks, 180
color in Swatches panel, 113
colors with Live Color, 124–125
gradients, 150
graphic styles, 252
images in Adobe Bridge, 446
paths within clipping sets, 181
patterns, 139
selections, 90
symbols, 313

Effect menu commands
Convert to Shape, 260
Crop Marks, 54
Distort & Transform, 100
Effect Gallery, 272–273
Sharpen, 271
Stylize, 261

effects
accented edges, 275
applying multiple, 272
blur, 270
controlling with selections, 273
convert to shape, 260
cutout, 274
diffuse glow, 275
drop shadow, 263
dry brush, 274
Fresco, 274
gaussian blur, 270
glass, 275
glowing edges, 275
grain, 276
graphic pen, 276
Illustrator, 258–259
inner glow, 262–263
mosaic tiles, 276
note paper, 275
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outer glow, 262–263
panel knife, 274
Photoshop Effect Gallery, 268–269
plastic wrap, 276
previewing, 258
raster graphics, 266
scribble, 261
spatter, 276
stained glass, 276
stamp, 275
text, 210
3D, 264–265
unsharp mask, 271
vector objects, 267

Ellipse tool, 66
ellipses, drawing, 66
embedded graphics, 244–245
endpoints, 165
Enhanced Metafile format, 375
Envelopes, reshaping with, 102
EPS format, 25, 371, 384–385
Eraser tool, 182
erasing path parts, 182
exiting Illustrator, 26
Expand button (Pathfinder panel), 174
Expand command (Objects menu), 139, 148
expanding

gradients, 148
panels, 7
patterns, 139

exporting
documents

as bitmap, 376
Export command, 374
as Flash Movie, 380–381
to Photoshop, 378
with presets, 379
as TIFF format, 377

export file formats, 375
Extension Manager (Adobe), 436, 456
Extensions command (Window menu),

116–117
Eyedropper tool

applying colors and attributes with,
136–137

color attributes, changing, 137
Save For Web & Devices tool, 394

F
families, font, 218
File Handling & Clipboard preferences, 431
File Info command (File menu), 370
file information, inserting into documents,

370–371
File menu commands

Browse in Bridge, 14–15, 240–241
Close command, 26
Device Center, 39
Document Color Mode, 108, 356
Document Setup, 32, 147
File Info, 370
New, 28–29
New From Template, 30
Open, 12, 238
Open Recent, 13
Open With, 240
Place, 16, 239, 242, 244
Print, 356, 358
Return to Adobe Illustrator, 14
Revert, 24
Save, 24
Save a Copy, 25
Save As, 25, 31
Save For Web & Devices, 392–394
Scripts, 342–343

files
deleting, 12
saving actions as, 333

fills
applying color to, 109, 122, 128
blending fill colors, 140
patterns as, 138–139

Find and Replace command (Edit menu),
352–353

Find Font command, 354
Fit All In Window command (View menu),

44
Fit Artboard In Window command (View

menu), 44
Flare tool, 67
Flash format, SWF, 375, 393
Flash Movie, exporting documents as,

380–381
Flattener Preview command (Window

menu), 39, 367
flattening layers, 200
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fonts
bold, 218
condensed, 218
families and styles, 218
Find Font command, 354
finding, 219
italic, 218
replacing, 219
reusing recent, 218
size, 220

Free Transform tool, 96–97
Fresco effects, 274
full screen mode, 43
FXG format, 25, 386-387

G
gamut warning icon, 111
Gap options, 290
gaussian blur effects, 270
General preferences, 420
Get Photos from Camera command

(Adobe), 439
GIF documents, optimizing, 400–401
GIF format, 371
glass effects, 275
global colors, 118–120
glowing edges effects, 275
glyphs, 233
Go to Bridge button, 14–15
Gradient tool, 151
gradients

applying to objects, 148
creating, 149
editing, 150
expanding, 148
Gradient tool, 151
linear type, 149
mesh, 102, 152-153
radial type, 149

grain effects, 276
graphic pen effects, 276
graphics

embedded, 244–245
linked, 244–245
linking, 242–243
mosaic, 256

opening graphic images, 238
placing, 239–241
print options, 362
raster

interpolation and, 62
tracing, 246–248
understanding raster graphics, 62

styles
applying, 249
breaking links to, 253
creating, 250
deleting, 253
duplicating, 251
editing, 252

graphs, 346-347
add designs, 348
create and format, 346-347

Grayscale color mode, 28, 110
grayscale images, 119
grid colors transparency settings, 33
grid patterns, 19
Grid, Perspective

adjusting, 77
copying, 78
customizing, 79
drawing, 76
moving, 78
objects, adding, 78
resizing, 78
text, adding, 78

grid, pixel aligned, 65
grid size transparency setting, 32
grids. See also guides

color, 52
displaying in back of artwork, 52
Polar Grid tool, 73
preferences, 52
Rectangle Grid tool, 72
showing and hiding, 52
Snap to Grid command, 52
styles, 52
subdivisions, 52
Transparency, 147

Group command (Objects menu), 86
Group Selection tool, 80
grouping objects, 86–87
groups, creating clipping masks for, 179
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guides. See also grids
clearing, 49
color, 48
converting vector objects to, 49
creating, 49
locking, 48
preferences, 48
ruler, 47
showing and hiding, 48
smart guides

object transformation, 97
preferences, 51
turning on/off, 50
working with, 50–51

snap to point, 48
style, 48
switching, 49

H
Hand tool

moving elements around with, 53
quick access to, 53
Save For Web & Devices tool, 394

handles, 423
hanging indents, 227
hardware, Illustrator system 

requirements, 3
Help menu commands

Adobe Product Improvement Program,
23

Illustrator Help, 22–23
Updates, 21
Welcome Screen, 13

help options
Community Help site, 22
searching topics, 23

Hide Edges command (View menu), 63
Hide Panels command (Window menu), 18
hiding

anchor points, 63
direction lines, 63
grids, 52
guides, 48
layers, 196
panels, 8, 43
rulers, 47

slices, 408–409
Transparency grid, 147

highlighting anchor points, 158
histograms, 441
History tab (File Info dialog box), 371
HSB color slider (Color panel), 110
HTML text, adding to slices, 412
hue, 111
hyphenation, 229, 427

I
icons, collapsing and expanding panel sets

between icons and panels, 9
Illustrator Help command (Help menu),

22–23
Illustrator tab (File Info dialog box), 371
images

inserting in documents, 16
replacing, 16
working with images using Bridge, 15

importing text, 211
indentation

hanging indents, 227
paragraphs, 227

Info panel
color fill and stroke information, 56
uses for, 56

inner glow effects, 262–263
installing Illustrator

in Macintosh, 3
in Windows, 2

Internet, checking for updates from, 20
interpolation, 62
Inverse command (Select menu), 88
inverting colors, 120
IPTC tab (File Info dialog box), 370
Isolation Mode, 181
italic font, 218

J
joining anchor endpoints, 165
joins, 131
JPEG documents, optimizing, 398–399
JPEG format, 371, 375
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K
kerning type, 222
Keyboard Increment general preference,

420
keyboard shortcuts, 433
Knife tool, 169
Knockout Group option, 146
Kuler panel, 116–117

L
landscape/portrait orientation, 35
language settings, document creation, 33
Lasso tool

selecting objects with, 83
understanding selections, 80

layers. See also Layers panel
arranging, 192–193
creating clipping masks for, 179
creating top level layers, 186–187
deleting, 189
deselecting, 188
duplicating, 194
flattening, 200
hiding, 196
locking, 195
merging, 197
moving, 192–193
moving objects to, 198–199
naming, 187
releasing objects to, 199
selecting, 188
selecting objects with, 190–191
showing and hiding, 196
sublayers, 186–187

Layers panel. See also layers
accessing, 184
components of, 184
locating objects in, 201
options, setting, 185

layouts, workspace, 58
leading text, 221
line graphs, 346-347
Line Segment tool, 69
line segments, drawing, 69
linear gradient type, 149
linked graphics, 244–245
linking

documents, 16
graphics, 242–243
slices, 409

Liquify tools, 309
Live Color feature

applying color groups to objects with,
124–125

editing colors with, 124–125
Live Paint Bucket tool

paint fills, 284
preferences, setting, 283
selecting options to paint fills or strokes

with, 282
stroke edges, changing, 285

Live Paint Groups
adding paths to, 289
converting traced objects to, 281
creating, 280–281
Gap options, 290
reshaping or moving paths in, 288–289

Live Paint Selection tool, 286–287
locking
guides, 48
layers, 195

lossy compression, 401
lowercase text, 355
luminosity, 111

M
Macintosh

Illustrator system requirements, 3
installing Illustrator in, 3
starting Illustrator in, 5

Macintosh PICT format, 375
Magic Wand tool

selecting objects with, 84–85
understanding selections, 80

marks print options, 360–361
Measure tool, 56
measurement

distance between objects, measuring, 56
measurement units, document creation,

32
menus, 6
merging

layers, 197
paths, 172–173
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mesh, 102, 152-153 
metadata, 371
Microsoft Office, saving documents as, 388
Mini Bridge, 440
miter bend style, 93
miter joins, 131
Mobile SWF tab (File Info dialog box), 370
mode, drawing, 64
mosaic tiles effects, 256, 276
Move tool, 50
moving

anchor points, 158–159
artboards, 36
document elements with Hand tool, 53
layers, 192–193
objects, 91
objects to layers, 198–199
segments, 158–159
slices, 410
text, 209, 214–215
between tools, 53

N
naming

layers, 187
selections, 90
workspaces, 58

navigation
artboards, 37
within artboards, 34

Navigator panel
customizing, 42
view area, 41
view box color, 42
view size, 40

New command (File menu), 28–29
New From Template command (File menu),

30
New View command (View menu), 38
Next Object Above command (Select

menu), 88
Next Object Below command (Select

menu), 88
9-slice scaling, 326-327
nonglobal colors, 118–120
normal screen mode, 43
note paper effects, 275

O
objects

alignment, 94
applying color to, 109, 122, 128
clearing, 91
deleting, 91
distributing, 94
duplicating, 92–93
grouping, 86–87
measuring distance between, 56
moving, 91
moving to layers, 198–199
Perspective Grid

adjusting, 77
copying, 78
customizing, 79
drawing, 76
moving, 78
objects, adding, 78
resizing, 78
text, adding, 78

pixel grid, aligned, 65
reflecting, 95, 99
rotating, 95–96, 98
scaling, 95, 98
selecting

with Lasso tool, 83
with Magic Wand tool, 84–85
similar objects, 88–89
using Direction Selection tool, 82
using Select menu, 88–89
using Selection tool, 81

Shape Builder tool, 74-75
transforming, 95–97

Objects menu commands
Blend, 141–142
Clipping Mask, 178
Compound Path, 176
Expand, 139, 148
Group, 86
Text Wrap, 234
Transform, 100
Ungroup, 86

offsetting paths, 93
opacity, blends, 145
Open command (File menu), 12, 238
open paths, 63, 163
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Open Recent command (File menu), 13
Open With command (File menu), 240
opening

documents
with Adobe Bridge, 14–15
existing documents, 12
recently opened, 13
from Welcome Screen, 13

graphic images, 238
panels, 7

Origin tab (File Info dialog box), 371
outer flow effects, 262–263
Outline view, 38–39
outlines, 235
output print options, 364–365
output slice settings, 415
overflow, text, 216–217
Overprint Preview command (View menu),

39, 363

P
Paintbrush tool, 167
painting

art brushes, 298–299
Brushes panel, 291
calligraphic brushes, 296–297
Live Paint Bucket tool, 282–285
Live Paint Groups

adding paths to, 289
converting traced objects to, 281
creating, 280–281
Gap options, 290
reshaping or moving paths in,

288–289
Live Paint Selection tool, 286–287

Paintbrush tool, 292–293
pattern brushes, 300–301
scatter brushes, 294–295

panel knife effects, 274
Panel Options menu, 7, 9
panels

adding, 8
closing, 7
collapsing, 7
displaying hidden, 43
docking/undocking, 8
expanding, 7

hiding, 8, 43
opening, 7
Panel Options menu, 9
sets, collapsing and expanding between

icons and panels, 9
subtracting, 8

paragraphs
alignment, 226
indentation, 227
spacing, 227

Paste command (Edit menu), 214–215
Paste in Back command (Edit menu), 215
Paste in Front command (Edit menu), 215
Pathfinder commands, 175
Pathfinder panel, 174-175
paths

anchor points and, 63
clipping mask, 178–181
closed, 63
compound, 176–177
convert mesh object to, 160
convert strokes to compound, 176
dividing, 169
erasing parts of, 182, 278
join, 165
merging, 172–173
offsetting, 93
open, 63, 163
reshaping, 166–167
segments and, 63
Shape Mode command, 174
shape of, changing, 63
simplify, 168
splitting, 170–171
spliting into grid, 171

pattern brushes, 300–301
patterns

applying to objects, 138
editing, 139
expanding, 139
as fills, 138–139

PDF format, 25, 371, 382–383
Pen tool

anchor points, adding, 163
drawing curves with, 157
drawing polygons with, 156

Pencil tool
preferences, 279
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reshaping paths with, 167
working with, 278–279

Perspective Grid
adjusting, 77
copying, 78
customizing, 79
drawing, 76
moving, 78
objects, adding, 78
resizing, 78
text, adding, 78

Photoshop Effect Gallery, 268–269
Photoshop, exporting to, 378
Photoshop format, 375
pie graphs, 346-347
pixel grid, align, 65, 328
Pixel Preview command (View menu), 39
pixels, 35
Place command (File menu), 16, 239, 242,

244
placing graphics, 239–241
plastic wrap effects, 276
Play button (Actions panel), 333
playback, action, 335
plug-in preferences, 428
PNG format, 371, 375
PNG-8 document, 402–403
PNG-24 document, 404
point type, 205
point/pica size, 46
points, anchor

adding new, 162–163
alignment, 164–165
average, 159
Convert Anchor Point tool, 161
converting, 160–161
deleting, 163
direction lines, 158
endpoints, 165
highlighting, 158
moving, 158–159
paths and, 63
preferences, 158
selecting with Direct Selection tool, 82
showing and hiding, 63
smooth points, converting to corner

points, 160
Polar Grid tool, 73

Polygon tool, 68
polygons, drawing, 68, 156
portrait/landscape orientation, 35
preferences

Adobe Bridge, 444–445
anchor points, 158
Appearance of Black, 432
cursor, 420
File Handling & Clipboard, 431
General, 420
grids, 52
guide, 48
hyphenation, 427
keyboard shortcut, 433
Live Paint Bucket tool, 283
Pencil tool, 279
plug-in, 428
ruler, 46
Scratch Disk, 429
Selection & Anchor Display, 422–423
slices, 427
smart guides, 51
text, 424–425
Transparency grid, 147
type, 424–425
Units Performance, 426
updates, 20
user interface, 430

presets
artboard, 34
creating new documents using, 29
exporting with, 379
list of, 29
printing with, 357, 366

Preview view, 38–39
Preview View command (View menu), 278
previewing

artboards, 36
color separations, 363
effects, 258

Print command (File menu), 356, 358
Print Presets command (Edit menu), 357
printing

advanced print options, 366–367
bleed options, 361
color management settings, 368
color separations, previewing, 363
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printing (continued)
documents, 356
general print options, 358–359
graphics print options, 362
marks options, 360–361
number of copies, specifying, 359
output options, setting, 364–365
Overprint preview, 363
overprints, 366
presets, 366
with presets, 357
Print command, 356
print problems, checking for, 369
print tiling, 359
reverse order, 358
Separations preview, 363
summary print options, 369

Product Improvement Program (Adobe), 23
Proof Colors command (View menu), 126
Proof Setup command (View menu), 39
proofing colors, 126
PSD format, 371
Pucker tool, 306
punctuation, 232

Q
Quit Illustrator command (Illustrator menu),

26
quotes, 33

R
radar graphs, 346-347
radial gradient type, 149
raster graphics

effects, 259, 266
interpolation and, 62
Resolution Independent Effects (RIE), 259
tracing, 246–248
understanding raster graphics, 62

Raw Data tab (File Info dialog box), 371
Record button (Actions panel), 333
recording actions, 334
Rectangle Grid tool, 72
Rectangle tool, 67
rectangles, drawing, 67
Redo command (Edit menu), 57
Reflect tool, 99

reflecting objects, 95, 99
registration, 4–5
registration point, 329
releasing

compound paths, 177
objects from clipping masks, 179
objects to layers, 199

renaming
data sets, 345
selections, 90
workspaces, 59

rendering intent color management print
option, 368

replacing
colors, 118–119
fonts, 219
images, 16

Reselect command (Select menu), 88
Reshape tool, 166
reshaping paths, 166–167
resizing

artboards, 36
slices, 410

Resolution Independent Effects (RIE), 259
resolution preset transparency setting, 33
Return to Adobe Illustrator command (File

menu), 14
reverse order printing, 358
Revert command (File menu), 24
revolving 3D effects, 265
RGB (Red, Green, Blue) color mode, 28, 107,

110
Rotate tool, 98
rotating

artboards, 36
objects, 95–96, 98
text, 225

round bend style, 93
round joins, 131
Rounded Rectangle tool, 67
RTF format, 211
rulers

artboard display options, 37, 47
displaying, 46–47
document, 46–47
guides

alignment, 51
changing, 47
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clearing, 49
color, 48
converting vector objects to, 49
creating, 49
locking, 48
preferences, 48
ruler, 47
showing and hiding, 48
smart guides, 50–51
snap to point, 48
style, 48
switching, 49

hiding, 47
origin, changing, 47
preferences, 46

S
safe area, artboard display options, 37
Same command (Select menu), 89
saturation, color, 111
Save a Copy command (File menu), 25
Save As command (File menu), 25, 31
Save command (File menu), 24
Save For Web & Devices command (File

menu), 392–394
Save Selection command (Select menu), 80
Save Workspace command (Workspace

menu), 58
saving

actions
as files, 333
into sets, 333

documents, 24–25
as Adobe Flex File, 386-387
as EPS format, 384–385
as FXG format, 386-387
as Microsoft Office, 388
as PDF format, 382–383
as template, 389
for the Web, 392–393

selections, 80
slices for Web, 414–415
slices (from selection) for Web, 416
symbols, 311

Scale tool, 98
scaling

9-slice scaling, 326-327

objects, 95, 98
type, 224

Scallop tool, 306
scatter brushes, 294–295
scatter graphs, 346-347
Scissor tool, 170
Scratch Disk preferences, 429
screen modes, 43
scribble effects, 261
scripts, actions, 342–343
searching

fonts, 219
for help information, 23

segments
curve, 159
moving, 158–159
paths and, 63
selecting with Direct Selection tool, 82

Select menu commands, 88–89
Edit Selection, 80
Same command, 89
Save Selection, 80

Selection & Anchor Display preferences,
422–423

Selection tool. See also selections
aligning and distributing objects using,

94
duplicating objects with, 92–93
moving objects with, 91
reflecting or shearing objects, 99
rotating and scale objects with, 98
selecting objects with, 81
transforming objects with, 95
understanding selections, 80

selections. See also Selection tool
anchor points, 82
controlling effects using, 273
deleting, 80
editing, 80
examples of, 80
inverting color of, 88
layers, 188
naming, 80
renaming, 80
reselecting, 88
saving, 80
selecting next object above/below 

current, 88
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selections (continued)
slices, 408–409
type, 212–213
understanding selections, 80

sentence case, 355
Separations Preview command (Window

menu), 39
Shape Mode command (Pathfinder panel),

174
Share My Screen command, 450, 451
Sharpen command (Effect menu), 271
Shape Builder tool, 74-75
Shear tool, 99
shortcuts

starting Illustrator, 4–5
tool, 11

Show Bounding Box command (View
menu), 95

Show Edges command (View menu), 63
Show Panels command (Window menu), 18
Show Print Tiling command (View menu),

38
Show Text Threads command (View menu),

216
Show Transparency Grid command (View

menu), 147
simplify paths, 168
single quotes, 33
size

artboard, 35
font, 220
views, 40

Slice Selection tool, 394
slices

alignment, 411
arranging, 410–411
auto, 406
deleting, 408
distributing, 411
duplicating, 408
hiding, 408–409
HTML text, adding, 412
linking, 409
moving, 410
output option settings, 415
preferences, 427
resizing, 410
saving for Web, 414–415, 416

selecting, 408–409
showing, 408–409
stacking, 411
subslices, 407
unlinking, 409
URL links, adding, 413
user, 406
viewing slice options, 408–409
working with, 409

smart guides
object transformation, 97
preferences, 51
turning on/off, 50
working with, 50–51

Smart Punctuation, 232
smooth points, converting to corner points,

160
Snap to Grid command, 52
Snap to Point command, 48, 422
soft proof colors, 126
software, Illustrator system requirements, 3
spacing paragraphs, 227
spatter effects, 276
spell checking, 350–351
Spiral tool, 70–71
spirals, drawing, 70–71
splitting paths, 170–171
stacked bar graphs, 346-347
stacked column graphs, 346-347
stacking slices, 411
stained glass effects, 276
stamp effects, 275
Star tool, 68
stars, drawing, 68
Start menu, opening documents using, 13
starting Illustrator

in Macintosh, 5
shortcuts, 4–5
Welcome screen, 4
in Windows, 4

status bar, 17
Stop button (Actions panel), 333
stops, adding to actions, 336
stroke

alignment, 130
applying color to, 109, 122, 128
arrowheads, 132-133
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attributes, changing, 130–133
caps or joins, changing, 131
dashed, 132
weight of, changing, 130

styles
font, 218
graphic

applying, 249
breaking links to, 253
creating, 250
deleting, 253
duplicating, 251
editing, 252

grids, 52
guides, 48
type, 230–231

Stylize command (Effect menu), 261
sublayers, 186–187
subscript text, 33
subslices, 407
subtracting panels, 8
summary print options, 369
superscript text, 33
SVG format, 25, 393
Swatches Library

copying swatches between libraries, 114
customized swatch panels, saving, 115
displaying, 114
gradient library, 148

Swatches panel
creating color groups in, 113
deleting colors from, 112
display of, changing, 112
editing or duplicating color in, 113
sorting colors in, 112
swatches, displaying by type, 112
Swatches Library, 114–115

SWF format, Flash, 375, 393
symbols

9-slice scaling, 326-327
creating, 310
deleting, 311
duplicating, 312
editing, 313
links, breaking, 314–315
pixel grid, align, 328
registration point, 329

saving, 311
sets, expanding instances of, 325
Symbol Libraries, 309
Symbol Screener tool, 323
Symbol Scruncher tool, 319
Symbol Shifter tool, 318
Symbol Sizer tool, 320
Symbol Spinner tool, 321
Symbol Sprayer tool, 316
Symbol Strainer tool, 322
Symbol Styler tool, 324
symbolism tool options, setting, 317
Symbols panel, 308

system requirements, 3

T
tab stops, 228
tabbed documents, 18
tabs, 228
Targa format, 375
templates

creating documents from, 30–31
document, 16, 30–31
saving documents as, 389

text
anti-aliasing, 218
case, 355
copying, 214–215
effects, 210
fonts, 218–220
glyphs, 233
hyphenation, 229
importing, 211
kerning, 222
leading, 221
moving, 209, 214–215
outlines, 235
overflow, 216–217
paragraphs, 226–227
preferences, 424–425
rotating, 225
scaling, 224
selecting, 212–213
styles, 230–231
subscript, 33
superscript, 33
tabs, 228
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text (continued)
threads, 216–217
tracking, 223
typing new, 205–206
wrapping, 234

Text Format, 375
Text Wrap command (Objects menu), 234
themes, color, 116–117
threads, text, 216–217
3D effects, 264–265
thumbnail views, 41
TIFF format, 371, 375, 377
Tolerance selection option, 422
tool tips, 421
tools

accessing in Tools panel, 10
accessing multiple, 10
Control panel, 6
moving between, 53
shortcuts to, 11

Tools panel
accessing tools in, 10
contents of, 6

tracing raster graphics, 246–248
tracking type, 223
transformations

applying multiple, 100–101
blends, 144
Distort & Transform command, 100
repeating, 100
Transform Each command, 100

transforming objects, 95–97
Transparency Flattener Presets command

(Edit menu), 367
Transparency grid, 147
transparency settings

blends, 146
colored paper simulation, 33
controlling transparency effects, 146
document creation, 32–33
grid colors, 33
grid size, 32
resolution preset, 33

trim marks, editable, 55
turning on/off smart guides, 50
TXT format, 211

type
anti-aliasing, 218
Area Type tool, 207
copying, 214–215
deleting empty text paths, 214
fonts, 218–220
kerning, 222
leading, 221
moving, 214–215
outlines, 235
overflow, 216–217
paragraphs, 226–227
preferences, 424–425
rotating, 225
scaling, 224
selecting, 212–213
styles, 230–231
threads, 216–217
tracking value, 223
Type on a Path tool, 208
Vertical Area Type tool, 207
Vertical Type on a Path tool, 208
Vertical Type tool, 205
wrapping, 234

Type on a Path tool, 208
Type tool, 204
typographer's quotes, 33
Twirl tool, 306

U
Undo command (Edit menu), 57
undocking

documents, 19
panels, 8

Ungroup command (Objects menu), 86
Units Performance preferences, 426
unsharp mask effects, 271
Updater (Adobe), 21
updates

checking for, 20–21
preferences, 20

Updates command (Help menu), 21
updating, from previous versions, 2
uppercase text, 355
URL links, adding to slices, 413
user interface preferences, 430
user slices, 406
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V
variables, data

creating, 344–345
deleting, 344–345
renaming, 345

vector objects
converting to guide, 49
effects, 267
understanding vector graphics, 62

Vertical Area Type tool, 207
Vertical Type on a Path tool, 208
Vertical Type tool, 205
Video Data tab (File Info dialog box), 370
video safe areas, artboards, 35
View menu commands

Bounding Box, 288–289
Edit View, 38
Fit All In Window, 44
Fit Artboard In Window, 44
Hide Edges, 63
New View, 38
Overprint Preview, 39
Pixel Preview, 39
Preview View, 278
Proof Colors, 126
Proof Setup, 39
Rulers, 46
Show Bounding Box, 95
Show Edges, 63
Show Print Tiling, 38
Show Text Threads, 216
Show Transparency Grid, 147
Smart Guides, 50
Soft Proof, 126

view size, documents, 17
views

box color, 42
changing, with Zoom tool, 44–45
display view, changing, 38–39
document, 38–41
fit in window, 44
Outline, 38–39
Preview, 38–39
ruler options, 46
size, 40
thumbnail, 41

W
Warp tool, 306
WBMP document, optimizing, 405
Web

file formats, 396–397
GIF documents, optimizing, 400–401
images, optimizing to file size, 395
JPEG documents, optimizing, 398–399
PNG-8 document, optimizing, 402–403
PNG-24 document, optimizing, 404
saving documents for, 392–393
saving slices for, 414–415
WBMP document, optimizing, 405

Web-safe color, 111
Welcome screen, 4, 13
Welcome Screen command (Help menu), 13
Window menu

Extensions, 116–117
Flattener Preview, 39
panel display, 7–8

Window menu commands
Flattener Preview, 367
Hide Panels, 18
Separations preview, 39
Show Panels, 18

Windows
Illustrator system requirements, 3
installing Illustrator in, 2
starting Illustrator in, 4

windows
active, 18
document, 18–19

Windows Metafile format, 375
Workspace menu commands, 58
workspaces

creating, 58
deleting, 59
displaying, 58
layouts, 58
naming, 58
renaming, 59

wrapping text, 234
Wrinkle tool, 306

X
X and Y positioning, 35
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XMP format, 370
XMP Software Development Kit, 371

Z
zoom

in/out, 45
using Navigator thumbnail, 41
view size, 40

Zoom tool
changing view with, 44–45
Save For Web & Devices tool, 394
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