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Introduction

Welcome to Microsoft Expression Web 3 On Demand, a 
visual quick reference book that shows you how to work 
efficiently with Expression Web 3.  This book provides com-
plete coverage of basic to advanced Expression Web 3 skills.

How This Book Works
You don’t have to read this book in any particular order.
We’ve designed the book so that you can jump in, get the
information you need, and jump out. However, the book does
follow a logical progression from simple tasks to more com-
plex ones. Each task is presented on no more than two facing
pages, which lets you focus on a single task without having
to turn the page. To find the information that you need, just
look up the task in the table of contents or index, and turn to
the page listed. Read the task introduction, follow the step-
by-step instructions in the left column along with screen illus-
trations in the right column, and you’re done.

What’s New
If you’re searching for what’s new in Expression Web 3, just
look for the icon: New!. The new icon appears in the table of
contents and throughout this book so you can quickly and
easily identify a new or improved feature in Expression Web.
A complete description of each new feature appears in the
New Features guide in the back of this book.

Keyboard Shortcuts
Most menu commands have a keyboard equivalent, such as
Ctrl+P, as a quicker alternative to using the mouse. A com-
plete list of keyboard shortcuts is available in the back of this
book and on the Web at www.perspection.com.

How You’ll Learn

How This Book Works

What’s New

Keyboard Shortcuts

Step-by-Step Instructions

Real World Examples

Workshop

Get More on the Web

Get Updates

Expression Studio

www.perspection.com
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Step-by-Step
Instructions
This book provides concise step-
by-step instructions that show you
“how” to accomplish a task. Each
set of instructions includes illus-
trations that directly correspond to
the easy-to-read steps. Also
included in the text are time-
savers, tables, and sidebars to
help you work more efficiently or
to teach you more in-depth infor-
mation. A “Did You Know?” pro-
vides tips and techniques to help
you work smarter, while a “See
Also” leads you to other parts of
the book containing related infor-
mation about the task. 

Real World Examples
This book uses real world exam-
ples files to give you a context in
which to use the task. By using
the example files, you won’t waste
time looking for or creating sam-
ple files. You get a start file and a
result file, so you can compare
your work. Not every topic needs
an example file, such as changing
options, so we provide a complete
list of the example files used
through out the book. The exam-
ple files that you need for project
tasks along with a complete file
list are available on the Web at
www.perspection.com.

Real world
examples help
you apply what
you’ve learned
to other tasks.

Illustrations
match the
numbered
steps.

Numbered
steps guide
you through
each task.

Did You Know? alerts
you to tips, techniques
and related information.

See Also points you to
related information in
the book.

Easy-to-follow
introductions
focus on a
single concept.

www.perspection.com


Workshops
This book shows you how to put
together the individual step-by-
step tasks into in-depth projects
with the Workshop. You start each
project with a sample file, work
through the steps, and then com-
pare your results with project
results file at the end. The Work-
shop projects and associated files
are available on the Web at
www.perspection.com.

Get More on the Web
In addition to the information in
this book, you can also get more
information on the Web to help
you get up to speed faster with
Expression Web. Some of the
information includes: 

More Content
◆ Photographs. Download

photographs and other
graphics to use in your Web
pages.

◆ More Content. Download new
content developed after
publication.

You can access these additional
resources on the Web at 
www.perspection.com.

The Workshops
walks you through
in-depth projects to
help you put
Expression Web 
to work.

Introduction xvii

Additional content 
is available on the
Web. You can
download
photographs for
your own use.

www.perspection.com
www.perspection.com
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Get Updates
Like any software, it continues to
change and get better with
updates and patches, so it’s
important to regularly check the
Microsoft Expression Web 
site at www.microsoft.com
/expression, and then click 
Expression Web under Products.

Expression Studio
Expression Web is part of the
Microsoft Expression Studio,
which includes Expression Blend
plus SketchFlow, Design, and
Encoder. Expression Blend is a
professional design tool that lets
you create engaging, Web-con-
nected, user experiences for Win-
dows. SketchFlow is a prototyping
tool that makes it easy to sketch
out your user interface. Expres-
sion Design is a professional illus-
tration and graphic design tool
that lets you build compelling ele-
ments for both Web and desktop
application user interfaces.
Expression Encoder is a profes-
sional tool that allows you to pub-
lish videos to Micosoft Silverlight.
See Chapter 16, “Working with
Expression Studio” on page 385
for more information and step-by-
step instructions for using individ-
ual Expression Studio programs.

Check the
Expression Web
onlne site to Get
Updates.

Expression Studio
combines Web
tools to create
an expanded Web
development
environment.

www.microsoft.com/expression
www.microsoft.com/expression


Working with Web Pages

Introduction

Once on the Web, you can open other Web pages in the
Folder List or Folders views, or you can even open up
another page using the Windows menu. Microsoft Expression
Web provides several ways to navigate between pages. After
you open a Web page, you can use the document tabs at the
top of the editing window in Design view, choose the Web
page’s name from the Window menu, or press Ctrl+Tab until
the page you want appears in the window to navigate
between pages. 

One of the most user-friendly components of Expression
Web is its capability to automatically convert text and images
into HTML format. When you save a Web site or Web page, it
is actually being saved in HTML format. After you create a
Web site, you can use the Folder List view to quickly and eas-
ily manage individual Web pages.

When looking at a Web site, there are certain details that
can make your Web pages a site that visitors will return to.
Microsoft Expression Web helps you generate that type of
site.  Visitors might notice a washed out background picture
called a watermark. Or maybe it’s a soothing color or light
sound as you pass over certain feature of the page. Having a
custom feel will express to your visitors that you’ve spent
time and looked at every detail of your site.

You can preview your Web pages in a browser, or in
Design view. Because each browser can display your site dif-
ferently, you will want to examine your site using several of
the most popular browser formats. You can also create your
own template, instead of using one of the built-in page tem-
plates that comes with Expression Web. 3

3
What You’ll Do

Create an HTML Page

Open Web Pages from Within a Web

Navigate Web Pages

Display Web Pages in the HTML Format

Manage Web Pages

Set the Home Page

Change the Web Page Title

Change Web Page Properties

Insert Background Pictures and
Watermarks

Change Background Colors

Add Background Sound

Set Page Size

Preview Web Pages

Print Web Pages

Create a Page Template

Use a Dynamic Page Template

Create a Master and Content Page

Save a Web Page with 
Different Formats

Animate Page Transitions

43
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An HTML page is a common Web page. HTML is a coding language
that describes the elements on a Web page and instructs a Web
browser how to display it. As you add elements to an HTML page in
Design view, Expression Web creates the HTML code behind it. If you
are familiar with the HTML language, you can use the Code view to
make code changes. Split view allows you to display Design and Code
view at the same time, which makes it a beneficial learning tool. When
you add an element in Design view, you can view the related code in
Code view. You can use the New submenu on the File menu or the New
button on the Common toolbar to create a new HTML page. With the
Page Editor Options dialog box, you can set the default type for new
documents and the default file extension—either .html or .htm—for
new HTML documents.

Creating an HTML
Page

Create an HTML Page Quickly

Click the Web Site tab for the site
in which you want a new page. 

Use any of the following methods:

◆ Click the File menu, point to
New, and then click HTML.

◆ Click the New button arrow on
the Common toolbar, and then
click HTML.

◆ Click the New button on the
Common toolbar (applies when
HTML is set as the default
document type).

TIMESAVER Press Ctrl+N to
create a new HTML page.

An untitled Web page appears
without the use of New dialog box. 

Click the Save button on the
Common toolbar, type a name for
the page, and then click Save.

3

2

1
2 New HTML page
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Create an HTML Page

Click the Web Site tab for the site
in which you want a new page. 

Click the New button arrow on the
Common toolbar, and then click
Page.

In the left pane, click General.

Click HTML.

Click OK.

An untitled Web page appears. 

Click the Save button on the
Common toolbar, type a name for
the page, and then click Save.

Set the Default Document Type

Click the Tools menu, and then
click Page Editor Options.

Click the Authoring tab.

Click the Default Document list
arrow, and then select the
document type you want.

Click the .html or .htm option for
the default HTML file extension.

To add a byte order mark (BOM) to
a new UTF-8 document, select the
check boxes next to the
extensions you want, or deselect
the ones you don’t want.

Click OK.6
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Expression Web allows you to multi-task, which means you can have
more than one Web page open at the same time. After you open a Web
site, you can quickly open Web pages in Folders view, or from the
Folder List instead of using the Open button on the Common toolbar or
the Open command on the File menu. If you want to view open Web
pages in a separate Expression Web window, you can display the page,
and then choose Open in New Window from the Window menu. You
can press Alt+Tab to switch between the separate windows. Instead of
starting from scratch to create a new page, you can open a copy of an
existing page with the default new Web page title of Untitled_1.htm.
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Opening Web Pages
from Within a Web

Open a Web Page in Folders
View

Open the Web site with the Web
page you want to open.

Click the Web Site tab.

Click the Folders button.

Double-click the icon or file name
representing the page you want to
access.

4

3

2

1

3

2

4

See Also
See “Opening an Existing Web Page”
on page 13  for information on opening
an external Web page.

Did You Know?
You can open a linked page from
Design view. Press and hold Ctrl and
click a hyperlink in the page, or right-
click a hyperlink in a page that’s
already open, and then click Follow
Hyperlink.
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Open a Web Page Using the
Folder List

Open the Web site with the Web
page you want to open.

If necessary, click the Panels
menu, and then click Folder List to
display the Folder List.

Double-click the page you want to
open.

Open a Copy of a Web Page
Using the Folder List

Open the Web site with the Web
page you want to open.

If necessary, click the Panels
menu, and then click Folder List to
display the Folder List.

Right-click the page you want to
copy, and then click New From
Existing Page.

A new untitled page appears in the
Editing window with content and
formats from the original template
Web page.

Click the Save button on the
Common toolbar.

Navigate to the Web site folder
location where you want to add
pages.

Type a name for the page, or use
the suggested name, and then
click Save.
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Expression Web provides several ways to navigate between pages.
After you open a Web page, you can use the document tabs at the top
of the Editing window, choose the Web page’s name from the Window
menu, or press Ctrl+Tab until the page you want appears in the window
to navigate between pages. 
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Navigating Web 
Pages

Navigate Web Pages Using
Document Tabs

Open the Web site with the Web
page you want to display, and then
open the Web page.

Click the document tab with the
page you want to display.

Navigate Web Pages Using the
Windows Menu

Open the Web site with the Web
page you want to display, and then
open the Web page.

Click the Window menu.

This displays a list of up to nine
open Web pages.

Click the page you want to open.
The Web page opens in Page
view.
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One of the most user-friendly components of Expression Web is its
capability to automatically convert text and images into HTML format. If
you’re familiar with HTML, you might be comfortable enough to work in
this mode. HTML adds a series of format instructions to your content
using tags, such as <i>, that indicate how to format the text for display
on the Web. Use the Quick Tag Selector to select any tag in your Web
page. Use the Quick Tag Editor to insert, wrap, and edit HTML tags.
Expression Web uses colored text to distinguish between elements
when working in HTML format.

Working with Web Pages 49

Displaying Web 
Pages in the HTML
Format

Display a Web Page in HTML

Open the Web page you want to
display in the HTML format.

Click the Split or Code button at
the bottom of the window. 

The Web page appears in HTML
coded form.

Display HTML Tags in 
Design View

Open the Web page you want to
display HTML tags.

Click the View menu‚ and then
click Quick Tag Selector.

HTML tags appear in capsule-size,
six-sided frames within the text.

To turn off HTML tags, click the
View menu‚ and then click Quick
Tag Selector again.

3

2

1

2
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2 Quick Tag Selector1
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After you create a Web site, you can use the Folder List to quickly and
easily manage individual Web pages, files and folders. If a page name
is not exactly what you want, you can quickly rename it. The page
name is the file name in your folder list, such as default.htm. You can
create and name a new folder and move pages to a different location. If
you no longer need or want a Web page, you can remove it. You can
determine whether you want the page deleted from your hard drive or
just from the Web.
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Managing Web Pages

Rename a Web Page

Open the Web site with the Web
page you want to rename.

If necessary, click the Panels
menu, and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to rename, and
then click Rename.

TIMESAVER Click the file
name in the Folder List, click the
file again to highlight it.

Select the name of the Web page
file, except the extension, such as
.htm.

Type a new name, and then press
Enter.

5

4

3

2

1 1

3

2

5Did You Know?
You can delete a Web page. In the
Folder List, right-click the Web page
you want to delete, click Delete, and
then click Yes.
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Create a New Folder

Open the Web site with the Web
page you want to rename.

If necessary, click the Panels
menu, and then click Folder List to
display the Folder List.

Select the folder where you want
to create a new folder.

In the Folder List, right-click a
blank area, point to New, and then
click Folder.

TIMESAVER Click the New
Document button arrow on the
Common toolbar, then click Folder.

Type a new name, and then press
Enter.

Move a Web Page

Open the Web site with the Web
page you want to move.

If necessary, click the Panels
menu, and then click Folder List to
display the Folder List.

In the Folder List, display the page
you want to use.

Drag the page icon to the position
where you want it to occupy on
your site.

4
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Did You Know?
You can delete a folder. In the Folder
List, right-click the folder you want to
delete, click Delete, and then click Yes.

2
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When you create a Web site using a template, Expression Web auto-
matically creates a home page called default.htm or default.html, which
is the first page visitors see when they visit your site. If you already
have a home page or want to create a different one, you can quickly
set the one you want as the new home page using the Folder List.

Setting the Home 
Page

Set a Web Page as the Home
Page

Open the Web site with the Web
page you want to change.

If necessary, click the Panels
menu, and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to set as the new
home page, and then click Set as
Home Page.

Click Yes to confirm you want to
rename the previous home page.

If prompted, click Yes to update
hyperlinks.

If prompted, click Yes to confirm
you want to rename the home
page.

6
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A Web page title is the text that visitors see on the title bar of their Web
browser when they display the Web page. Expression Web automati-
cally sets the Web page title to the same text as the Web page file
name. However, the two perform different tasks. The Web page title
displays a message, while the Web pane name identifies a file. When
you save a Web page, you can change the title. If you didn’t change the
title during the save process or you want to change it, you can use the
Properties dialog box.

Changing the Web
Page Title

Change the Web Page Title

Open the Web site with the Web
page you want to change.

If necessary, click the Panels
menu, and then click Folder List to
display the Folder List.

In the Folder List, right-click the
page you want to change, and
then click Properties.

The Properties dialog box opens,
displaying the General tab with the
current title selected.

Type a new name for the title.

Click OK.5

4

3

2

1
2

3
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5
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Did You Know?
You can change a Web page title in
the Title column. If the Title column in
the Editing window is enabled, you can
select the title text, and then type a
new title.
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Expression Web allows you to change individual Web page properties
using the Page Properties dialog box. You can change the Web page
title, add a page description, and specify keywords for search engines
(which aren’t used to much anymore; most search engines use other
methods). You can also insert a background sound or image, make the
background image a transparent watermark, or change the color. When
you insert a background sound, it plays once when you open the Web
page unless you select the Loop option. In addition, you can change the
color of page text and hyperlinks. For advanced feature, you can set
page margins, work with code snippets, or specify a language.

Changing Web Page
Properties

Change Web Page Properties

Open the Web site with the Web
page you want to change, and
then click the Web page tab.

Click the File menu, and then click
Properties.

Click the tab you want to use, and
then select the options you want:

◆ General. Use this tab to change
the Web page title, add a page
description, specify keywords
for search engines, and insert a
background sound. You can
also specify a base location,
which changes the root
location (where your home
page is typically located). 

◆ Formatting. Use this tab to
insert a background image, and
make it a watermark
(transparent). To delete a
background, select the image
path and delete it. You can also
use this tab to change the
background, text, or link colors
on the current page. If you
insert a background sound, you
can also select the look option.

Continue Next Page

3

2

1
General properties

Add text

Add background
sound

Change colors

Change background

Formatting properties
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◆ Advanced. Use this tab to set
margins for the current page.
However, it’s more efficient to
make margin changes using
CSS.

◆ Custom. Use this tab to add,
modify, or remove custom code
snippets based on system and
user variables. A code snippet
is a reusable segment of code.

◆ Language. Use this tab to
specify the page language and
HTML encoding you want to
use. These options make sure
your Web browser and
Expression Web uses the right
characters set for the selected
language. The default for HTML
encoding is Unicode (UTF-8).
You can also include a byte
order mark (BOM).

Click OK.5

Advanced properties

Set margins

Language properties

Set language and
HTML encoding
options

Select to include a byte order mark (BOM)

See Also
See “Setting Byte Order Marks” on
page 382  for information on byte order
marks (BOM).

Did You Know?
What is a Unicode? A character cod-
ing standard that defines a set of let-
ters, numbers, and symbols that
represent almost all of the written lan-
guages in the world.
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You can use a picture as the background for a page. Pictures can be
taken from elsewhere on your site, a file, clip art, or the Web. You can
also use a background picture in watermark form. A watermark is a
background effect that displays a graphic in a light shade behind your
text on your page. You can use a washed out version of your company
logo, or you can add graphical text such as Under Construction.
Pictures and watermarks display in the background titled across the
page. Be aware that not all Web browsers support watermarks.

Inserting Background
Pictures and
Watermarks

Insert a Background Picture

Open and display the Web page
you want to use. 

Right-click anywhere on the page
to which you want to insert a
background picture, and then click
Page Properties.

Click the Formatting tab.

Select the Background Picture
check box. 

TROUBLE? If the option is
grayed out, you need to open the
master page.

Click Browse.

Locate and select the picture you
want to insert, and then click
Open.

The picture you selected now
opens as a background image.

Click OK.7
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5

4

3

2

1
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5

Did You Know?
You can avoid picture background
tiling. Make your picture wider than
any typical computer screen. You can
use a solid background color or make
it transparent to achieve the look you
want.
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Insert a Background Picture
Watermark

Open and display the Web page
you want to use. 

Right-click anywhere on the page
to which you want to insert a
background picture, and then click
Page Properties.

Click the Formatting tab.

Select the Background Picture
check box. 

Select the Make it a watermark
check box.

Click Browse.

Locate and select the picture you
want to insert, and then click
Open.

The picture you selected now
opens as a background image. 

Click OK.8
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If you’d like to add some interest to your pages, you can add back-
ground colors. When selecting background colors, some creative judg-
ment is required. For example, if you choose a dark color for your
background, make sure you use a light color for your text (the most
commonly used is white) to generate the appropriate contrast required
for easy reading.

Changing Background
Colors

Change the Background Color of
a Web Page

Open and display the Web page
you want to use. 

Right-click the page to which you
want to change a background
color, and then click Page
Properties.

Click the Formatting tab.

Click the Background list arrow.

Click the color you want on the
color palette.

Click OK.6
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You can introduce background sounds to accompany and enhance
your Web page. There’s nothing like hearing a favorite tune when you
enter a site or visit a particular page. The sound can be played continu-
ously in a loop, or you can set it for a desired number of plays. Be
aware that not all browsers support background sound.

Adding Background
Sound

Add a Background Sound to a
Web Page

Open and display the Web page
you want to use. 

Right-click the page to which you
want to add a background sound,
and then click Page Properties.

If necessary, click the General tab.

Type the sound file name or click
Browse, locate and select the
sound file you want to use, and
then click Open.

To set the sound to repeat
continuously, clear the Forever
check box, and then click the
number arrows in the Loop box to
set the number of times you want
the sound to play.

Click OK.

Whenever a visitor opens the
page, they will hear the sound
effect you chose.

6
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Since visitors to your Web site can use different screen resolutions or
window sizes, you need to develop Web pages so a variety of users
can view it without having to zoom in or scroll to much. You can use the
Page Size command to simulate different page size to see how your
pages look. The page sizes available using the Page Size command
correspond to standard screen resolutions, which include 640 x 480,
800 x 600 and 1024 x 768 (all maximized). 

1 2

Setting Page Size

Change the Page Size View

Click the View menu, and then
point to Page Size.

Click the page size you want.

TIMESAVER Click the current
page size on the status bar, and
then click a new size.

Change the Page Size

Click the View menu, point to Page
Size, and then click Modify Page
Sizes.

Perform the commands you want:

◆ Add. Click Add, enter width,
height and a description, and
then click OK.

◆ Modify. Select a page size,
click Modify, make changes,
and then click OK.

◆ Remove. Select a page size,
and then click Remove.

◆ Reset. Click Reset to return to
default page sizes.

Click OK.3

2

1

2

1

3

2



Working with Web Pages 61

With the Snapshot panel (New!), you can preview Web pages for the
different browsers installed on your computer right in Expression Web.
The Snapshot panel provides a quick and easy way to preview Web
pages. The other preview options—Preview in Browser and
SuperPreview—in Expression Web, open another program, so they
take more time to use. However, you get a more accurate preview. You
can use Snapshot panel to display any HTML, PHP, ASP, or ASPX page
that you have opened and selected in Expression Web. In the Snapshot
panel, you can select a browser, the browser window size, and refresh
the screen. The Snapshot panel works like any other panel in
Expression Web. You can move and dock it where ever you want.

Previewing Web
Pages in Snapshot

Preview a Web Page Using the
Snapshot Panel

Open the Web page you want to
preview.

Click the Panels menu, and then
click Snapshot.

A timer progress meter appears as
Expression Web generates the
preview snapshot. 

To change the browser preview,
click the Browser button in the
Snapshot panel, and then select
the browser you want. 

To change browser display size,
click the Browser window size
button in the Snapshot panel, and
then select a window size or
Custom Size.

To refresh the contents of the
Snapshot panel, click the Always
Preview Active Document button
in the Snapshot panel.

When you’re done, click the Close
button in the Snapshot panel.

6
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2 1 Snapshot panel
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Because each browser can display your site differently, you will want
to examine your site using several of the most popular browser formats
and different sizes. When you are ready to see how your page will look
to visitors, click the Preview in Browser button arrow on the Common
toolbar and then select a browser and a window size. When you select
a browser, the program starts and displays your Web page as you
would see it on the Web. If you want to add additional browsers to the
list, you can select them using the Edit Browser List dialog box. You can
also simulate the page size of a browser as you work in Design view by
selecting different page sizes on the Page Sizes submenu on the View
menu.
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Previewing Web
Pages in a Browser

Add Browsers to the Preview 

Click the File menu, point to
Preview in Browser, and then
click Edit Browser List.

Click Add.

Type the browser’s name.

Click Browse.

Navigate to the location where the
browser program is stored, select
it, and then click Open.

Click OK.

To automatically save a Web page
before previewing, select the
Automatically save page before
previewing check box.

To specify the window sizes you
want, select the 640 x 480, 800 x
600, or 1024 x 768 check boxes.

Click OK.9
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Did You Know?
You can preview ASP.NET or PHP Web
pages by using Microsoft Expression
Development Server. Click the Site
menu, click the Preview tab, click Site
Settings, select the Use Microsoft
Expression Development Server check
box, and then click OK.
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Preview a Web Page Using 
a Browser

Open the Web page you want to
preview.

Click the Preview in Browser
button arrow on the Common
toolbar.

Click the browser with the specific
size you want to use to preview
your site or page, or click More
Browsers to select other available
browsers from a list. 

TIMESAVER Press F12 to
preview the Web page in the most
recently used browser and size.

3

2

1

2 3

Click to preview selected
page in multiple browsers

Preview in Internet Explorer

Did You Know?
You need to install other browsers
before you can preview your pages.
You must have previously installed the
full version of other browsers like
Netscape Navigator or Firefox if you
want to preview how your pages will
appear to users of those browsers.

You need to save your pages before
you can preview them. To be sure that
you have saved the page you want to
preview, click the Automatically save
page before previewing check box to
select it in the Edit Browser List dialog
box. Click the File menu, point to
Preview in Browser, and then click Edit
Browser List.

You can change the Web page size in
Design view. Click the View menu,
point to Page Size, and then select the
size you want. If the Design view win-
dow is wider than the width you spec-
ify, gray areas appear on either side. If
Design view is narrower than the width
you specify, you’ll need to scroll the
Design view window right or left. A
dotted line across the page indicates
the bottom of the browser window.

1
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SuperPreview (New!) makes it easy to view and compare a Web page
or sections of a Web page in multiple browsers at the same time.
SuperPreview gives you an array of tools—such as Selection and
Panning Mode pointers, Layout modes (Side-by-side, Stacked, and
Overlay), and Zoom, and Positioning Guides—to test and debug Web
page issues across different browsers. After you compare a page or
sections of a page in specified browsers, you can make adjustments in
Expression Web back in Design view.

Displaying Web Pages
in SuperPreview

Preview Pages in SuperPreview 

Open and display the Web page
you want to preview.

Click the File menu, and then click
Display in SuperPreview.

TIMESAVER Click the Display
in SuperPreview button on the
Common toolbar or press
Shift+F12.

The SuperPreview window opens.

Click a browser icon to select a
browser preview in the Baseline
pane (left side) and Comparison
pane (right side).

Click an element to display the size
and position of the element.

To switch panes, click the Switch
baseline browser location button.

To add another comparison
browser, click the Add button, and
then click a browser icon.

To switch between comparison
browsers, click a browser icon in
the Comparison browser selector.

To view an element in the
Document Object Model (DOM),
click the DOM tab.

To remove a browser, click the
Close button in the browser
selector.

When you’re done, click the Close
button on the program window.
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Work with Web Pages in
SuperPreview

Open and display the Web page
you want to preview.

Click the File menu, and then click
Display in SuperPreview.

The SuperPreview window opens.

Click a pointer mode button.

◆ Selection Mode. Use to select
individual page sections for
comparison.

◆ Panning Mode. Use to drag a
page inside the browser view. 

In Selection Mode, click a high-
lighting mode button.

◆ Box Highlighting Mode.
Highlights the selected element
in blue in the baseline view and
green in the comparison view.

◆ Lights-Out Highlighting Mode.
Displays the selected element
normally, while dimming out
everything else.

To show/hide the ruler, click the
Toggle Ruler Visibility button.

To show/hide guides, click the
Toggle Guide Visibility button.
Drag the horizontal or vertical ruler
onto the page to create a
horizontal or vertical guide.

To show/hide the thumbnail
display, click the Toggle
Thumbnail Visibility button. Drag
the shaded area in the thumbnail
to display a region of the page.

To change the layout, click the
Vertical Split Layout, Horizontal
Split Layout, Overlay Layout, or
Single Layout button.

When you’re done, click the Close
button on the program window.
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Thumbnail

Click to change Zoom view. In Panning Mode,
the mouse wheel changes the zoom.



Printed pages are helpful when you are working in Preview view.
Rather than toggling between a page in progress and a Browser
Preview of that page, for example, you can print the Preview so that
you have it in hard copy format. Printouts are also helpful when editing
your pages. Before printing, you can preview the page to determine
that there are no obvious errors.
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Printing Web Pages

Print Preview Web Pages

Open and display the Web page
you want to preview.

Click the File menu‚ point to Print,
and then click Print Preview. This
opens a scaled-down image of the
page you want to print and a
series of buttons. The button
choices are:

◆ Print button. Engages the
printing process. The preview
closes and the Print dialog box
opens.

◆ Next Page button. Displays the
next page in the sequence for
multiple-page printing.

◆ Previous Page button. Takes
you to the previous page in a
sequence.

◆ Two Page button. Toggles
between a single-page and a
two-page spread in Preview
mode.

◆ Zoom In button. Magnifies the
preview image.

◆ Zoom Out button. Reduces the
size of the characters to show
more of the page preview.

◆ Close button. Closes the
Preview mode.

When you’re done, click the Close
button.
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Print Web Pages

Open and display the Web page
you want to print.

Click the File menu‚ point to Print,
and then click Print.

Select the print options you want.

Click OK.4
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Setting Up the Print Page Format 
When you print a Web page, you can use the Print Page Setup dia-
log box to control the printing of text and graphics on a page. To
open the Print Page Setup dialog box, click the File menu, point to
Print, and then click Page Setup. The Print Page Setup dialog box
allows you to specify page margins and header and footer informa-
tion. In the Headers and Footers text boxes, you can type text to
appear as a header and footer of a Web page you print. In these text
boxes, you can also use variables to substitute information about the
current page, and you can combine text and codes. For example, if
you type Page &p of &P in the Header text box, the current page
number and the total number of pages print at the top of each print-
ed page. Check Expression Web and Internet Explorer Help for a
complete list of header and footer codes.

For Your Information



Instead of using one of the built-in page templates that comes with
Expression Web, you can create your own. There are two kinds of page
templates: static and dynamic. A static template is a Web page you
create and design, which is completely editable. After you save a static
page template, you can access it in the My Templates tab of the Page
Templates dialog box. A dynamic template is a Web page with editable
areas like a static template, yet also contains non-editable areas with
content that changes based on circumstances, such as actions taken
by a user or the date. 
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Creating a Page
Template

Create a Static Template

Design and display the Web page
you want to create into a static
template.

Click the File menu‚ and then click
Save As.

Type a name for the template.

Click the Save as type list arrow,
and then click Page Template
(*.tem).

The folder location changes to the
Pages folder, where Expression
Web stores page templates.

Click Save.

Type the title you want for the
template.

Type a description for the
template.

To save the template in the current
Web site, select the Save
Template in Current Web site
check box.

Click OK.

If prompted, click OK to save
embed files.
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Create a Dynamic Template

Design and display the Web page
you want to create into a dynamic
template. Be sure to leave areas
open to create editable regions.

Click the File menu‚ and then click
Save As.

Type a name for the template.

Click the Save as type list arrow,
and then click Dynamic Web
Template (*.dwt).

The folder location changes to the
Pages folder, where Expression
Web stores page templates.

Click Save.

If prompted, click OK to save
embed files.

Create and Work with Editable
Regions for a Dynamic Template

Display the Dynamic Web
Template you want to change.

Select the page area you want to
vary from page to page.

Click the Format menu‚ point to
Dynamic Web Template, and then
click Manage Editable Regions.

Type a name for the area you
selected.

Click Add.

To rename an editable region.
select the region name, type a
new name, and then click Rename.

To remove an editable region.
select the region name, and then
click Remove.

Click Close.8
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After you create a dynamic Web template, you can apply, or attach, the
template to an open Web page. When you attach a dynamic Web tem-
plate to a Web page, Expression Web tries to map regions on the ordi-
nary Web page to editable regions in the template. If you don’t like the
initial mapping, you can modify or skip it. After you attach a dynamic
Web template to an ordinary Web page, you can modify non-editable
regions in Code view, or any editor other than Design view to create
updatable content.
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Using a Dynamic 
Page Template

Attach a Dynamic Web Template

Display the Web page in which
you want to apply a dynamic page
template.

Click the Format menu‚ point to
Dynamic Web Template, and then
click Attach Dynamic Web
Template.

Locate and select the dynamic
Web template you want to apply.

Click Open.

Select which regions in the new
page will receive content/regions
from the old page.

Click Modify, select a new
mapping, and then click OK.

Click OK to attach the template.

Click Close.8
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Did You Know?
You can manage editable regions.
Click the Format menu, point to
Dynamic Web Template, and then click
Manage Editable Regions.
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Update a Dynamic Web
Template

Open the dynamic Web page
template, and then make the
changes you want to update on
other pages.

Click the Format menu‚ and then
point to Dynamic Web Template.

Click the update command you
want.

◆ Update Selected Page

◆ Update All Pages

◆ Update Attached Pages

3
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Did You Know?
You can detach a Dynamic Web
Template from a Web page. Open and
display the Web page with the
Dynamic Web Template attached, click
the Format menu, point to Dynamic
Web Template, and then click Detach
from Dynamic Web Template. If you
want to open an attached Dynamic
Web Template page, click Open
Attached Dynamic Web Template on
the submenu.
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A Master page is a special type of ASP.NET page that allows you to
share contents, such as graphics, HTML code, and ASP.NET controls,
between pages. Master pages are similar to Dynamic Web Templates
because they share elements between pages. However, Master pages
add the ability to share code. If you have ASP.NET 2.0 available on your
Web server, you can take advantage of Master pages. A Master page
uses content controls instead of editable regions in a Dynamic Web
Template. The content control on the Master page (ContentPlace
Holder) maps to the content control on the Content page (Content).
After you create a Master page using a template in the New dialog box,
you need to save it with the .master file extension. Now, you can create
a Content page and link it to a Master page.

Creating a Master 
and Content Page

Create a Master Web Page

Click the File menu‚ point to New,
and then click Page.

In the left pane, click General or
ASP.NET.

Click Master Page.

Click OK.

An Untitled_1.master page
appears in the Editing window.

Click the File menu‚ and then click
Save As.

Type a name for the master page.

Click the Save as type list arrow,
and then click Master Page
(*.master).

Click Save.8
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Did You Know?
You can manage content regions. Click
the Format menu, point to Master
Pages, and then click Manage Content
Regions.
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Create a Content Web Page

Click the File menu‚ point to New,
and then click Page.

In the left pane, click General or
ASP.NET.

Click Create from Master Page.

Click OK.

Click the Specific Master Page
option.

Click Browse, locate and select
the master page, and then click
Open.

Click OK.

An Untitled_1.aspx content page
appears in the Editing window.

The Content page pulls in the
content from the Master page in
the ControlPlaceHolder control.

Click the File menu‚ and then click
Save As.

Type a name for the content page.

Click the Save as type list arrow,
and then click Web Pages.

In this case, the content page is
saved with the .aspx extension.

Click Save.11
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Did You Know?
You can detach a Master page. Open
and display the Content page, click the
Format menu, point to Master Pages,
and then click Detach from Master
Page. If you want to open an attached
Master page, click Open Attached
Master Page on the submenu.
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A file type specifies the file format (for example, a template) as well as
the program and version in which the file was created (for example,
Expression Web). You might want to change the type if you’re creating
a custom template or sharing files with someone who needs them for
use in another program. You use the Save As dialog box to change the
file type for a page. The Save as type list arrow displays a list of the
available formats for the program or current selection.

Saving a Web Page
with Different Formats

Save a Web Page as a 
Different Type

Open and display the Web page
you want to save in a different
format.

Click the File menu, and then click
Save As.

Navigate to the drive and folder
location where you want to save
the Web page.

Type a name for the page, or use
the suggested name.

Click the Save as type list arrow,
and then click the file type you
want.

Click Save.6
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See Also
See “Expression Web Formats” on
page 75 for information on selecting
the right file format.

Saving Web Related Files

When you use Web related-files, typically scripts, created in other
programs, make changes, and save the Web page or Web site,
Expression Web saves the other Web related-files in their native file
format. Some of the native file formats include ColdFusion Markup
Language (.cfm), PHP Script (.php, .php2,.php3, .php4, .php5, php6),
HTML File with Server Side (.shtm, .shtml, .shm), State Transition
Diagram model file (.stm), Hypertext template (.htt), Hypertext appli-
cation (.hta), HTML Component (.htc), Ascii text file (.asc), and
Microsoft .NET Web Service file (.asmx). The files listed in the Save
File Formats table on the next page are included in this list too.

For Your Information
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Save As file type Extension Used to save

All Files *.* Complete Web site

Web Pages Files in their native format; includes the formats in this 
list and the ones in the side bar on the previous page

HTML Files .htm, .html Web pages as a HTML file

Dynamic Web Template .dwt Web pages as a changeable Expression Web template

ASP and ASPX Files .asp, .aspx Web pages as a Microsoft Active Server Page

Master Page .master Web pages as Expression Web master page file; a 
special type of ASP.NET file

JScript Files .js Scripts as a Microsoft Scripting Language "JScript" file

VBScript Files .vbs Scripts as a Visual Basic for Applications file

PHP Files .php, .php2, .php3, .php4, Web pages as a PHP file
.php5, .php6

CSS Files .css Web pages as a cascading style sheet

XML .xaml, .xml, .xsd,.xsl, .xslt, Web pages as an XML file
.dtd

Text .txt Web pages as a text file

Page Template .tem Web pages as a static Expression Web template
(Save only)

Expression Web Formats

Expression Web Open and Save File Formats

Import file type Extension Used to save

All Files *.* Complete Web site

HTML Files .htm, .html Web pages as a HTML file

GIF and JPEG .gif, .jpg Web pages as a changeable Expression Web template

Microsoft Office Files .doc, .xls, .ppt Web pages as a cascading style sheet

Expression Web Import File Formats



76 Chapter 3

You can use animation in your Web site to provide interest and call
attention to important information. When you move from one Web page
to another, you can display a transition effect between the two pages.
You can select a transition effect, and then specify when the page tran-
sition occurs, and how long it lasts. The only disadvantage of page
transitions is that the browser must wait for the entire Web page to
load before it can apply the transition effect. Be aware that animated
page transitions are not supported by all browsers.

Animating Page
Transitions

Apply a Page Transition

Open and display the Web page
you want to use. 

Click the Format menu, and then
click Page Transition.

Click the Event list arrow, and then
click an event type: Page Enter,
Page Exit, Site Enter, or Site Exit.

Click the transition effect you
want.

Set the duration (in seconds) of
the transition effect.

Click OK.6
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Index

A

About Microsoft Expression Web, 20
absolute positioning, 307

options, 134
accelerator keys to menu, assigning, 368
accessibility information

Accessibility Properties dialog box, 27
checking Web pages for, 345
prompts for, 372

Accessibility Properties dialog box, 27
actions in behaviors, 196
ActiveX controls

running, 167
previewing media, 168-169
setting security options, 166

Adobe
Acrobat files, hyperlinks to, 177
Flash

checking for, 206
inserting movies, 154-155
playing movies, 168-169
setting properties, 156-157

Shockwave, checking for, 206
advanced buttons in forms, 263, 272-273
AIFF sounds, playing, 212
alignment. See also tables

of graphics, 138-139
for inline frames, 251
of interactive buttons, 192
of layout tables, 215
line alignment, changing, 91
of text, 88

animating page transitions, 76
antonyms, finding, 113
Apple QuickTime (MOV)

ActiveX controls, setting security
options, 166

checking for, 206
overview, 153
previewing, 168-169

Apple Safari
work with Silverlight, 162

Application Options dialog box, 371
Apply Styles panel, 8, 289, 297
artboard

in Expression Design, 387
in Expression Blend, 394

ASP (Active Server Pages), 219, 337. See
also ASP.NET

database, saving form results to, 282
as form handler, 280

ASP.NET. See also Master page
overview, 315, 316
controls, 317-321

AJAX, 317, 320
custom, 321

creating Web pages in, 316
customizing options, 371
hyperlink parameters, adding, 175
login, adding, 317
options, customizing, 371
preview pages, with Expression

Development Server, 360-361
saving Web pages in, 75
validation, for forms, 317
WebParts, adding, 317

ASPX format, 37
saving Web pages in, 75

attachments
dynamic templates, attaching, 70
Master page, attaching, 72

attributes of HTML tags, 288, 294
audio. See sounds
AutoHide panels, 8
Auto Thumbnail button, 130-131
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AutoFit To Contents command, 229
AutoFormat for tables, 239
Auto Indent, 373
Auto-Scale of cells, 215
autostretching layout tables, 218

B

backgrounds. See also tables
changing colors, 58
deleting images, 54
inserting images, 54, 56
for interactive buttons, 193
sounds, inserting, 54, 59

Backspace key, 80
Banner and Contents template, 245-246
base location, specifying, 54
behaviors, 191

Call Script behavior, 211
Change Property behavior, 208-209
Check Browser behavior, 206
deleting, 198
elements, adding to, 197
Go To URL behavior, 199
Jump Menu behavior, 200-201
modifying, 198
Open Browser behavior, 210
order of behavior, changing, 197
paragraph, adding to text in, 197
Play Sound behavior, 212
Popup Message behavior, 202
Preload Images behavior, 204
Set Text behavior, 202
Swap Images behavior, 204-205
viewing, 196

Behaviors panel, 191
Besides New Window target hyperlink, 179
bevels to graphics, adding, 144
Blink effect, 100
BMP files, 118
boilerplate text, 78
boldfacing

text, 98
updates tags for, 372

Bookmark dialog box, 172
bookmarks

creating, 172

deleting, 172-173
hyperlinks, creating, 174
navigating to, 172-173

borders, 243. See also frames pages; tables
Change Property behavior, 208-209
for inline frames, 251

Borders and Shading dialog box, 146-147
padding for graphics, setting, 145

Borders button, 146-147
brightness of graphic, adjusting, 140
Bring Forward/Send Backward, 135
browsers. See also hyperlinks

colors, safe, 378
frames, resizing, 250
low resolution graphics, support for, 

150-151
Open Browser behavior, 210
previewing Web pages in, 62-63
symbols, support for, 89
version, checking, 206
watermarks, support for, 56

built-in styles, 95
bulleted/numbered lists

adding items to, 92
creating, 92
custom bullets, inserting, 93
format, changing, 92

buttons. See also interactive buttons; tool-
bars

forms, inserting in, 272-273
Menu bar, assigning to, 368

Byte Order Mark (BOM)
adding/removing, 382-383

C

Call Script behavior, 211
camera, inserting graphics from, 124
Capitalize effect, 100
captions. See tables
Cell Properties dialog box, 236-237, 242
cells. See layout tables; tables
centering

table cell contents, 233
text, 88

CGI script as form handler, 280
Change Property behavior, 208-209



Index 413

Change Property Restore behavior, 208-209
characters

spacing, changing, 86
special characters, inserting, 89

check boxes in forms, 263, 271
Check Browser behavior, 206
Check for Updates command, 20
Check Plug-In behavior, 206-207
check-in/check-out, documents

removed from product, 403
Citation effect, 100
class-based styles, 300

creating, 301
clearing properties, 307
clip art, inserting, 148
Clipboard for moving/copying text, 84-85
closing

panels, 9
Web pages, 21

code. See also code snippets; HTML
(Hypertext Markup Language)

default font, 380
finding/replacing, 102-103
fixed-width fonts for, 114
formatting options, 374-375

Code effect, 100
code snippets, 288

changing options, 376
editing, 55
List Code Snippets command, 298
reusing, 376

Code view, 4, 14-15, 16
dynamic template regions, editing, 70
for HTML code, 44-45, 288

colors. See also backgrounds; fonts; 
graphics; tables

browser safe colors, 378
custom colors, creating, 378-379
defining custom palette, 378
deleting custom colors, 379
hyperlink colors, changing, 180-181
for interactive buttons, 192-193
line color, changing, 91
more colors, adding, 101
of table borders, 235

color scheme
changing, user interface, 5

columns and rows. See also tables

frames into columns or rows, 
splitting, 257

commands. See also toolbars
in Help Menu, 20

Common toolbar, 6
community information, 20
compatibility

checking Web page compatibility, 
346-347

highlighting incompatible HTML, 373
viewing the Compatibility panel, 347

Compatibility panel, 346-347
Complete Word command, 298
CompuServe's Graphics Interchange, 118
confirmation page, custom, 277
contact information forms, 259
Contact Us information, 20
containers

paragraph containers, 82
text containers, 78

Content page, creating, 72-73
Contents template, 245-246
contrast of graphic, adjusting, 140
conventional tables. See tables
copying

exporting Web content by, 84
files, 12
graphics from Web, 125
interactive buttons, 194
reports, 342-343
styles, 303
template pages for new Web page, 29
text, 84-85
in Web page, 11

Crop button, 132
cropping graphics, 132
CSS (Cascading Style Sheets), 24, 77, 287,

289. See also external style sheets;
IntelliSense

adding pages to Web site with, 37
Code Formatting options, 374-375
embedded CSS, creating, 95
error-checking, 312-313
ID styles for layout, creating, 310-311
layouts, 289, 308

scratch, creating from page from, 310-
311

template, creating page from, 308-309
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CSS (continued)
moving internal styles to external style

sheets, 305
options, setting, 314
overflow property, 294
pages, creating, 308
saving CSS files, 75
tools, 289, 297
usage problems, checking for, 312-313

CSS Properties panel, 289, 297
CSS Reports, 312-313
Custom Dictionaries dialog box, 108
customizing, 365. See also macros

ASP options, 371
bullets, 93
confirmation pages, 277
frames page template, 246
FTP transfer options, 371
general options, 366-367
Reports view, 370
startup options, 368

D

data formatting. See formatting
data view. See XML
databases

form results to database, saving, 282-283
updating, 283
Web sites, configuring connections for,

360-361
Deep Zoom Composer

download, 399
images,

creating, 400
inserting in Web pages, 165

starting, 399
default.htm, 26

setting Web page as, 52
Definition effect, 100
definition list, creating, 96-97
Delete key, 80
deleting. See also toolbars

backgrounds, 54
behaviors, 198
bookmarks, 172-173
bullets/numbers from lists, 92
colors, custom, 379

files, 12
forms or form fields, 261
frames, 256
hidden data for Web site, 41
hotspots, 186
layers, 136
properties, 209
spell-checking symbols, 112
styles, 95, 303
table elements, 232
template pages, 28
Web pages, 50
Web sites, 41

Design mode, 4
Design view, 14-15, 16

default text, changing, 114
formatting options, setting, 377
grid, working with, 306
HTML

pages, displaying, 44-45
tags, displaying, 49

linked Web pages, opening, 46
optimizing published HTML code in, 349
rulers, working with, 306, 381
size of Web page, changing, 63

dialog boxes, help in, 19
dictionaries. See spell-checking
digital camera, inserting graphics from, 124
disabled users. See also accessibility

information
visually impaired persons, alternative

text for, 121
discussion form handler, creating, 281
disk-based sites, 24-25

for empty Web site, 31
Distribute Columns Evenly command, 229
Distribute Rows Evenly command, 229
DOC files

hyperlinks to, 177
inserting text from, 115

docking toolbars, 6-7
doctype declarations, 346
document check-in/check-out

removed from product, 403
document tabs, navigating with, 48
double-spacing text, 86-87
downloading. See also updates

Slow Pages report, 370
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drag-and-drop
text, moving/copying, 84

Draw Layout Cell button, 218
drop-down boxes in forms, 263, 268
.dwt files, 26
dynamic templates

attaching, 70
creating, 68-69
detaching, 71
editable regions

creating, 69, 70
removing, 69
renaming, 69

saving, 75
updating, 71

Dynamic Web Template, 37

E

Edit Browser List dialog box, 62-63
Edit Hyperlinks dialog box, 190
Edit Tag command, 296
editing

frames pages, 255
graphics, 127
horizontal lines, 90-91
hotspots, 186
hyperlinks, 180-181
interactive buttons, 194-195
styles, 303
target frames, 254
text, 80

Editing window, 10
editors. See also Quick Tag Editor

configuring external editors, 369
effects

bevels to graphics, adding, 144
font effects, adding, 100

e-mail
form results, sending, 278-279
hyperlinks to addresses, 178

embedded style sheets, 289
embedding Windows media, 158-159
Emphasis effect, 100
empty Web site, creating, 30-31
encoding videos, Silverlight, 164
error-checking CSS, 312-313

events
in behaviors, 196
in HTML code, 288

exclusion dictionaries, 108-109
existing Web site, opening, 32-33
exiting Expression Web, 22
Export Web Package dialog box, 38
exporting. See importing/exporting
Expression Blend, 1, 3, 162, 385

artboard, 394
interactivity, adding, 398
project, 394
XAML, creating, 394
work in, 396-397

Expression Design, 1, 3, 385
new document, 387
open graphic, 387

format types, 387
overview, 386
work in, 388-389

Expression Development Server
enabling, for PHP and ASP.NET, 360-361
previewing, 62

Expression Encoder, 1, 3, 162, 385
encode jobs, 392-393
overview, 390-391
profiles, 392-393
work in, 390-391, 392-393

Expression Encoder Screen Capture, 3, 393
Expression Web SuperPreview, 3

displaying Web pages, 64-65
Extending Expression Web, 20
Expression Studio, 1, 3, 385
external style sheets, 289

attaching to Web page, 304-305
creating, 304

Eye icon, 136-137

F

feedback forms, 259
fields. See forms
File command, 115
file formats. See also specific types

different format, saving Web page in, 74
supported formats, list of, 75
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files. See file formats; folders and files
Fill Color button, 240
Fill Down command, 225
Fill Right command, 225
Find and Replace dialog box, 102-105
Find panel, 102-105
finding/replacing

code, 102-103
HTML tags, 104-105
query, saving search as, 105
text, 102-103

Firefox, Mozilla
version checking, 206
work with Silverlight, 162

fixed positioning, 307
fixed-width fonts, 114, 380
Flash. See Adobe
flipping graphics, 133
floating properties, 307
Folder list, 10. See also importing/exporting

graphics, inserting, 120-121
opening Web page with, 47
publishing individual files in, 359

Folder List panel, 8
folders and files, 10. See also file formats;

forms; templates; 
copying files, 12
deleting files, 12
deleting folder, 51
determining contents of, 10
graphics from files, inserting, 120
hidden files, tracking, 24
hyperlinks to files, creating, 176-177
importing Web content from, 34
metadata, tracking with, 24
moving files, 12
new folders, creating, 51
renaming

files, 12
Web folder, 40

text from file, inserting, 115
Folders view, 14

opening Web pages in, 46
publishing individual files in, 359

Font dialog box, 99
fonts

Change Property behavior, 208
changing, 98-99

colors
more colors, adding, 101
selecting, 98

default fonts, changing, 114, 380
effects, adding, 100
for interactive buttons, 192
for Jump Menu, 201
size, changing, 98-99

Footer template, 245-246
footers. See headers and footers
Footnotes template, 245-246
Form Controls, 260
form handlers

overview, 284-285
saving results to, 280-281

formatting. See also CSS (Cascading Style
Sheets)

bulleted/numbered lists, 92
graphics formats, changing, 148-149
setting Design View options, 377
showing/hiding marks, 82
tables, 238-239
text, 98-99
Web page formatting, setting, 54
XML formatting, applying, 334-335

forms, 259. See also registration forms
advanced buttons in forms, 263, 272-273
buttons, inserting, 272-273
check boxes in, 263, 271
confirmation page, custom, 277
creating, 260-261
custom form handler, results to, 280-281
customizing options, 372
database, saving results to, 282-283
deleting forms or fields, 261
discussion form handler, creating, 281
drop-down boxes in, 263, 268
e-mail, sending results as, 278-279
fields

deleting, 261
file upload fields, inserting, 275
understanding, 263

files
saving form results to, 276
upload fields, inserting, 275

form handlers, saving results to, 280-281
group boxes for, 263, 269
labels for, 263, 255a
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list of element types, 263
naming, 262
picture buttons, inserting, 263, 274
properties

setting, 262
text properties, changing, 267

push buttons in, 272
radio buttons in, 263, 270
Reset buttons in, 263, 272
saving

custom form handler, results to, 280-
281

database, results to, 282-283
file, saving results to, 276

Submit buttons in, 263, 272
tab order, setting, 264
tables, inserting, 261
text boxes/areas, inserting, 263, 266-267
types of, 259

Frame Properties dialog box, 250
frames, 243. See also frames pages; inline

frames
columns or rows, splitting into, 257
content, adding, 248
deleting, 256
hidden frame borders, 258
initial page display, 250
inline frames, inserting, 247
margins, setting, 250
New Page option, 248-249
properties, changing, 250-251
resizeable frames, creating, 250
resizing, 249
scrollbars, 250

for inline frames, 251
showing/hiding, 255

Set Initial Page option, 248
showing/hiding

borders, 258
scrollbars, 258

size, setting, 250
splitting, 257
target frames, creating, 254

frames pages
creating with templates, 245
customizing templates, 246
editing, 255
reselecting, 253

saving, 252-253
showing/hiding borders, 258
titles, modifying, 253
viewing, 244

framesets, 252-253
FrontPage Extensions

database, saving form results to, 282-283
form handlers requiring, 280
form results as e-mail, sending, 278-279
form results to file, saving, 276
as remote server, 356
WebDAV, 34

FTP (File Transfer Protocol), 24-25
customizing transfer options, 371
for empty Web site, 31
as remote server, 356

G

GIF format, 118. See also graphics
bullets, customizing, 93
for transparent graphics, 142
importing, 34-35

Go To URL behavior, 199
grammar-checking, 112
graphics, 117-118. See also hotspots;

thumbnails; transparent graphics
aligning, 138-139
bevels, adding, 144
borders, adding, 144, 146-147
brightness, adjusting, 140
camera, inserting graphics from, 124
contrast, adjusting, 140
copying graphics from Web, 125
cropping, 132
defaults, changing, 119
directly resizing, 128
display, changing, 150-151
files, inserting from, 120
flipping, 133
Folder list, inserting from, 120-121
formats, changing, 148-149
forms, picture buttons in, 263, 274
Graphics Editor Program, 

configuring, 150
grayscale, converting to, 142
hyperlinks, adding, 182-183
layers, working with, 136-137
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graphics (continued)
low resolution graphics, creating, 

150-151
margins, adding, 145
moving, 126
numerically resizing, 129
pasting graphics from Web, 125
Pictures toolbar, modifying with, 127
Photoshop files, inserting, 122-123
positioning, changing, 134
resampling, 128-129
resizing, 128-129
restoring, 152
rotating, 133
scanner, inserting graphics from, 124
selecting, 126
shading, adding, 146-147
stacking order, changing, 135
tables, adding to, 242
tracing, 121
vertical alignment of, 138-139
washing out color in, 141
Web page save, changing format 

during, 149
wrapping text around, 138

Graphics Editor Program, configuring, 150
grayscale, converting graphic to, 142
Greek, setting keyboard for, 110
grid, working with, 306
group boxes in forms, 263, 269
guest book forms, 259

H

Header template, 245-246
headers and footers

Microsoft Excel data, tables created
from, 219

Print Page Setup dialog box, 
setting in, 67

tag-based styles for, 300
headings

centered text for, 88
creating, 96

Hebrew, setting keyboard for, 110
height. See also tables

layout tables, 215, 218

of lines, 91
help

dialog box, help in, 19
Help Viewer, 18-19
searching for, 19

Help menu, 18-19
commands in, 20

Help Viewer, 18-19
hiding. See showing/hiding
Highlight Hotspots button, 186
highlighting

HTML code, invalid/incompatible, 373
text, 98

home page, setting, 52
horizontal alignment options, 138
horizontal lines, inserting, 90-91
Hot Java version, checking, 206
hotspots

adding to graphics, 184
edges, showing, 186
editing, 186
text-based hotspots, adding, 184-185

hover image for interactive buttons, 193
HSL (hue, saturation, luminosity) 

colors, 379
HTML (Hypertext Markup Language), 37,

288. See also bookmarks; code snip-
pets; CSS (Cascading Style Sheets);
Master page; Quick Tag Editor; Quick
Tag selector; tag-based styles

attributes of HTML tags, 288, 294
Code view displaying, 16
compatibility, checking for, 346-347
for CSS pages, 308
displaying Web pages in, 49
finding/replacing tags, 104-105
form results, saving, 276
importing, 34-35
inserting

common tags, 290-291
tags, 292
text from HTML code, 115

invalid/incompatible HTML, 
highlighting, 373

language of page, specifying, 55
optimizing published HTML code, 

348-349
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pages, creating, 44-45
properties of tags, showing, 292
Quick Tag Selector/Quick Tag Editor, 288
saving files, 75
tabs, support for, 224
tag tools, using, 292-293
text, tags for, 78
working with, 288

HTTP (Hyper-Text Transfer Protocol). 
See also HTTP sites

Internet URLs including, 33
HTTP sites, 24-25

for empty Web site, 31
HTTPS sites, 24-25
hue of color, 379
hyperlinks. See also hotspots

to Adobe Acrobat files, 177
to bookmarks, 174
colors, changing, 180-181
deleting, 180
editing, 180-181
to e-mail addresses, 178
to files, 176-177
graphics, adding to, 182-183
for interactive buttons, 192-193
for new internal page, 182-183
to non-available Web pages, 174-175
Open Browser behavior, 210
parameters, adding, 175
recalculating hyperlinks, 189
repairing broken links, 190
ScreenTips, adding, 187
single hyperlink, verifying, 189
tag-based styles for, 300
to target frames, 179
verifying, 189
to Web pages, 176

Hyperlinks view, 14-15, 188

I

IDs
CSS layout, styles for, 310-311
layers, value for, 136
for tables, 372

image maps for hotspots, 184
images. See graphics

importing/exporting
copy and paste, exporting with, 84
folders and files, importing content

from, 34
Photoshop files, 122-123
Web content, exporting, 84-85
Web site, importing content from, 34-35

Microsoft Office Files (DOC, XLS,
PPT), GIF, JPEG, HTM, and HTML,
34-35

indenting
with Auto Indent, 373
paragraph indentation, changing, 86-87

inherit positioning, 307
inline frames

inserting, 247
properties, changing, 251

inline styles, 289
creating, 302

input elements in forms, 263
Insert HTML command, 296
Insert Table dialog box, 220
insertion point, 11
Install Now option, 3
installing

browsers, 63
Expression Web, 3
.NET Framework 2.0, 2

IntelliSense, 288
options, setting, 299

PHP for, 324-335
using, 298

interactive buttons, 191
copying, 194
creating, 192-193
editing, 194-195

interlaced graphics, 119
internal style sheets, 289
Internet Explorer 

version, checking, 206
work with Silverlight, 162

Internet Information Services (IIS), 219
Internet URLs, 33
ISAPI as form handler, 280
italicizing

text, 98
updates tags for, 372
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J

JavaScript, 37
Call Script behavior with, 211
saving files, 75

job
in Expression Encoder, 392-393

JPEG format, 118. See also graphics
bullets, customizing, 93
importing, 34-35

Jump Menu behavior, 200-201
style, changing, 201

Jump Menu Go behavior, 200-201
justified text, 88

K

Keyboard effect, 100
keyboards

languages, switching for, 372
layout, specifying, 110

keywords, specifying, 54

L

labels for forms, 263, 255a
languages

keyboards, automatic switching of, 372
spell-checking, 110-111
for Web site, 55, 360-361

layers, creating, 137
Layers panel, 136-137
layout tables

creating, 214-215
drawing tables and cells, 216-217
height, 215, 218
modifying, 218
moving, 216-217
properties, changing, 215
resizing, 215-217

layouts. See CSS (Cascading Style Sheets)
left-aligning

table cell contents, 233
text, 88

lines
breaks, inserting, 82-83
horizontal lines, inserting, 90-91
marks, showing/hiding, 82

numbers, displaying, 373
spacing, changing, 86-87

links, 171. See also hyperlinks
Web pages, opening, 46

List Members command, 298
lists. See also bulleted/numbered lists

definition list, creating, 96-97
sublists, creating, 94

log on forms, 259
logos as watermark, 56
Loop option, 55
low resolution graphics, creating, 150-151
luminosity of color, 379

M

Managed Sites list
adding to, 42
creating site, adding to, 25, 30-31
opening site, adding to, 32-33
removing from, 42

Manage Styles panel, 200, 289, 297
tag-based styles in, 300

margins
current page margins, setting, 55
frame margins, setting, 250
graphics, adding to, 145
for inline frames, 251
in layout tables, 215
left margin, adding, 373
Print Page Setup dialog box, 

setting in, 67
viewing and changing, 17

Margins and Padding command, 17
Master page

creating, 72
detaching, 73
format, 37
saving, 75

master.dwt, 26
mathematical symbols, inserting, 89
menus

accelerator key, assigning, 368
commands, executing, 7
Jump Menu behavior, adding, 200-201

merging cells in tables, 230-231
metadata, 24

configuring use of, 360
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Microsoft Access, saving form 
results to, 282

Microsoft Excel data, tables from, 219
Microsoft Expression Blend. See Expression

Blend
Microsoft Expression Design. See

Expression Design
MIcrosoft Expression Development Server.

See Expression Development Server
Microsoft Expression Encoder. See

Expression Encoder
Microsoft Expression Encoder Screen

Capture. See Expression Encoder
Screen Capture

Microsoft Expression Web SuperPreview.
See Expression Web SuperPrivew and
SuperPreview

Microsoft Silverlight. See Silverlight
Microsoft Expression Web Online, 20
Microsoft Expression Web Setup Wizard, 3
Microsoft FrontPage. See also FrontPage

Extensions
importing page from, 34

Microsoft Office Files (DOC, XLS, PPT),
importing, 34-35

Microsoft Visual Basic, 398
Microsoft Windows Media Player, 206
Microsoft Windows (XP, Vista, and 7) system 

requirements, 2
MIDI, Play Sound behavior with, 212
More Colors option, 101
MOV. See Apple QuickTime
moving

external style sheets, internal 
styles to, 305

files, 12
graphics, 126
hotspots, 186
layout tables, 216-217
text, 84-85
toolbars, 6-7
in Web pages, 11, 51

Mozilla 5.0 version, checking, 206
MPEG (Motion Picture Experts Group), 153

ActiveX controls, setting security
options, 166

previewing, 168-169
multimedia, 153 See also sounds

ActiveX Controls
options, setting, 166

running, 167
inserting

Flash, 154-155
Silverlight media, 163
Windows Media, 158-159

playing, 168-169
previewing, 169-170

multiple remote Web sites, 354
My Templates tab, 68

N

naming/renaming
bookmarks, 172
class-based styles, 301
files, 12
forms, 262
frames for hyperlinks, 250
inline frame hyperlinks, 251
UNC (Universal Naming Conventions),

363
Web site, renaming, 40, 360

navigating
to bookmarks, 172-173
in tables, 222
Web pages, 48

.NET Framework, installing, 2
Netscape Navigator version, checking, 206
New command, 11
New dialog box

adding pages to Web site, 36-37
for one page blank Web site, 30
templates in, 245
Web Site tab, 25

New Document button, 11
New Document dialog box

in Expression Design, 387
new folders, creating, 50
New Style button, 300
NSAPI as form handler, 280
numbered lists. See bulleted/numbered

lists
numerically resizing graphics, 129

O

objects. See graphics
ODBC-compliant database, saving form

results to, 282
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one page site, creating, 30
one-celled table, creating, 224
Open Browser behavior, 210
opening

existing Web pages/Web sites, 13, 32-33
Find and Replace dialog box, 104
folders and files, 10
panels, 9
Pictures toolbar, 139
supported formats, list of, 75
template pages, 26

Opera version, checking, 206
optimizing published HTML code, 348-349
order forms, 259
Overline effect, 100

P

padding. See also tables
graphics, adding to, 145
viewing and changing, 17

Page Default target hyperlink, 179
page descriptions, adding, 54
Page Editor Options dialog box, 119

code formatting options, 374-375
code snippet options, changing, 376
compatibility, checking, 346
CSS options, setting, 314
customizing with, 372-373
default text, changing, 114
IntelliSense in, 298

page numbers, adding, 67
Page Options dialog box

grid options, 306, 381
ruler options, 306, 381

Page Properties dialog box, 54-55
Page Size command, 60-61
Page view, opening Web page in, 13
panels

AutoHide, 8
contents, displaying, 9
opening/closing, 9
rearranging, 9

paragraphs
behaviors to text, adding, 197
breaks, inserting, 83
containers, 82

indentation, changing, 86-87
marks, showing/hiding, 82
Paste Text options, 85
tag-based styles for, 300

Parameter Info command, 298
Parent Frame target hyperlink, 179
passwords for forms, 263
pasteboard

in Expression Design, 387
Paste command, 84-85
Paste Text command, 84-85

options, 85
pasting

exporting Web content by, 84
graphics from Web, 125
ID duplicates, eliminating, 372
text, 84-85

PDAs (personal data assistants). See CSS
(Cascading Style Sheets)

PDF files, hyperlinks to, 177
Photoshop PSD files

inserting, 122-123
editing, 122-123

PHP
create, page, 323
IntelliSense, for PHP, 325
code

overview, 322
example, 322
insert script, 326-327
work with, 324

options, setting for Web sites, 360-361
preview pages, with Expression

Development Server, 360-361
PHP hyperlink parameters, adding, 175
Picture Actions button, 128
Picture dialog box for thumbnails, 121
pictures

background, using as, 56
bullets, using as, 93
forms, picture buttons in, 263, 274
tables, adding to, 242

Pictures toolbar. See also graphics
Bring Forward/Send Backward 

buttons, 135
Crop button, 132
graphics, modifying, 127
opening, 139
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pixels
in Expression Design, 386

plain text option, 85
Play Sound behavior, 212
plug-ins

changing properties, 384
checking for, 206-207

PNG files, 118
Popup Message behavior, 202
Position Absolutely button, 134
Position dialog box, 135
positioning. See also absolute positioning

graphics, 134
properties, 307
table captions, 227

preloading images, 204
button images, 193

pressed image for interactive button, 193
Preview in Browser button, 62
previewing

in browsers, 62-63
printed Web pages, 66-67
Web sites, 360

Print Page Setup dialog box, 67
Print Preview, 66-67
printing Web pages, 66-67
printouts, previewing, 66-67
privacy information, obtaining, 20
profiles

in Expression Encoder, 392-393
progressive passes graphics, 119
project

in Expression Blend, 394
properties. See also forms; tables

adding, 209
Change Property behavior, 208-209
clearing properties, 307
deleting, 209
floating properties, 307
frame properties, changing, 250-251
inline frame properties, changing, 251
layout table properties, changing, 215
modifying, 209
publishing properties, changing, 365

Properties dialog box, 53, 54
proportional fonts, 114, 380
Publishing view, 14, 352-353, 356-357

files, displaying, 359
Publishing Status panel, 362
publishing Web sites, 339

destination, entering, 352-353, 356-357
entire site, publishing, 358
"Excluding from Publishing" publish

pages, marking, 344
individual pages, publishing, 359
optimizing published HTML code, 

348-349
properties, changing, 355
settings changing, 360-361
UNC (Universal Naming Conventions)

and, 352-353
updating Web sites, 360-361
working on, 352-353, 356-357

push buttons in forms, 272

Q

quality graphics, 119
query, saving search as, 105
query strings, 175
Quick Tag Editor, 49, 288

using, 296
Quick Tag Selector, 49, 288

using, 295
QuickTime (MOV), Apple

ActiveX controls, setting security
options, 166

R

radio buttons in forms, 263, 270
Real Audio, 212
RealNetworks, 206
RealPlayer, 206
RealVideo (RAM), 153, 168
recalculating hyperlinks, 189
redoing typing, 81
REG (red, green, blue) colors, 378
registration forms, 259

form handlers, creating, 281
relative positioning, 307
remote servers, connecting to, 352-353,

356-357
renaming. See naming/renaming
repairing hyperlinks, 190
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replacing. See finding/replacing
reports

saving or copying, 342-343
Web site reports, 340-341

Reports view, 14-15
customizing, 370
hyperlinks, verifying, 189

request forms, 259
Resample button, 128
resampling graphics, 128-129
Reset buttons in forms, 263, 272
Reset Workspace Layout option, 9
resizing. See also tables

frames, 249
graphics, 128-129
hotspots, 186
layout tables and cells, 215-217
positioning layer, 135
toolbars, 6-7
Web pages, 60-61, 63

Restore button, 152
restoring

with Change Property Restore behavior,
208-209

graphics, 152
with Swap Image Restore behavior, 

204-205
right-aligning

table cell contents, 233
text, 88

rotating graphics, 133
RSS feed. See XML
RTF files, inserting text from, 115
rulers, working with, 306, 381

S

Same Frame target hyperlink, 179
Sample effect, 100
saturation of color, 379
Save All command, 39
Save As dialog box, 12

file type, changing, 74
Save As Type list arrow, 74
Save Embedded Files dialog 

box, 39, 119, 127
formats, changing, 148

saving
different formats, Web pages in, 74
frames pages, 252-253
framesets, 253
list of formats, 75
and previewing, 63
reports, 342-343
Web pages, 12
Web sites, 39

scanner, inserting graphics from, 124
ScreenTips

hyperlinks, adding to, 187
tag attributes for, 294

scripts
Call Script behavior, 211
executing, 211
Web site script language, 360-361

scrollbars. See frames
search forms, 259
searching. See also finding/replacing

for help, 19
Section 508 accessibility requirements, 345
Select File dialog box, 115
selecting

graphics, 126
table elements, 223
text, 79

Selector, 289, 300
Send Backward/Bring Forward, 135
servers

opening Web site from, 33
remote server, connecting to, 352-353,

356-357
Set Text behavior, 202
Set Text of Frame behavior, 202
Set Text of Layer behavior, 202
Set Text of Status Bar behavior, 202-203
Set Text of Text Field behavior, 202
shading

for graphics, 146-147
for lines, 91

Show Tag Properties button, 294
showing/hiding. See also toolbars

line marks, 82
paragraph marks, 82
scrollbars, 255
Status bar, 366-367
visual aids, 17
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sight impaired persons, alternative 
text for, 121

Silverlight
creating

in Expression Blend, 394
in Expression Encoder, 390-391, 

392-393
encoding videos, 164
inserting, 163
overview, 162, 385

Site Settings dialog box, 360
size. See also resizing

font size, 98-99
frame size, setting, 250
of Web page, 60-61, 63

Sketchflow, 1
Slow Pages report, 370
Snap to Grid, 306
Snapshot panel, 61
snippets. See code snippets
solid lines, creating, 91
sorting in Web site reports, 341
sounds

background sounds, inserting, 54, 59
Play Sound behavior, 212

source control, 363
spacing. See also tables

character spacing, changing, 86
double-spacing text, 86-87
line spacing, changing, 86-87

span of cell, changing, 237
spell-checking

as you type, 112
custom dictionaries, using, 108
default spelling language, setting, 111
exclusion dictionaries, 108-109
languages, setting, 110-111
symbols, deleting, 112
Web pages, 106
Web sites, 106-107

Split view, 4, 14-15, 16
HTML

code, viewing, 288
pages in, 44-45

splitting
cells in tables, 230
frames, 257

SSL (Secure Sockets Layer), 24-25
for empty Web site, 30-31

stacking order for graphics, changing, 135
starting Expression Web, 4
static positioning, 307
static templates

creating, 68
saving, 75

Status bar
code errors in, 346
Set Text of Text Field behavior, 202-203
showing/hiding, 366-367

Strong effect, 100
Style Application toolbar, 297
Style list arrow, 93
styles, 77, 287. See also class-based styles;

inline styles; tag-based styles
definition list, creating, 96-97
deleting, 95
heading styles, 96
for Jump Menu, 201
text, applying to, 95
working with, 303

sublists, creating, 94
Submit buttons in forms, 263, 272
SuperPreview, 3

displaying Web pages, 64-65
survey forms, 259
Swap Image Restore behavior, 204-205
Swap Images behavior, 196, 204-205
swapping images, 204-205
switching

between tables, 214
between Web pages and views, 16

symbols, inserting, 89
synonyms, finding, 113
system requirements, 2

T

Table AutoFormat Combo button, 238
table cell padding. See padding
Table Properties dialog box, 219, 240, 242
tables, 213. See also layout tables

adding cells, rows or columns to, 228
alignment

of captions, 226
cell alignment options, 237
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tables, alignment (continued)
of cell contents, 233
changing, 234

AutoFormatting, 239
backgrounds

changing, 240-241
formatting, 238

borders
changing, 235
colors, changing, 240-241
setting, 221

captions, 226-227
deleting, 232
repositioning, 227

colors
background colors, changing, 238
of borders, 235
elements of table, adding to, 240-241

converting text to, 224
creating, 220
deleting elements of, 232
drawing cells, 216
Excel data, creating with, 219
filling cells with information, 225
floating text in, 234
formatting, 238-239
forms, inserting into, 261
graphics, adding, 242
height and width

changing, 234
setting, 221

horizontal cell alignment, 237
HTML tab support for, 224
ID attributes, adding, 372
images, adding, 242
information, filling cells with, 225
layout of cells, changing, 237
merging cells in, 230-231
navigating in, 222
one-celled table, creating, 224
padding of cells

changing, 234
setting, 221

properties, 221
changing, 234-235
setting, 221

resizing
cells, rows or columns, 236
columns and rows, 229

selecting elements in, 223
spacing of cells

changing, 234
setting, 221

span of cell, changing, 237
splitting cells, 230
switching between, 214
text

converting text to table, 224
entering, 222
filling cells with, 225
floating, 234

vertical cell alignment, 237
Tables toolbar, 238
tabs

document tabs, navigating with, 48
form tab order, setting, 264
HTML tabs, 224

Tag Properties panel, 8, 275, 289, 292-293,
297

attributes of tags, setting, 294
display, changing, 292-293

tag-based styles, 289
creating, 300

tags. See HTML (Hypertext Markup
Language)

target frames, creating, 254
target hyperlinks, creating, 179
tasks for misspelled words, 107
Team Foundation source control system,

363
templates, 23. See also dynamic templates;

frames pages; static templates
adding pages to Web site with, 36-37
copying pages for new Web pages, 29
creating Web sites with, 25
for CSS layout page, 308-309
deleting pages in, 28
for layout tables, 214
opening template pages, 26
planning, 24
replacing content in, 27
text from, 78
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text, 77. See also fonts; headings; lines;
paragraphs; tables; wrapping text

alignment, setting, 88
behaviors, adding, 197
blank page, entering on, 78
character spacing, changing, 86
default text, changing, 114
drag-and-drop, moving/copying with, 84
editing text, 80
file, inserting text from, 115
finding/replacing, 102-103
floating properties, 307
formatting, 98-99
hotspots, adding text-based, 184-185
for inline frames, 251
inserting and editing, 80
Open Browser behavior with, 210
redoing typing, 81
selecting text, 79
styles, applying, 95
symbols, inserting, 89
template text, working with, 78
undoing typing, 81

text area/text boxes in forms, 263, 266-267
text files, 37

inserting text from, 115
saving, 75

text messages in Popup Message window,
202

thesaurus, using, 113
thumbnails

auto thumbnail properties, setting, 
130-131

creating, 130
displaying images, 121

tiling, avoiding, 56
titles

centered text for, 88
of frames, 250-251, 252-253
for inline frames, 251
Web page title, changing, 53, 54

toolbars
commands

choosing, 6
moving, 6-7
resizing, 6-7
showing/hiding, 6

Toolbox, 8

tools
CSS tools, 289, 297
tag tools, using, 292-293

tooltips. See ScreenTips
Trace Image option, 121
tracing graphics, 121
transparent graphics, 119

converting to, 142-143
turning on/off paste options, 85

U

UNC (Universal Naming Conventions), 352-
353

Under Construction Pictures, 56
underlining text, 98
undocking toolbars, 6-7
undoing

bevel changes, 144
text, 81

Unicode, 55
updates

checking for, 20
databases, 283
dynamic templates, updating, 71
Web sites, 360-361

upload fields in forms, 275
URLs (Uniform Resource Locators)

existing Web page, opening, 13
for frames, 250
Go To URL behavior, 199
hotspot URLs, editing, 186
Internet URLs, 33
Open Browser behavior, specifying, 210
opening Web sites with, 32
and publishing Web sites, 352-353, 

356-357
user-defined styles, 95
user interface, in Expression Web

color scheme, changing, 5

V

Variable effect, 100
VBScript files, saving, 75
vector graphics

in Expression Design, 386, 388-389
verifying hyperlinks, 189
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versions of browser, checking for, 206
vertical alignment of graphics, 138-139
Vertical Split template, 245
video formats, 153
View tabs, 4
views and viewing

behaviors, 196
frames pages, 244
switching between Web pages and, 16
Tables toolbar, 238
Web site reports, 340
working with views, 14-15

visibility behaviors, 208-209
Vista. See Windows Vista
visual aids, showing/hiding, 17
Visual Aids menu, 17
visually impaired persons, alternative text

for, 121

W

watermarks, 54, 56
background picture as watermark, insert-

ing, 56-57
WAV files, 212
WCAG accessibility requirements, 345
Web Package

creating, 38
importing, 34

Web pages. See also backgrounds; hyper-
links; Master page; previewing; pub-
lishing Web sites; saving; text; Web
sites

accessibility, checking for, 345
advanced properties, setting, 55
animating page transitions, 76
ASP.NET pages, creating, 316
closing, 21
compatibility, checking for, 346-347
Content page, 72-73
copy of page, opening, 47
CSS pages, creating, 308
deleting, 50
disabilities, accessibility for users 

with, 345
existing page, opening, 13
external style sheets, attaching, 304-305
finding/replacing text or code, 102-103
Folder list, opening with, 47

Folders view, opening in, 46
formats for, 37
formatting options, setting, 54
general options, setting, 54
Go To URL behavior, 199
graphic format, changing, 149
home page, setting as, 52
HTML pages, creating, 44-45
hyperlinks, creating, 176
language of page, specifying, 55
moving, 51
navigating, 48
new folders, creating, 51
page numbers, adding, 67
previewing, 62-63
properties, changing, 54-55
recently opened pages, opening, 13
renaming, 50
saving, 12
simple page, creating, 11
size, setting, 60-61, 63
spell-checking, 106
switching between views and, 16
title, changing, 53

Web servers. See servers
Web Site Wizard, importing with, 34
Web sites. See also publishing Web sites;

templates; Web pages; 
adding pages to, 36-37
animating page transitions, 76
deleting, 41
empty Web site, creating, 30-31
existing site, opening, 32-33
finding/replacing text or code, 102-103
folders and files, list of, 10
Go To URL behavior, 199
importing content from, 34-35
introduction to, 23
languages, setting, 110-111
last opened site, opening, 32
multiple remote sites, 354
names, changing, 360
one page site, creating, 30
planning, 24
previewing, 360
recently opened site, opening, 32
remote servers, connecting to, 352-353,

356-357
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renaming, 40
reports, generating, 340-341
saving, 39
spell-checking, 106-107
types of, 24
updating, 360-361

WebDAV, 34
as remote server, 352-353, 356-357

WebTV version, checking, 206
Whole Page target hyperlink, 179
width. See also tables

of interactive buttons, 193
of layout tables, 215, 218
line width, changing, 91

window, viewing, 5
Windows color scheme

changing, user interface, 5
Windows Media Audio (WMA)

inserting, 158-159
setting options, 160

Windows Media Video (WMV)
inserting, 158-159
setting options, 160

Windows menu, navigating with, 48
Windows Vista

exclusion dictionary in, 109
languages, setting keyboard for, 110

Windows Presentation Foundation
in Expression Blend, 394

Windows XP
exclusion dictionary in, 109
languages, setting keyboard for, 110

WMF files, 118. See also graphics
WMfiles, 119
Word 2007 files, 115
word wrap, 373

workgroups
removed from product, 403

Wrap Tag command, 296
Wrapping Style options, 138
wrapping text, 11

on graphics, 138
word wrap, 373

WYSIWYG view, 14

X

XAML (eXtensible Application Markup
Language)

creating, 394
inserting, Silverlight media, 163
overview, 162-163

XHMTL 1.0 Transitional rules, 346
XML (eXtensible Markup Language), 37, 328

applying, 339
checking, pages, 334
creating

page, 328
data view

creating, 329
formatting, 332-333
work with, 330-331

form results, saving, 276
formatting, applying, 335
RSS feed, 336
saving, 75

Z

ZIP files, hyperlinks to, 177
z-value

for layers, 136
for positioning graphics, 135
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