
Printing in Excel
Print Preview mode in Excel is a very convenient way to prepare your work-
sheets for printing, without having to print numerous copies of a worksheet to
“get it right.” Using Print Preview mode, you can access all the printing
options, and even make changes that will be saved with your worksheet in
case it’s printed again in the future.

In Excel, you can print your worksheets by using a basic printing procedure, or
you can enhance the printout with several print options. Options for setting up
the printed page include orientation, scaling, paper size, and page numbering.
You can use these options to change how the worksheet is printed on the page
(across or down) or even so that your multi-page worksheet prints on a single
page.

Sheet options control what elements of your worksheet are printed—gridlines,
notes, row headings, and so on. You might want to make some changes to
these options depending on how you want your printout to look. Another com-
mon change is to repeat column or row headings on a multi-page worksheet.
On worksheets that span two pages, the information on the second page might
not make sense without proper headings.
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Print Preview Printing Options
Moves you to the next page in the worksheet (can also press the [page down] key)

Moves you to the previous page in the worksheet (can also press the [page up] key) 
Toggles the worksheet data in and out of magnification

Opens the Print dialog box
Opens the Page Setup dialog box tabs (Page, Margins, Header/Footer, Sheet)

Toggles the margin lines display for the page (top, bottom, left, right),
header, footer, and columns

Displays the worksheet when in Page Break Preview 
Returns you back to the Normal worksheet view

Provides help with printing questions

Page margins Column margins

Header 
information

Displayed comments

Zoom

Number of Pages or Margin Width

Footer Margin

Worksheet
Centered

Gridlines 

Row/Column
Headers

Landscape 
orientation

Cell error 
indicators
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Start

With the worksheet you want to print open on your desktop, click the Print
Preview button on the Standard toolbar.

The Print Preview window opens, displaying the worksheet in Print Preview mode.
Click the Next button to move to the next page in the worksheet.
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Using Print Preview
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jobs, possibly containing hundreds of pages. Waiting
until all these pages are printed to verify that the
information is printed correctly can cost a lot in both
time and printing supplies. To help prevent printing
mistakes, use Print Preview to ensure that all the nec-
essary elements appear on the pages being printed.

Click
11 22

Click
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Page Break Preview Button
Click Page Break Preview to see exactly what is
selected to print (in the print area). If you haven’t set the
print area, see “Setting the Print Area.” If you were
already in Page Break Preview view when you clicked the
Print Preview button, the toolbar button will display
Normal view instead, which will display your entire work-
sheet (regardless of whether you have set the print area).
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Setup Button in Print Preview
Click the Setup button to open the Page Setup dialog box. Use the Page tab to alter the page orientation and
scaling (see “Printing Portrait or Landscape Orientation” and “Printing a Worksheet on One Page”). Use the
Margins tab to alter the margins or center your data horizontally and vertically (see “Centering a Worksheet on
a Page”). Use the Header/Footer tab to add a header and footer (see “Adding Headers and Footers”). Finally,
use the Sheet tab to alter the gridlines and row and column headers (see “Printing Gridlines and Row/Column
Headers”), cell comments (see “Printing Cell Comments”), cell errors (see “Printing Cell Error Indicators”) and print
repeating titles (see “Printing Repeating Row and Column Titles”). 
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Click the Zoom button to increase the viewable size of the worksheet in Print
Preview mode. (Click Zoom again to return to the original page size.) 

Click Margins to toggle between displaying the margin indicators, which you can
drag to set more or less of your worksheet to print.

Click the Close button to return to the worksheet’s Normal view.

End
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Open the File menu, choose Print Area, and select Set Print Area to store the
print area as part of the worksheet. Only the cells in the print area will print.

Start

In Print Preview mode, press the page down key on your keyboard to move
through your worksheet to see what your printed worksheet will look like.

Click the Close button to return to Normal view so you can set your print area.

Select the exact cells you want to print (in this example, all the cells in the first two
tables in this worksheet).
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Setting the Print Area
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columns; setting the print area enables you
to specify which rows and columns to
print. If you don’t set a print area, all cells
that contain data will be printed. The
worksheet in this task contains four tables
that span seven pages. By default, all will
print unless you set a print area.
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Choosing the print area
You can also select the print area from the Page Setup dialog box
(open the File menu and choose Page Setup, and then select
the Sheet tab) as long as you aren’t in Print Preview mode. Click
the Print area button and select the cells you want to print in
your worksheet using the mouse. When finished, click the Print
area button again on the shrunken dialog box, and the cell loca-
tion will be indicated on the Sheet tab.
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Insert a row or column into your worksheet (refer to the first task in Part 8). Parts of
the table now fall outside the current print area. 

To reset the print area to include the new row or column, again open the File menu,
choose Print Area, and select Set Print Area.

Your new print area is stored as part of this worksheet.
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Clearing the print area
If you only need to set the print
area to print a portion of data
in your worksheet once, you
will probably want to clear the
print area after you print. Open
the File menu, choose Print
Area, and select Clear Print
Area.

End
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Long and short dashes
The long dashed lines in your worksheet indicate the print area, and the
smaller dashed lines indicate the current page margins. If your print area
data (long dashed lines) falls outside the current page margins (short
dashed lines), you will need to alter the page margins (see the next task).
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Start

When in Print Preview mode, if you have a page that displays some carryover data
from another page, click the Margins button.

Excel activates Print Preview’s margin lines. Press page up or page down to dis-
play the page in your worksheet on which you want to fit all the data.
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Setting Page Margins
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headers and footers are printed. Occasionally, margins might need to be
changed to make room for a letterhead or logo on preprinted stationery.
When in Print Preview mode, Excel allows you to alter your column widths
and margins simultaneously.

Click 11
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Print Preview Button
Click the Print button to open
the Print dialog box (refer to the
task “Printing Worksheets”).
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Entering specific margins
There might be times when you need to set your worksheet margins to a
specific measurement. Perhaps your worksheet data is being placed in a
binder, and you need to have a left margin of 1.25''. You can alter this in
Print Preview mode, or choose File, Page Setup, click the Margins
tab, and alter the margins as necessary (Left, Right, Top, Bottom, Header,
Footer). Click the OK button to return to your worksheet or Print to print
immediately.
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Drag the Left Margin line from the default 1'' to 0.34'' (you can see the exact
measurement in the bottom-left corner of the screen).

Click and drag the Right Margin line from the default 1'' to 0.34'' (again, you can
see the exact measurement in the bottom-left corner of the screen).

Thanks to the margin change, the total number of pages to print is reduced from four
to two.
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Removing margin 
indicators
If you no longer want to see the
margin lines in Print Preview
mode, click the Margins but-
ton on the Print Preview toolbar
again to turn them off.

End
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Click &
Drag

Drop Drop
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Start

Open the View menu and choose Page Break Preview to change to Page
Break Preview mode.

Press the page up and page down keys on the keyboard to move through your
worksheet in Page Break Preview. Notice that cells outside the print area are grayed out.
Open the File menu, choose Print Area, and select Clear Print Area to elimi-
nate any current print area settings.
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Inserting Page Breaks
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When a worksheet page is filled to the margins with data, Excel automati-
cally inserts a page break for you. There may be times, however, when you
want to insert a page break manually. For example, if you are creating a
report with multiple topic sections, you might want each topic to begin on a
new page. Inserting a page break enables you to print each page sepa-
rately, and the best way to insert page breaks is using Page Break Preview
view (instead of Normal view).

Removing page breaks
To remove a page break, place
the active cell so that one of the
cell borders is touching the
page break line. Then, open the
Insert menu and choose
Remove Page Break. (You
can also do this in Normal
view.)

Click

Click
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Why not simply add more rows?
Suppose you want each of two tables that fit on one page to print on sepa-
rate pages. Instead of inserting a page break, you could add several blank
rows to the end of the first table, which will automatically kick the second
one onto a second page. If, however, you later add any rows to the first
table and forget to delete the same number of blank rows before the sec-
ond one, the tables might not print correctly.

187

Click the cell below and in the left-most column in which you want to insert a page
break.

Open the Insert menu and choose Page Break to insert the page break.

The page break is inserted.
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Page break intersection
A page break is always
inserted as an intersection
between rows and columns. If
the active cell isn’t in the first
column, the page break will be
inserted as four quadrants.

End
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Choose View, Page Break Preview. If a print area has been set, it is displayed;
if not, the entire worksheet is displayed.

Move through the worksheet to find page breaks (if any). Naturally occurring page breaks
appear as blue dashed lines, and inserted page breaks appear as solid blue lines.
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Working in Page Break Preview Mode
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Clearing the print area
If you only need to set the print area to print a portion of data in your
worksheet once, you will probably want to clear the print area after you
print. Open the File menu, choose Print Area, and select Clear Print
Area to clear the previously set print area.

Page Break Preview mode dis-
plays the area you have selected
for your set print area. It also
allows you to click and drag
where your page breaks are
instead of using the Insert, Page
Break command. You can also
edit the text and data just as you
can in Normal view.

Click
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Removing a page break
To remove a page break in
Page Break Preview mode, click
and drag the page break line
off to the right/left/top/bottom
of the worksheet.
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To move a page break that is poorly placed, click and drag it to a better location.
(Moving a natural page break changes it to an inserted break—solid-blue.

To exclude a column or data to the right of your set print area, click and drag the
vertical page break.

End
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The excluded column outside the print area is grayed out.55
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Drag
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Drag
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View your worksheet in Print Preview mode. If only a few rows of data spill onto a
second page, you can alter the page scale; click the Setup button to begin.

In the Page tab of the Page Setup dialog box, click the Fit to 1 pages(s) wide by
1 tall option button. (To fill more than one page, type the number of pages here.)

Click OK.

Your worksheet appears in Print Preview mode, all on one page. Notice that the
scaling change reduced the total number of pages to print from two to one.
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Printing a Worksheet on One Page
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Changing from letter to
legal
To choose a different paper size
for your printout, click the
Options button in the Page
Setup dialog box. The scaling
setting automatically adjusts to
the selected paper size.

By default, Excel prints your work-
sheet at a scale of 100%. You can
decrease this percentage if you
want to fit more data on a page,
or increase it to fit less data on a
page. In addition, you can have
Excel fit your entire worksheet on
one page. (If your worksheet is
large, the data might become too
tiny to read when scaled down.)

Returning to the default
scale
When you want to return the
preview of your worksheet to
the default scale, click the
Adjust to option button in the
Page Setup dialog box and
type 100 into the % normal
size field.

End
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191Printing in Portrait or
Landscape Orientation

View your worksheet in Print Preview mode. If your worksheet is too wide to fit all its
columns on a single page in Portrait mode, click the Setup button.

In the Page tab of the Page Setup dialog box, click the Landscape option button.

Click OK.

Your worksheet appears in Print Preview mode, Landscape orientation. Notice that
the orientation change reduced the total number of pages to print from four to two.
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Depending on the data in your
worksheet, you might want to
change its orientation from
Portrait (vertical, the default) to
Landscape (horizontal).

Switching back to
Portrait
You can easily switch your
worksheet back to Portrait 
orientation by following the
steps in this task, selecting the
Portrait option button in 
step 2.

End
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View your worksheet in Print Preview mode. If the data in your worksheet appears
toward the top or on the far left of the page, click the Setup button.

Click the Margins tab in the Page Setup dialog box, and click the Horizontally
and/or Vertically checkboxes in the Center on page area.

Click OK.

Your worksheet appears in Print Preview mode, centered.

192
P
A

R
T
 9

Centering a Worksheet on a Page
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If you want a cleaner, more pro-
fessional looking printout for a
presentation, you might want to
center your worksheet data on the
page before you print it. This is a
particularly good idea if you plan
to print your worksheet on one
page.

Centering vertically or
horizontally
You don’t have to center your
data both vertically and hori-
zontally. You can choose one or
the other, depending on how
you want your printed work-
sheet to look.

End
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193Printing Gridlines and Row/Column Headers

View your worksheet in Print Preview mode. If no gridlines or row/column headers
appear, click the Setup button.

Click the Sheet tab in the Page Setup dialog box, and click the Gridlines and Row
and column headings checkboxes in the Print area to select them.

Click OK.

Your worksheet appears in Print Preview mode, with gridlines and row/column
headers visible.
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sheet gridlines or row/column head-
ers. You can, however, instruct Excel
to print them. Gridlines help you
read information in a printed work-
sheet, keeping rows and columns of
data visually organized. Row and
column headers can help you quickly
find data in your worksheet.
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Repeating titles
Displaying row and column headers is not the same as
printing repeating titles. Repeating titles are column head-
ers and row headers that you have assigned in your
worksheet. For more information, see the task “Printing
Repeating Row and Column Titles” later in this part.
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Choose File, Page Setup and click the Sheet tab in the Page Setup dialog box.

Click the Comments field down arrow and choose either At end of sheet, to
print the comments, As displayed on sheet, or (None).

Click OK.

View your worksheet in Print Preview mode to review the comments as displayed
in your worksheet (as in this example) or at the end of your worksheet.
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Printing Cell Comments
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Some cells contain data or formulas that require an explanation or special
attention. Comments provide a way to attach this type of information to
individual cells. A red triangle in the upper-right corner of the cell indicates
that a comment is present. This task shows you how to print your worksheets
so that the printouts include the information in your comments, either as
they appear in the worksheet or at the end of the worksheet.

As displayed on sheet
You must have your comments
“showing” in your worksheet
(choose View, Comments)
for them to display when the
As displayed on sheet
option is selected. If they aren’t
showing, they won’t display in
the printout or in Print Preview.

End
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195Printing Cell Error Indicators

Choose File, Page Setup, and click the Sheet tab in the Page Setup dialog box.

Click the down arrow next to the Cell errors as field and choose displayed,
<blank>, --, or #N/A depending on how you want errors to be displayed.

Click OK.

View your worksheet in Print Preview mode to review how cells containing errors
are displayed.
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When you print worksheets for friends or colleagues (or even yourself), cal-
culation errors that appear on your worksheet can create a negative impres-
sion, which is why they’re not printed by default. If you want these errors to
be visible in your printout, however, you can display them, or replace them
with any of the following: <blank>, --, or #N/A.

Errors that print
All the error messages
explained in Part 5 (#DIV/0!,
#Name?, #Value!, #REF!,
and Circular Reference errors)
will print in this task, except the
##### error (unless your
columns are too narrow in the
printed version).

End
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Start

Choose File, Page Setup, and click the Sheet tab in the Page Setup dialog box.

Click the Rows to repeat at top selection box in the Print titles area. Excel
shrinks the Page Setup dialog box, making your focus the worksheet on your desktop.

Click the row containing the titles that you want to repeat on each page of your work-
sheet, and press Enter to reopen the Page Setup dialog box with your selection inserted.

Click OK. If you like, view the worksheet in Print Preview mode to get an idea of
what your printed worksheet will look like with repeating row headings.
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Printing Repeating Row and Column Titles
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Repeating titles in Print
Preview
You cannot assign repeating
titles while you are in Print
Preview mode; you must be in
the worksheet view and select
File, Page Setup.

You might have noticed that when
a worksheet spans multiple pages,
it is difficult to keep the column
and row titles organized. A quick
way to rectify this is to make par-
ticular titles repeat on each page
of the printed worksheet. In this
task, you’ll learn how to make
row headers repeat.

Repeating column 
headings
To repeat column headings
across several pages, follow the
steps in this task, but click the
Columns to repeat at left
selection box in step 2. Then,
click the columns you want to
repeat, and proceed as normal.

End
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197Adding Headers and Footers

Choose View, Header and Footer to open the Page Setup dialog box with the
Header/Footer tab displayed.

Click the down arrow next to the Header field and scroll through the header
options. If you see one you like, click it to see what it looks like.

Click the down arrow next to the Footer and scroll through the footer options. If
you see one you like, click it to see what it looks like. Then click OK.

If you like, view the worksheet in Print Preview mode to get an idea of what your
printed worksheet will look like with headers and footers.
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Creating custom headers and footers
You can create your own custom header or footer by clicking the appropri-
ate Custom Header or Custom Footer button in the Page Setup dialog
box. A separate Header or Footer dialog box will appear, allowing you to
click a button to place text or any the following fields in the header/footer:
Page number, Total Pages number, Date, Time, Path & Filename, Filename
only, tabs, and insert graphic objects. For example, you could add page
numbers and the total page count to the header or footer.

Headers and footers appear at
the top and bottom of printed
pages of Excel worksheets and
can display the filename, the date
and time the worksheet was
printed, the worksheet’s name, or
you can create your own custom
header or footer.

End
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Start

Choose File, Print to open the Print dialog box.

Click the down arrow next to the Printer Name field to choose the printer or fax
you want to use.

In the Print range area, click Page(s) From and To and type the pages you want
to include in the range (for example, from 2 to 5), or keep the All (default).
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Printing Worksheets
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Quick printing
If you simply click the Print
button on the Standard toolbar,
your entire worksheet will print
using the default printing
options unless you have
changed them beforehand. 

Printing a worksheet, workbook,
or chart sheet is quite simple, but
setting the options for printing can
be complex. The number of
options that must be set before
printing depends on the amount
of data stored in the workbook,
how it is arranged, how much of
it needs to be printed, and how
you want the printout to look.

Setting additional print
options
To set additional print options,
such as the paper size, graphic
options, font options, and
printer details, click the
Properties button in the Print
dialog box.
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Type the number of copies you want to print in the Number of Copies field, which
defaults to 1.

If you want the printed pages to be collated, click the Collate checkbox to select it.

In the Print what area, click either Selection (only selected cells), Active
Sheet(s) (currently sheets), or Entire workbook (all worksheets and chart sheets).

Click OK to send your printout to the printer. Alternatively, click Preview to preview
your printout; then click the Print button on the Print Preview toolbar.
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Canceling printing
Click the Cancel button to can-
cel printing. Alternatively, if
you’ve already sent the work-
book to the printer, double-click
on the Printer icon in the system
tray (to the left of the clock on
the taskbar) and click Cancel.

End
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Vertical or horizontal page order
If you are working with a large worksheet, you can specify the page order
by which your worksheet is printed. Open the File menu and choose
Page Setup, and select the Sheet tab. Review the options of Down,
then over (default) and Over, then down in the Page order area of
the Page Setup dialog box. This is convenient if you have numerous
columns that you want printed according to a specific row header.
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