
Working with Graphic
Objects

You can draw in a worksheet or on a chart using one of several Excel drawing
tools. You can add a picture you draw yourself, insert a picture from another
file, add an organization chart, as well as ClipArt, AutoShapes and WordArt.
Charts, pictures, clip art, and drawn items are all considered graphic objects.

In addition to inserting objects, you can resize and move them. You can also
format them and delete objects.P
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Inserted Graphic Objects

An example of
WordArt

An example of
a picture file

An example
of an object
(PowerPoint
presentation)

An example of
a diagram

An example
of ClipArt

An example of an
organization chart

An example of
an AutoShape

A Text box
drawing tool
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Start

Click the Drawing button on the Standard toolbar. The Drawing toolbar appears
above the window’s Status bar.

Click any of the drawing tools’ buttons—for example, the Arrow button on the
Drawing toolbar. The mouse pointer turns into a plus sign.
Click and drag in the chart to draw an arrow; release the mouse button when the
arrow is the length you want it to be (the pointer end will be at the point of release).
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Using Drawing Tools
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Color and style
Click the Line Color and Line
Style buttons in the Drawing
toolbar to change the color and
style of the lines used to draw
objects.

Excel has drawing tools that you
can use to draw on a worksheet
or chart sheet (that is, a worksheet
that contains only a chart). In this
task, you’ll learn about the advan-
tages of using Excel’s drawing
tools to help point out information
on a worksheet.

Text boxes
A text box is an object that
contains text. You can move a
text box, resize it, and even
add formatting options.

Click

Click

DropClick &
Drag
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Using AutoShapes
The Drawing toolbar includes tools for drawing
common shapes, such as lines, circles, squares,
and so on. If you aren’t much of an artist or if
you want to try some prefab symbols, insert an
AutoShape. You can select from several lines,
connectors, basic shapes, arrows, flowchart
symbols, stars, callouts, banners, and more.

151

As another example, click the Text Box button on the Drawing toolbar. The mouse
pointer turns into an insertion pointer.

Click and drag in the worksheet to draw a text box; release the mouse button when
the box is the size you want it to be.

Type the text you want to enter in the text box.

Click anywhere outside the chart area to see how your drawings look.
End
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Modifying drawing objects
A drawn object is just like a picture—you can resize,
move, and delete it as needed. To resize a drawn
object, click on the object to see its sizing handles,
drag the sizing handles to the size you want, and
release the mouse button. To move the object, click
on the object and drag it to the desired location in
the worksheet. To delete an object, click on the object
and press the Delete key on the keyboard.

Drop

Click &
Drag
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Start

Open the Insert menu, choose Picture, and select Clip Art to open the Clip Art
task pane.

Type a description for the clip art you are looking for in the Search for text box,
and press Enter (or, click the Go button).

If Microsoft has clip art that matches the description you typed, it is displayed in the
Clip Art task pane. Click an image in the results list to insert it into your worksheet.

The clip art is inserted into your worksheet. (You might need to move or resize
the image; see the tasks “Moving an Object” and “Resizing an Object”.)
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Inserting Clip Art
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clip art, you can choose from numerous professionally prepared
images, sounds, and movie clips. After you have added graphics,
you can move them around in the worksheet and even assign text
wrapping. (Be aware that the first time you try to use Microsoft’s clip
art, you might be asked to set up your collections and organize your
clips. Make sure you do this.)
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Using the Picture toolbar
When you insert a piece of clip
art, the Picture toolbar appears;
it contains tools you can use to
crop the picture, add a border
to it, or adjust its brightness
and contrast.
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153Inserting a Picture from File

Open the Insert menu, choose Picture, and select From File to open the Insert
Picture dialog box.

Locate the file you want to use and click it to see a preview (you might need to select
Preview from the dialog box Views button).

Click the Insert button.

The image is inserted into your worksheet.
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pictures online becoming more
popular, there will certainly be
times when you want to insert a
picture file into a worksheet. You
can insert all types of graphics files:
Windows Metafiles, JPEG files,
PNGs, Macintosh PICT files, Kodak
Photo CD files, and many more.

End
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Inserting other things
You can insert clip art by opening the Insert menu, choosing
Picture, and selecting Clip Art, and then searching through the
Clip Art task pane to find the image you want. You can also choose
Insert, Picture, Organization Chart to insert an organization
chart ready for you to input information. When you insert a picture,
the Picture toolbar appears; it contains tools you can use to crop the
picture, add a border to it, or adjust its brightness and contrast.
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Open the Insert menu, choose Picture, and select Organization Chart to insert an
organization chart into your worksheet, and to display the Organization Chart toolbar.

An organization chart containing dummy text is inserted into your worksheet. Click a
chart box and type over the dummy text with your own text.

To add a subordinate, co-worker, or assistant, click the appropriate chart position.
Then click the down arrow next to the Insert Shape button on the toolbar.

The new chart box containing dummy text is added to the chart. Click the chart
box and type over the dummy text with your own text.
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Adding an Organization Chart
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tion chart directly into your work-
sheet. You can insert the chart
and then add the appropriate
information, in a manner very
similar to inserting a table and
adding data in Word or
PowerPoint.
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Placing new chart boxes
When adding a subordinate, co-worker, or assistant chart box,
click the chart box with which the new chart box should be asso-
ciated before choosing the desired option from the Insert Shape
drop-down list. For example, if you’re adding an assistant, start
by clicking the chart box for the person to whom that assistant
will report. If you make a mistake, click the new chart box and
drag it to the correct chart position.
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155Inserting an AutoShape

Open the Insert menu, choose Picture, and select AutoShapes to display the
AutoShapes toolbar.

Click on an AutoShape button, such as the Basic Shapes button, on the toolbar
and select from the different shape options (here, Heart).

The mouse pointer changes to a plus sign. Click and drag the pointer to draw the
object at the desired size; then release the mouse button.

The new shape is added, complete with sizing handles. Click the Close (×) button on
the AutoShape toolbar to close it.
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Resizing and moving
objects
Move the mouse over an object
border; the pointer becomes a
four-headed arrow and you can
move it (see the “Moving Objects”
task); a two-headed arrow allows
you to resize it (see the “Resizing
Objects” task).

There are numerous predesigned
shapes, called AutoShapes, that
Excel allows you to add to your
worksheets. For example, you can
insert any one of the following
AutoShapes into your worksheet:
Lines, Connectors, Basic Shapes,
Block Arrows, Flowchart, Stars
and Banners, Callouts, and more.

Formatting AutoShapes
To format your AutoShape,
right-click the object and select
Format AutoShape from
the shortcut menu. Click the
Colors and Lines tab and
choose from the various colors,
line types and arrows.

End
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Open the Insert menu, choose Picture, and select WordArt to open the WordArt
Gallery.

Double-click on the WordArt style you want to use to open the Edit WordArt Text
dialog box.

Type your text into the Text box, and click OK.

The WordArt text is inserted into your worksheet.
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Inserting WordArt
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Formatting WordArt
Once your WordArt is inserted into your worksheet, the WordArt
toolbar appears (while the WordArt object is selected). You can
use the various buttons on the toolbar to edit the text, alter the
style, format the text, and add more WordArt.

WordArt is a text-based object
that Microsoft provides to apply
special effects to text. You don’t
have to add these text effects
manually; the different styles of
WordArt are indeed the text
effects themselves.

End
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157Inserting a Diagram

Open the Insert menu and choose Diagram to open the Diagram Gallery dialog
box.

Double-click the desired diagram type; a diagram of that type containing dummy text
is inserted into your worksheet.

Click each instance of dummy text and type over it with text of your own.
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Inserting an organization chart
You can choose to insert an organization chart from the
Diagram Gallery or open the Insert menu, choose
Picture, and select Organization Chart to insert an
organization chart ready for you to input information.

Excel lets you insert diagrams
directly into your worksheets. You
can insert the diagram and then
add the appropriate information,
in a manner very similar to insert-
ing an organization chart and
adding the data.

End
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Open the Insert menu and choose Object to open the Object dialog box.

Scroll through the Object type list and double-click on the object you want to
insert—for example, Microsoft PowerPoint Presentation.

Edit the object according to the individual object properties (in this example, as you
would when creating a PowerPoint presentation).
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Inserting an Object
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Inserting clip art
You can insert clip art by open-
ing the Insert menu, choosing
Picture, and selecting Clip
Art. Search through the Clip
Art task pane; when you find a
piece of art you like, click it to
insert it.

In addition to inserting all the dif-
ferent types of graphic objects that
you’ve learned about in this part,
you can also insert objects that
aren’t as commonly added to Excel
worksheets. For example, you can
insert a media clip, a PowerPoint
slide, a Microsoft Works chart, a
video clip, and much more.

End
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159
Selecting an Object

Click the object you want to select; selection handles appear around the edges of the
object.
Move the mouse over the object border; the pointer becomes a four-headed arrow
and you can move it; a two-headed arrow allows you to resize it.
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Selecting multiple objects
To select multiple objects, click
the first object, press and hold
down the Shift key, and click
on the second object. Continue
until all the objects you want
are selected.

As you have seen, you can add
charts to a worksheet, draw objects,
insert pictures, and more. Each of
these items exists on a separate layer
on top of the worksheet and is gener-
ically called an object. As you will
discover in the next several tasks, you
can format, move, resize, and delete
objects; first, however, you must select
the object you want to modify.

Reselect
If you select a cell instead of an
object by accident, try again—
this time, making sure to put the
pointer right on the edge of the
object. Alternatively, click the
Select Objects button on the
Drawing toolbar and then click
the object.

End
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Click the object you want to format; selection handles appear around the edges of
the object.

Right-click the object and select Format [object name] (here, AutoShape) from the
shortcut menu.

A Format [object name] dialog box opens. Click the available tabs and alter the
formatting options and click OK.

The formatting changes are applied to the object.
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Formatting an Object
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sheets. Depending on the object, the standard formatting options you can
change are as follows: font (text changes in the object), alignment (where
text aligns in the object), colors and lines (whether lines are filled or colored
or have arrows), size (the height, width, and scale of the object), protection
(whether others can alter your object), properties (how you position the
object and whether you can print it), and Web (text to display while the
object loads online).
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Formatting
You can also double-click
directly on the object to auto-
matically open the Format dia-
log box associated with it.
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161Moving an Object

Select the object you want to move; selection handles appear around the edges of
the object.

Click directly on the object or its border (not the selection handles) and hold the left
mouse button while dragging the object to the new location.

Release the mouse button to drop the object in the new location. The object is
moved.
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Copying objects
To copy an object, press and
hold down the Ctrl key on your
keyboard as you drag; a copy
of the original object will be
moved, with the original
remaining intact where it is.

When you draw an object on or
add an object to a worksheet, you
might not like its placement.
Perhaps the object obscures the
worksheet data, or maybe it
needs to be moved a little closer
to (or farther away from) the
data. Fortunately, you can easily
move an object.

Moving an object to
another worksheet
Select the object, and then open
the Edit menu and choose Cut.
Move to the new sheet or work-
book, click in the spot where
you want the object to appear,
and then open the Edit menu
and choose Paste.

End
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Select the object you want to resize; selection handles appear around the edges of
the object.

Move the pointer over one of the selection handles (here, a corner handle). When
the pointer is in the right spot, it changes to a two-headed arrow.

Click on the handle, drag it, and release the mouse button when the object is the
desired size.

The object is resized.
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Resizing an Object
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Corners versus sides
Dragging the sides increases or
decreases the height or width of
an object, while dragging the
corners increases or decreases
the height and width of an
object at the same time.

If an object is too big (or too
small), change the size. You can
modify any type of object, includ-
ing a picture you have added, a
chart, or a drawn object. In addi-
tion, you can continue to resize
the object over and over until it is
the size you want.

Resizing proportionally
If you hold the Shift key down
while dragging a corner, the
image enlarges or decreases in
proportion.

End
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163Deleting an Object

Select the object you want to delete; selection handles appear around the edges of
the object.

Press the Delete key on your keyboard. Excel deletes the object.
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Undoing a deletion
If you delete an object by acci-
dent, click the Undo button on
the Standard toolbar to undo
the deletion.

As you experiment with charts,
drawings, and pictures, you may
go overboard, or you might make
a mistake and want to start over.
In any case, if you add an object
and no longer want to include it,
you can delete it, as described
here.

End
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