
In this chapter

• Using macros to automate step-heavy tasks
you frequently perform.

• Recording a series of keystrokes and com-
mands to create a macro.

• Running macros by pressing a key or click-
ing a button. 

• Editing macro commands in Microsoft’s
Visual Basic Editor.

• Protecting Excel worksheets and your com-
puter against macro viruses.

13

Automating Tasks 

with Macros

Excel is packed with tools to help you enter commands without wind-

ing through a series of menus and submenus. You can press Ctrl+S to

save a workbook, click the Print button to print a worksheet, or press

Ctrl+N to create a new workbook, just to name a few. By learning the

dozens of toolbar buttons and shortcut keystrokes available in Excel,

you can significantly reduce the amount of time you spend entering

commands. To become even more efficient, you can create your own

macros, as explained in this chapter. 
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Type a description for the macro

Choose where to store the macro

Name your macro

Assign a shortcut
key to your macro

What Is a Macro?
A macro is a recorded series of commands you can
play back in Excel by selecting the macro’s name
from a list or by pressing a keystroke or clicking a
button that’s assigned to the macro. In this chapter,
you learn how to record commands with the macro
recorder, name and run your macros, and create
toolbar buttons and keystrokes for convenient
access to your macros.

Recording a Macro
The easiest way to create a macro is to use Excel’s
macro recorder. You simply turn on the recorder,
type a name for the macro, perform the task you
want to record, and then stop the recorder. The fol-
lowing instructions lead you step-by-step through
the process of recording a macro:

1. Open the Tools menu, point to Macro, and
choose Record New Macro. The Record Macro dialog box appears, as
shown in Figure 13.1, prompting you to name the macro.
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Before creating your
own macro to automate a

task you commonly perform,
check Excel’s help system to
determine whether Excel already
offers a shortcut for that task.
Also, ask yourself whether you
can use an easier feature, such as
AutoCorrect or AutoText, instead
of a macro.

FIGURE 13.1

Type a name for

your macro in

Excel’s Record

Macro dialog

box.
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2. Type a unique, descriptive, and brief name for your macro,
up to 64 characters (no spaces). The macro
name must start with a letter—never a
number. The macro recorder supplies a
default name—Macro1, Macro2, and so
on, as you keep recording macros—but
nondescriptive names such as these are
not very helpful when you’re trying to
determine the purpose of each macro.

3. Open the Store Macro In drop-down list,
and choose one of the following options:

Personal Macro Workbook to make
the macro available in all workbooks.

New Workbook to have Excel create a
new workbook and store the macro in that
workbook.

This Workbook to make the macro
available only in the currently open work-
book.

4. To assign a shortcut key to the macro, click
in the Shortcut key: Ctrl+ box and hold
down the Shift key while pressing the letter key that you want to use in com-
bination with the Ctrl key to launch your macro. This assigns the macro a
Ctrl+Shift+letter key shortcut.

5. Click in the Description text box, and type a brief description of the macro’s
function (the task it performs).

6. Click the OK button. The Stop Recording toolbar appears with buttons for
stopping the recording and for switching between relative and absolute cell
references, as shown in Figure 13.2. (If the toolbar does not appear, right-click
any toolbar and click Stop Recording.)

7. Perform the task whose steps you want to record. You can select menu com-
mands, click toolbar buttons, and press keystrokes to enter commands. To
select a cell, click it. To select a range of cells, drag over the cells. You can also
type entries and select objects, such as charts and clip art. 
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When specifying a
shortcut key, avoid using
keys that Excel has
already assigned to
other tasks, such as
Ctrl+C to copy or Ctrl+P to print. By
holding down the Shift key when
assigning a keystroke, you avoid
most conflicts. For example, if you
press Shift+P, Excel assigns the
Ctrl+Shift+P shortcut to the macro.
If you were to press P, Excel would
assign the Ctrl+P keystroke to the
macro, and whenever you pressed
Ctrl+P, Excel would run the macro
rather than print a worksheet.

caution
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8. When you are finished performing the steps,
click the Stop Recording button, or open
the Tools menu, point to Macro, and click
Stop Recording. Excel saves your macro
with the name you entered in step 2.

Running a Macro
When you record a macro, its name is added to the
list of macros you have recorded. If you assigned a
shortcut keystroke to the macro, the easiest way to
run the macro is to press the keystroke. If you did
not assign a keystroke to the macro, you must
select the macro from a list, as explained in the fol-
lowing steps:
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FIGURE 13.2

Excel’s Stop

Recording tool-

bar can turn off

recording when

you’re done.

Toggles between absolute and relative cell references

Stop Recording button

Excel macros
automatically record any

cell selections by using absolute
references. If you want to use rel-
ative references, click the
Relative Reference button on
the Stop Recording toolbar. You
can click this button repeatedly to
switch back and forth from
absolute to relative references. For
an explanation of the difference
between absolute and relative cell
references, see Chapter 6,
“Automating Calculations with
Formulas and Functions.”
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1. Open the Tools menu, point to Macro, and choose Macros (or press
Alt+F8). A list of available macros appears, as shown in Figure 13.3. 
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FIGURE 13.3

You can select

the macro you

want to run

from a list of

recorded

macros.

Click the name of the
macro you want to run

Click the Run button

2. Click the name of the macro you want 
to run.

3. Click the Run button.

Although selecting a macro from a comprehensive
macro list is a foolproof way to find and play the
macro, it is hardly the most efficient. If you find
yourself frequently playing back the macro, con-
sider assigning a shortcut keystroke to the macro.
To assign a keystroke to an existing macro, follow
these steps:

1. Open the Tools menu, point to Macro,
and choose Macros (or press Alt+F8). A
list of available macros appears, as you saw
in Figure 13.3. 

2. Click the name of the macro to which you
want to assign a keystroke.

3. Click the Options button. The Macro
Options dialog box appears, as shown in Figure 13.4.

4. Click in the Shortcut key: Ctrl+ box and hold down the Shift key while
pressing the letter key you want to use in combination with the Ctrl key to
launch your macro. By doing so, you assign the macro a Ctrl+Shift+letter
key shortcut.

Before running your
macro for the first time,
save your workbook. If
the macro performs
some actions that you do
not approve, close the workbook
without saving the changes. If,
however, the macro includes a File,
Save command, you might be out
of luck. To stop a macro before it
does too much damage, press
Ctrl+Break to stop the macro, and
then use the Undo feature to try to
recover from any damage the macro
has caused. 

caution
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5. Click the OK button to close the Macro Options dialog box and return to the
Macro dialog box.

6. Click the Macro dialog box’s Close button. You can now use the shortcut key-
stroke you assigned to your macro to run it.

Another way to run a macro is to create a toolbar button for it, as explained in the
following section.

Creating a Toolbar Button for Your Macro
Excel’s toolbars give you quick access to the most commonly used commands.
Instead of having to flip through a series of menus and submenus, you simply click
a button in one of the toolbars or select the desired option from one of the drop-
down lists. These toolbars can give you quick access to your macros as well. To add a
macro to one of Excel’s toolbars, follow these steps:

1. Make sure the toolbar on which you want
to place your macro button is displayed.
(Select View, Toolbars to display a list
of available toolbars.)

2. Open the Tools menu and choose
Customize.

3. Click the Commands tab. 

4. In the Categories list, click Macros, as
shown in Figure 13.5. 

5. Drag the Custom Button from the
Commands list over the toolbar on which
you want it to appear, drag it to the
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FIGURE 13.4

Enter your pref-

erences in the

Macro Options

dialog box.

Assign a shortcut key to the macro

tip
To learn how to create

your own toolbars, flip back
to the section named
“Creating Your Own
Toolbars” in Chapter 12,

“Customizing Excel.”
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desired location (watch for a dark I-beam pointer that shows where the but-
ton will appear), and release the mouse button. (See Figure 13.5.) The button
appears on the toolbar. (Leave the Customize dialog box open to perform the
next steps.)
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FIGURE 13.5

You can add

macro buttons

to any toolbar.

Drag the Custom button up to the toolbar

6. To change the name of the button, right-click it, drag over the entry in the
Name text box, and type a new name for the button.

7. To add an image to the button, right-click the button, point to Change
Button Image, and click the desired image, as shown in Figure 13.6. If you
want to display the image only, not the button name, right-click the button
and select Default Style.

8. Right-click the button and choose Assign Macro. The Assign Macro dialog
box appears, as shown in Figure 13.7.

9. Click the name of the desired macro and click OK.

10. When you are finished, click the Custom dialog box’s Close button to close
the dialog box.
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FIGURE 13.7

Assign the

desired macro to

the button you

created.
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FIGURE 13.6

You can pick a

different image

for your macro

button.

Click the desired image

Pick a macro to assign it to the button
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Editing Macros in Visual Basic Editor
If you run a macro and it does not perform the desired task as you intended it to,
you do not need to re-record the macro. Instead, you can modify the macro’s
recorded commands in Visual Basic Editor or delete commands you inadvertently
recorded. To open a macro and edit it in the Visual Basic Editor, follow these steps:

1. If you saved the macro you want to edit in a particular workbook, open the
workbook file in which you created and saved the macro.

2. Open the Tools menu, point to Macro, and choose Macros. The Macro dia-
log box appears, as shown in Figure 13.8.
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FIGURE 13.8

You can edit any

recorded macro.

Click Edit

Click the macro's name

3. Click the name of the macro you want to
edit.

4. Click the Edit button. Visual Basic Editor
appears and displays the commands that
compose the selected macro, as shown in
Figure 13.9.

5. To delete a command or any text, drag
over the command or text to highlight it
and then press the Delete key.

6. To add a command or text, type the com-
mand or text where you want it to “play”
in the macro. 

7. To save your macro, open the File menu
and choose Save, or press Ctrl+S.

If you try to edit a
macro stored in the
Personal Macro
Workbook (Personal.xls),
Excel displays a warning
box indicating that you cannot edit
a macro stored in a hidden work-
book file. Click OK to close the
warning box, and then click the
Macro dialog box’s Cancel button
to close it. In Excel, open the
Window menu and choose
Unhide. Click PERSONAL.XLS and
click OK. Repeat steps 1–3 to open
the macro in Visual Basic Editor.

caution
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These steps make it sound as though typing macro commands is easy. You soon
realize, however, that you must know the command to type it. When you start using
Visual Basic Editor, use it to delete superfluous com-
mands and edit any text entries that are part of the
macro. For example, if you have a macro that
inserts your company’s logo into a cell, the macro
contains the location of the logo’s graphic file, as
shown in the fourth line of the following example:
Sub InsertLogo()

InsertLogo Macro

Macro recorded 11/21/2003 by Sally Rogers

ActiveSheet.Pictures.Insert
(“C:\AcmeInc\logo.gif”).Select

End Sub

If you move the graphic file, you can open the
macro in Visual Basic Editor and edit the path to
the file rather than record a new macro.
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FIGURE 13.9

Use Visual Basic

Editor to edit

your macro.

Macro description Macro commands

End of Macro

Macro
editing
window

Beginning of macro

When you’re ready to
do more with Visual Basic

Editor, purchase a book that’s
devoted to it, such as The
Complete Idiot’s Guide to Visual
Basic 6.
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Choose a security level

Protecting Your System Against 
Macro Viruses

Excel’s macros are powerful programs that can
enter a complex series of commands with a mere
keystroke, but this power comes with some risks.
Just imagine the damage a macro could do if it
were designed to highlight a worksheet, delete
everything on it, and then save the blank work-
sheet to disk.

To prevent macros from running on your system
without your permission, you can tighten Excel’s
macro security settings. These settings can warn
you whenever you open a workbook that con-
tains macros, so you can decide whether you
want the workbook’s macros to run.

To change the macro security setting in Excel, 
follow these steps:

1. Open the Tools menu, point to Macro,
and click Security. The Security dialog
box appears, as shown in Figure 13.10.
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If you don’t share work-
books or open work-
books from the Web,
you don’t need to worry
about macro viruses.
However, if you open workbooks
you receive from friends, relatives,
colleagues, or unknown sources,
your system is at risk, even if you
trust the person who sent you the
workbook.

caution

tip
Macro security warnings

are annoying. Install a good
antivirus utility, such as
Norton or McAfee AntiVirus,
and choose the Low macro

security level in Excel.

FIGURE 13.10

Excel enables

you to choose

the desired

macro security

level.

2. Click the desired macro security level:

High to run only digitally signed macros from trusted sources.
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Medium to have Excel display a warning dialog box before you open a
workbook file that contains macros. (You can then choose to disable macros
for this workbook.)

Low to have Excel open all workbooks without warning you about macro
viruses. Choose this option only if you never open workbooks from outside
sources or if you have a good antivirus program that can identify macro
viruses.

3. Click OK to save the security setting and close the Security dialog box.

The Absolute Minimum
When you find yourself frequently entering the same series of commands to perform
the same task in Excel, that’s a good sign that you need a macro. The next time you
perform the task, record the steps, save the recording as a macro, and assign the
macro to a keystroke or toolbar button. To play back the macro, simply press its key-
stroke or click its button. As you work with macros, keep the following in mind:

To start recording a macro, open the Tools menu, point to Macro, and
choose Record New Macro.

When assigning a keystroke to a macro, hold down the Shift key while
pressing one of the letter keys.

You can play a macro by pressing its keystroke, clicking the button you cre-
ated for it, or selecting it from a list of macros.

To edit a macro, open the Tools menu, point to Macro, and click Macros.
Click the name of the macro you want to edit, and click the Edit button.

Macros can contain both commands and text.

To prevent macro viruses from damaging your files and infecting your com-
puter, set the macro security level to Medium or High, or install a good
antivirus program.

With the skills you acquired in this chapter, you can save a significant amount of
time performing common, repetitive tasks. You can also secure Excel and your com-
puter system from the outside threats posed by macro viruses. The next chapter
focuses not on the threats posed by outside sources, but on the Excel features that
enable you to share your worksheets on the Internet and access resources that are
available there.
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