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Getting Started
This chapter introduces you to two Linux applications that you’ll use with the 
web. The idea is to let you know these applications exist, to tell you what they can 
do, and to show you the basics of using them.

The first application is the Firefox browser, which is enormously popular and 
gaining widespread use on Windows as a safe replacement for Internet Explorer. 
If you’re not already using Firefox, you might want to switch to it on both Linux 
and Windows. In mid-2004 the U.S. Government’s Computer Emergency 
Response Team advised users to stop running Internet Explorer because of its 
security flaws.

The second application is Linspire’s Nvu program, which helps you create your 
own web pages.

Firefox Browser
Linspire 5 comes with the Linspire Internet Suite bundle of tools. This bundle 
includes the Mozilla open source browser. It’s a fine tool, but the Mozilla people 
are now all working on Mozilla’s next generation browser, Firefox. The Firefox 
browser is available for Linux, the Mac, and Windows. Firefox is where the action 
is now. The www.w3schools.com web site ranked Firefox with a 20% browser 
market share in early 2005. That’s probably representative of their customers 
rather than the overall Internet, but it’s a clear indication of how things are 
changing.

 Linspire Internet Suite and Hot Words

The Mozilla-based Linspire Internet Suite has a new feature called Hot 
Words. Hot Words lets you do a Google search on text from a web page you 
are browsing, without taking all the steps of opening a new tab, going to 
Google, and pasting the search term.

With Hot Words, select the search term in the page where you’re reading it, 
then right-click and choose Search Web. (You can also select the Lookup 
dictionary.com entry to get the dictionary definition of the word.) Hot Words 
will automatically open a new browser tab with the results of the search.
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There is also a spelling checker in the Linspire Mozilla email client and in 
web forms. It follows along as you type and suggests corrections for words it 
does not recognize. The spell checker does not work with Firefox yet, nor 
with the Thunderbird email client. It starts automatically, and you can click 
the Spell button on the email toolbar to see a list of suggested replacements 
for misspelled words.

It’s great to have a browser with integrated spelling checks and web 
searching. But I still prefer the leaner, faster feel of Firefox over its ancestor 
Mozilla. Firefox will get these features soon. Spell checking is available now 
as a browser extension, described in Spelling Check on page 195.

Downloading Firefox
Firefox is based on the Mozilla browser, simplified and improved. It has tabbed 
browsing for faster, easier web page displays. I recommend you use the Firefox 
browser instead of the older Mozilla suite that is bundled with Linspire. Firefox is 
in CNR (the Click-N-Run warehouse), and you can also download it from the web 
at http://www.mozilla.org/products/firefox.

Firefox is shown in Figure 6-1.

Figure 6-1 Firefox’s tabbed browsing 
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Getting to Know Firefox
The areas highlighted in Figure 6-1 show tabbed browsing, which might be new to 
you if you’ve mostly used Internet Explorer. The main window of Firefox 
displays a single web page, but you can easily switch to another web page by 
clicking one of the tabs. 

The browser does not have to open and fill a complete new window (which is 
slow). It only has to bring the new tab to the front (which is very fast). If you want 
to browse half a dozen web sites at once, your screen stays manageable without 
windows open everywhere.

In Figure 6-1, two web pages have been opened. You create a new empty tab by 
right-clicking on the bar in which the tabs appear (or on a tab itself). That brings 
up the context menu shown in Figure 6-2. 

Figure 6-2 The tab control menu

• You can create a new tab by choosing the New tab menu item. You can close 
the tab you are on or all the other tabs. 

• You switch to a new tab by clicking on it. The active tab is the one with the 
lighter colored tab label. In Figure 6-1, the tab labeled Google is the active tab 
(the tab shows as much of the web page title as will fit). The URL text field 
displays the URL for the active tab.

• You can right-click on a link in a web page and select the displayed option for 
opening it in a new tab. You get the same effect by holding down the control 
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key on the keyboard and clicking on the link in a web page. This is 
particularly useful, as it allows you to continue browsing on the original web 
page while the new one loads in a new tab. The new tab gives an indication of 
when the page has finished loading.

Associating Applications with File Types
It’s one thing to install Firefox (or any application). It’s quite another to make 
Firefox the default application used whenever the system needs to handle an 
HTML file. This section explains how to make a permanent association between a 
file type, and the application that you want to handle it.

Making Firefox the Default Browser
1 You use a panel in the control center to make file/application associations. 

Reach it by clicking Launch > Control Center > File Browsing > File 
Associations. 

2 That brings up the window shown in Figure 6-3.

Figure 6-3 Using the Control Center to associate applications and files

3 Type html in the Find filename pattern field. A tree-list of known file types 
is the second column. Out of all the categories of file types in that second 
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column, you’d guess correctly that HTML files are probably under Text. So 
click on Text to expand the tree.

4 Now find html in the expanded list, and click on it. That sets the file type 
you’re dealing with. 

5 It causes a third column to appear, (shown in Figure 6-3 with the two tabs 
General and Embedding). This third column gives the list of applications that 
the system knows about that can handle HTML files. (You can add another 
application by clicking the Add button.)

Instead, click on Mozilla Firefox, and click the Move Up button repeatedly, 
until Firefox is at the top of the Application Preference Order list. 

6 Click the OK button to lock in the change.

Associating Any File Type with an Application
You can make this kind of association for any file type that is listed in the Known 
Types, to state your preferred program for handling it. For example, you could 
associate K3b with the .iso file type. Clicking on the icon for an ISO file would 
then launch the K3b application to burn an ISO CD as described in Chapter 9, 
‘‘Filesystems and Optical Storage (CDs and DVDs).’’

Fill in iso in the Find filename pattern field, and when that brings up the 
application entry in Known Types, click to expand it. My system shows a type 
x-iso. When highlighted, the description confirms it is an ISO9660 image file. 
You can then set K3b or another application to deal with it automatically by 
clicking the Add button of Application Preference Order. In case you’re 
wondering, there’s an industry-wide standard for these file types; anyone can 
change or add handy new ones that aren’t in the standard, and the convention is to 
stick “x-” on the beginning to signify that.

Making That Application Preference Stick
Reports indicate that sometimes this procedure is not enough to make your chosen 
application be used for this file type. 

1 If you see that problem, then call up the File Associations panel again.

2 Click Launch > Run Programs > Utilities > Screen Capture to save a 
picture showing the existing settings. If you want to switch back, you’ll have 
all the old details shown in that screen dump.
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3 Remove all other applications except your selection from the Application 
Preference Order list. Click OK.

If you still can’t associate Firefox with html, type these in a command tool.

mv /usr/bin/mozilla /usr/bin/mozilla.old
ln -s /usr/bin/mozilla-firefox /usr/bin/mozilla 
The first command moves the Mozilla program to one side. The second command 
puts a link from the place where Mozilla was, so that it now invokes the Firefox 
binary. Admittedly a fierce and ugly kludge, but it will force the system to do 
what you tell it if you run up against this bug.

Making Email Open Links with Firefox 
Once you’re using Firefox, you’ll probably want your Thunderbird email applica-
tion to use Firefox to open any links in email messages. The configuration file that 
controls this is /usr/lib/mozilla-thunderbird/defaults/pref/all.js and the root user can 
open it with any text editor. To open one text editor, just choose Launch > Run 
Programs > Software Development > Advanced Text Editor (Kate). You’ll 
see two lines in the file like this:

// pref("network.protocol-handler.app.http","mozilla-firefox");
// pref("network.protocol-handler.app.https","mozilla-firefox");
Remove just the two slashes at the start of each line (the slashes make the lines 
into comments). Save the file, and restart Thunderbird. It will now use Firefox to 
open links in email messages.

Changing Font Size
You can enlarge or reduce the typeface used in Firefox using the following 
approaches.

• Control with “+” key increases the font size – Pressing the control key and the 
“-” key will make the typeface smaller. I like this approach because it works 
the same way under Windows and Linux.

• Control and mouse scroll wheel – Scrolling the wheel toward you while 
holding down the Control key increases the font size for a zoom-in effect. 
Control-scrolling away from you reduces the font size. You have very fine 
control over the end result, and get there quickly using this method.
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• Firefox’s color preferences window – Choose Edit > Preferences > Fonts 
and Colors; the resulting window lets you set the font minimum size. This 
sets the minimum type size permanently, while the other two approaches only 
affect the browser window you are in.

Configuring Firefox with Browser Extensions
The Firefox browser is probably the most customizable browser on the web. To 
see one aspect of this, type about:config in the URL field. Firefox will display 
scores of its configurable settings.

When you install it, Firefox is basic, fast, and simple. Hundreds of little programs 
known as browser extensions are freely available; they add some new feature or 
appearance to Firefox. It’s your choice whether to add them or not. Some people 
prefer an uncluttered look. Others want to keep track of the latest information 
from the web. Everyone gets what they like best.

Some of the best Firefox extensions have been collected and put on the web site 
https://addons.update.mozilla.org/extensions.

Here are a couple of useful extensions; you can find more on your own.

The “ForecastFox” Weather Icons
I live in Silicon Valley, California. They say there are just two seasons here: green 
and brown. For eight months of the year, the daily weather forecast is always the 
same: mild and overcast early, with temperatures reaching into the 90’s by noon 
as the cloud cover burns off, sunny for the rest of the day with light winds from 
the west. I don’t know how the weather clowns on TV here justify their salary. 
But if you live in a place where the weather does vary, take a look at the 
ForecastFox extension.

You can reach ForecastFox by searching at the Mozilla extensions site mentioned 
previously. When you install this extension, it will display the weather forecast for 
the next few days as little icons in your browser. See Figure 6-4 for an example.

Silicon Valley was in the green (rainy) season when I took this screendump, and 
the icons are saying today will be sunny, and the next two days rainy.

I briefly mention Mozilla browser extensions in Chapter 11, “Keeping Your Data 
Private,”  and explain they are blissfully simple to install: you just browse the link 
to an .xpi file and it installs automagically. 
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Figure 6-4 The local weather forecast in your browser

1 Once you arrive at the ForecastFox web page, you’ll see a button on the page 
marked Install Now. Click it to start the process, and you’ll get a dialog box 
like that shown in Figure 6-5.

Figure 6-5 Software Installation window 

Heed that warning when you see it on other sites. It’s probably safe to install 
extensions that are from the same web site as the browser itself. But you need 
to really think about whether you trust a web site before allowing it to install 
something on your computer, and the default response should be cancel. One 
of the problems with Internet Explorer is that you can’t rely on it to warn you 
of outside attempts to install software on your PC. When Microsoft smuggled 
the Explorer application into the kernel, they also opened a door to all kinds of 
self-installing horrorware.
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2 When you click Install, you’ll get the dialog box shown in Figure 6-6. You 
use this to customize what kind of weather forecast is shown, what area the 
forecast is for, and so on.

Figure 6-6 Customizing ForecastFox

3 Click the button marked Find Code. That lets you type in the name of your 
town (or airport). It fills in the corresponding weather code representing that 
area. All the information for ForecastFox comes from the www.weather.com 
site, and it’s possible that they will block it eventually rather than supply free 
weather forecasts without the chance to beam ads at you.

4 The other tabs in Figure 6-6 allow you to set the kind of weather data you 
want to appear, and where on the browser page you want it to appear. Just 
experiment to get the effect you want. As you might guess, this configuration 
window will reappear when you right-click on one of the weather icons and 
select Options.

5 Finally, completely exit the Firefox application, and restart it to see your 
weather forecast. Just don’t bother with it in California from March to 
November.

Dictionary Search
This extension lets you look up the definition of any words you find in web pages. 
It provides the same service as Linspire’s Hot Words, but for Firefox. 

1 From the Mozilla extensions site, look for the DictionarySearch extension, 
and install it by clicking as explained previously. Remember to exit and 
restart Firefox.
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2 Now when you see a term you want explained, highlight it and right-click, 
then select Dictionary Search, as shown in Figure 6-7.

Figure 6-7 Choosing to do a dictionary search

3 In the example you’re doing a dictionary search for the word lacuna. Selecting 
the Dictionary Search menu item opens a new tab with the results of the 
search, shown in Figure 6-8.

Figure 6-8 The word search results

justlinux.book  Page 181  Thursday, July 14, 2005  8:14 AM



182 CHAPTER 6  WEB TOOLS

4 From this you can see that a lacuna is a medical or legal term for an empty 
space, a missing part, or a gap. You can get roughly the same service by 
typing define:lacuna in the search web text field at Google.

BugMeNot—Site Registration
How do you feel about sites that require free registration before they’ll let you 
look at their web pages? It’s very common on news sites—the more they know 
about their reader demographics, the more they can charge advertisers.

Many people find it a burden to provide a page of personal information, in order 
to read a few paragraphs of news story. Some people get creative and register 
fictitious details (you’d be amazed how many 94-year old millionaire Peruvian 
goat herders read the New York Times).

Figure 6-9 shows what happens when you try to access a story on the New York 
Times web site; it challenges you for registration details.

Figure 6-9 Site with registration required

Now there’s an alternative in the form of a Firefox extension called BugMeNot. 
You can find BugMeNot at http://extensions.roachfiend.com/index.php#bugmenot. 
This site maintains a database of existing registrations. When you install the 
extension, and you are confronted with a free registration required page, use 
BugMeNot to automatically get the name/password of a pre-registered account 
filled out.
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Try it! Install the BugMeNot extension, restart Firefox and visit any page that 
requires free registration. Quite properly, BugMeNot doesn’t work for paid 
registration sites. Right-click on the user name field. You’ll see a pop up menu 
similar to that shown in Figure 6-10. 

Figure 6-10 Choosing BugMeNot to get a name and password

Select BugMeNot from the menu, and a user ID/password combination will be 
filled in automatically, allowing access without an additional registration. If the 
site has already revoked that user ID/password (to cut down on readership among 
wealthy Peruvian goatherders), then right-click in the field again to obtain another 
name/password pair, as shown in Figure 6-11.

Figure 6-11 BugMeNot fills in the name and password

Some people feel that providing genuine registration data is a fair price to pay to 
view other people’s web sites. Others believe in discouraging data fishing expedi-
tions by web site operators, and maintain that they should not have to provide any 
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personal data to view content that is laden with ads. Personally, I think it’s all 
gone downhill since cable TV started showing ads. Every web site already has a 
traffic log showing volume and geographic location of readers, and many surfers 
think that should be enough.

Smarter web sites are already making data capture less of an imposition by 
providing a small, optional form at the top of the desired web page asking for age, 
gender and zip code. I don’t expect BugMeNot to keep working indefinitely 
(registration-required sites hate it), but whatever your views on registration data, 
BugMeNot is a clever Firefox extension and more fun than a big barrel of really 
fun things.

Spoofing the User Agent String
An extension for Firefox changes the user agent to an arbitrary string. The user 
agent is a string that your browser sends to server sites, identifying itself and the 
system it’s running on. A typical user agent string is Mozilla/4.0 (compatible; 
MSIE 5.5; Windows NT 5.0) which comes from Internet Explorer 5.5 running on 
Windows 2000.

The Microsoft browser still identifies itself as Mozilla from the days when 
Microsoft bought it from the Spyglass company. Some misguided web sites use 
the agent string to identify the browser you are using and will disable access if it’s 
a browser they haven’t tested with. Spoofing the user agent string allows you to 
access the site anyway.

Visit http://extensionroom.mozdev.org/more-info/useragentswitcher to get the 
extension that allows you to let your browser identify itself to servers as anything 
you like. Internet Explorer-specific code such as ActiveX won’t run, not that you 
should have that enabled in Explorer, but you’ll be able to do more than if you 
can’t see the site at all.

Removing an Extension
In Firefox, choose Tools > Extensions to display the extensions that you have 
installed. Click on one extension to highlight it, then click Uninstall to remove it.

Reviewing Firefox Settings
Firefox has an excellent mechanism for reviewing and changing custom settings. 
Type about:config in the URL bar, and press Return. You’ll see a window like the 
one in Figure 6-12.
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Figure 6-12 Firefox configuration

The browser displays a list of dozens and dozens of Firefox settings. To change 
one, right-click on one and select New. Then select String, Integer, or Boolean 
according to what kind of field it is.

A web search will reveal what a setting does, if it is not obvious from the name. 
Figure 6-12 shows that I have changed the default setting that leaves the down-
load manager window open after a file download completes. That window will 
now close on completion. After changing a setting, save it and put it into effect by 
completely exiting the Firefox program and restarting it.

Nvu Web Page Editor
Nvu is an editor that lets you create web pages without having to know HTML. 
It’s like the old Netscape Composer, or Macromedia’s Dreamweaver or 
Microsoft’s FrontPage tool. Nvu is best for relatively simple web pages, and can’t 
do some of the slick stuff that Dreamweaver can do. Nvu only deals with HTML 
and CSS files, and not other kinds of web content such as .php files.

OpenOffice.org also has an HTML editor, but Nvu is generally simpler to use. 
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To open Nvu, click Launch > Programs > Web Authoring. Figure 6-13 shows 
how Nvu looks when you start it, and also indicates the names of various controls.

Figure 6-13 Names of the Nvu GUI components

After you have finished creating or editing a web page, Nvu can automatically 
upload it to your web site.

 Who do you thank for Nvu?

The lead developer on the Nvu project is Daniel Glazman, who was the chief 
architect on Netscape Composer. Nvu started from the Composer code base. 
It’s an open source project that will eventually be merged back into the main 
Mozilla code base.

The Linspire organization is backing Nvu financially, and with server space 
and technical expertise. Because of this backing it is very likely that Nvu will 
become the premier web authoring system for Linux. The Nvu site is http://
www.nvu.com. They also have a forum where you can pose questions and talk 
to other Nvu users at http://forum.nvudev.org.

Nvu is a WYSIWYG editor, meaning you don’t have to know much about HTML 
tags. You just type what you want into the Nvu window, then format the layout 
and text using the Format menu. The HTML tags that control page formatting 
will be generated automatically. When you are satisfied, click the Publish button 
to put the page on your web site.

Main window

Lower tabs

Format toolbar

Toolbar
Menus
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Create a Web Page
Figure 6-14 shows a finished web page I created in Nvu to showcase Gray’s 
Beach on Cape Cod, Massachusetts. You can look at this finished web page at 
http://afu.com/beach/swim.html.

Figure 6-14 The finished web page created by Nvu

Walk through all the steps to create this web page.

1 Create a new page by clicking on the New button at the left of the toolbar (the 
toolbar is the strip of icon buttons near the top of any GUI). 

You can work on an existing page by choosing File > Open File. You can 
even use an existing web page (such as http://afu.com/beach/swim.html) as your 
starting point by choosing File > Open web location.

2 Type the text for the heading of the web page Visit Gray’s Beach, Yarmouth Port, 
Massachusetts in the main window of Nvu. 

3 Highlight the line you just typed, so you can select a format. In the drop-down 
list on the top left side of the Nvu window, select Heading 3. 

4 Choose Format > Align > Center. Both choices are shown in Figure 6-15
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Figure 6-15 Formatting a line of text as a heading

5 Put a table on the web page. The table will have one row and two columns. 
Each entry in the body of the table is called a cell. You can put anything you 
like into a cell: a link, some text, a picture, or any combination of these. Put 
the words in the left cell, and the picture in the right cell. It’s common to use a 
table to space and separate elements on a web page.

Click the Table button on the toolbar to bring up the Insert Table window 
seen in Figure 6-16.

6 Roll your mouse over the table grid to highlight cells starting from the top left. 
When you have highlighted the exact number of rows and columns you want, 
click the mouse and click OK. 

Alternatively, you can click the Precisely tab, and set rows and columns by 
typing numbers. Your action fills in the blank frame of the two-cell table in 
the main window.
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Figure 6-16 Placing a table in the web page

7 Click on the right cell in the table; this becomes the place where things are 
entered. Click the icon marked Image in the toolbar to bring up Figure 6-17.

Figure 6-17 Adding the Image file
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8 Click the Choose File button on the Image Properties window to open the 
Select Image File window also shown in Figure 6-17. This allows you to 
browse for the image file that you want to go on the web page. Select an 
image file in GIF, JPEG or PNG format, since these are displayable by most 
browsers.

9 After selecting the image file, click the Open button. 

10 Click in the left cell of the table and in the space that appears, type a few 
words describing the image, as shown in Figure 6-18. This is for people who 
are using text-only browsers that can’t display pictures. This should be an 
optional field, but you currently have to enter something.

Figure 6-18 Adding the text to the table cell

11 You’re ready to add a link to a web page that displays a map of access to 
Gray’s Beach. 

The easiest way to find street maps for U.S. addresses is to type the address 
into the Google search field of your browser. Google will offer links to maps 
as the very first choice of search results. Street maps for Great Britain and 
many other countries are at the excellent web site http://www.multimap.com.

In this example, I happen to already know the address of Grays Beach; the 
address is 499 Center Street, Yarmouth Port, MA. When I type in that address, I get 
the map shown in Figure 6-19. 
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Figure 6-19 Finding the URL for the map to the beach

You don’t need the map itself, though; you need the link to it. To get the URL, 
place your cursor in the URL field of the browser displaying the map. 
Highlight the entire URL, right-click, and select Copy.

12 Now create a link from your web page to the map web page. Click the Link 
icon on the Nvu toolbar to bring up the Link Properties window shown in 
Figure 6-20.

13 Paste the link from the previous step into the field labeled Link Location. 
You can right-click at the point where you want to paste the text, and select 
Paste.

14 Enter the text to display for the link in the textfield labeled Link Text. 
Something like Map of Grays Beach is sufficient. Then click OK.
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Figure 6-20 Clicking the Link button to add the link

15 That table would look better without a visible border. You can edit a table 
after creating it; click on the edge of the table, then choose Table > Table 
Properties. That brings up the tabbed window shown in Figure 6-21.

Figure 6-21 Removing the table’s visible border
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16 One tab lets you edit table properties, the other tab lets you edit an individual 
cell (highlight it before bringing up the window). Make sure the Table tab is 
selected. Set the border to zero pixels, and click OK to exit.

17 Now review the web page, and if satisfied, save it to disk. Click the toolbar 
icon Save shown in Figure 6-22 to bring up a Save Page As dialog. 

18 Select a folder and file name, and click Save in the dialog to put the file on 
your local disk.

Figure 6-22 Reviewing the finished page in the Preview window

Let’s mention the function of the lower tabs (refer back to Figure 6-13). These 
four tabs display four different views of the web page you are constructing. 
You can edit the web page in any of these views (you’ve been using the 
Preview view so far). These are the differences:

Normal – This is how you will see the web page in a browser, but with 
tables outlined in red, to make it easier to see where they are, and to select 
them. Spelling mistakes are underlined in red (I’ll tell you how to turn 
that feature on in just a minute).
HTML Tags – This has the features of the Normal window, and also dis-
plays a little icon next to every HTML tag (the tag itself is not displayed). 
This makes it easy to edit any tag, including ones that otherwise require 
precise clicking, such as a table versus a cell within a table.

justlinux.book  Page 193  Thursday, July 14, 2005  8:14 AM



194 CHAPTER 6  WEB TOOLS

Click on any of the tag icons to bring up the appropriate window for 
editing that tag. This is a clever and powerful editing feature.

HTML Source – This view allows you to see (and edit) the HTML tags 
that control how a page is displayed in a browser. Tags aren’t that hard to 
decipher. They are enclosed in a pair of angled brackets so a browser can 
easily tell them apart from regular text.
Preview – This is how you will see the web page in a browser.

19 The last step is to upload your web page (HTML file and images) to your web 
site. Click the Publish button in the toolbar. It brings up the Publish Page 
window shown in Figure 6-23.

Figure 6-23 Providing access details for your web site

20 The first time you publish, you will have to fill in all the details of where your 
web site is, and the account name/password that you use to access it. This 
information is entered on the Settings tab.

21 Then click on the Publish tab shown in Figure 6-24. Fill out the details, 
saying whether the images need to be uploaded too (unless they are already on 
your web site, respond Yes). 

22 Click the Publish button, and the window will be replaced by one showing 
progress bars for each file being uploaded.
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Figure 6-24 Uploading the files to your web site

Nvu is a wonderful program: it has a good combination of features, and is easy to 
use. By paying for its development, and keeping the program open source and 
available for all distros, Linspire is showing its commitment to Linux and its 
willingness to invest back in the open source community.

Additional Nvu Tips
Here are a few additional tips for using Nvu.

Settings Are Reset
If you install a newer version of Nvu, all your existing publish settings are wiped 
out. It’s either a bug or a very unhelpful design feature, depending on who you 
talk to. If you plan to install a later version of Nvu, you might want to bring up the 
publish window first, and write down the settings (or just take a screen snapshot, 
using the Screen Capture utility).

Spelling Check
Choose Tools > Preferences > Advanced. Click on the option labeled Underline 
misspelled words shown in Figure 6-25.
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Figure 6-25 Turning on spell checking

In passing, let’s elaborate on the words in the Special Characters drop-down list: 
Output the following characters as entities: All characters having an entity 
equivalence in the HTML 4 specification. It looks like some kind of scare-the-
newbie joke. It actually means use the symbolic name, not the numeric code, for a 
special character (like a trademark symbol). 

If you select that choice, Nvu will put &trade; in the HTML instead of &#8482; to 
represent the trademark symbol ™. The numeric form of characters was part of 
HTML 2, but the named form was introduced with HTML 4. This feature lets you 
be friendly to older browsers, that’s all.

I asked Daniel Glazman (Nvu chief developer) about the wording. He gave me a 
candid reply, “Peter, the answer is easy: I am just a geek, and geeks rarely find the 
best or simplest wording in user interfaces. ;-)” This suggests a great way for non-
programmers to contribute to open source software: review the user interface and 
suggest constructive improvements; write better documentation; participate in 
testing early releases.
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Program Errors Are Logged
Nvu is still under development. The version that I used while writing this chapter 
was version 0.70, and later versions will be available by the time you read this.

It’s possible that you will find a bug in Nvu—something that doesn’t work 
properly. You can get more information about what Nvu is doing by bringing up 
the console. Choose Tools > Web Development > Javascript Console to bring 
up the window shown in Figure 6-26. Repeat the action that caused the bug, and 
see if it generates a message in the console.

Figure 6-26 Looking at errors

If a message does appear in the console, you can provide more information when 
you post an enquiry/bug report in the Nvu user forum at http://forum.nvudev.org. As 
ever, the better the information you provide, the more likely you are to get a useful 
answer.

Correcting Web Pages Produced by Microsoft Tools
Microsoft has many different tools that produce HTML. Unfortunately they often 
output incorrect and unportable HTML. Sometimes Microsoft’s own browser 
cannot read Microsoft-generated HTML, and Microsoft deliberately writes 
HTML that is incompatible with browsers from other organizations.
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Research scientist John Walker got fed up with this situation, and he wrote a 
software utility to, as he put it, “Remove the moronic parts of Microsoft’s HTML 
output.” If you have some HTML files that were originally produced by Microsoft 
tools, you might be able to bring them back to standard portable form by using 
John’s program at http://www.fourmilab.ch/webtools/demoroniser.

Advanced Users Only
Advanced users might like to note that Nvu supports the following features, not 
described here.

• Nvu can call W3C’s HTML validator to check that the web page under 
construction is portable and correct. Choose Tools > Validate HTML to run 
the validator.

• Nvu has a CSS editor. Cascading Style Sheets (CSS) are a way of customizing 
HTML tags in a document. Choose Tools > CSS Editor to start the editor.

• Nvu can edit several documents at once using a tabbed window. This is the 
function of the option labeled Upper tabs in Figure 6-13.

• Nvu supports the creation and editing of web forms. Web forms provide a 
simple GUI for collecting information from the browser user. Nvu will only 
help you create the form, not do any of the server-side wiring needed to make 
it run.

 Legends of Linux—The name game 

The Linspire distro jettisoned its former name of Lindows in exchange for a 
$20 million payment from Microsoft. Some of the other Linux distros have 
names with amusing or surprising origins, too. Here’s a selection for your 
entertainment. 

Slackware is the oldest distro still in existence. Founded by Patrick 
Volkerding in 1993, Slackware is a no-frills distro that emphasizes installing 
and working without a GUI. For this reason, running Slackware as your main 
desktop is considered a mark of studliness among many in the Linux world. 
These days, Patrick tells questioners that all the good names were already 
taken then changes the subject. But actually, Slackware was named after 
1980s counter-culture icon J.R. “Bob” Dobbs of the Church of the Sub-
Genius. For a while Dobbs’ pipe-smoking paternal face could be found in 
the most unexpected of places, and would-be revolutionaries bought into his 
message of “Slack”. Today, we’d call it “tilt”. Since the Great Big Tech Bust 
of 2000, www.subgenius.com is just another web site hawking (as they put it) 
doo-hickeys and geegaws. But the concept lives on in Slackware.
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Gentoo Although Slackware has the reputation, Gentoo is the distro that 
real studly nerds run. Most users install Gentoo by compiling it from scratch, 
resulting in the highest possible performance by matching the hardware they 
have. But where does the name come from? It’s from Pygoscelis papua, 
commonly known as the Gentoo penguin. Gentoo was a penguin species 
long before it was a Linux distro. Gentoos are the only breed of penguin with 
a white stripe on the top of the head and an orange beak. They are also the 
fastest underwater swimming penguins and can reach 36 kph. And speed is 
the reason the name was appropriated for a distro.

Debian is the distro on which Linspire and many other sub-distros are 
based. Debian adheres very strictly to the philosophy of open source 
software, and will not ship any code that is not openly licensed. Another key 
tenet of the Debian distro is stability. The project is organized and run to 
favor stable code over the latest new developments or early release dates. 
The Debian project was started in 1993 by Ian Murdock while he was still a 
student at Purdue University. He combined the first names of himself and his 
girlfriend (now wife) Debra to coin the project name Debian. Debian is very 
highly regarded in the Linux community, and has over one thousand 
programmers volunteering their labor to work on different aspects of the 
project.

Red Hat While still an undergraduate, Marc Ewing, the eventual founder of 
Red Hat Linux, was given his grandfather’s Cornell lacrosse team cap. The 
Cornell lacrosse cap featured dazzling red and white stripes. In spite of its 
striking appearance, Marc managed to lose the historic cap and searched 
for it with increasing desperation. The manual for the original Red Hat Linux 
beta contained an appeal for readers to return Marc’s red hat if found. By 
rights, this distro should be called Red and White Striped Cap Linux.

SUSE Originally a spin-off from Slackware founded by some programmers 
in Germany, SUSE acquired the same name as their software company, 
S.u.S.e. That was an abbreviation for Software-und System-Entwicklung 
(Software and system development). Later the distro was rebranded as 
“SUSE” which was deemed not to be an acronym for anything. In 2004, the 
Novell company bought SUSE and has focused it on corporate computing. 
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