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What’s Your Preference?:

\

have a little twitch. I'm not quite obsessive compulsive. I don't have to

wash my hands constantly or make sure to turn light switches on and off a

certain number of times. My twitch happens when I see someone else's
desktop. I walk up behind you when you are using your computer and see the
default desktop wallpaper, the default icons, the default task bar items, and all
the same colors that came with your desktop environment.

"Rrracowuugal” I yell as I stand directly behind you.

You jump, startled, and turn around. I don't like the furious look on your
face.

“What?" I ask.

"Why are you sneaking up on me and yelling?” you ask.

"I'm not,” I claim.

You look at me with incredulous eyes and a fed-up grimace. "I just heard
you. What do you mean, you didn't do it? What do you want?”

I'm thinking that you're a little testy today, but, hey, I'll cut you some slack.
You are reading my book, after all. “It's a twitch, you know, a tick. It's like
Tourette's syndrome.”

"Wouldn't that mean that you should be cussing me out right now?”

you ask.

119



chpt_04.gxd

120

1/20/05

3:58 PM Page 120 $

"Oh no, Tourette's has many forms. In fact, it's a common myth that most
sufferers of the syndrome swear. Noises are more common,” I kindly inform
you. I pull out a tote bag. "Here. Please take this informative brochure on
Tourette's syndrome. Also, here is a video tape of an admirable piece done on
ABC's '20/20" about Tourette's. Barbara Walters, a paragon and legend of the
journalism community, hosted "20/20." She can make people cry faster than hot
lemon juice on a self-inflicted flesh wound. Isn't she great?”

You're giving me that grimace again. “What do you want?” you repeat.

“"Well, I don't really have Tourette's, but I can't stand to see someone's desk-
top when the wallpaper isn't even changed. It hurts me.”

"I could hurt you,” you say.

Although I think that is a kind offer, I don't think that I will take you up on it.
[ remind you that, instead of hurting me, you are supposed to be out in the
world spreading that rumor that [ am a genius.

“Why would it matter to you if [ customize my desktop?” you ask.

[ take a deep breath and sit down beside you. “Pull up a chair.” You look
down at the chair you are already sitting in. “"Okay, I guess you have a chair. It's
just that there are so many options in Linux for customizing everything about
your desktop, fonts, wallpaper, colors, window borders, icons. . . . When you
don't change any of it, [ can't help but think that you're not living life to the
fullest. It's like not stopping to smell the roses. It's like not ever taking that trip to
Europe you always dreamed of. It's like not hugging your teddy bear.”

You scoot your chair a little farther away from me.

"It's okay,” I say, “"We will get through this crisis together. Let's start off by
looking at all of the ways to customize your desktop environment.”

You remove the arm that I put on your shoulder and continue to move your
chair farther away from me. You're such a joker, always kidding around and
pretending you think I'm creepy.

What Can You Change on Your
Desktop?

There are so many preference options in KDE and GNOME that you can make

your desktop look nothing like a traditional desktop (see Figure 4.1). You can
change everything from your desktop wallpaper to themes for your Window
Manager to fonts and icons. KDE and GNOME each have their own tools to
help you customize your desktop and make it your own.
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KDE Control Center

Program Info

Fedora/GNOME menu  Preferences > Control Center
Mandrake/KDE menu  System > Configuration > Configure Your Desktop

Terminal command kcontrol

One-stop shopping. Everyone likes that. The KDE Control Center makes config-
uring and customizing your desktop one-stop shopping. In the KDE Control
Center, you can change most of the preferences for your desktop environment,
from a simple task such as changing your desktop wallpaper to more complex
jobs such as installing fonts and adjusting your screen resolution settings.

As we discussed in earlier topics, the KDE version in Mandrake is different
than the KDE version in Fedora. Most of the changes were in an effort to stan-
dardize icons, themes, labels, and tools between GNOME and KDE with their
"Bluecurve” theme. The KDE Control Center has a few different categories and

items between Mandrake and Fedora. Let's look at the Mandrake version.

SETTINGS AND PREFERENCES

Don’t just customize your desktop environment. Programs in Linux
have lots of options, too. Whenever | try any new program, from a
simple text editor to a whole new desktop environment, the first

UNDER
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Fedora KDE users can still follow along, but you might have to poke around the
expandable list choices to locate a few items that have been rearranged.

The kcontrol interface is similar to the help section of many KDE programs.
There are three tabs in aleft column, a brief menu above, and a content area to
the right. Of the three tabs, you will spend the most time in the Index. The Index
is where the tree-view list of expandable items is for accessing the many parts
of the Control Center. The Search tab enables you to search by keyword for
what you want and then displays the matching modules of the Control Center
in a panel below. Searching for modules can be helpful when you are new to
the Control Center, but [ find it more useful to just start at the top of the Index
and work my way down the list, adjusting everything I want along the way.
Then, the next time [ use the Control Center, I already have a good idea where
the preference [ want is located in the Index. I tend to be more of the "poke
around and find things” type than the “search and destroy” type, so use
whichever method fits you best. From the Help tab, you can access the Control
Center manual or read help topics on whichever module you have open.
Simply highlight one of the subitems on the list and then hop over to the Help
tab to see the text for that item.

In the menu under View > Mode, you can find Icon View and Tree View. It's
best to stick to the default tree view because the icon view is jumbled and con-
fusing. Under the Settings menu are choices for shortcuts. The Help menu does
the same thing as the Help tab, but the tab view is easier to look at and work with.

Back in the Index tab is where all the fun is. There are 11 items in the tree
view, each with several subitems. All the choices might seem daunting at first.
Take a little bit of time to work through the list, and you will learn more about
the possibilities of your KDE desktop than regular use could give you in a week.
Here is a brief description of each of the main categories.

Accessibility

Settings for people with disabilities are in the Accessibility module. You can
adjust language preferences in Country-Region & Language, as well as how
dates and money information are displayed. You can also adjust your key-
board layout by region. The Keyboard Shortcuts module is useful for power
users as well as users with disabilities. Be careful when changing and adding
keyboard shortcuts. You could inadvertently change a keyboard shortcut spe-
cific to another program or add a dumb keyboard shortcut, such as setting the
spacebar to something that would make that action come up constantly while

typing.

place | go is the Settings (or Options, or Configure, or whatever the cus-
tomization menu item is in that program). Tweaking the settings is the best
way to first poke around and see what a program can do, what you can do to
make it your own, and learn some of the options that are available. When

o
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Components

The Component Chooser and File Association modules are important to you if
you plan to use programs other than those that KDE chooses as the default pro-
grams for e-mail, text editing, the terminal, and many document, image, and
multimedia types. The Session Manager lets you adjust a few things that hap-
pen automatically when you log in and out of KDE.

Information

The Information section is just what it says it is: information. There aren't any
settings to adjust here, but you can view info about your system status.

LookNFeel

This is the big one. The LookNFeel section has most of the fun options in it (see
Figure 4.2). You can change almost everything about the look and feel of your
desktop. Check out Table 4.1 for paths to some common settings. These are the
settings for which it is better to just go through than to read about. Some KDE
particulars include the Behavior and Window Behavior modules, where you
can change things such as mouse focus, system behaviors, and how your win-
dows behave when minimizing and closing. The rest of the modules mostly
cover the look of your desktop environment, so have fun and play.

File View Settings Help

Index | Search | Help
P Accessbily

L
+- [ Information

-~ gl LookNFeel

- | Background

& Behavior

[ colors

~[Ad Fonts

~y lcons

— & Launch Feedback
~ A Multiple Deskiops
(L4 Panels

- @ Screen Saver

-6l splash Screen
i Style

= J7 System Notifications
- (f§ Taskbar

5y Window Behavior
5 Window Decorations
+- @ Network

+-<7 Peripherals

T—.j_\ PawerContral

+- ) Security

+-& Sound

+-0 System

+- % WebBrowsing

4 [

KDE Control Center

nfigure your desktop environment

Welcome to the "KDE Control Center”, a central place ta canfigure your desktop
environment. Select an item from the index on the leftto load a configuration module.

3.2 BRANCH >= 20040204
susan

kozyshack

Linux

2.6.3-Tmdk

1686

KDE version:
User:
Hestname:
System:
Release:
Machine:

Click on the "Help” tab on the left to view help for the active control module. Use the
"Search" tab if you are unsure where to look for a particular configuration option.
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Figure 4.2

The KDE
Control Center
with the
LookNFeel sec-
tion expanded.

you're done looking around in the settings, use the program for a bit and
then go back to the settings again when you know some things that you
might want to change.
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Network

Most of the modules in the Network section have preferences that you can also
set in individual programs. The E-mail module settings apply only if you use
KMail as your e-mail program. If you are on a local area network on which a
common username and password is required to access shares on other net-
work computers, you can set those in the Local Network Browsing module. The
settings are effective when using Konqueror and Samba to browse network
computers. You can play with the sliders in the Preferences module, but they
can easily be left alone. The Proxy module settings require information about
your network and firewall. If you are in an office environment, your network

administrator should help you.

Peripherals

The Peripherals section can be useful for dealing with devices that are complex
to make adjustments to and add with only command-line tools. You can
change your screen resolution and gamma, and work with multiple monitors
in the Display module. Be careful adjusting the refresh rate unless you know
the proper range for your monitor. Keyboard adjustments include the repeat
rate and delay, numlock, and key click volume. For your mouse, you can adjust
right-handed or left-handed mode, clicking preferences, cursor themes, and
speed. Printers is an important module with tools for adding printers, monitor-
ing jobs, setting up network printers, and doing PDF conversion.

PowerControl

The PowerControl section has only one item in it. Here you can enable or dis-
able power management. With power management enabled, you can adjust
the amount of time before your computer goes into standby, suspend, or power-
off when there has been no activity within the set time.

Security

In the Crypto module, you can adjust settings for, add, or delete Secure Socket
Layer (SSL) certificates and authorizations. If that sentence just made your eyes
glaze over in a moment of techno-ignorance, leave the Crypto module alone.
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Frankly, most advanced users won't need to adjust these settings, either. The
KDE Wallet System is a place to keep personal information handy for use on
Web pages, to keep passwords, and to make your life easier. Anything
designed to make your life of passwords and security easier puts that informa-
tion in potential jeopardy, so use the KDE Wallet with care.

Sound

If you are familiar with sound card settings, the preferences in the Sound sec-
tion will be useful for you. Newer users should leave the Mixer and Sound
Settings areas alone. Check that box in the System Bell area only if you enjoy
being annoyed by bells constantly.

System

You can install new fonts, add keyboard shortcuts and mouse gestures (move-
ments to trigger commands or actions), change the look of your login manager
avatar, change your system password, and adjust default directory paths all in
the System section. You can also change the look of the login manager by
choosing Administrator Mode and entering your root password. The KDE
Performance module is another area to be careful with. You can adjust the
amount of memory used by KDE, but keeping the default middle ground is the
best choice.

WebBrowsing

Most of the preference settings in the WebBrowsing section are actually the set-
tings for the Konqueror Web browser in KDE. Make adjustments to all of these
pretferences when you have Kongueror open so you can see what you are
changing.

There are so many options in the KDE Control Center that you will learn
much more by playing with the options yourself. Don't be afraid that you will
horribly break things. If you are afraid, change only one or two things at a time
and then click Apply to see the changes. You can also keep your mouse hand
ready to click the Defaults button in each module to undo any changes that you

make.

125



chpt 04.gxd 1/20/05 3:59 PM Page 126 $

126

Table 4.1 How to Find Frequently Used Preferences in the
KDE Control Center

Desktop wallpaper/color LookNFeel > Background
or

Right-click your desktop and choose
Configure Desktop

Window theme LookNFeel > Colors to change individ-
ual colors or load and save color
schemes

LookNFeel > Style to change window
controls using themes

LookNFeel > Window Decorations to
change the window frame and top
buttons using themes

File associations Components > File Associations
Default fonts LookNFeel > Fonts

Screensaver LookNFeel > Screen Saver
Keyboard and mouse settings Peripherals > Keyboard

Peripherals > Mouse
Printer addition and configuration | Peripherals > Printers

New fonts System > Font Installer

Notification sounds LookNFeel > System Notifications

Change K&E Wallpaper, “T,l,\er\n‘e, Window Iecorationsy,
and Colory

The best place to look for anything to do with the look of KDE is, naturally,
http://www.kde-look.org. At kde-look, you can find icons, wallpapers, themes,
splash screens, and everything else you need. You can still look for icons and themes
elsewhere, hut kde-look has the largest collection and is the safest place to down-
load themes, to ensure that you don't get any oddly corrupted files.

Today we are going to grab a desktop wallpaper from the Web site. Plenty of
good themes come with KDE, so we will use two of those for the style and window
decorations.

1. Fire up a Web browser and head over to kde-look.org.
2. Under the category for Wallpapers, navigate to find one you like that fits your
current screen resolution. If you don't know your current screen resolution, look
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in the Control Center under Peripherals > Display. Save your wallpaper to your
computer, somewhere you can find it, or create a folder such as /home/
[username]/MyLook/. I'm choosing the one called Spot the Fish.

. Open the KDE Control Center and go to the LookNFeel section.
. First choose Background. In the content area on the right, you should see two

outlined sections, Background and Options. In Background, Picture should
already he chosen. Use the file icon to browse for your new wallpaper image.
Mine is in /home/susan/MyLook/2992-pinguinz_1024.jpg. If you chose a wall-
paper image that is the right size for your resolution, you can click Apply and be
done. If you have an oddly sized image, use the Position drop-down list to
choose Scaled, Centered, or Centered Auto Fit. You can click Apply after trying
each setting and then look at the wallpaper to see which you like best.

. In the Control Center LookNFeel section, next go to Style. There are three tahs.

On the Style tab, use the drop-down list in the Widget Style section to choose a
style theme that you like. The whole hottom part of the tab previews each style
for you. I'm going with Thememdk. Click Apply when you decide on one. The
Effect and Miscellaneous tahs have features for visual effects such as trans-
parency and tear-off menus. Some of the effects can be processor intensive for
your computer, so don't enable too many until you see if they slow your com-
puter's performance too much.

. Go to the Window Decorations section of the Control Center's LookNFeel list. On

the Window Decorations tab, use the drop-down list to choose which one you
like. It will be previewed for you below. Click Apply when you are done. | will
use the theme Glow.

. Finally, you can change the colors to match. Go to Control Center > LookNFeel >

Colors. You can choose a predefined scheme in the Color Scheme selection hox
or create your own scheme by using the Widget Color drop-down list to choose
each widget type and then choose a color below. You can also change the con-
trast. Itis a good idea to save your custom scheme so you won't have to re-
create it later if you try out some changes. Use the Save Scheme hutton below
the Color Scheme select box. | am going to call mine Hoofooglers. Click Apply
when you are done.

8. Close the Control Center and hehold your creation.

You can download new KDE style themes and window decorations themes

from kde-look.org. If you download a theme, pay attention to the install direc-

tions on that theme's page. Installing a new theme is similar to installing soft-

ware from the source code. You need to open a terminal and follow the install

directions for that theme. Make sure you download a theme for your version of

KDE. If you are not sure of your KDE version number, open the Control Center

and, without clicking or highlighting anything, look in the content area on the

right for the number next to "KDE version.”
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GNOME Control Centex

Program Info

Fedora/GNOME menu

Preferences > Control Center
or the Start Here icon on your deskiop

Mandrake/KDE menu  Applications > System > Configuration > GNOME > GNOME
Control Center

Terminal Command gnome-control-center

GNOME doesn't really have a control center. I think they started calling the
collection of preference modules a Control Center because that is what KDE
calls it. Names aside, the GNOME Control Center is a view of icons in the
Nautilus file manager (see Figure 4.3). Besides main menu and terminal
command access, you can open Nautilus in file browsing mode and type
preferences:/// into the address bar to access the Control Center icon view.
Of course, Mandrake and Fedora have a few differences in the GNOME
Control Center. Most of the differences are in the icons used and the labels
attached to each module.
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With the GNOME Control Center merely consisting of a collection of icons,
you can double-click on any icon to access the dialog box for that preference
module. If you want quick access to any single module, you can choose it from
the submenu in the main menu under Preferences. One theming option is not
in the Control Center. You can find the preferences for changing GDM (your
login manager) themes in the main menu under System Settings > Login
Screen. Whereas the KDE Control Center contains a few items that could be
considered system administration tasks, the GNOME Control Center has only
personal preferences. GNOME keeps all the system administration tasks in the
main menu under System Settings and System Tools. Let's look at the GNOME
Control Center in Fedora.

Accessibility

The Accessibility option in the main menu is a submenu, so here it acts like a
sub as well by opening a new icon view of two more module icons. The
Accessibility module is where users with disabilities can adjust keyboard and
mouse options to make access easier. Some of the keyboard settings are
repeated in the Keyboard and Mouse modules. In the Assistive Technology
Preferences dialog box, you find options for a screen reader, a magnifier, and
an on-screen keyboard.

Moxre Preferences

The More Preferences icon is another pointer that opens a new icon view of five
other icons. Most of these options are advanced, are unnecessary to change, or
can be accessed elsewhere.

About Myself

In case you didn't know your name when you were asked for it during the
installation, you get a second crack at getting that question right. You can score
bonus points for knowing your phone number and office information. None of

that information is important to complete. Leave the Login Shell option set to

/bin/bash.

CD and DVD

This module is a wonderful addition to GNOME. You can set what action is
taken automatically when different types of CDs or DVDs are put into the drive.
Sure, GNOME stole this idea from Apple, but it is still nice to have. Try the
defaults before you decide to make changes.
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Control Center

[ cannot tell you why there is a Control Center icon in the Control Center.
Because the Control Center view is just a copy of the main menu items under
Preferences, this icon snuck into the view. You can click on it all day, but this

icon isn't going to do anything but open the window you already have open.

Desktop Background

The Desktop Background module is the place to add pictures of naked farm
animals—or whatever you like—to your desktop. The options are simple:
Choose a picture, set the style, and pick a color.

File Types and Programs

When you double-click a document, media file, archive, or image in your file
manager, Nautilus, a default application, attempts to launch. If you don't like
the default program that Nautilus uses for a particular file type, you can
change it here. You can also add file types that are not already defined and set
applications for file types that do not have an associated application. This mod-
ule gets better with each release, but File Types and Programs is still one of
those preferences that you should be careful with. If you set an application for
a specific file type and then change your mind later, taking out the association
can be frustrating.

Font

The Font Preferences dialog box is another way to make your desktop look all
your own. You can change the default fonts used for applications, desktop
icons, window titles, and the GNOME terminal.

Keyboard

You can change the keyboard speed settings and regional layouts in the
Keyboard module. A very groovy new feature in this dialog box is the Typing
Break tab. If you are someone who forgets to take frequent breaks to move
around, give your eyes a rest, and stave off carpel tunnel fun, use the typing

break options to enforce breaks.

Keyboard Shortcuts

You know what keyboard shortcuts are. GNOME has a lot of keyboard short-
cuts set up already for you, but you can adjust them here. Be careful that you
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do not use a keyboard shortcut that will interfere with one being used by an
application. Also make sure that you don't set any keyboard shortcuts that will
activate too easily when you are working on something else. For instance,
Enter would be a bad keyboard shortcut.

Login Photo

Use the Login Photo module only if you have set your login manager, GDM, up
to use the face browser option. If you did that, you can choose a picture for it
here. With all of the cool themes for GDM, you don't really need the face
browser.

Menus & Toolbaxrs

This is a simple dialog box with only a few choices for how you want to view the
menus and toolbar in different applications.

Mouse

In the Mouse module, you can change your click speed, decide whether you
are left-handed, and adjust cursor and mouse speed options. You know, they
used to burn left-handed people as witches. I'm not saying anything about

you—I'm just telling you that. (*ehem™ witch! *ehem®)

Network Proxy

In an office environment, you will need your network administrator to help you
with your proxy settings. If you have a proxy server in your home, then you, or
whoever set it up for you, will know what to do with the Network Proxy module.

Password

To change the password for your username, open this dialog box, enter your
current password, and then enter your new password. This is not the place to
change your root password. To change your root password, go to the main
menu and choose System Settings > Root Password.

Preferred Applications

Fedora and GNOME choose default applications for you, but once you decide
on your favorite programs, you will want to visit the Preferred Applications
module. You can choose a preferred Web browser, mail reader, text editor, and

terminal application.
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Screen Resolution

Here you can change your screen resolution and the refresh rate for your mon-
itor. Don't mess with the refresh rate unless you know the range your monitor
allows. Check any paperwork that came with your monitor or search online for

documentation to find out the capabilities of your monitor.

Screensaver

The screensaver in GNOME is the XScreenSaver program, so this module
brings up the XScreenSaver preferences. You can choose from a bazillion
already installed screensavers, have random screensavers or only one, and
set the time for the screensaver to activate. The Advanced tab has lots of picky
settings for using desktop images in screensavers, diagnostics, and color maps.
You might want to check out the Display Power Management section for

standby and sleep options.

Sound

These preferences handle the sound server, Sound Events (system notification
sounds), and the System Bell. Each option is pretty clear just by reading the
description. You won't break anything by trying out these options, but you
might annoy yourself with a few of those sound choices.

Theme

The Theme module (see Figure 4.4) is one of the most important, as far as my
fun factor is concerned. Themes are where you can radically change the look
of GNOME. There are four types of themes: large overall themes, window con-
trols themes, window border themes, and icon themes. The last three are in a
subdialog box that shows up when you click the Theme Details button. When
you make changes in the subdialog box, your overall theme shows up as a cus-

tom theme. You can then save your custom theme.

Windows

Open this one, and you see the Window Preferences dialog box with options for
focus follows mouse (Select Windows When the Mouse Moves over Them) and
other options for window behavior and moving windows.
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Custom theme

Bluecurve
Red Hat Linax default theme

Crux
Smoath gradients with teal highlights

%Iﬂlﬂ

Grand Canyon
& Dusty orange appearance

This theme does not suggest any panicular font or background.

BB Yo can save this theme by pressing the Save Theme butd

s
Controls | Window

=

Atlanta 20 Go To Theme Folder
Bluecurve-classic
Bright
Crux
Esco
Metabox
Mist
Sandwish
Simple

(v New themes can also be installed by dragging
them into the window.
xome | [ @

GNOME makes changing your preferences painless. Most of the options in

the modules need little explanation. You can try them without fear that you will

mess up anything very important. The modules don't have a Defaults button as

the KDE Control Center does, so remember what you change, in case you want

to undo your actions. I often find it easier to access the modules in the GNOME

Control Center through the main menu, especially for changing only one or

two preferences.

Table 4.2 How to Find Frequently Used Preferences in the
GNOME Control Center

Desktop wallpaper

Window theme

Window colors

File associations
Default fonts
Screensaver

Keyboard and mouse settings

Printers

Desktop Background
Theme > Theme Details > Controls
Theme > Theme Details > Window Border

You can change window colors only by
changing the window control and window
border themes.

File types and programs
Font

Screensaver

Keyboard

Mouse

[Main Menu] > System Settings > Printing
(root password required)

continues
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Control
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Preferences
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box.
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Table 4.2 How to Find Frequently Used Preferences in the
GNOME Control Center (Continued)

New fonts Installing new fonts is not in the Control
Center but is easily done. Open Nautilus,
type fonts:// in the address bar (or use File
> Open Location if Nautilus is in spatial
mode), and then drag and drop TrueType
font (.ttf) files into the directory.

Notification sounds Sound > Sound Events

“TOBO1. | Change GNOME Wallpaper, Theme, and Window

KIT,_ 4.9 Drecorationy

Desktop wallpapers are all over the Internet for you to download. When you want
' a GNOME- or Linux-related image, you can head over to http://art.gnome.org or
http://gnome-look.org. Besides wallpapers, you can download window control
themes, window border themes, GDM (login manager) themes, icon themes, indi-
vidual icons, tutorials, and more.

Let's download a wallpaper image to use. Then we can change the window horder

and control themes using some of GNOME's already installed choices.

1. Open a browser, such as Mozilla, GNOME's default browser, and go to
http://art.gnome.org.

2. Click on the link for either Backgrounds > GNOME or Backgrounds > Other.
Choose a background image that you like and download it. The background
images on art.gnome are not arranged by resolution, so download one that is at
your resolution or larger. If you don't know your current screen resolution, look
in the Control Center under Screen Resolution. Save the image to your computer
somewhere you can find it, or create a folder such as /home/[username]/
MyLook/. I'm choosing the one called Big Munkey (Blue).

3. Open the GNOME Control Center and click the Desktop Background icon.

4. Inthe Desktop Background dialog box, click the Add Wallpaper button. Browse
to the directory where you saved your wallpaper image, select the image, and
click Open. Use the drop-down choice next to Style to choose the placement
style that works best for that image. Click Close when you are done.

5. Now we want to change the themes. In the Control Center, double-click the
Theme icon. You'll see a list of themes. Click any of them, and the theme imme-
diately takes effect. Like one? Just click the Close button. Like only parts of a
theme? You can mix and match by clicking the Theme Details button.

6. To change the window controls theme, click any of the themes in the list on the
Controls tah. The theme changes right away.

7. To change the window horder theme, use the list on the Window Border tab.
Select different themes to see them applied.
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8. Click the Close button when you are done with the theme details. Back in the
main Theme dialog hox, your theme now is listed as Custom. If you want to save
the current theme choices, click the Save Theme button. You can fill in a name
and description for your custom theme. Click Close when you are done.

9. Check out your new desktop, resplendent in its pulchritude—you know, pretty.

Installing new window border and control themes in GNOME is easier
than it is in KDE. All you need to do is download the compressed file from a
Web site with GNOME themes, such as http://art.gnome.org or http://gnome-
look.org. Open the Theme dialog box in the Control Center and click the Theme
Details button. Go to the right tab for the type of theme that you downloaded
and click the Install Theme button. Select your downloaded file, and you are
done. You should see the new theme that you installed in the list on the appro-
priate tab.

Icons

Most distributions try to design a nice icon set for the default desktop. You could
use the default set of icons, but then you would be default. Default is mediocre.
You don't want to be mediocre, do you? Do you want to be mundane?
Unexciting? I think better of you than that. I think you want to put your own per-
sonal stamp on every aspect of your desktop. We spend so much time in our
desktop these days that we should make ourselves at home there. I might be
badgering you, but I think it's really fun to find new icons and design the desk-
top I live in.

Desktop and Panel Icons

Changing icons for items on your desktop and panel is easy. Whether you are
in KDE or GNOME, you just have to right-click the item and choose the new
icon that you want.

To change icons for desktop and panel items in GNOME, right-click the
item and go to Properties on the right-click menu. Click the icon in the
Launcher Properties dialog box. You will be in a dialog box to browse the icons
in the directory where the current icon lives. Select a new icon from one of the
icons displayed, or use the address bar to type in or browse for a different
directory. Click OK when you are done.

UNDER
HOOD

CHANGE THE MAIN MENU ICON

A simple right-click on your main menu icon doesn’t give you a way
to change the icon for the main menu. Neither Mandrake nor Fedora
wants to encourage you to take its logo off your desktop. If you

o
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In KDE, the method to change icons for desktop and panel items is almost
the same as in GNOME. Right-click the item, choose Properties from the menu,
and click the picture of the icon in the dialog box. The difference in KDE is that
you have two categories to choose the new icon from, system icons and other
icons. The system icons are the ones that come with KDE. Clicking Other Icons
brings up another available directory full of icons, such as /usr/share/pixmaps,
as well as a Browse button. Use Browse to go to another directory of icons that
you choose, such as one you might have downloaded an icon image to.

File Manager Icons and Emblems

Your file manager need not be the plain sea of folders that you see by default.
You can change many aspects of the look of Nautilus and Konqueror, including
icons, emblems, and background colors and images. Personally, I tend not to
mess with these customization options too much because I don't spend a lot of
time in my file manager. However, you might be a file-browsing fool who wants
green camouflage backgrounds and tiny kitty icons.

You cannot directly change the icon for each item in Nautilus. You can,
however, add an emblem to any item. An emblem is a small icon that sits next
to the item denoting a category or whatever you want to use it to denote. To add
an emblem to an item in Nautilus, right-click the item, choose Properties, and
then go to the Emblems tab. You will see a whole bunch of small icons. You can
check as many as you like and then click OK when you are done. You can
change the icons for file types in Nautilus by installing Nautilus themes that you
can download from the Internet. Nautilus toolbar icons are affected by your
choice of window control theme, but not all window control themes include
Nautilus icons with them.

In Konqueror, there are no emblems. You can right-click any item in
Konqueror to change the icon for that item, just as if it were a desktop item.
Icons for different file types and for the Konqueror tool bar are often changed
when you install a new desktop style theme.

Both Nautilus and Konqueror give you the option to change the back-
ground of your file manager. You can choose from preinstalled patterns, add
your own pattern image, or choose a solid color. In Nautilus, go to Edit >
Backgrounds and Emblems in the menu bar. Nautilus has options for patterns
and colors, and a place in this dialog box to add new emblem images. In
Kongqueror, you go to View > Background Color or View > Background Image
from the menu bar. Both file managers allow great flexibility for the look of your
directories, but they also provide a couple hideous choices to steer clear of.

cannot fight the desire to change the main menu icon, you have to find the
image file itself, rename it, and then copy the image you want to the original
name and location of the main menu image file. The image locations change
depending on your distro, version, and other factors, but two good places to

o



chpt_04.gxd

1/20/05 3:59 PM Page 137 $

Finding and Creating New Icons

You can never have too many icons. Although both KDE and GNOME come
with lots of good icon choices, you will have to look online to find more unique
icons. There are lots of Web sites for icons, including the same great sites we
looked at for themes, kde-look.org and art.gnome.org. You can find icons on
non-Linux Web sites as well. Good sites such as htip://www.deviantart.com/
and http://www.wincustomize.org/ have mostly Windows icons, but you can
grab them for use in Linux as well. The Links section at the end of this topic has
more URLs for desktop customization sites. Just download any file and then
convert it to a .png file to use it as an icon.

To create icons in Windows, you have to use programs that will work with
the special .ico file type. To create icons in Mac OS X, you have to use a special
file type as well. To create icons in Linux, you don't need any voodoo—ijust a
graphics editor. Most icons in KDE and GNOME use the .png file type. Unlike
.ico files, PNG files are common and can be created by most graphics editors.

When creating your own icons remember a few general rules of thumb:

®  Keep your image square.
®  Size your image as 32 x 32 pixels or 45 x 45 pixels, for the most flexibility.
®  Make the surrounding space of your icon transparent.

®m Keep the image simple. Complexity doesn’t come through well in such a
small image.

Fonts

Fonts used to be one of the big “issues” in Linux. You couldn't tell anyone that

Linux was ready for the desktop while they were making faces at the weird,
jagged fonts on your screen. I made those faces, too. A few versions back, we
got the ability to use TrueType fonts and antialiased fonts. No one makes faces
anymore.

The default fonts that come on most Linux distributions are much nicer
than they used to be. The fonts in the Lucida and Nimbus families can be used
in place of a favorite sans serif font such as Arial. In addition to the Linux font
families, you can download fonts from the Internet to use in Fedora and
Mandrake. Download almost any .ttf font file (.ttf files are usually Windows
fonts) and then install it.

137

start the detective search for the main menu icon image file are these:
Fedora: /usr/sharelicons/Bluecurve/4Ex48/apps/gnome-main-menu.png
Mandrake: /usr/share/icons/mandrake.png
Alternatively, you can search for the filenames to find out what super-
secret place they are hidden in.

o
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Figure 4.5

A custom font

for every-
thing—the Font
preference in
Fedora.
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Install Fonts in Fedora/GNOME

Open Nautilus, type fonts:// in the address bar (or use File > Open Location,
if Nautilus is in spatial mode), and then drag and drop TrueType font files (.ttf)
into the directory.

Install Fonts in Mandrake/KDE
In the KDE Control Center, go to System > Font Installer.

Some TrueType fonts found online are copyrighted material or for pur-
chase only. There are lots of free font sites online to download from. Look up
something such as “free font download” in your favorite search engine to get
lots of hits. Make sure you have your pop-up blockers on in your browser, and
prepare yourself for blinking text. The free font sites are heavily saturated
with ads.

Both KDE and GNOME give you a place in their Control Center to change
the fonts used for window titles, menus, the terminal, and more (see Figure 4.5).
Some programs also offer their own font choices.

v Font Preferences *

Sans | 10 |

Application font:
De:

Window title font: Sans 10 |

|

sktop font: | Sans 10 |
|
|

Terminal font: Nimbus Sans L 10 |

Font Rendering

() Monochrome (@) Best shapes

abcfgop AO abcefgop|labefgop AO abcefgop

(O Best contrast (O Subpixel smoothing (LCDs)

abefgop AO abcefgop||abefgop AO abcefgop

UNDER

“THE
‘HODD

AVOID THE ICON FILE TYPE TANGLE

Yes, you can convert Windows .ico files and Mac icon files to .png
files to use as icons in Linux. You can also easily convert GIF and
JPG files to PNG. Why bother with all that mess? If you see an icon

o
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Links

GNOME's theme sites:
http://art.gnome.org

http://gnome-look.org

KDE's theme site:
http:/f'www.kde-look.org

Other Linux theme sites:
http://www.themedepot.org/
http://themes.freshmeat.net/
http://'www.wincustomize.org/
http://'www.deviantart.com/

you like online, just take a screenshot. Then open a graphics editor such as the
GIMP and open the screenshot image. Crop the image of the icon you liked,
clean it up, and save it as a .png file. You're done converting the icon, and you
didn’t have to worry once about what file type the original icon was in.

o
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